Jump to content


Photo

ClockworkMod Recovery for Huawei U8815/Ascend G 300


  • Please log in to reply
268 replies to this topic

#21
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Home button to select, not power button.

  • 0

#22
feckineejit

feckineejit

    Addict

  • Members
  • PipPipPipPipPip
  • 578 posts
  • Gender:Male
  • Location:Derry/Ireland
  • Devices:ZTE BLADE, Huawei G300

Home button to select, not power button.

Cheers Davidoff59, sorted that thanks, just one other thing, i need to pull battery then replace battery, hold vol+ and power everytime so i can get into cwm is that what everyone else has to? never had to pull battery in SF

Edited by feckineejit, 26 April 2012 - 11:09 PM.

  • 0
Posted Image

#23
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
you can select reboot into recovery if you have rom manager installed. Rom manager and clockworkmod recovery go together like fish and chips, beer and kebabs and planes and wings. All made for each other.

  • 0

#24
feckineejit

feckineejit

    Addict

  • Members
  • PipPipPipPipPip
  • 578 posts
  • Gender:Male
  • Location:Derry/Ireland
  • Devices:ZTE BLADE, Huawei G300

you can select reboot into recovery if you have rom manager installed. Rom manager and clockworkmod recovery go together like fish and chips, beer and kebabs and planes and wings. All made for each other.

Cheers Davidoff59 :) that one problem sorted, will have to try sort out my adb tomorrow, just out of curiosity, do i need to put a custom rom on my phone for me to be able to use adb to copy/remove files from my phone, or can that be done with stock rom installed?

  • 0
Posted Image

#25
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
titanium backup or Rom Toolbox can copy, move and remove apps and files.

You used adb to push CWM recovery image so yes it works with stock rom.

  • 0

#26
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Is anyone getting any lag or freezing on the lock screen. I am rooted and have the clockworkmod recovery image installed. The lag seems to have appeared after the cwm recovery image was installed.
It can happen on the lock screen, and in the rom itself and when this happens, the capacitive touch buttons usually don't light up or work.

A reboot fixes it sometimes but mostly it doesn't and it can lag after a battery pull also.

Could the clockworkmod recovery image have caused this.

I did a full wipe and installed the debranded rom by sebastian and installed no apps, just set up my account and its lagging again.

I tried posting a log before but uploads appear broken on the new modaco layout.

Any advice to offer me and will flashing the stock rom on Sebastian's page break the rooting that was done so it will have to be rooted again?
Contemplating a return of the phone as its only a week old.

  • 0

#27
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Phone now frozen at lockscreen. Reboot or battery pull doesn't fix. I can reboot into clockworkmod recovery but I can't select anything. Volume moves selection up and down but home does not select.
Lockscreen icon doesn't budge at all.

  • 0

#28
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404
It sounds like you have some hardware problems there, I'd take it back and see if you can get it swapped

  • 1

#29
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Cheers for that Sebastian, will return it tomorrow. Will have to pay for unlock again is a bit of a bummer

  • 0

#30
strowger

strowger

    Newbie

  • Members
  • Pip
  • 11 posts
I've successfully installed the "super recovery" but on trying to install Clockworkmod I get:

# fastboot-linux flash recover recovery-clockwork-4.0.1.5s-hwu8815.img
sending 'recover' (5212 KB)... OKAY
writing 'recover'... FAILED (remote: partition table doesn't exist)

  • 0

#31
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

I've successfully installed the "super recovery" but on trying to install Clockworkmod I get:

# fastboot-linux flash recover recovery-clockwork-4.0.1.5s-hwu8815.img
sending 'recover' (5212 KB)... OKAY
writing 'recover'... FAILED (remote: partition table doesn't exist)


fastboot-linux flash recovery recovery-clockwork-4.0.1.5s-hwu8815.img

  • 0

#32
strowger

strowger

    Newbie

  • Members
  • Pip
  • 11 posts

fastboot-linux flash recovery recovery-clockwork-4.0.1.5s-hwu8815.img


*Sigh*. Sorry. And thank you.

Where's your tip jar?

  • 0

#33
warwound

warwound

    Regular

  • MoDaCo Silver
  • PipPip
  • 91 posts
  • Gender:Male
  • Location:Norfolk, UK
  • Interests:Cycling, camping, photography and computers.
  • Devices:Galaxy S3, Galaxy Tab2
I've rooted my G300 and installed ClockworkMod and also installed ROM Manager.

If i try and use the ROM Manager 'Backup current ROM' option it tells me i don't have ClockworkMod installed and offers to install it.
I click no - if i clicked yes would it install a version of ClockworkMod that is incompatible with the G300?

Is there any way to tell ROM Manager that i DO have a working version of ClockworkMod already installed?

  • 0

#34
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,640 posts

I've rooted my G300 and installed ClockworkMod and also installed ROM Manager.

If i try and use the ROM Manager 'Backup current ROM' option it tells me i don't have ClockworkMod installed and offers to install it.
I click no - if i clicked yes would it install a version of ClockworkMod that is incompatible with the G300?

Yes it would attempt to install an incompatible recovery that may brick your device.

Is there any way to tell ROM Manager that i DO have a working version of ClockworkMod already installed?

No. ROM manager only functions with officially supported recovery images that have been built by the developer of ROM manager (Koush). The G300 recovery image is unofficial.

  • 0

#35
Frankish

Frankish

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,535 posts
  • Gender:Male
  • Devices:iPhone 4S Xiaocai X9 THL W200
I always thought there was an option to tell it, actually i do have some form of recovery installed thanks.

  • 0

#36
flibblesan

flibblesan

    Token Northern bloke

  • Assistant Admin Team
  • PipPipPipPipPipPip
  • 5,640 posts

I always thought there was an option to tell it, actually i do have some form of recovery installed thanks.


Yes there is but if I remember right it doesn't let you access recovery or make backups if you use this option.. unless it changed? Sebastian404 may sort his own recovery manager out soon.

  • 0

#37
bumps

bumps

    Enthusiast

  • Members
  • PipPipPip
  • 241 posts
  • Gender:Male
  • Location:S.Wales
  • Devices:Huawei G300, Desire Z
anyone got a problem of when you power the phone off with usb plugged in CWM automatically comes on

Edited by bumps, 03 May 2012 - 05:22 PM.

  • 0

#38
Sebastian404

Sebastian404

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 2,104 posts
  • Gender:Male
  • Location:Somwhere Near Mountain View, California
  • Devices:lots of them
  • Twitter:@sebastian404

anyone got a problem of when you power the phone off with usb plugged in CWM automatically comes on


Thats a 'common' problem with all the Huawei devices I've seen, I have a feeling its something to do with the broken implmentation of a charging animation when powered off.

  • 0

#39
bumps

bumps

    Enthusiast

  • Members
  • PipPipPip
  • 241 posts
  • Gender:Male
  • Location:S.Wales
  • Devices:Huawei G300, Desire Z
yup you are right, did a little research on google. common bug when any phone has a charging animation with its original recovery.img

  • 0

#40
Rednose01

Rednose01

    Newbie

  • Members
  • Pip
  • 34 posts
OK having spent the last 3 hours going round in circles im am about to give up. I have never atempted anything like this.
I have managed to root the phone which i think went OK i can see SU installed.

So now i want to ClockworkMod it.
I followed the link and have installed Android SDK. and downloaded the file "Recovery image"
Where i am getting stuck is the Command Prompt run 'fastboot flash recovery <filename>.img.
Where does the fastboot bit come in, is this a seperate download?
Then What, run that and then type "Recovery"?

I am a noob, be gentle!

Carl..

  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users