Jump to content


Photo

Voice apps using the loud speaker instead of the earpiece

- - - - -

  • Please log in to reply
14 replies to this topic

#1
mentar

mentar

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Devices:Huawei Ascend G300
  • Twitter:@mentarus
Hi all,
This problem has been driving me mad and after a lot of googleing I finally decided to pick the minds of people on this forum.
Basically normal calling with inbuilt caller works fine, but when calling with any voip apps like Viber/Skype/Nimbuzz/SipDroid the audio is coming out of the loudspeaker and not the earpiece one :S
This was the problem on the stock rom and the MoDaCo Custom ROM Gr2, what's even weirder I had the same problems on my previous phone, the ZTE Blade :S

Anyone have any ideas? Or am I just stupid (never found the options to change the audio out channel)
Thanks for looking!

  • 0

#2
devee

devee

    Newbie

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Devices:G300, Blade
Strange, I also have a Blade but all my voip Apps work perfectly on the G300. I use SipDroid,Freecall and skype....
Currently running B888

  • 0

#3
Hogweed

Hogweed

    Diehard

  • Members
  • PipPipPipPip
  • 392 posts
  • Devices:Huawei Ascend G300
I use the official sipgate android app and call audio definitely comes out of the headphones if plugged in. Was thinking about downloading sipdroid as the sipgate app seems a bit buggy (but it is usable).

  • 0

#4
runlevel5

runlevel5

    Enthusiast

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
  • Location:Yorkshire
  • Interests:mtb-xc, tech, nites out, music, all sorts of stuff :-)
  • Devices:Nexus 5 32GB
  • Twitter:@@36ctJack
never use voip , but there is a thread on here detailing people's woes with Skype, no specific mention of your loudspeaker issue tho...

sorry I cannot be more help.

  • 0

#5
devee

devee

    Newbie

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Devices:G300, Blade
@ Hogweed

I have no problems with Sip droid....only buggy thing is the bluetooth headset implementation, but it is listed as in development.
The Freecall App in market is very good though

  • 0

#6
skull_fcuk

skull_fcuk

    Regular

  • Members
  • PipPip
  • 107 posts
  • Gender:Male
  • Location:scotland
  • Interests:Playing with gadgets, trying to get fit. Lol.
  • Devices:TF300t, Galaxy SIII
  • Twitter:@BigFairbairn
happens for me also, and on my blade too. I remedy this by turning down the call volume and flipping the phone over and putting the speaker to my ear.
Works great, until i get a notification, at which point the other side of my head explodes!

WTF Skype??

  • 0

#7
tillaz

tillaz

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 5,836 posts
  • Gender:Male
  • Location:R* North
  • Interests:ET Life
  • Devices:Moto G

  • 0

#8
RussellS

RussellS

    Diehard

  • Members
  • PipPipPipPip
  • 452 posts
  • Gender:Male
  • Location:Hampshire, UK
  • Devices:Blade, Huawei G300, Jiayu G3

Hi all,
This problem has been driving me mad and after a lot of googleing I finally decided to pick the minds of people on this forum.
Basically normal calling with inbuilt caller works fine, but when calling with any voip apps like Viber/Skype/Nimbuzz/SipDroid the audio is coming out of the loudspeaker and not the earpiece one :S
This was the problem on the stock rom and the MoDaCo Custom ROM Gr2, what's even weirder I had the same problems on my previous phone, the ZTE Blade :S

Anyone have any ideas? Or am I just stupid (never found the options to change the audio out channel)
Thanks for looking!

When actually in the call you can change it between earpiece & rear speaker with the second icon at the bottom of the screen as shown in this screenshot:
Posted Image

However, on mine it seems to default to the earpiece and you have to change it to the speaker if you need to the same as a normal call which seems to be the opposite to your phone.

I'm running the Huawei B888 rom.

Edited by RussellS, 30 June 2012 - 07:31 AM.

  • 0

#9
mentar

mentar

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Devices:Huawei Ascend G300
  • Twitter:@mentarus
Ooops didn't realised the defaults were to NOT get notified on new posts, sorry for the late reply.

When actually in the call you can change it between earpiece & rear speaker with the second icon at the bottom of the screen as shown in this screenshot:

Thanks, I'm aware of that, but in both instances the sound goes to the speakerphone on the back. Weird!

have a look here
http://www.modaco.co...viberskype-fix/

Thanks, but the "FM radio" force closes, wonder if my rom got corrupted somehow, just strange that using different roms or even devices doesn't solve the problem, must be an app I have installed is doing this :S

sorry I cannot be more help.

Thanks for trying :)

Guess I'll just have use a headset when using any voip service as that seems to work fine, Android has let me down here :(
Thanks for your input though peeps, much appreciated!

  • 0

#10
RussellS

RussellS

    Diehard

  • Members
  • PipPipPipPip
  • 452 posts
  • Gender:Male
  • Location:Hampshire, UK
  • Devices:Blade, Huawei G300, Jiayu G3
I don't think it is Android that has let you down here. I think it must just be a bug in the rom as mine switches fine between earpiece & speaker on the B888 rom.

  • 0

#11
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
This issue was on the Zte Blade, there was a rep on from one of those voip providers and I still don't think they could fix it as they don't didbt have a device to test it with.

  • 0

#12
weckl

weckl

    Enthusiast

  • Members
  • PipPipPip
  • 237 posts
  • Devices:Huawei Ascend G300
Just update the ROM at least up to B892 and problem solved.

  • 0

#13
RussellS

RussellS

    Diehard

  • Members
  • PipPipPipPip
  • 452 posts
  • Gender:Male
  • Location:Hampshire, UK
  • Devices:Blade, Huawei G300, Jiayu G3

Just update the ROM at least up to B892 and problem solved.

Doesn't even need to go that far, B888 works fine as well.

  • 0

#14
mentar

mentar

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Devices:Huawei Ascend G300
  • Twitter:@mentarus

Doesn't even need to go that far, B888 works fine as well.

B888 is what I have!

  • 0

#15
fedakim

fedakim

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:U8230
Hi, I had that problem with some devices i had, specially with some older devices. So we made our own softphone that routes audio correctly. Give it a try:
https://play.google....tanvoxphonefree

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users