Jump to content


Photo

How to improve Wi-fi range altough doing these decrease battery

- - - - -

  • Please log in to reply
6 replies to this topic

#1
weckl

weckl

    Enthusiast

  • Members
  • PipPipPip
  • 237 posts
  • Devices:Huawei Ascend G300
All credit to Lishuo !

http://bbs.anzhi.com...359080-1-1.html

Google Translation:


RE Manager to enter the system \ wifi directory mounted read-write


To open nvram.txt find pa0maxpwr = 66 (the official default 66) the value changed to any value within 66 to 100, the higher the value, the greater the power to modify completed remember to save. The open nvram_MSM8255_C8860.txt to find pa0maxpwr = 76 (the official default 76) the value changed to any value within 76 to 100, the higher the value, the greater the power to modify completed remember to save.
Improve the value to change the big WIFI coverage to improve the network speed, but power consumption when using WIFI is equally rapid increase
any questions welcome to I the microblogging Feedback: lishuo0427
the way recommended I the ICS ROM: July 13 [lishuo0427] official ICS-B926 〓 personal Ultimate service pack 2.52 〓

  • 0

#2
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
So obviously lowering the number should conserve power? I was attempting this yesterday with a market app, not sure it worked though

  • 0

#3
FrankieADZ

FrankieADZ

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,255 posts
be interesting to see if anyone gets this to work

  • 0

#4
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
I followed this guide although I used a different iwconfig.

http://jhanford.word...wer-in-android/

There is then a market app which can set the power from 4-32 dbm. It didn't appear to work for me and while I have iwconfig, adb can't see it

  • 0

#5
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
Changed mine to 10 and 26 with no slowdowns or ill affects next to the router and I still have full coverage. If coverage drops when upstairs, I will report back.

  • 0

#6
jikobutsu

jikobutsu

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,704 posts
  • Gender:Male
  • Devices:OSD
I cannot get mount/sdcard to work, no such file or directory ? is it named different on g300 ? like sdcard2 ?

edit: got it, no need to add mount in the command so, cd /sdcard

Strange, when I run iwconfig I see no values ?

Attached Files


Edited by jikobutsu, 15 July 2012 - 09:42 PM.

  • 0

#7
Davidoff59

Davidoff59

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,317 posts
  • Gender:Male
  • Devices:Orange San Francisco, G300
That's what I got jiko. I think the WiFi chip has to support it bit it appears that its already there so I didn't have to add it as I did previously.
As an update, there is no drop in signal with my set values from above. Hard to know if it actually works as my setting is considerably lower than stock and I am 3 stories up with good signal.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users