Jump to content


Photo

CM9 Device Tree, thanks to ArCee

- - - - -

  • Please log in to reply
15 replies to this topic

#1
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E
https://github.com/C...device_lge_e400

anyone got the chance to build this?

  • 0

#2
jomkingal

jomkingal

    Newbie

  • Members
  • Pip
  • 20 posts
wow! i hope it works. :) looking forward to a cm working on lg optimus l3 e400. :) good luck to us! :)

  • 0

#3
kgdhost

kgdhost

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Königsberg
  • Devices:LG Optimus L3 E400

https://github.com/C...device_lge_e400

anyone got the chance to build this?

I tried to build. The first steps: ./extract-files.sh, receive a warning that a files is missing:
remote object '/system/lib/hw/lights.msm7x27a.so' does not exist
remote object '/system/lib/hw/sensors.e0.so' does not exist
508 KB/s (43504 bytes in 0.083s)
4797 KB/s (1844096 bytes in 0.375s)
1749 KB/s (192544 bytes in 0.107s)
1037 KB/s (96896 bytes in 0.091s)
168 KB/s (13712 bytes in 0.079s)
14 KB/s (1156 bytes in 0.079s)
113 KB/s (9220 bytes in 0.079s)
remote object '/system/lib/libC2D2.so' does not exist
1353 KB/s (259804 bytes in 0.187s)
500 KB/s (42720 bytes in 0.083s)
remote object '/system/lib/libsc-a2xx.so' does not exist
2429 KB/s (162184 bytes in 0.065s)
3190 KB/s (559904 bytes in 0.171s)
3127 KB/s (497840 bytes in 0.155s)
1018 KB/s (58552 bytes in 0.056s)
remote object '/system/lib/hw/camera.msm7x27a.so' does not exist
105 KB/s (8586 bytes in 0.079s)
failed to copy '/system/etc/firmware/wlan/volans/WCN1314_qcom_wlan_nv.bin' to '../../../vendor/lge/e400/proprietary/etc/firmware/wlan/volans/WCN1314_qcom_wlan_nv.bin': Permission denied
1174 KB/s (134008 bytes in 0.111s)
failed to copy '/system/etc/firmware/wlan/volans/WCN1314_qcom_cfg.ini' to '../../../vendor/lge/e400/proprietary/etc/firmware/wlan/volans/WCN1314_qcom_cfg.ini': Permission denied
494 KB/s (42216 bytes in 0.083s)
1187 KB/s (115992 bytes in 0.095s)
168 KB/s (13708 bytes in 0.079s)
330 KB/s (28188 bytes in 0.083s)
65 KB/s (5288 bytes in 0.079s)
4908 KB/s (1968016 bytes in 0.391s)
64 KB/s (5256 bytes in 0.079s)
799 KB/s (38060 bytes in 0.046s)
1527 KB/s (155440 bytes in 0.099s)
342 KB/s (29216 bytes in 0.083s)
807 KB/s (38304 bytes in 0.046s)
1039 KB/s (97164 bytes in 0.091s)
116 KB/s (9496 bytes in 0.079s)
1159 KB/s (58768 bytes in 0.049s)
431 KB/s (36848 bytes in 0.083s)
167 KB/s (13592 bytes in 0.079s)
65 KB/s (5352 bytes in 0.079s)
4277 KB/s (1136192 bytes in 0.259s)
115 KB/s (9368 bytes in 0.079s)
414 KB/s (35360 bytes in 0.083s)
353 KB/s (30064 bytes in 0.083s)
941 KB/s (88160 bytes in 0.091s)
264 KB/s (22592 bytes in 0.083s)
1802 KB/s (198384 bytes in 0.107s)
116 KB/s (9448 bytes in 0.079s)
393 KB/s (33652 bytes in 0.083s)
927 KB/s (86836 bytes in 0.091s)
850 KB/s (76324 bytes in 0.087s)
121 KB/s (9840 bytes in 0.079s)
607 KB/s (51880 bytes in 0.083s)
118 KB/s (9616 bytes in 0.079s)
66 KB/s (5376 bytes in 0.079s)
2385 KB/s (321248 bytes in 0.131s)
4241 KB/s (1178300 bytes in 0.271s)
477 KB/s (42672 bytes in 0.087s)
1244 KB/s (131760 bytes in 0.103s)
2551 KB/s (203088 bytes in 0.077s)
766 KB/s (38528 bytes in 0.049s)
355 KB/s (30320 bytes in 0.083s)
984 KB/s (96048 bytes in 0.095s)
1207 KB/s (127664 bytes in 0.103s)
1607 KB/s (189824 bytes in 0.115s)
523 KB/s (46828 bytes in 0.087s)
remote object '/system/lib/libOmxIttiamVdec.so' does not exist
1621 KB/s (185072 bytes in 0.111s)
768 KB/s (38528 bytes in 0.048s)
355 KB/s (30320 bytes in 0.083s)
957 KB/s (93472 bytes in 0.095s)
749 KB/s (38636 bytes in 0.050s)
386 KB/s (17832 bytes in 0.045s)
262 KB/s (22364 bytes in 0.083s)
481 KB/s (43008 bytes in 0.087s)
768 KB/s (38528 bytes in 0.048s)
307 KB/s (26208 bytes in 0.083s)
723 KB/s (67852 bytes in 0.091s)
1609 KB/s (100956 bytes in 0.061s)
165 KB/s (13372 bytes in 0.079s)
Added the files from the CM9 from the other device. Firmware build and even installed on the smartphone. But then the white screen does not work.
Sorry my english :)
http://www.multiupload.nl/LD63OM7L00 NOT WORK...

Edited by kgdhost, 25 August 2012 - 05:56 PM.

  • 0

#4
tony_secreto

tony_secreto

    Newbie

  • Members
  • Pip
  • 12 posts
Thanks, great job.
How long time to have a cyanogenmod for E400??
:D

  • 0

#5
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E
ha you beat me kgdhost, found all missing prop files apart from /system/lib/libOmxIttiamVdec.so

if you are getting a white screen, does adb work, can you grab a logcat?

  • 0

#6
tony_secreto

tony_secreto

    Newbie

  • Members
  • Pip
  • 12 posts
I can try to install new experimental roms.

  • 0

#7
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E
i'm still downloading it, may be running "fix permissions" in recovery after installing cm9 fixes the white screen issue

  • 0

#8
tony_secreto

tony_secreto

    Newbie

  • Members
  • Pip
  • 12 posts
Don´t work. White screen always.

  • 0

#9
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E
thanks for testing tony_secreto

pastebin of build.prop http://pastebin.com/AdhNgdTw

why why why is it using mdp composition not gpu composition in build.prop

  • 1

#10
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E
logcat of error is here: http://pastebin.com/7AxKpE4G

  • 0

#11
tony_secreto

tony_secreto

    Newbie

  • Members
  • Pip
  • 12 posts
Thanks for your dedication for this theme hecatae.

  • 0

#12
tilal6991

tilal6991

    Hardcore

  • Developer Team
  • PipPipPipPipPipPip
  • 3,781 posts
  • Gender:Male
  • Devices:ZTE Skate, Huawei U8150
Your kernel doesn't have genlock. It needs backporting.

  • 0
If you like my work or if I helped, click the Plus button.

#13
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E

Your kernel doesn't have genlock. It needs backporting.


thank you, will have a look at this then https://github.com/C...0f67d36a8a96c73

  • 0

#14
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E
CM9 Preview for Lg Optimus L3 has been sitting on Rom Manager since yesterday, downloadable from here http://developer.clo...FICIAL-e400.zip

  • 0

#15
OppiFjell

OppiFjell

    Newbie

  • Members
  • Pip
  • 17 posts
  • Devices:LG L3 e400

CM9 Preview for Lg Optimus L3 has been sitting on Rom Manager since yesterday, downloadable from here http://developer.clo...FICIAL-e400.zip



Some screenshots please? :)

Thanks for this awesome work!!!

Edited by OppiFjell, 26 August 2012 - 05:00 PM.

  • 0

#16
hecatae

hecatae

    Hardcore

  • Moderator Team
  • PipPipPipPipPipPip
  • 3,245 posts
  • Gender:Male
  • Location:northampton
  • Devices:Moto E

Some screenshots please? :)

Thanks for this awesome work!!!


New thread to discuss it is here: http://www.modaco.co...ptimus-l3-e400/

it's from CM's arcee, the main LG dev for CM

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users