Jump to content


Photo

Dead Acer Liquid E

- - - - -

  • Please log in to reply
1 reply to this topic

#1
Sexy.Devil

Sexy.Devil

    Newbie

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Devices:Acer Liquid E Ferrari
Hello, I have an Acer Liquid E Ferrari Special Edition.
Android Eclair.
I wanted to upgrade it to Froyo. I downloaded it from the acer website. It was OS_Acer_4.005.04.AAP.G2F_A22F_LiquidE Ferrari. Used the Acer Liquid Tool Setup Wizard. The upgrade stopped after sometime and asked me to "Remove the battery for 10 seconds. Turn on your Acer and connect it to a PC". I followed but the upgrade again stopped after 50% with the same instruction.
Now my phone is completely blank. When I press the power button it vibrates once and nothing happens. I tried Power + Vol. Down + Camera, it vibrates 3 times then released these 3 buttons and again Power + Camera. But still nothing happens.
I cannot get into Recovery.
I tried to flash it with Acer A1 DL Tool. It starts to flash but a pop up comes out "connect to pc"
My phone is not rooted.
Please find a way out !!..
Please help me.

  • 0
Everything Balances.
• »тнể●๋•کểxý●๋• ●๋•d€√!ℓ♥●๋•™

#2
Diljeet

Diljeet

    Enthusiast

  • Members
  • PipPipPip
  • 272 posts
  • Gender:Male
  • Location:Acer Liquid Modaco Forum
  • Interests:CM7.2 - CM9 - CM10
  • Devices:Acer Liquid A1
if your problem is not solved then may be i can give you another acer download tool, which is a new version of acer A1 download tool.
And you can try that, it may be the problem of rom you downloaded.

Edited by Diljeet, 28 September 2012 - 05:47 PM.

  • 0
@Developers: Thanks for your hard work




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users