Jump to content


Photo

CIDotW - ZTE V970

- - - - -

  • Please log in to reply
29 replies to this topic

#21
whettingstone

whettingstone

    Newbie

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Devices:Huawei Ascend Y300
I recieved this phone yesterday and I must say that I am impressed with it. It cost me $220 and I got specs comparable to phones way more expensive.

The first thing that struck me is how light it is. When I compare to my old ZTE Blade it feels like it's lighter eventhough it's quite a bit larger. Everything is snappy and I haven't had any problems when installing apps so far. I ordered mine from etotalk with their custom ROM so I got play store installed and all chinese apps removed.

The only problem I've had so far is that the phone thinks that I am roaming. I use the SIM from my old phone (bought in Sweden) that both works perfectly and does not consider me roaming. The new phone lets me surf but only if I say "Allow roaming on mobile network". Anyone who has any knowledge about this? APN settings are same as on my old phone. Are there any country settings or such that I should set? It might believe that the phone's "home country" is China?
I also haven't been able to do a backup using etotalks custom recovery. It seems to hang on "Backing up boot image", this could be that I didn't wait long enough though.

I'll come back with more information when I've had some time to use the phone.

EDIT: I changed my IMEI numbers from 86** to 35** but it still says roaming. My provider sent me an SMS with APN information though. I choose that APN but still roaming.

Edited by whettingstone, 23 October 2012 - 09:24 AM.

  • 0

#22
longo213

longo213

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:ZTE Blade
  • Twitter:@longo213

The only problem I've had so far is that the phone thinks that I am roaming. I use the SIM from my old phone (bought in Sweden) that both works perfectly and does not consider me roaming. The new phone lets me surf but only if I say "Allow roaming on mobile network". Anyone who has any knowledge about this?

Anychance your provider is using MVNO network? I noticed someone mentioned an issue with MVNO networks in XDA thread about V970.

  • 0

#23
whettingstone

whettingstone

    Newbie

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Devices:Huawei Ascend Y300

Anychance your provider is using MVNO network? I noticed someone mentioned an issue with MVNO networks in XDA thread about V970.


I checked with my provider and they don't use MVNO.
Thanks though.

  • 0

#24
slowlydownwards

slowlydownwards

    Newbie

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Devices:ZTE V970
Just got this phone. How do I sideload Google Play Store?

Edit: Got it. Flashing sequence for cwm is a bit particular, but got it in the end.
http://forum.xda-dev...d.php?t=1856578

  • 0

#25
jimac

jimac

    Newbie

  • Members
  • Pip
  • 40 posts
  • Devices:ZTE Blade + SE W995
Hello chaps!

How is the battery life? :)
How is the screen in sunlight and is the GPS functionality OK?

cheers!

J

Edited by jimac, 25 October 2012 - 01:39 PM.

  • 0

#26
Holehouse

Holehouse

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:England
  • Devices:Motorola Moto G
Can someone who has the phone tell me if it has an FM radio?

Thanks

  • 0

#27
whettingstone

whettingstone

    Newbie

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Devices:Huawei Ascend Y300
@jimac: Note that I've only had the phone for less than a week and that I am currently running it on only one SIM.

Battery seems to be on par with most modern smartphones that does not have obscenely huge batteries, meaning that you have to charge it every night with a moderate to heavy usage. If you use it very little I guess it could go up to 1½-2 days but that'd mean very sparse usage.

I've not had any issues so far with the GPS but admittedly I've only used it 3-4 times so far. It seems accurate and has a reasonably quick lock.

@Holehouse: It does. I haven't tested it yet though.

  • 1

#28
jimac

jimac

    Newbie

  • Members
  • Pip
  • 40 posts
  • Devices:ZTE Blade + SE W995
Thanks! I think I will give it a whirl then. :)

  • 0

#29
jimac

jimac

    Newbie

  • Members
  • Pip
  • 40 posts
  • Devices:ZTE Blade + SE W995
ordered. :) paid for DHL, hopefully will be here in a week or so.

  • 0

#30
jimac

jimac

    Newbie

  • Members
  • Pip
  • 40 posts
  • Devices:ZTE Blade + SE W995
UPDATE - There are a few custom ROMs now, the Jellybean ROM on XDA is fantastic.
All things considered, the phone is great.

There are two things that really bother me though.

That silver bezel is painted on and easily damaged. Mine is looking quite tatty now.
The "textured" back is also fairly easily marked.

Other than that, it is a fantastic bit of kit for the money!

Now waiting for my next bargain Chinese purchases of and Umi x2 and Pipo M9 Max (3G version) to be dispatched!
Also considering a Cube U30GT2 - but will wait for some reviews before ordering as I'm concerned about the screen quality and how the Mali400 copes with the resolution.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users