Jump to content


Photo

why my blade is so slow with cm9 or cm10 vs cm7?

- - - - -

  • Please log in to reply
14 replies to this topic

#1
luisfeser

luisfeser

    Newbie

  • Members
  • Pip
  • 35 posts
Sorry about this offtopic, but i have seen this video where you can see how perform cm9 and cm10



And my blade is realy slow compared with that!! with cm7 my phone works great, but with cm9/10 is realy slow. Open menus is anoying, and when i want to write i get desesperate. And always back to cm7

Can be because a i have a gen1 --> gen2 blade?

Any idea what can be?

Thank you.

  • 0

#2
jventura

jventura

    Diehard

  • Members
  • PipPipPipPip
  • 454 posts
  • Gender:Male
  • Location:Portugal
  • Devices:ZTE Blade
Maybe you have a chinese ZTE Blade with only 256MB RAM?

  • 0

#3
Lister Of Smeg

Lister Of Smeg

    Diehard

  • Members
  • PipPipPipPip
  • 387 posts
  • Devices:ZTE Blade (San Fran)
Hi luisfeser,

I am in the same boat / situation as you.... My phone is just to slow for daily use... :( However what you got to take into account is our phones are like 3yrs old now, and werent designed for this kinda of you. They werent even designed to go above Froyo (back in the Android 2.1 days). So getting CM7 (Gingerbread, Android 2.3.x) is a bonus....

.... and then to get anything above that, CM9 / Ice Cream Sandwich - Android 4.0.x or CM10.x Jelly Bean - Android 4.1.x / 4.2.x is an even greater bonus.

CM9 and CM10 require far much more memory than what the Blade has, or can use efficiently. Not only that, but depends whats installed on your phone as compared to the review. My phone is amazingly fast running CM10.1 without any Apps, but as soon as you install Apps to make it into a Smartphone, it soon becomes a SlowPhone.

So your prolly better to either stick with CM7 or think about upgrading handset (which is what I am going to be doing).

Cheers, Lister

  • 0

#4
luisfeser

luisfeser

    Newbie

  • Members
  • Pip
  • 35 posts
I have an European blade with 512 ram joaoventura.

Lister, i agree with you, but why other "same " blades works better than ours if are the same machine?

I can't understand


  • 0

#5
De@n

De@n

    Addict

  • Members
  • PipPipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:UK
  • Devices:Xperia S & Blade
Not this Again >_>

  • 0

#6
jventura

jventura

    Diehard

  • Members
  • PipPipPipPip
  • 454 posts
  • Gender:Male
  • Location:Portugal
  • Devices:ZTE Blade

I have an European blade with 512 ram joaoventura.


Maybe you are expecting too much of your phone?! Mine isn't also as fast as that in the video..
You have always my Eco CM7 which is very fast and relatively updated: http://www.modaco.co...list-cm7-build/

  • 0

#7
luisfeser

luisfeser

    Newbie

  • Members
  • Pip
  • 35 posts

Maybe you are expecting too much of your phone?! Mine isn't also as fast as that in the video..
You have always my Eco CM7 which is very fast and relatively updated: http://www.modaco.co...list-cm7-build/


Yes, i know it. I make my own rom very very clean and i use your proprietary repo ;).

But i wanted a navbar (like some cm10) cause my back button is failing a bit, and i don't know how to do in cm7

  • 0

#8
ZTR

ZTR

    Enthusiast

  • Members
  • PipPipPip
  • 259 posts
  • Gender:Male
  • Location:India
  • Devices:Galaxy S i9000,Dell XCD 35
  • Twitter:@Zakitheracer
You could try CyanMobile which is basically CM7 with tons of tweaks and addons and it also has navbar just like ICS ;)

  • 0
ROM:CM10.1 KonstaKANG 24/07/13
Recovery:CWM 6.0.2.7

#9
styrofoam

styrofoam

    Regular

  • Members
  • PipPip
  • 121 posts
  • Gender:Female
  • Location:France
  • Devices:Huawei G300
I'm CM10 with TSF Shell launcher and my phone is an iPhone! :blush: :P :D

  • 0

#10
HDuser

HDuser

    Enthusiast

  • Members
  • PipPipPip
  • 268 posts
  • Devices:Zte blade

Sorry about this offtopic, but i have seen this video where you can see how perform cm9 and cm10

http://vimeo.com/49987976

And my blade is realy slow compared with that!! with cm7 my phone works great, but with cm9/10 is realy slow. Open menus is anoying, and when i want to write i get desesperate. And always back to cm7

Can be because a i have a gen1 --> gen2 blade?

Any idea what can be?

Thank you.

I face same thing. Basically CM9 and specially CM10/.1 uses a lots of ram to show more polished UI and there are few special services and features in CM10/.1 i.e. google now etc which also takes ram. Polished UI requires CPU power. The blades CPU is pretty weak and old (armv6) and is designed for android 2.xx only. I am currently using CM10 because it uses less ram than CM10.1 and is also battery friendly as compared to CM10.1. I would preferably use CM7 but laggy animations destroys mobile experience and also feels bad to eyes. Otherwise CM7 is one of best rom. Now its all up to you. If you want speed and battery life stick with CM7. If you want speed with smooth experience use CM9 because CM9 is much faster than CM10 and CM10.1. If you want to try latest roms with ease of speed then preferably buy a phone with better hardware.
Hope that helps.

I'm CM10 with TSF Shell launcher and my phone is an iPhone! :blush: :P :D

I don't like TSF, Always difficult and time consuming to use.

  • 0

#11
luisfeser

luisfeser

    Newbie

  • Members
  • Pip
  • 35 posts
Thanks for your opinions,

I'm trying cm9, is working so good, i'll give a try.

joaventura, could you import konstat navigation bar to your eco-cm9. I have recompiled eco-cm9 with ics navigation bar enabled and works good, but you can't modify heigh, only buttons.

  • 0

#12
ElrOnDPT

ElrOnDPT

    Newbie

  • Members
  • Pip
  • 31 posts
  • Devices:ZTE Blade
Try this:

Install burstlam's last build of CM 10 and program your phone to restart each morning (disable SIM PIN so the restart is smooth, and make sure the restarts are happening by checking the battery lifespan, which may not show more than 23h awake).

You'll get a fast OS (and i mean really fast) pretty close to state of art :)

The problem with CM10/10.1 is ram management, once you start having services and apps running in background the OS becomes really laggy. Nothing a cold reboot won't solve :)

  • 0

#13
HDuser

HDuser

    Enthusiast

  • Members
  • PipPipPip
  • 268 posts
  • Devices:Zte blade

Try this:

Install burstlam's last build of CM 10 and program your phone to restart each morning (disable SIM PIN so the restart is smooth, and make sure the restarts are happening by checking the battery lifespan, which may not show more than 23h awake).

for that purpose "fast reboot" will work perfect. At the moment im using CM10.1, battery drainage very very high so im reverting back to ICS which is best for ever for me. :)

  • 0

#14
wuiwu

wuiwu

    Regular

  • Members
  • PipPip
  • 54 posts
  • Devices:blade
cm10.1 is better

  • 0

#15
killer99

killer99

    Regular

  • Members
  • PipPip
  • 126 posts
I have the same problem with an europen sf to.
The software was made of mobistar.
Any solutions ?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users