Jump to content


Photo

[GUIDE] How to unbrick the G300

- - - - -

  • Please log in to reply
47 replies to this topic

#1
Stefan1803

Stefan1803

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:-
I've seen so many posts on this site about people who bricked their phones, so i decided to make a post about how to unbrick them.

Before everything, make sure your phone is charged!

I've found 3 situations:

1. Phone stuck at Huawei logo and CWM can be accesed:
  • Enter CWM
  • Wipe Data and Cache
  • Go to mounts & storage -> format \system
  • Go to advanced -> wipe dalvik cache
  • Flash any custom rom you want, but pay attention to the baseband!
2. Phone stuck at Huawei logo and CWM is not accesible:
  • Download the official ICS firmware from Huawei (b952): http://www.huaweidev...softid=NDcwMjk=
  • Put the dload folder on your external SD Card and insert it into your phone
  • While the phone is turned off, press the VolumeUp + VolumeDown buttons at the same time and then press the power button, holding the three at the same time
  • A pink bar should show up and the update procces will start
  • Give it time and when it's ready it should boot on ICS
3. Phone doesn't respond to anything
  • In this case, it might be a dead battery. Replace the battery with anotherone and see if the phone boots. If the phone still doesn't boot, it is a dead phone and you have to send it back to Huawei and ask for a replacement.

Hope this helps the people having trouble with their G300.
Have a good day! :D

  • 4

Current Device: Huawei Ascend G300
Current ROM: Tesla ROM by kyan31

 

I no longer have a Huawei Ascend G300 :( Dropped it in water :(


#2
kieranswhite

kieranswhite

    Diehard

  • Members
  • PipPipPipPip
  • 443 posts
  • Gender:Male
  • Devices:Huawei Acend g300
  • Twitter:@@kieran9969
good guide!! i was thinking about doing one myself the other day. anyone with problems should just post on here instead of making new topics left right and centre

  • 0

#3
sartana

sartana

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Florence
  • Devices:Huawei Ascend G615
  • Twitter:@egoroby
Hi, i have a problem...G300 of my girlfriend don't boot, it's remaining on huwei logo.
Turn it in Recoverry it gaves some errors (can't mount cache/recovery/command - cache/recovery/log) ....i tried to wipe data, cache and dalvik and to flash a new ROM whitout result, anything i try doen't work...i tried also to format sd, but even if it says process done, don't wipe anithing.
Tried to flash another recovery, don't work.

So , it seems that recovery don't work.

I go to the next step, and try to force update of official firmware....put in sd card, force update but....don't apper a pink bar, only an empty bar...so, what' now?

  • 0

"La sapienza è figliola della Sperienza" Leonardo da Vinci


#4
Stefan1803

Stefan1803

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:-

Hi, i have a problem...G300 of my girlfriend don't boot, it's remaining on huwei logo.
Turn it in Recoverry it gaves some errors (can't mount cache/recovery/command - cache/recovery/log) ....i tried to wipe data, cache and dalvik and to flash a new ROM whitout result, anything i try doen't work...i tried also to format sd, but even if it says process done, don't wipe anithing.
Tried to flash another recovery, don't work.

So , it seems that recovery don't work.

I go to the next step, and try to force update of official firmware....put in sd card, force update but....don't apper a pink bar, only an empty bar...so, what' now?


At first you don't have to format the SD Card, you have to format system.

If you want to install a new recovery and CWM doesn't allow you, flash another one through fast-boot, like you have flashed CWM for the first time.

To force update your phone you must make sure the dload folder is on the root of the SD. If this still doesn't give you any result, put the dload folder (with the update file inside) in your internal storage. It seems this worked for some.

  • 1

Current Device: Huawei Ascend G300
Current ROM: Tesla ROM by kyan31

 

I no longer have a Huawei Ascend G300 :( Dropped it in water :(


#5
sartana

sartana

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Florence
  • Devices:Huawei Ascend G615
  • Twitter:@egoroby
I tried to format System, and then when nothing seems to be done also sd card, whitout result because i can see that every file and folder is stiil there.

Tryed to flash trough fast-boot but gives error in writing image.


dload folder in in root of sd, but nothing happen. inside i read the log, and there is always the same errore, can't read or write sd .

how can i put dload folder in internal sd card? It has CWM 5.0.2.8, and seems that don't have a filemanager, and i can mount usb storage only whit external sd.

  • 0

"La sapienza è figliola della Sperienza" Leonardo da Vinci


#6
Stefan1803

Stefan1803

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:-

I tried to format System, and then when nothing seems to be done also sd card, whitout result because i can see that every file and folder is stiil there.

Tryed to flash trough fast-boot but gives error in writing image.


dload folder in in root of sd, but nothing happen. inside i read the log, and there is always the same errore, can't read or write sd .

how can i put dload folder in internal sd card? It has CWM 5.0.2.8, and seems that don't have a filemanager, and i can mount usb storage only whit external sd.


Oh yeah, silly me :D You can't put it on the internal storage (as far as I know)

Well, it seems that the SD Card can't be read or write (as you said). First, try entering CWM and mount SD Card and then try again the force update. If still no result, try with another SD Card or format this one with a PC or with another android phone (recommended) because PC has multiple options of formating and some may be not accepted by your girlfriend's G300. Then put the dload folder with the update file inside on the SD Card and try again. If this still doesn't work... well... i've never experienced something like this, so ideas from other Modaco users will be good. But first try what I said because this seems to be a SD Card problem, which can't be read or written.

  • 1

Current Device: Huawei Ascend G300
Current ROM: Tesla ROM by kyan31

 

I no longer have a Huawei Ascend G300 :( Dropped it in water :(


#7
tonystark03

tonystark03

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:The Amazing HUAWEI G300
bricked my phone today... but thanks to your guide now it's unbricked!!! my phone got stuck at huawei logo and didn't enter CWM, so i followed your second situation and worked!! :D i just put the dload folder from that site on my sd, put it in my phone and force update. everything worked very good! i flashed CWM again and now i am using Lighting ROM by kyan, and it works with no problems :D thanks so much for the guide!

  • 1

#8
sartana

sartana

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Florence
  • Devices:Huawei Ascend G615
  • Twitter:@egoroby

Oh yeah, silly me :D You can't put it on the internal storage (as far as I know)

Well, it seems that the SD Card can't be read or write (as you said). First, try entering CWM and mount SD Card and then try again the force update. If still no result, try with another SD Card or format this one with a PC or with another android phone (recommended) because PC has multiple options of formating and some may be not accepted by your girlfriend's G300. Then put the dload folder with the update file inside on the SD Card and try again. If this still doesn't work... well... i've never experienced something like this, so ideas from other Modaco users will be good. But first try what I said because this seems to be a SD Card problem, which can't be read or written.


I tryed to mount sdcard or whaterer folder in CWM (system , cache) whitout result so i think that it's not External sd card problem cause when i try to restore Backup CWM let me see al files in.

I think it' internal Sdcard related, in fact also whitout Sd card gives me the same error when i try to use fastboot to install recovery.


But the strange is that if i select "install zip from internal sd card" it see al my folder on sdcard. Maybe it's as said in another 3d, it's a problem in cache folder, or i don't know.

I try to bring in assistence, hoping that in Italy they don't put too much attention on the fact that there is a CWM instead of an original recovery, like they do in other country.

  • 0

"La sapienza è figliola della Sperienza" Leonardo da Vinci


#9
Stefan1803

Stefan1803

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:-

I tryed to mount sdcard or whaterer folder in CWM (system , cache) whitout result so i think that it's not External sd card problem cause when i try to restore Backup CWM let me see al files in.

I think it' internal Sdcard related, in fact also whitout Sd card gives me the same error when i try to use fastboot to install recovery.


But the strange is that if i select "install zip from internal sd card" it see al my folder on sdcard. Maybe it's as said in another 3d, it's a problem in cache folder, or i don't know.

I try to bring in assistence, hoping that in Italy they don't put too much attention on the fact that there is a CWM instead of an original recovery, like they do in other country.


So...it's a problem with the internal partitions of the phone. That means that each of them (cache, data, system...) must be formatted, but you said CWM isn't formatting them. If you find a way to format them, it's very possible to work then. I don't know another method except CWM. You may try going to send it back to Vodafone, they may repair it or give you a replacement. But if you are going to do this, don't mention that you have rooted, installed CWM..etc... because it may cost you. But they may still find your CWM there. You just have to hope they don't find out.

Good luck! :D

  • 0

Current Device: Huawei Ascend G300
Current ROM: Tesla ROM by kyan31

 

I no longer have a Huawei Ascend G300 :( Dropped it in water :(


#10
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300
Over the weekend my phone bricked itself, (Daz'sjellybean) apps wouldn't open so I rebooted and arrived at the white flash screen with chinese writing (I had a early g300 from vodafone and flashed using the first available method)

I can't enter clockwork mod (latest touch version) at present i've tried method number 2 in the original post with 2 different sd cards with the same result - pink bar fills, but only to a third then nothing else no writing or nothing.

I'm going to redownload the file and hopefully that will work,but if someone can point me in what I'm doing wrong will be gratefully recieved.

  • 0

#11
Stefan1803

Stefan1803

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:-

Over the weekend my phone bricked itself, (Daz'sjellybean) apps wouldn't open so I rebooted and arrived at the white flash screen with chinese writing (I had a early g300 from vodafone and flashed using the first available method)

I can't enter clockwork mod (latest touch version) at present i've tried method number 2 in the original post with 2 different sd cards with the same result - pink bar fills, but only to a third then nothing else no writing or nothing.

I'm going to redownload the file and hopefully that will work,but if someone can point me in what I'm doing wrong will be gratefully recieved.


what do you mean by white flash screen with chinese writing? could you post a pic?

  • 0

Current Device: Huawei Ascend G300
Current ROM: Tesla ROM by kyan31

 

I no longer have a Huawei Ascend G300 :( Dropped it in water :(


#12
kieranswhite

kieranswhite

    Diehard

  • Members
  • PipPipPipPip
  • 443 posts
  • Gender:Male
  • Devices:Huawei Acend g300
  • Twitter:@@kieran9969

what do you mean by white flash screen with chinese writing? could you post a pic?

its the chinese splash screen i think

  • 0

#13
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300
Posted Image

That's my normal slalsh screen btw

Edited by crankykick, 21 May 2013 - 08:46 PM.

  • 0

#14
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300
This photo shows how far the it goes before it stops. yes I know my screen dirty!!! but it has a protector on it last for tonight.
Posted Image

  • 0

#15
Stefan1803

Stefan1803

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:-
About the force update that fails: As I have seen in other posts, it seems to be a problem with the IMEI. To install ANY update.app your imei must be 0. I found this topic useful: http://www.modaco.co...teapp-20032013/ but i don't know if it works through fast-boot, but you may try it and see if there are any results. If it doesn't work you may try flashing other original updates from the Huawei site.

  • 0

Current Device: Huawei Ascend G300
Current ROM: Tesla ROM by kyan31

 

I no longer have a Huawei Ascend G300 :( Dropped it in water :(


#16
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300
Thanks for the reply, haven't got time tonight today to give that a whirl but I'll give it a go on Thursday night and let you know the results.

Thanks Again

  • 0

#17
Stefan1803

Stefan1803

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Devices:-

Thanks for the reply, haven't got time tonight today to give that a whirl but I'll give it a go on Thursday night and let you know the results.

Thanks Again


Good luck! :)

  • 0

Current Device: Huawei Ascend G300
Current ROM: Tesla ROM by kyan31

 

I no longer have a Huawei Ascend G300 :( Dropped it in water :(


#18
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300
Hi again tried flashing different files with or without sim card on various memory cards, I can't get that pink line to go any further:(.
Win 7 does not "beep" to say a device has been attatched via usb, so, I can't push clockwork mod on it.

I don't feel like this is going anywhere now sadly, thank you for the help.

  • 0

#19
sharkyo01

sharkyo01

    Enthusiast

  • Members
  • PipPipPip
  • 286 posts
  • Gender:Male
  • Location:Walsall
  • Devices:Raised from the Dead G300 :P

Hi again tried flashing different files with or without sim card on various memory cards, I can't get that pink line to go any further:(.
Win 7 does not "beep" to say a device has been attatched via usb, so, I can't push clockwork mod on it.

I don't feel like this is going anywhere now sadly, thank you for the help.


Have you tried flashing a middle file before you flash the ROM? Also what ROM are you trying to flash to the phone?

  • 0

#20
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300
Files I tried to flash was the one in the original Post and another file i had on the pc both different versions. (update.app)

Sorry but what's a middle file?

  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users