Jump to content


Photo

[GUIDE] How to unbrick the G300

- - - - -

  • Please log in to reply
47 replies to this topic

#41
dalyer

dalyer

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,164 posts
  • Gender:Male
  • Location:Dublin, Ireland
  • Devices:Haier W910, Coolpad F1 8297W

Just to be sure...

 

- make sure that the update.app downloaded correctly - check the MD5 checksim of the zip

- make sure that you have /dload/update.app on the external micro sdcard


  • 0

#42
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300

tried with variety of update.app, but it fails at the second stage.


Edited by crankykick, 25 October 2013 - 01:16 PM.

  • 0

#43
crankykick

crankykick

    Newbie

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Devices:zte blade/ Huawei G300

Success

 

all thanks to

Mamuvamjebem

 

Thank you

 

and thanks to all who helped me over a long time

 

reflashed the file which he linked to this time included the vendor file this time it worked.

 

A couple of chinese apps are in the vendor file but no play store or any google apps


Edited by crankykick, 25 October 2013 - 02:36 PM.

  • 0

#44
cryptoncore

cryptoncore

    Regular

  • Members
  • PipPip
  • 133 posts
  • Gender:Male
  • Location:England
  • Interests:Android, Gaming, Computers, Music (Dubstep, Drum and bass, Hard electro) And most other technology related things.
  • Devices:Motorola Moto G, G300

This has worked for me twice now, thank you.  :D


  • 0

"The real problem is not whether machines think but whether men do" - B. F. Skinner
 


#45
landreths

landreths

    Newbie

  • MoDaCo Silver
  • Pip
  • 14 posts
  • Gender:Male
  • Devices:Huawei Ascend G300+

Hello Modaco

I think I have a similar problem to many but am unsure which fix option/road to go down

This is what I have found so far

I bought an G300+ from ebay.com.au and it is running gingerbread 2.3.6 and has a baseband 109808

I have managed to root the phone using instructions from www.huaweig300.com

All of the other instructions were followed and worked ok until the pink bar stopped and 'load failed' while trying to load the official ICS firmware - also the phone froze at this point and needed the battery removed to proceed - the phone restarted again to the old firmware which I guess is good.... The tutorial asked me to copy the 'middle file' into the dload folder onto the phone's sd card overwriting the one that was there and I did so and retried the firmware load

This time the pink bar went quickly further along but again stopped at stage 2/2 displaying 'load fail' and the battery needed to be removed and replaced before it would allow a restart of the phone

BTW - I have also found that I have Samsung memory inside the phone - I am not sure if this has any bearing on anything, but it might...

OK - which fix route do I take???

 

Thanks for your help i advance

 

Steve


Edited by landreths, 20 November 2013 - 01:41 AM.

  • 0

#46
Tippon

Tippon

    Newbie

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Devices:Advent Vega; San Francisco

From what I've seen on this topic, I had almost the same problem. I couldn't acces CWM, so I decided to force official update and the one given here got stuck exsactly where yours did. I also tried those middle files, and they got stuck just as yours. So I tried this http://www.huaweidev...softid=NDE4NjY=, and it worked.

 

Hope that works for you too.

Does anyone have a copy of this file? the site seems to be down at the moment, and my phone's having the same problems as the OP :(


  • 0

#47
dalyer

dalyer

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 2,164 posts
  • Gender:Male
  • Location:Dublin, Ireland
  • Devices:Haier W910, Coolpad F1 8297W
Not sure what it is.
If you need to unbrick have you tried force updating stock ICS B952?
You can get it from the "official bootloader unlock" tutorial thread and elsewhere.

  • 0

#48
Tippon

Tippon

    Newbie

  • Members
  • Pip
  • 33 posts
  • Gender:Male
  • Devices:Advent Vega; San Francisco

Thanks for replying :)

Yeah, I've tried that, as well as several other roms, stock and CM. I've tried switching recovery versions, including stock, and I've tried a few middle files. The current problems are:

I can't boot to recovery, it gives the Huawei logo and lights up the keys after a few seconds, but no matter how long I wait, that's as far as it goes.

Normal boot stops on the Huawei logo.

Any forced update (both volume keys) shows just the progress bar on the screen, and it fills to between one third and half way with pink, with no obvious pattern.

Holding the down volume key stops at the Huawei logo and lets me flash recoveries etc. but it still doesn't make a difference when I try to boot the phone again.

I've got a feeling that I've messed up the filesystem somewhere along the line, and think it's the /system folder. I took a backup through CWM before starting, but the /system section under advanced restore won't restore.

I've got two logs from failed update attempts, but I can't make much sense out of them. I've copied sections of them below. The rest of the file is the same, so I won't clog up the thread.

filename = /mmc1/dload/update.app
call RCV_MODULE_END_EVENT failed,module = OEMSBL_VER_LIST
index 5 not same--old:00,new:40
index 8 not same--old:00,new:02
index 13 not same--old:00,new:08
index 14 not same--old:00,new:10

This continues until:

new partition same as old.

Then the following repeats for a while:

QCSBLHD_CFGDATA fail.
OEMSBL_VER_LIST,is_rx_finish=0,is_operate_succ=1,current_operate=2
call first dload_machine failed,module = QCSBLHD_CFGDATA

Until this which, looking at the log, I think carries over to another attempt, but I'm not sure

OEMSBL_VER_LIST,is_rx_finish=0,is_operate_succ=1,current_operate=2
call dload_machine data process failed,module = QCSBLHD_CFGDATA
CMD=0xf,moduleaddr = 0xf0000000, len_tmp=0x2524
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!
filename = /mmc1/dload/update.app
call RCV_MODULE_END_EVENT failed,module = OEMSBL_VER_LIST
OEMSBL_VER fail.
OEMSBL_VER_LIST,is_rx_finish=0,is_operate_succ=1,current_operate=2
call dload_machine data process failed,module = OEMSBL_VER
OEMSBL_VER fail.

 

With this at the end:

OEMSBL_VER_LIST,is_rx_finish=0,is_operate_succ=1,current_operate=2
call dload_machine data process failed,module = OEMSBL_VER
CMD=0xf,moduleaddr = 0xe9000000, len_tmp=0x19
dload_sd_ram_data_proc->(retry >= DLOAD_RETRY) failed!

If it helps, my wife has the same phone running stock and rooted, so if there's a way to copy files from her phone to mine, I've got a working source and programs that allow me to access the Linux filesystem on a working phone through the PC.

Thanks for any help :)


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users