Jump to content


Photo

Grand X Switzerland (tegra2) CWM Backup data restore

- - - - -

  • Please log in to reply
3 replies to this topic

#1
slewa

slewa

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:ZTE My Surf Pure
Hello MoDaCo Forum!


Couple of weeks ago I bought Grand X (tegra2) in switzerland (the name is here: My Surf Pure, or Mimosa X)
I succesfully rooted my device, and successfully installed CWM recovery with Grand X tool.
The first thing in the CWM I made a backup, and full wipe, (system, data, zteconfig, cache, dalvik cache) after that i tired couple of ROM-s, ie: StarscreamMOD 1.7, ZTE V970V1.0.0 B05 (RU) etc.
But when I try to going back my stock ROM the first thing what I realised, CWM tell me, the MD5 sum mismatch.
I solved this problem, I generated md5, but when I tired to restore my backup, the CWM tell me, cannot restore data, .android.secure, and sd-ext.
After that I wipe everything (system, data, zteconfig, cache, dalvik cache), I choose the advanced restore --> system, it will be successfull, but not perfect, because my bootlogo missing, and bootsound also missing, and when I go to the About phone --> baseband version: Unaviable, Build number --> Unaviable.
I tired to check my build.prop, it is contains my original (stock) details, but in the /zteconfig -->manualfactoryInfo.txt the last part contain my original build number and my last ROM build number also. (P943FV1.0.0B07ZTE V970V1.0.0B05.7) Maybe this cause the unaviable thing in the about phone option...
I tired to delete the last part, but with every reboot, came back...

So my question, can I restore my phone to the stock properly, if I need warranty repair?

Or anybody have switzerland SD card update, it would be best!

I would be thankful for any help

Thanks

Edited by slewa, 06 July 2013 - 01:34 PM.

  • 0

#2
sam tyler

sam tyler

    Diehard

  • Members
  • PipPipPipPip
  • 303 posts
  • Gender:Male
  • Devices:ZTE Blade Gen1 R.B.M.1 Grand X
i had the same problem with c.w.m. recovery, if you look in this topic http://www.modaco.co...le/page__st__80 (last post i gave the answer.) but i didn`t touch any other files. but if you have lost the original ROM that came with the phone you and ZTE for your country wont give the stock ROM,you may have to down load the B05 update ROM the Russian forum that starscream mod ROM is based on. here is a link for the Russian site. http://4pda.ru/forum...=398670&st=2740 i don`t know if ZTE in your country will update your version of the Grand X but ZTE said they wont update it to jellybean and i gave up with it and went back to my trustee ZTE Blade(saving up for a new phone!), as i was forever not receiving texts and e-mails(and some not even turning up!! ) hopefully you know how to install the B05 update ROM via recovery. and maybe some one posted on this forum your version of your stock ROM.

  • 0
Hello?could someone help me with my dead ZTE Blade? as i`m trapped in 1973!

#3
slewa

slewa

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:ZTE My Surf Pure

i had the same problem with c.w.m. recovery, if you look in this topic http://www.modaco.co...le/page__st__80 (last post i gave the answer.) but i didn`t touch any other files. but if you have lost the original ROM that came with the phone you and ZTE for your country wont give the stock ROM,you may have to down load the B05 update ROM the Russian forum that starscream mod ROM is based on. here is a link for the Russian site. http://4pda.ru/forum...=398670&st=2740 i don`t know if ZTE in your country will update your version of the Grand X but ZTE said they wont update it to jellybean and i gave up with it and went back to my trustee ZTE Blade(saving up for a new phone!), as i was forever not receiving texts and e-mails(and some not even turning up!! ) hopefully you know how to install the B05 update ROM via recovery. and maybe some one posted on this forum your version of your stock ROM.


Thanks for your answer.
Actually I exactly coming from B05 from 4pda.ru site.
Is it not to nice.
So actually we got for this device 2 different root method, and one broken cwm recovery. :( (just the wipe and install working)
The ZTE support in here (and also worldwide) is exactly nothing, so I can't download the Switzerland factory image.
My device is working properly, because I successfully restore the system partition (I also had to generate md5sum, but I can restore just the system partition) , just couple of things missing, ergo I've lost my warranty...
It is really strange......

Edited by slewa, 06 July 2013 - 09:50 PM.

  • 0

#4
slewa

slewa

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:ZTE My Surf Pure
But I really don't understand something.... The boot animation and any other stuff what I missing, it's placed on /system or /system/media
So I don't know why cannot restore this things?
Anybody know, how can I extract any useful data from CWM backup folders, and blobs folders? Because, the data what I missed may already in my CWM backup and if I can extract from there I will try to manual push to the right folders.
The most imprtant things for me the for solve the mess about bulid numbers (what i tried to explain my first post), and boot animation & sound.

Edited by slewa, 15 July 2013 - 10:31 AM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users