Jump to content


Photo

Proximity Sensor NOT WORKING ...

- - - - -

  • Please log in to reply
4 replies to this topic

#1
waqas95ali

waqas95ali

    Newbie

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Devices:Huawei Ascend G300
I dropped my Huwaei Ascend G300 a few days ago and now I notice that my proximity sensor is not working so when I called somebody the screen would just go off and never come back on until the call was picked by the other person.
This is quite annoying so could anyone please tell me what I can do to get rid of this ?

Thank You

  • 0

#2
george109

george109

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,105 posts
  • Gender:Male
  • Location:Kent, England
  • Interests:Cycling, Tech and Canoeing
  • Devices:Samsung Galaxy S4 - GT-I9505
You can completely disable the proximity sensor, If you are rooted, then you can download build.prop editor from the play store and then change this line:
gsm.proximity.enabled=true
to:
gsm.proximity.enabled=false
Hope that fixes it :)

Edited by george109, 15 July 2013 - 08:27 PM.

  • 0

Hello. I have an S4 now, and I hardly ever use MoDaCo now. 

Therefore you will receive no replies to any PMs

Please post in the forum instead. You will get more help there :)

:excl:A WARNING TO ALL G300 OWNERS! Please Read! (The Flash Memory Problem!) :excl:

Tutorial: How To (Officially) Unlock Your Bootloader! (The long way, but which definitely works)

Please, Do not use the HuaweiG300.com Tutorial on how to unlock your bootloader, it is better to unlock it officially with my tutorial!

Spoiler

My Device:

Huawei Ascend G300 (U8815) - Sold!

Samsung Galaxy S4 (Black) - The LTE Version - GT-I9505

(Ignore the links above (if there is one). It's a skimwords (advertising) link and nothing to do with me!)

The ROMS I have used:

Spoiler

Download Blink, a great app that controls the status LED on the G300!

Wait for 5 seconds and then click skip ad! Do not download anything in the ad window, that is not the app!

Did I help you?

If I did, Please press the rep_up1.png button, in the bottom right hand corner of my posts.

(If not, Press it anyway!)

If I really helped you, you could also donate to me. Thanks!  :) 


#3
george109

george109

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,105 posts
  • Gender:Male
  • Location:Kent, England
  • Interests:Cycling, Tech and Canoeing
  • Devices:Samsung Galaxy S4 - GT-I9505
*Double Post*

Edited by george109, 15 July 2013 - 08:26 PM.

  • 0

Hello. I have an S4 now, and I hardly ever use MoDaCo now. 

Therefore you will receive no replies to any PMs

Please post in the forum instead. You will get more help there :)

:excl:A WARNING TO ALL G300 OWNERS! Please Read! (The Flash Memory Problem!) :excl:

Tutorial: How To (Officially) Unlock Your Bootloader! (The long way, but which definitely works)

Please, Do not use the HuaweiG300.com Tutorial on how to unlock your bootloader, it is better to unlock it officially with my tutorial!

Spoiler

My Device:

Huawei Ascend G300 (U8815) - Sold!

Samsung Galaxy S4 (Black) - The LTE Version - GT-I9505

(Ignore the links above (if there is one). It's a skimwords (advertising) link and nothing to do with me!)

The ROMS I have used:

Spoiler

Download Blink, a great app that controls the status LED on the G300!

Wait for 5 seconds and then click skip ad! Do not download anything in the ad window, that is not the app!

Did I help you?

If I did, Please press the rep_up1.png button, in the bottom right hand corner of my posts.

(If not, Press it anyway!)

If I really helped you, you could also donate to me. Thanks!  :) 


#4
kyan31

kyan31

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,868 posts
  • Gender:Male
However the build.prop change is only usable on stock based ROMs, so don't try it on CyanogenMod or any other ROM which isn't stock.

  • 0

e2199c4dbb.png823c51b6b0.pngc3f6e04cdb.pngbc36a18046.pngead60d1912.pnge46a22ae54.png

 

Phones: Samsung Galaxy S4 Qualcomm & Huawei Ascend G300

PC: AMD FX 8350 8 CORE 4.2Ghz CPU, 16GB 1600Mhz Kingston HyperX RAM, Gigabyte R9 270X Winforce Edition GPU

Like my work? Hit that +1 button as a thank you! Want to support me? You could consider donating!  :)

Subscribe to my YT Channel: https://www.youtube.com/user/thekyan31


#5
waqas95ali

waqas95ali

    Newbie

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Devices:Huawei Ascend G300

You can completely disable the proximity sensor, If you are rooted, then you can download build.prop editor from the play store and then change this line:

gsm.proximity.enabled=true
to:
gsm.proximity.enabled=false
Hope that fixes it :)


I installed the build.prop editor and searched but found no ' gsm.proximity.enabled ' entry.
The only thing I could find with the word proximity in it was ' ro.config.hw_proximity

What do I do next ?

P.S: I am using Stock +

  • 0

#6
kyan31

kyan31

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,868 posts
  • Gender:Male

I installed the build.prop editor and searched but found no ' gsm.proximity.enabled ' entry.
The only thing I could find with the word proximity in it was ' ro.config.hw_proximity

What do I do next ?

P.S: I am using Stock +


Just change ro.config.hw_proximity to 0/false (depending on the variable).

  • 0

e2199c4dbb.png823c51b6b0.pngc3f6e04cdb.pngbc36a18046.pngead60d1912.pnge46a22ae54.png

 

Phones: Samsung Galaxy S4 Qualcomm & Huawei Ascend G300

PC: AMD FX 8350 8 CORE 4.2Ghz CPU, 16GB 1600Mhz Kingston HyperX RAM, Gigabyte R9 270X Winforce Edition GPU

Like my work? Hit that +1 button as a thank you! Want to support me? You could consider donating!  :)

Subscribe to my YT Channel: https://www.youtube.com/user/thekyan31


#7
george109

george109

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,105 posts
  • Gender:Male
  • Location:Kent, England
  • Interests:Cycling, Tech and Canoeing
  • Devices:Samsung Galaxy S4 - GT-I9505

Just change ro.config.hw_proximity to 0/false (depending on the variable).

So If it is like this:
ro.config.hw_proximity=true
change it to:
ro.config.hw_proximity=false

Otherwise if it looks like this:
ro.config.hw_proximity=1
Then change it to this:
ro.config.hw_proximity=0

That should hopefully disable it :)

Edit: sorry for my bad code tags, it's very hard to type code in tapatalk! :wacko:

Edited by george109, 17 July 2013 - 10:48 PM.

  • 0

Hello. I have an S4 now, and I hardly ever use MoDaCo now. 

Therefore you will receive no replies to any PMs

Please post in the forum instead. You will get more help there :)

:excl:A WARNING TO ALL G300 OWNERS! Please Read! (The Flash Memory Problem!) :excl:

Tutorial: How To (Officially) Unlock Your Bootloader! (The long way, but which definitely works)

Please, Do not use the HuaweiG300.com Tutorial on how to unlock your bootloader, it is better to unlock it officially with my tutorial!

Spoiler

My Device:

Huawei Ascend G300 (U8815) - Sold!

Samsung Galaxy S4 (Black) - The LTE Version - GT-I9505

(Ignore the links above (if there is one). It's a skimwords (advertising) link and nothing to do with me!)

The ROMS I have used:

Spoiler

Download Blink, a great app that controls the status LED on the G300!

Wait for 5 seconds and then click skip ad! Do not download anything in the ad window, that is not the app!

Did I help you?

If I did, Please press the rep_up1.png button, in the bottom right hand corner of my posts.

(If not, Press it anyway!)

If I really helped you, you could also donate to me. Thanks!  :) 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users