Jump to content


Photo

Vivacity - screen not turning back on after timing out

- - - - -

  • Please log in to reply
2 replies to this topic

#1
larkim

larkim

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:T-Mobile Vivacity
I'll confess that I know part of the reason behind this - my wife managed to cover her phone in hot tea a few days ago, and since drying it out and leaving it in a tub of rice for a few days we've come to try out the phone.

The good news at first was that everything seemed to be working properly. Speaker / camera / wifi / calls / capacitive screen / LCD display - all looking good.

The ONLY thing which appears to be not working is that once the screen times out, pressing the power button doesn't cause it to light up again.

I've tested the fact that it isn't just the screen "dying" on me by changing the timeout period to 30 minutes, and the screen remains lit up perfectly.

If it times-out automatically, pressing the power button activates the capacitive sensing and I can unlock the phone by swiping (though I can't see what I'm doing), and once it is unlocked like this I can apparently press the illuminated buttons at the bottom, and if I press where an icon would be on the screen I get the haptic feedback that I'd expect. If it gets a message or receives a call, again the screen doesn't come on but in all other respects the phone works properly.

The same happens if I manually time-out the screen by pressing the power button.

I know water damage can cause erratic issues, but can anyone think of any potential solutions? I will continue with more dry-rice treatment in case there are residual bits of water which need to be resolved, but other than that I presume it would be a repair / replace job.

Thanks for any help you can give!

Matt

  • 0

#2
dodgetimmy

dodgetimmy

    Enthusiast

  • Members
  • PipPipPip
  • 295 posts
  • Gender:Male
  • Location:East Sussex, UK.
  • Devices:ZTE Crescent, HTC Desire
The only thing I can think of is to install a custom rom to see if it goes away.

I had a problem similar when using slimbean but it was only when trying to turn the phone screen on and off in quick succession.

Have you tried waiting a good few mins until trying to turn the screen back on?

  • 0

#3
larkim

larkim

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:T-Mobile Vivacity
I've not tried a custom ROM, but unfortunately now the screen doesn't even come on at all, so I suspect the fault was just some component which was failing to "power up" on command, and perhaps has now failed the whole screen.

Perhaps I didn't leave it long enough in the rice.

Anyway, have moved onwards and upwards - bought a Huawei Y300 as a replacement for just under £70 which feels like a complete bargain - and a nice step up from the TMV which was starting to feel very slow.

Thanks for the thought!

Matt

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users