Jump to content


Photo

GApps for CM11 (last updated: 2014-12-07)


215 replies to this topic

#41
NBatalha

NBatalha

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Programming, Tecnology, Games, Formula 1.
  • Devices:Huawei G300, OnePlus One

Just helped a guy to install CM11 an hour ago and it worked for him.

Have you formatted the /system partition before installied the ROM and GApps?

Have you wiped the /data partition?

Tried now, still doesn't work. It says: "There was a problem communicating with Google servers.". And during the initial configure of the phone, it asks for cm account, but after that is supposed to ask for a google account, but it doesn't happen.


  • 0

#42
ProHunter

ProHunter

    Regular

  • Members
  • PipPip
  • 86 posts
  • Gender:Male
  • Devices:Y300

Hi,i have problems with 20140111-stripped,i had 20121231-stripped before that,i only wiped cache/dalvik and installed 20140111 version,and for me google play freezes when i open it,i had no problems with 20121231,did i done something wrong? :unsure:


  • 0

My Windows app for unlocking bootloader,flashing recovery and rooting for Huawei Y300:

http://www.modaco.co...-with-tutorial/

:D

Phone:Huawei Y300

ROM:CM11

Kernel:Stock CM11

Recovery:TWRP 2.6.3.3


#43
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300

Tried now, still doesn't work. It says: "There was a problem communicating with Google servers.". And during the initial configure of the phone, it asks for cm account, but after that is supposed to ask for a google account, but it doesn't happen.

Skip the CM account settings. After that, Google Account "wizard" should be started.

Maybe try to install google play services module too.

do a Wipe data /factory reset after install, start over the Android setup.

 

Hi,i have problems with 20140111-stripped,i had 20121231-stripped before that,i only wiped cache/dalvik and installed 20140111 version,and for me google play freezes when i open it,i had no problems with 20121231,did i done something wrong? :unsure:

Try to install google play services module too.

The 20140111 pack deletes the play services if you have already installed.

 

Maybe I have to put back Play Services to the base pack.

I removed it since it is available on the play store. [link]

 

Please report it back if installing Play Services is solved the problem or not?


Edited by rhen, 13 January 2014 - 08:17 PM.

  • 0

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#44
ProHunter

ProHunter

    Regular

  • Members
  • PipPip
  • 86 posts
  • Gender:Male
  • Devices:Y300

Skip the CM account settings. After that, Google Account "wizard" should be started.

Maybe try to install google play services module too.

do a Wipe data /factory reset after install, start over the Android setup.

 

Try to install google play services module too.

The 20140111 pack deletes the play services if you have already installed.

 

Maybe I have to put back Play Services to the base pack.

I removed it since it is available on the play store. [link]

 

Please report it back if installing Play Services is solved the problem or not?

It's working after installing play services... :)


  • 0

My Windows app for unlocking bootloader,flashing recovery and rooting for Huawei Y300:

http://www.modaco.co...-with-tutorial/

:D

Phone:Huawei Y300

ROM:CM11

Kernel:Stock CM11

Recovery:TWRP 2.6.3.3


#45
NBatalha

NBatalha

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Programming, Tecnology, Games, Formula 1.
  • Devices:Huawei G300, OnePlus One

Yup, it now works. You might think about put Google play services again into the base pack.


  • 0

#46
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300
Google Play services is now placed in the base install again. (Without Play Services, you can't connect to Google Accounts an play store doesn't work so it turns out it is essential)
 
If you updated to the 20140111 version on the last two days and haven't installed Play Services, please update your GApps package to the most recent one.
 
first and second post updated

Edited by rhen, 13 January 2014 - 10:29 PM.

  • 1

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#47
murtagh

murtagh

    Newbie

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Soccer, Information Security, Business Intelligence.
  • Devices:Huawei Ascend G300; Chromecast

 

Google Play services is now placed in the base install again. (Without Play Services, you can't connect to Google Accounts an play store doesn't work so it turns out it is essential)
 
If you updated to the 20140111 version on the last two days and haven't installed Play Services, please update your GApps package to the most recent one.
 
first and second post updated

 

 

Still shows "There was a problem communicating with Google servers.". I follow the guide (Clean update) on the first page but it still displays the same error. Any help? I can't install the module play services :/


  • 0

#48
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300

Still shows "There was a problem communicating with Google servers.". I follow the guide (Clean update) on the first page but it still displays the same error. Any help? I can't install the module play services :/

You don't have to install Play Services Module.

Play services is in the Base pack now.

 

Have you installed the correct package what you have downloaded today?

It should be 44MB large. MD5 sum should be 6d0419d1fe7db0a5da60a38494e610d9

 

Edit: Just done a clean update and works for me.


Edited by rhen, 14 January 2014 - 12:35 PM.

  • 0

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#49
murtagh

murtagh

    Newbie

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Soccer, Information Security, Business Intelligence.
  • Devices:Huawei Ascend G300; Chromecast

You don't have to install Play Services Module.

Play services is in the Base pack now.

 

Have you installed the correct package what you have downloaded today?

It should be 44MB large. MD5 sum should be 6d0419d1fe7db0a5da60a38494e610d9

 

Edit: Just done a clean update and works for me.

 

I made something wrong yesterday. It already works, thanks :)


  • 0

#50
rederik75

rederik75

    Enthusiast

  • Members
  • PipPipPip
  • 257 posts
  • Gender:Male
  • Location:Italy
  • Interests:Computers, Linux, Photography, Motorcycles
  • Devices:Huawei Y300-0100

Nice work, thanks!

 

Regarding the modules, it would be nice to have a module for Maps/streetview.

Yes, it'a available in Play, but that way it would be easy to save space for user apps putting Maps in system/app/ ...


  • 0

I won't say sorry for my bad english, because actually it's not so bad....  even if I'm Italian!

 

:D  :D  :D


#51
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300

Nice work, thanks!

 

Regarding the modules, it would be nice to have a module for Maps/streetview.

Yes, it'a available in Play, but that way it would be easy to save space for user apps putting Maps in system/app/ ...

This GApps package primarily packed for G300 that has a very limited space on /system. 5MB free space left after the base GApps installed.

All the Y300/G510 user can use PA's original GApps packages. They have plenty of space available.

But I will considering it.

 

An issue discovered, second post updated:

- Without Google Calendar, Calendar sync doesn't work with the AOSP Calendar app. Problem is that Google removed GoogleCalendarSyncAdapter.apk and replaced with Google Calendar in all Official ROM started with 4.0.4. I will not provide this in the GApps package since it is obsoleted. If you want Calendar sync, install the Google Calendar module.


Edited by rhen, 14 January 2014 - 05:42 PM.

  • 0

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#52
NBatalha

NBatalha

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Programming, Tecnology, Games, Formula 1.
  • Devices:Huawei G300, OnePlus One

Hi again! Well, I tried the updated GApps, the one you added the Google play services. And the problem still persists. Is it me? Or the GApps?


  • 0

#53
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300
 

Hi again! Well, I tried the updated GApps, the one you added the Google play services. And the problem still persists. Is it me? Or the GApps?

It need to work. It works for me and murtagh too.

Have you installed the correct package what you have downloaded today?

It should be 44MB large. MD5 sum should be 6d0419d1fe7db0a5da60a38494e610d9

 

Edit: Just done a clean update and works for me.

I made something wrong yesterday. It already works, thanks :)

You must be do something wrong.

How did you update, you downloaded the right GApps?


  • 0

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#54
NBatalha

NBatalha

    Newbie

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Programming, Tecnology, Games, Formula 1.
  • Devices:Huawei G300, OnePlus One

Fixed! But it isn't installed like the normal way. Normal way was just wipe data/factory reset and install the GApps. It's not like that anymore.


  • 0

#55
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300

Fixed! But it isn't installed like the normal way. Normal way was just wipe data/factory reset and install the GApps. It's not like that anymore.

How it is fixed, what was the problem?

 

You don't have to wipe data/factory reset to update GApps.

I try to make every version to able to update the previous version without formatting and wipe-ing anything.

In this case, If you have done a "Clean update" when installing the previous version, you should be able to update without wipe/format anything.

But clean update method should work every time without loosing any data.


Edited by rhen, 14 January 2014 - 09:50 PM.

  • 0

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#56
fonsecav

fonsecav

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Huawei Ascend G300

continuing this 
"fonsecav, on 16 Jan 2014 - 5:36 PM, said:

snapback.png

Hi guys!
First of all great work, so far this ROM seems to be ok.
I have just one problem and would like to know if it is mine only or not.
Currently i have the last version of the rom, 20140116, and the updated stripped version.
I also used some modules to delete both CMWallpapers and VideoEditor, and the one to add Google Calendar.
The problem is related with this one, i think, when i search for calendars to sync it just keeps loading without retrieving any results. Also, if i go to the sync options of the account through settings, it says that there was a sync error, and there is no entry to sync calendar.
 
Is there any specific order to add/delete modules that i might have done wrong, or is it some problem with the modules?
I would love to get this feature to work as it is very important to me, but other than that, i love this ROM.

Can you describe it what version of GApps do you use and what was the order of the GApps and module installation?
We can continue this thread in GApps thread."

 

Hi rhen.

 

So i installed the pa_gapps-modular-mini-4.4.2-20140111-stripped-signed.zip,  but the "new" one with the google account problem solved.

I think I first installed the google-calendar module, and then deleted CMWallpapers and VideoEditor.

 

In the sync menu, the symbol is red and says "sync error" and at the bottom of the screen says "Sync is currently experiencing problems. It will be back shortly."

 

Also, i performed a clean install.


  • 0

#57
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300

Hi rhen.

So i installed the pa_gapps-modular-mini-4.4.2-20140111-stripped-signed.zip, but the "new" one with the google account problem solved.
I think I first installed the google-calendar module, and then deleted CMWallpapers and VideoEditor.

In the sync menu, the symbol is red and says "sync error" and at the bottom of the screen says "Sync is currently experiencing problems. It will be back shortly."

Also, i performed a clean install.

So you installed with this?

Wipe data/factory reset (for clean install only) -> format /system -> install latest nightly -> install gapps -> install google calendar -> remove CMWallpapers -> remove VideoEditor -> start phone and setup wizard.

It should work with this install, but I prefer the remove stuff before any module install.

 

Do you have Calendar Provider installed? (check in Settings -> Application -> All)

Try delete Calendar and Calendar provider data and starting google calendar after.


  • 1

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#58
fonsecav

fonsecav

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Huawei Ascend G300

So you installed with this?

Wipe data/factory reset (for clean install only) -> format /system -> install latest nightly -> install gapps -> install google calendar -> remove CMWallpapers -> remove VideoEditor -> start phone and setup wizard.

It should work with this install, but I prefer the remove stuff before any module install.

 

Do you have Calendar Provider installed? (check in Settings -> Application -> All)

Try delete Calendar and Calendar provider data and starting google calendar after.

 

Hi. I guess I had done a clean update and not a clean install.
I've done a clean install now, removing the modules before adding the calendar one and now everything looks ok.

Maybe the problem was caused by not doing the factory reset since i had the 10.2 installed.

Well, everything ok now, so thanks for your help and great work! :)


  • 1

#59
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300

Hi. I guess I had done a clean update and not a clean install.
I've done a clean install now, removing the modules before adding the calendar one and now everything looks ok.

Maybe the problem was caused by not doing the factory reset since i had the 10.2 installed.

Well, everything ok now, so thanks for your help and great work! :)

wipe dalvik cache and/or delete Calendar and Calendar provider data and starting google calendar after didn't helped?


  • 0

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.


#60
rhen

rhen

    Addict

  • Members
  • PipPipPipPipPip
  • 719 posts
  • Gender:Male
  • Location:Hungary
  • Devices:Pulse, G300

GApps updated.

Now check free space available on /system before install and writes a log file about install to SD card thanks to PA guys.

 

The space checking will be included in the modules soon, too.


Edited by rhen, 17 January 2014 - 04:51 PM.

  • 0

GApps package for CM11: [link] (last updated 2014-12-07)

For non device specific issues, use CM bug tracker: [link]

Don't afraid to use the rep_up.png button if my answer was helpful.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users