Jump to content


Photo

[HELP] Phone bricked after 4.4.2 OTA wifi update, dunno what to do now


  • Please log in to reply
18 replies to this topic

#1
zoological

zoological

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Motorola moto g

Hi everyone, sorry if my first post in MoDaCo is about asking help but you are kinda my last hope.

 

I have a Moto G 8gb UK retail version, bought from amazon.co.uk and used in Italy.

3 days ago i received the ota, i installed it via wi fi, everything went smooth, i used the phone whole the entire day and no problem at all with it. At night i turned it off and put in charge, then the next morning i turned it on and it simply became useless: it stopedd int he home screen giving a lot of error messages like "the star process failed" "gapps stopped working" ecc ecc.

 

I tried to do the update process again via sideload but i get the error message:

 

"/system/app/3c_checkin.odex" has unexpected contents.
Installation aborted

 

29xzmv5.jpg

 

 

 

I tried to flash a custom recovery like CWM v3 found on xda to root it and install a rom to restore my phone or at least to make it working again, but CWM is not even booting.

I really don't know what to do now.

Downgrade to 4.3 seems not an option, cause it's not working for me.

Factory resete/wipe data and stuff is not an option neither cause IT DOESN'T DO ANYTHING. It's incredible but i can't factory reset my stock and i don't know why.

 

Guys, give me any idea, please. Thanks for your time.


Edited by zoological, 18 January 2014 - 10:36 AM.

  • 0

#2
irishpancake

irishpancake

    Diehard

  • Members
  • PipPipPipPip
  • 451 posts
  • Gender:Male
  • Location:Ireland
  • Devices:Galaxy SIII GT-I9300
Sorry to hear.....you have an unlocked bootloader?? Sounds like you have, as flashing recovery, etc If you have, there are many guides here or on XDA, showing how to flash the latest Moto KitKat ROMs,whether US or UK or EU. Also,then flashing latest CWM which works on KK, and rooting with SuperSU zip in recovery..... If you can get into BL, you can do almost anything. To enter Bootloader, power off Moto, then hold vol down and power together, then release power....you should get BL GUI.... Remember, when in BL, vol down key scrolls up/down menu, vol up key selects/activates the option, (like recovery)........ do not select with power key!!!! (It's not what you would expect intuitively, but that's how it is). If not unlocked, you can unlock, there is also a guide here....I think it's a "sticky" at the top of page. Main thing is don't panic, make sure you have Moto drivers (incl adb) and you have Moto fastboot, sometimes called mfastboot.... All these are available to download to your PC/Laptop, for Windows......not sure regarding Linux or Apple.

Edited by irishpancake, 18 January 2014 - 12:43 PM.

  • 0
Now got Galaxy S III I9300 ...and Momo11 Bird Tablet running Christian Troy CM9....the wife has an Ascend g300 running?? Stock+ R6 from Cyda!!

Get Dropbox....Please click and get 2GB free plus 250Mb for referral...Dropbox is useful

#3
zoological

zoological

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Motorola moto g

the problem is that when i flash all the CWM or twrp i don't get any error, but when i try to recovery from BL nothing happens, i just get the "dead robot" logo and with vol up + power button i can get only in classic stock moto g recovery


  • 0

#4
drdivx

drdivx

    Newbie

  • Members
  • Pip
  • 7 posts

Here zoo. watch this video and listen carefully to him. He explains your problem and

how to avoid it.

http://www.youtube.c...h?v=GrDYGmgbQEw

 

Be aware he is talking about 4.3 and you are 4.4 so the files are different of course.

Follow him with the correct files and all will be well.

Hope this helps.


Edited by drdivx, 18 January 2014 - 03:41 PM.

  • 0

#5
zoological

zoological

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Motorola moto g

Here zoo. watch this video and listen carefully to him. He explains your problem and

how to avoid it.

http://www.youtube.c...h?v=GrDYGmgbQEw

 

Be aware he is talking about 4.3 and you are 4.4 so the files are different of course.

Follow him with the correct files and all will be well.

Hope this helps.

 

Thanks but i already followed that good guide. the point is that i used a cwm that is said to work with 4.4, i flash it like in the video but then when i'm in BL and i select (with volume up ofc) recovery i don't get the cwm screen: i just get the broken android robot logo and if i press volume up + power then i get in stock normal recovery


  • 0

#6
ian00009

ian00009

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Devices:S500, desire and blade

zoologica

 

i had a similar problem....reinstall 4.3....instal ota by copying zip onto root folder of moto g...make sure you use mfastboot and flash cwm....

 

i got it sorted in the end

 

IAn


  • 0

#7
zoological

zoological

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Motorola moto g

zoologica

 

i had a similar problem....reinstall 4.3....instal ota by copying zip onto root folder of moto g...make sure you use mfastboot and flash cwm....

 

i got it sorted in the end

 

IAn

thanks for the answer man.

 

Reinstalling 4.3 was the first thing i tried: downgrading simply not working. i followed a guide i found on xda, nothing. My phone stay with a corrupted 4,4.2 android


  • 0

#8
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One

  • 0

#9
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One
If the first mirror doesn't work try the second mirror for cwm recovery, I got my update zip from here and the sideload worked finehttp://www.mediafire...n.GB_4.4.2.zip

  • 0

#10
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One
You gotta make sure the zip you're using is the standard UK ROM ota zip,other zips from different versions won't work,try this alsohttp://www.modaco.co...view=getnewpost

Edited by kieranc88, 20 January 2014 - 10:31 AM.

  • 0

#11
zoological

zoological

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Motorola moto g

I'm sure that zip file is the correct version of the update i need, the problem is it keeps giving me that message of "/system/app/3c_checkin.odex" has unexpected contents.

Installation aborted

 

 

Maybe, and i say maybe, if i try to flash a 4.4.2 retail uk gb system img only i could fix that, but i'm not sure if or where i can find a 4.4.2 en gb system image.


  • 0

#12
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One
Try the zip from the link I attached in my second post above it worked for me, have you tried the cwm recovery I linked you too,I have the same version moto g as you and both the recovery and the update zip worked for me.

Edited by kieranc88, 20 January 2014 - 06:16 PM.

  • 0

#13
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One
Stupid question have you tried wiping data in recovery and rebooting rom

  • 0

#14
ian00009

ian00009

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Devices:S500, desire and blade

HAve you sorted it yet??

 

i restored stock firmware using this guide http://forum.xda-dev...d.php?t=2542219

 

then tried to recieve the ota again....i failed so downloded the ota and transfered onto moto g 

 

IAn


  • 0

#15
zoological

zoological

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:Motorola moto g

Stupid question have you tried wiping data in recovery and rebooting rom

 

First thing i tried when everything failed: nothing happens when i try to wipe data or factory recover, the device just reboot with his 4,4.2 broken firmware. I'mm thinking abouth that my phone has simply something wrong from an hardware point of view. Something regarding the ghost sd card or the 8gb memory.


  • 0

#16
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One
I think you should post in the moto g XDA forum,to reach a wider audience

Edited by kieranc88, 21 January 2014 - 12:55 PM.

  • 0

#17
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One
http://forum.xda-dev...d.php?t=2542219

Try this,I can't see stock generic UK KitKat image but a us KitKat image might work

Edited by kieranc88, 21 January 2014 - 12:57 PM.

  • 0

#18
kieranc88

kieranc88

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:nexus 7 (2012) moto g HTC One
Any luck

  • 0

#19
irishpancake

irishpancake

    Diehard

  • Members
  • PipPipPipPip
  • 451 posts
  • Gender:Male
  • Location:Ireland
  • Devices:Galaxy SIII GT-I9300

First thing i tried when everything failed: nothing happens when i try to wipe data or factory recover, the device just reboot with his 4,4.2 broken firmware. I'mm thinking abouth that my phone has simply something wrong from an hardware point of view. Something regarding the ghost sd card or the 8gb memory.


I hate to ask again, but can you confirm you have in fact unlocked your bootloader??

Did you go to the Moto site and do this??

I ask cos I see no reference from you in the thread saying you have....

sorry if you already have.

  • 0
Now got Galaxy S III I9300 ...and Momo11 Bird Tablet running Christian Troy CM9....the wife has an Ascend g300 running?? Stock+ R6 from Cyda!!

Get Dropbox....Please click and get 2GB free plus 250Mb for referral...Dropbox is useful




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users