Jump to content

Recommended Posts

:) ;) Well done guys.

This proceedure worked for me on an ORANGE SPV C550:-

1) Run the RegEdit program at the start of this thread.

2) Set the required values to 1 and 40, as briefed, this will unlock your SIM and Reg features.

3) Now set the LocalPixelx and y values to 138 and 138 as briefed.

4) A quick on/off. Then run tomtom....

Works as if there was never a snag to begin with....no side-effects yet encountered.....

Spread the word......

HOWEVER....Tomtom.....Get going with a 240x320 enhanced display version! You know all the mobile phones out there will be following suit with the C550 soon!!! Even better, start your app with a screen resolution option menu.....sweet.

Gav.

Share this post


Link to post
Share on other sites
2) Set the required values to 1 and 40, as briefed, this will unlock your SIM and Reg features.

?? did I miss an instruction somewhere?

what values does this refer to please ?

Share this post


Link to post
Share on other sites

ah, ok

still needs the exe to be signed to mess with those keys :/ was hoping for a work around to fix the toggle, ah well :)

Share this post


Link to post
Share on other sites

Ok, so I had had my TomTom working now for a day at a good resolution 138x138.

I have noticed a few times when I exit TomTom my phone has locked up and I have had to take out the battery to get it working again. Has anyone else experienced this?

Also, the backlight gets set to Never (under settings / power management) when you use tomtom. Previously on my C500 it has set this back to xx seconds, however I am experencing this setting being lost but I think this is due to my phone locking up when I exit tomtom and there tomtom not setting this back correctly.

Just for the record if I load tomtom and have it running for 5 mins then I don't seem to get this problem, it only seems to happen when it has been running for about 30 mins.

Thanks

Mark

Share this post


Link to post
Share on other sites
How did you change your font?  Did you edit any of the registry, if so was it one of the keys in my previous email?

Thanks

<{POST_SNAPBACK}>

No it's the additional Key FontPath that you can add to specify the default font.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\FontPath]

"FontPath" = "\Storage\windows\Fonts"

Then put your desired font in this directory. Be aware though if you enter an invalid FontPath the phone will not boot, a hard reset will be required.

Share this post


Link to post
Share on other sites
Hi,

I have read the whole thread. Unlocked my phone (http://www.modaco.com/INFO_Decert_SIM_Unlock_C550-t222786.html) and i set the x and y in the register at 150 with Mobile Registry Editor. But when i start TomTom i get the green screen (to one where you must press OK) But when i press oke, nothing happens. Does anybody know what i did wrong?

<{POST_SNAPBACK}>

Nothing, but for what ever reason TomTom hasn't created a necessary file \Storage\My Documents\TomTom\CurrentMap.dat, this file contains just one line and specifies the map you are using, i.e. \Storage Card\Great Britain\

Share this post


Link to post
Share on other sites
Nothing, but for what ever reason TomTom hasn't created a necessary file \Storage\My Documents\TomTom\CurrentMap.dat, this file contains just one line and specifies the map you are using, i.e.   \Storage Card\Great Britain\

<{POST_SNAPBACK}>

Thats it!! Thanks!

But now i have to connect my c550 with my gps reciever. I paired them and set the outgoing com port at 7 and the incomming at 6. But it doesnt work in TomTom. Then i switched the outgoing to 6 and the incomming to 7, but it still doesn't work. Can anyone help me?

Thanx!

Share this post


Link to post
Share on other sites
Thats it!! Thanks!

But now i have to connect my c550 with my gps reciever. I paired them and set the outgoing com port at 7 and the incomming at 6. But it doesnt work in TomTom. Then i switched the outgoing to 6 and the incomming to 7, but it still doesn't work. Can anyone help me?

Thanx!

<{POST_SNAPBACK}>

Forget COM7, not needed. I've only ever had to set up COM6, actually can't remember whether it is outgoing or incoming.

Edited by ElGato65

Share this post


Link to post
Share on other sites
Forget COM7, not needed. I've only ever had to set up COM6, actually can't remember whether it is outgoing or incoming.

<{POST_SNAPBACK}>

Yep thats it!!

Share this post


Link to post
Share on other sites

Got to add that I have followed all the instuctions exactly and can get TomTom to start but it just hangs after acceping the agreements! I contacted TomTom and got a typical Dutch response!

We do not know at this time when this model will be supported if at all so all we can ask you to do is to keep an eye on this website:

http://www.tomtom.com/products/sellingpage...D=69&Language=1

With best regards,

The TomTom Customer Support Team

Guess I will have to wait for TomTom but I'm not holding out much hope in the short term!

Edited by aosuk

Share this post


Link to post
Share on other sites
ah, ok

still needs the exe to be signed to mess with those keys :/ was hoping for a work around to fix the toggle, ah well :)

<{POST_SNAPBACK}>

My apologies, yes I was referring to the SIM unlock thread above. However, I don't have a problem with signed exe's? Is your phone an Orange one? What is the problem?

Also, I have not had any 'lock-ups', but there does appear to be an issue with the backlight settings, but this can be configured both in TomTom and on the phone itself.

Share this post


Link to post
Share on other sites

I did have the problem you described at one stage (hangs after the licence agreement), however, If remove your tomtom card, get rid of all the tomtom files (possibly hard reset also), then insert it again and re-install it. This should cure the problem, it did for me.

Share this post


Link to post
Share on other sites
I did have the problem you described at one stage (hangs after the licence agreement), however, If remove your tomtom card, get rid of all the tomtom files (possibly hard reset also), then insert it again and re-install it. This should cure the problem, it did for me.

<{POST_SNAPBACK}>

You don't have to resort to such extremes, it's usually because for what ever reason TomTom hasn't created a necessary file \Storage\My Documents\TomTom\CurrentMap.dat, this file contains just one line and specifies the map you are using, i.e. \Storage Card\Great Britain\

Edited by ElGato65

Share this post


Link to post
Share on other sites

Thanks ElGato65 that sorted it - onder why it couldn't create the .dat? Probably a 'feature'of the C550 that TomTom will have to fix.

Share this post


Link to post
Share on other sites
Ok, so thanks to xnathanx for suggesting this work around fix for TomTom

http://www.modaco.com/C550_Registry_Hack_D...gs-t223886.html

I have now managed to change these settings on my phone using "Mobile Registry Editor" that accesses my registry from an app on my PC.

The keys to change are:

HKLM\Drivers\Display\GPE\LogicalPixelsX (Change from 131 - 176)

HKLM\Drivers\Display\GPE\LogicalPixelsY (Change from 131 - 220)

1. I initally tried to change these values using a registry editor on my phone but got access denied (or some similar message)

2. When I changed these using Mobile Registry Editor it allowed me.  After which I restarted the phone

3. When the phone came back up, all the fonts and menu bar, start menu are Extremely Large font

4. When I launched TomTom it worked a treat, with only slight problems in the font and icon proportions, for example the text in the TomTom menu's overlaps the icons slightly.

5. Other than that it seems to work fine!!! - YIPEE

I have a few questions that hopefully someone might be able to answer:-

1. Is there a work around to changing the main phone fonts, i.e. the start menu, so that it fits correctly on the new screen layout?

2. Is there a way to apply these registry change before running tomtom and revert back after exiting TomTom (assuming it works without a reboot in between!)  Could an app like QuickApp do this?

Its certainly progression...  Lets hope TomTom see this and speed their patch up!!!!!!!!

Feedback welcomed...

Regards

Mark

<{POST_SNAPBACK}>

No problem. Haven't even got it working myself.

I'll have to give it a go later on today.

Anybody have the details of unlocking C550 for free?

Share this post


Link to post
Share on other sites
No problem. Haven't even got it working myself.

I'll have to give it a go later on today.

Anybody have the details of unlocking C550 for free?

To unlock see the sticky thread in the Typhoon section - it works on C550 as well.

Share this post


Link to post
Share on other sites
No it's the additional Key FontPath that you can add to specify the default font.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\FontPath]

"FontPath" = "\Storage\windows\Fonts"

Then put your desired font in this directory. Be aware though if you enter an invalid FontPath the phone will not boot, a hard reset will be required.

<{POST_SNAPBACK}>

I have tried the above, copied the arial narrow true type font from my PC to the location described above, but the screen looks no different when rebooted.

Any help please.

Regards Stretchy

Share this post


Link to post
Share on other sites
I have tried the above, copied the arial narrow true type font  from my PC to the location described above, but the screen looks no different when rebooted.

Any help please.

Regards Stretchy

<{POST_SNAPBACK}>

Not sure what to say, it should work. I followed the intructions from somewhere on here. Basically as follows;

1. Create a new key under, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft called FontPath.

2. Add a new string value under FontPath, String name = FontPath, value = \Storage\windows\Fonts.

3. Copy required font to \Storage\windows\Fonts on smarthpone.

Here's a screengrab of the setting using Mobile Registry Editor;

post-107774-1123919895_thumb.jpg

Share this post


Link to post
Share on other sites
Not sure what to say, it should work. I followed the intructions from somewhere on here. Basically as follows;

1. Create a new key under, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft called FontPath.

2. Add a new string value under FontPath, String name = FontPath, value = \Storage\windows\Fonts.

3. Copy required font to \Storage\windows\Fonts on smarthpone.

Here's a screengrab of the setting using Mobile Registry Editor;

<{POST_SNAPBACK}>

Thanks for the walkthrough ElGato65, all sorted now, that will do nicely till tom tom release a proper fix.

Regards Stretchy

Share this post


Link to post
Share on other sites
Thanks for the walkthrough ElGato65, all sorted now, that will do nicely till tom tom release a proper fix.

Regards Stretchy

<{POST_SNAPBACK}>

Glad to help.

I've gotten quite used to the "fix" now and aside from the obvious menu corruption in TomTom itself, hardly notice it with Arial Narrow installed, although I've recently switched to Segoe (WM5 font) and not actually sure whether I prefer it over Arial Narrow. Also it seems to me at least that TT5 is actually using the extra resolution in the maps.

Edited by ElGato65

Share this post


Link to post
Share on other sites
Glad to help.

I've gotten quite used to the "fix" now and aside from the obvious menu corruption in TomTom itself, hardly notice it with Arial Narrow installed, although I've recently switched to Segoe (WM5 font) and not actually sure whether I prefer it over Arial Narrow. Also it seems to me at least that TT5 is actually using the extra resolution in the maps.

<{POST_SNAPBACK}>

Thought I'd give that segoe font a try, copied it to the font folder and tried to delete the arial font, but it wont let me, what's the trick to swapping fonts? The only way I can think of is to hard reset and start again, although this seems a bit drastic.

Regards Stretchy

Share this post


Link to post
Share on other sites
Thought I'd give that segoe font a try, copied it to the font folder and tried to delete the arial font, but it wont let me, what's the trick to swapping fonts?  The only way I can think of is to hard reset and start again, although this seems a bit drastic.

Regards Stretchy

<{POST_SNAPBACK}>

Unfortunately with this "hack" the only way I have managed to swap fonts is to change the FontPath string to \Windows, reboot phone, delete "old" font from \Storage\windows\FontPath, copy new font to location, edit FontPath string back to \Storage\windows\FontPath and reboot phone again.

Seems a bit drastic but as the font you use is in use once you have set the FontPath string I do not see any other way.

Edited by ElGato65

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.