Jump to content
brilliant-green

WIFI Connected, but Can't Browse Internet

Recommended Posts

hi, i am currently using HI3 rom and face the same problem.

i think the problem is at:

"Configure Wireless Network"

===================

Network Name : MywifiNetworkName

Connects To : can't choose anything, empty comboBox.

i had used a Chinese version of H4 Rom and had no problem connecting to the internet as I was able to choose "INTERNET" from this pull down menu

Right now i can't browse the web with Wifi but i CAN update my programs with RESCO update.

so i think it's not a problem with the connection itself, but OPERA/IE failing to identify WiFi as the channel for connection.

Edited by raymondst1

Share this post


Link to post
Share on other sites
hi, i am currently using HI3 rom and face the same problem.

i think the problem is at:

"Configure Wireless Network"

===================

Network Name : MywifiNetworkName

Connects To : can't choose anything, empty comboBox.

i had used a Chinese version of H4 Rom and had no problem connecting to the internet as I was able to choose "INTERNET" from this pull down menu

Right now i can't browse the web with Wifi but i CAN update my programs with RESCO update.

so i think it's not a problem with the connection itself, but OPERA/IE failing to identify WiFi as the channel for connection.

i see.... hmm... no wonder, after i re-flash for the 1st time.. then i open opera, there's some error message.

First time i buy ( HK Imported Version ZHH1 ), it's unstable, but it was able to browse the internet.

Then i reflash using Singapore version, and have this problem.

So, what can you suggest me to fix this problem ? so desperate ... T__T

this RESCO is using for that ?

Many thanksss :lol:

Share this post


Link to post
Share on other sites

Can someone give me some pointers please...

I have DXHH1 and can see my home wifi router SSID but when I try and connect the Omnia I enter the password but the phone never connects to the network.

Is there something I am doing wrong?

Do others have successful use of wifi with either DXHH1 ROMs or other ones?

Thank you - am pulling my hair out here :lol:

Share this post


Link to post
Share on other sites

Hi, I already reflash using hk ZHH2. And i can browse now.

Seems raymondst1 is right, "but OPERA/IE failing to identify WiFi as the channel for connection. "

But i don't know, what the connection between HK Version and My phone. Opera able to recognize the wifi if the version is ZHH1/ZHH2. But fail to recognize the wifi when i'm using DXHI1..DXHI3.

Can someone suggest me what to do with this, i'm already trying to hardreset, and reflash using DXHI3, still can't.

Seems my phone is only recognizing the HK ZHH1/ZHH2. Do anyone know why is that happen ? FYI, I bought the phone at HK, and want to reflash using singapore version, as HK Version is sucks, can't use samsung keyboard, and unstable.

Share this post


Link to post
Share on other sites

i try using the grandprix flash, my version now is PDA i900DXHH1 PHONE i900XXHG5.

Still can't using wifi to browse, the symptom is : on network configuration , the option for :

CONNECTS TO : XXXXXXXXXXXX <-- mine is blank comboBox.

==========

on Network Adapters Tab :

MY NETWORK CAR CONNECTS TO :

=======================

XXXXXXXXXXXX <-- also blank combobox.

Anyone also have this ? anyone know how to fix this ?

Many thanks...

Share this post


Link to post
Share on other sites
i see.... hmm... no wonder, after i re-flash for the 1st time.. then i open opera, there's some error message.

First time i buy ( HK Imported Version ZHH1 ), it's unstable, but it was able to browse the internet.

Then i reflash using Singapore version, and have this problem.

So, what can you suggest me to fix this problem ? so desperate ... T__T

this RESCO is using for that ?

Many thanksss :lol:

I have no idea how this problem can be fixed

That RESCO update is for updating Resco products (e.g. Explorer).

I assumed that if it could be used then the connection is not actually the problem.

guess we'll have to wait for a new ROM

Share this post


Link to post
Share on other sites

I used to get the empty combo box for the wifi connection, now i dont.

Reflash

After initial screen/date time setup and when phone starts up the first time it will detect the sim

DO NOT let phone import the settings - just press no

Next screen will be operator settings - will probably be blank, just close the window

You should now have a filled combo box to choose from.

I always select work to connect the wifi to the home router.

Other settings -

Browser Connection to Work

Connections Settings (Advanced / Select Networks) and set both to My Work Network.

Opera / Settings / Connections select Work, uncheck the auto detect.

Important note - HK phone users tend to have a couple of sims, so each time you change the sim MAKE SURE you say NO to any newly detected sim.

Hope this helps my HK brothers.

Edited by bobobird

Share this post


Link to post
Share on other sites
I used to get the empty combo box for the wifi connection, now i dont.

Reflash

After initial screen/date time setup and when phone starts up the first time it will detect the sim

DO NOT let phone import the settings - just press no

Next screen will be operator settings - will probably be blank, just close the window

You should now have a filled combo box to choose from.

I always select work to connect the wifi to the home router.

Other settings -

Browser Connection to Work

Connections Settings (Advanced / Select Networks) and set both to My Work Network.

Opera / Settings / Connections select Work, uncheck the auto detect.

Important note - HK phone users tend to have a couple of sims, so each time you change the sim MAKE SURE you say NO to any newly detected sim.

Hope this helps my HK brothers.

Many thankss, I'll try it tonight... indeed, after reflash, there's prompt out for the SIM setting...

I'll try your suggestion.. hope it work....

Thanks mann.. :lol:

Share this post


Link to post
Share on other sites

Hi all, just for you information, suggestion from bobobird is succeed, now i can set the

"MY NETWORK CARD CONNECTS TO:", can choose from the option.

Just one additional suggestion, you don't need to reflash the phone, you only need to Hard Reset the Phone, then after reset, do as BoboBird said. Press no to SIM Configuration, and then on next screen, don't select any SIM Setting, just exit the screen.

This is worked for the setup, but actually, today, my home wifi is broken, so i can't actually test it.. T__T...

But as the setup already appear, i guess will be okay for wifi internet browsing...

Many thanks to bobobird.... :lol:

Be careful, hard reset will ERASE all your data... :D

Share this post


Link to post
Share on other sites

Hi all,

I have been following this post with interest as I got my Omnia on Friday and had the same problems.

After changing all the settings to Work and back again and all the above suggestions nothing appeared to work. However, I went out for coffee yesterday and the phone would browse on an unsecured network. I came home and turned off network security and the wireless worked fine. I was using WPA-PSK and TKIP password, I have not yet been through all the settings to see if alternative security combinations will work.

All settings do not need to be changed to Work network, just "The Internet" and automatically detect network settings in browser connection.

Hope this helps!

Share this post


Link to post
Share on other sites
Hi all,

I have been following this post with interest as I got my Omnia on Friday and had the same problems.

After changing all the settings to Work and back again and tried all the above suggestions nothing appeared to work. However, I went out for coffee yesterday and the phone would browse on an unsecured network. I came home and turned off network security and the wireless worked fine. I was using WPA-PSK and TKIP password, I have not yet been through all the settings to see if alternative security combinations will work.

All settings do not need to be changed to Work network, just "The Internet" and automatically detect network settings in browser connection.

Hope this helps!

Have now tried WEP settings and Opera allows me to browse. It's a mystery, and hopefully there'll be a fix for this soon!

Share this post


Link to post
Share on other sites

I experience almost same problem with my sna6500 philips modem router.. I think it is the main reason of the problem, the router.

I did reset router several times and tried to connect without a password setted before.. It connects to the wi-fi, it browse the modem's ip page but nothing beside of it.. The problem accurs when my laptop connected before the omnia. If my omnia connected to wi-fi before pc, omnia is able to browse web but my pc not! How interesting, isn't it.:lol::D:D And also I have a static IP form cable modem which connects me to web, DHCP enabled..

(I can connect to wi-fi in school with omnia)

Any idea??

Share this post


Link to post
Share on other sites

I had the same problem WIFI would connect using WEP 128bit but would not browse in IE, Opera, Google Maps, etc.

Disabled the wireless security and reconnected works fine browsing, downloading maps, etc.

Re-enabled the WEP and now it works fine with that too.

Share this post


Link to post
Share on other sites

Hi all, any update on this problem? Hard reset fixed the problem, but for some reason, my "connect to" drop box would disappear again and again.

I tried hardreset and then recover the backup with Spd Backup, but the drop box is still gone after the backup (I verified that i can choose from the "connect to" drop box right after the hardreset tho). So it must be some system settings I recovered causing the problem. Please help.

Share this post


Link to post
Share on other sites

PLEASE HELP ME!!!!!!!!

MY OMNIA DOES NOT CONECT TO ANY WIFI NETWORK THAT IS PASSWORD PROTECTED PLEASE ANY ONE WHO MIGHT KNOW?PLEASE HELP ME

Share this post


Link to post
Share on other sites
Now i'm using DXHI3, previously i used DXHI1.

ppl used to forget the changes when u did....

yup u flashed ROM. it means u need to check 7 things as blw right after flashing

1. go to settings > connections > Operator Settings

choose anything except ur operator (mobile provider)

then ok, then choose again ur own operator.

it correcting ur 'My internet' connecton for GPRS feature.

check ur connections (Settings>Connection)

U need to have primary 'My internet' , secondary 'My work network'

2. Go to settings > usb to Pc and enable advanced network functionality.

3. Go to settings > Browser Connection then choose 'automatic' (or the internet)

4. Go to settings > Wifi and check

My network card connects to 'Work' or 'My internet'

then choose Sychip jaguar Wlan GSPI card.

5. When u first set up wifi,.it depends on ur wifi situation.

What is ur wireless modem set for security?

Easiest way, don't choose ur wifi in setting menu. just turn off and turn on wifi and

select wifi then input password. (I don' recommend u to hide ur wifi modem)

if u dont know about WEP, WPA, WPA2 etc. U gonna mess up ur phone while u are trying to connect.

and even after u seeing connected. it doesnt work if u didnt choose exactly what its required.

that's why Im telling u to choose wifi from Today screen with notification. it works better.

6. If u use Opera. what is ur Opera version. Original one(old one) has a bug about connection setting.

Go to setting in Opera and choose 'the internet' first then go for 'automatic'

7. Finally check ur enhanced GPS setting. (its ur call)

If u do above all right after flashing any ROM, u can use internet via wifi/GPRS/Activesync.

*about ActiveSync u have to check 'connection setting' in ActiveSync from ur desktop; Auto or the internet.

Good luck

Edited by [email protected]

Share this post


Link to post
Share on other sites

Hello folks!

I just flashed my rom to latest QBUS DXIA2 rom, now i have the same problem described in this thread... :S

have tried any sugestion mentioned here..

(sorry for my bad englisg btw)

somehow the phone is connected (i can even ping google using wifi companion) except IE/Opera cant detect the working connection, thus showing me the lame "network problem" screen.

any of you guys know a solution to this problem?

Thnx in advance!

Share this post


Link to post
Share on other sites

[[[1. go to settings > connections > Operator Settings

choose anything except ur operator (mobile provider)

then ok, then choose again ur own operator.

it correcting ur 'My internet' connecton for GPRS feature.]]]

This works! don't have to hard reset or reflash or anything! I have a i908 bought in taiwan flashed with singapore rom. wifi worked with hongkong english rom(but caused my phone to power off sometimes and keyboard sucks), but got the empty box after flasshing to singapore roms. Now, changed the operator settings to something other than my operator, and everything shows up. Able to browse now! Thanks a lot guys!

Share this post


Link to post
Share on other sites

Dear Taimex,

I'm also living in Taiwan and think about buying Omnia i908. After following your previous posts I have several questions for you.

1. So did you reinstall singapore rom version at the end? I'm little bit confused with your posts. Could you let me know which rom version you download for English platform? and where did you find the rom?

2. You said you installed i908zhhh2_eng without problem. But this is Hongkong rom version instead of singapore. Did you use this version for your i908?

3. You said that "This works! don't have to hard reset or reflash or anything! I have a i908 bought in taiwan flashed with singapore rom. wifi worked with hongkong english rom(but caused my phone to power off sometimes and keyboard sucks), but got the empty box after flasshing to singapore roms." Does this meas wifi works with only singapore rom? Not in HK version?

4. After you installed English rom, did you have any problem with other utilities like camera, messanger etc? Because Omnia is kind of a pc instead of phone, if we reinstall rom then we need to fix the drivers for the utilities. This is just my guess and could you let me know did you have any problem with these?

Thanks for your help in advance!

best,

Edited by omniasky

Share this post


Link to post
Share on other sites
Hm.. i found some strange thing :

I installed WIFI COmpanion, i used the tools :

1. WIFI Ping : to www.yahoo.com, and it can succesfully ping the www.yahoo.com, without timeout, 100% succed

2. WIFI Trace : to www.yahoo.com, and also no timeout, succesfully tracing.

But when i go to opera, and write www.yahoo.com it showed :

============

ERROR!

Network Problem

You tried to access the address http://www.yahoo.com, which is currently unavailable. Please make sure that the web address (URL) is correctly spelled and punctuaed, then try reloading the page.

*make sure your internet connection is active and checked whether other applicaitons that rely on the same connection are working.

============

did i miss something ?

opera setting is already "automatically detect settings"

Hey brilliant-green,

Did you get it to work by now ?

Im having the same problem with mine... Im getting tired of this trying and trying.

If you got yours working, would you share with us what you have done to get it in a working state?

THX

Share this post


Link to post
Share on other sites

I'm having exactly the same problem, I think your problem is same as mine.

The problem is that the option "My network card connects to" is blank, it should show the option to choose between "work" or "internet". Without that, the browsers don't know that they can use the wifi connections. Other programs can use the wifi as it can ping and resolve DNS without problem, I can update weather and time with the wifi, just no browsing.

I think this is due to the auto-configure utility on some roms that does not configure the service provider properly. This only happends to me after I changed SIM card and service provider, and when it auto-configures the service provider, the work/internet settings are gone.

I'm quite sure this can be fixed with a hard reset, but I'm too lazy to install everything again and I'm quite sure this has to do with the registry entries messing up. Anyone knows registry entries to fix the blank problem in "My network card connects to" field?

Share this post


Link to post
Share on other sites

ok, I fixed it. In case anyone is interested, it can be fixed by adding back the following registry :-

[HKEY_LOCAL_MACHINE\Comm\ConnMgr\Destinations\Work]

"ReadOnly"=dword:00000000

"Secure"=dword:00000000

"DestId"="{A1182988-0D73-439E-87AD-2A5B369F808B}"

[HKEY_LOCAL_MACHINE\Comm\ConnMgr\Destinations\Secure WAP Network]

"ReadOnly"=dword:00000000

"Secure"=dword:00000000

"DestId"="{F28D1F74-72BE-4394-A4A7-4E296219390C}"

[HKEY_LOCAL_MACHINE\Comm\ConnMgr\Destinations\The WAP Network]

"ReadOnly"=dword:00000000

"Secure"=dword:00000000

"DestId"="{7022E968-5A97-4051-BC1C-C578E2FBA5D9}"

[HKEY_LOCAL_MACHINE\Comm\ConnMgr\Destinations\The Internet]

"ReadOnly"=dword:00000000

"Secure"=dword:00000000

"DestId"="{436EF144-B4FB-4863-A041-8F905A62C572}"

Once the above is added back to the registry, you'll get back the "internet" or "work" settings under "My network card connects to" and wifi works with browser then

Share this post


Link to post
Share on other sites

I had the same problem. After few hours of banging my head against the keyboard, I accidentally stumbled over the solution. It was in to the security protocol in wifi router. Instead of TKIP I set it to AES. Now it works perfectly. Hope this will help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.