Jump to content
BamDastard

New ROM for Omnia i910

Recommended Posts

I am a dumba$!!! Does anyone have the original firmware version for the i910? I didnt make a backup and installed the wrong ROM. Someone please help.

There isn't a rom available for the original firmware. If you updated to the the wrong rom (not sure how that happens)...try updating to the one in the first post of this thread. If you bricked your phone...you bricked your phone.

EDIT: Ardvarkofdoom schooled me up on this one. AZIntergra did post the original rom...see below. Good looking out Ardvark!

Edited by GlassEyedPete

Share this post


Link to post
Share on other sites
To the ROM author - this is 5th or 6th brick already, with only few dozens of people who tried to flash. We followed the instructions in PDF precisely and it still bricked our phones. Perhaps you should consider withdrawing the ROM, removing the links and files from webhosting, and putting some more work into it, instead of asking for donations...

Really? Only a few dozen?

pdf.gif Alignment___Adjustment.pdf ( 402.15K ) Number of downloads: 1309

zip.gif UMDL_OMNIA_v2.3.rar ( 164.49K ) Number of downloads: 730

And that's JUST for the instructions and the actual flash program itself. This is also not taking into account people who have downloaded the programs/images from other places as well (there are "megaupload" links for these items now as well... There is a funny thing about good news and bad news... If something goes right, then yeah, you'll have a few people come here and say "thanks" and "+1" and "working" and the like, but you can count on pretty much EVERY person that bricks their phone one way or another will come and post and complain. From some of the bricks it sounds like it was user error/poor planning! Bad connects, phone turning off in middle of flashing, not actually following directions. I think there are s*** ton more people than you realize that have this up and running no problem. Am I saying that this is brick proof? No but that the number of working devices vs bricks are more staggering than you realize. Especially when you see the posts of "OH NOES! I BRICKED MY PHONE!" followed later by being slapped and then "OH LOOK, I FOLLOWED THE DIRECTIONS THIS TIME AND IT WORKS NOW!"

And to re-iterate what others have said, this is a leaked SAMSUNG ROM, not some homebrew. Its funny how people that don't read everything are more than not the ones with the bricks!

Share this post


Link to post
Share on other sites
There isn't a rom available for the original firmware. If you updated to the the wrong rom (not sure how that happens)...try updating to the one in the first post of this thread. If you bricked your phone...you bricked your phone.

Yeah there is, Tegra posted the original ROM as well.... It's in one of the threads, just look for posts with ALL CAPS :excl:

Share this post


Link to post
Share on other sites
Yeah there is, Tegra posted the original ROM as well.... It's in one of the threads, just look for posts with ALL CAPS :excl:

Could you post a link...I don't need it, but it may help some of the others.

Share this post


Link to post
Share on other sites
Could you post a link...I don't need it, but it may help some of the others.

Here is once again another ROM for Verizon i910. people were asking for another ROM so if they want to flash back they can.

I'm putting my ass on the line here so please don't go posting these on other forums

Also if anyone would like to make a donation please do. And thank you to the user's who have already it very much appreciated. please follow the link below to make a donation.

donation's: https://www.paypal.com/cgi-bin/webscr?cmd=_...tton_id=4614829

download: http://www.megaupload.com/?d=ETNWPPG5

ROM VERIZON IS CB06 GPS IS LOCKED I BELIEVE I HAVE NEVER TESTED IT BECAUSE ITS AN OLDER MODEL LOL. I'M GONA B REPLACING THIS LINK IN A FEW WITH CB26 ROM

NEW ROM WILL BE AVAILABLE SOMETIME IN THE BEGINNING OF MAY. THERE IS NO EXACT POSTED DATE AS OF YET. IT JUST STATES IN NEW INFO BLOG NEW RELEASE EARLY MAY FOR VERIZON WIRELESS. AS SOON AS ITS AVAILABLE I WILL POST IT FOR EVERYONE.

FEW UPDATES IT SAID TO LOOK FORWARD TO ARE:

UPDATED GPS ABILITY AND FUNCTIONALITY

INCREASED CALL VOLUME

INCREASE FOR RINGER VOLUME

UPDATED BROWSER

INCREASED BATTERY LIFE

BETTER TOUCH FUNCTIONS.

THAT'S ALL THAT'S POSTED SO FAR. ILL KEEP YOU ALL UPDATED IF ANYTHING NEW IS POSTED.

Share this post


Link to post
Share on other sites
There isn't a rom available for the original firmware. If you updated to the the wrong rom (not sure how that happens)...try updating to the one in the first post of this thread. If you bricked your phone...you bricked your phone.

I have tried multiple times and get the following message. "Eboot does not support dpram downloader. download aborted."

Share this post


Link to post
Share on other sites
I have tried multiple times and get the following message. "Eboot does not support dpram downloader. download aborted."

Somebody said they got around this error in an earlier post in this thread (within the last 5 pages). I would check that out.

Share this post


Link to post
Share on other sites

Wow. How did you do the wrong ROM lol? Im so glad you guys are able to get the phones replaced, that is a good sign. It is becoming obvious that this is a very risky ROM, if I hadn't done it already, reading all the comments, I may not have taken the chance. However, the risks are clearly stated in the first post, so we cant really blame anyone.

Share this post


Link to post
Share on other sites

I flashed the new rom and everything appeared to be working well. I then when into orb and streamed my tv tuner to my omnia. Strangely, the screen is badly cropped and lagging. (I clicked the fit to screen button in WMP) It was working fine on the old rom. Anyone else using orb notice this with the video in WMP?

Share this post


Link to post
Share on other sites
Really? Only a few dozen?

pdf.gif Alignment___Adjustment.pdf ( 402.15K ) Number of downloads: 1309

zip.gif UMDL_OMNIA_v2.3.rar ( 164.49K ) Number of downloads: 730

And that's JUST for the instructions and the actual flash program itself. This is also not taking into account people who have downloaded the programs/images from other places as well (there are "megaupload" links for these items now as well... There is a funny thing about good news and bad news... If something goes right, then yeah, you'll have a few people come here and say "thanks" and "+1" and "working" and the like, but you can count on pretty much EVERY person that bricks their phone one way or another will come and post and complain. From some of the bricks it sounds like it was user error/poor planning! Bad connects, phone turning off in middle of flashing, not actually following directions. I think there are s*** ton more people than you realize that have this up and running no problem. Am I saying that this is brick proof? No but that the number of working devices vs bricks are more staggering than you realize. Especially when you see the posts of "OH NOES! I BRICKED MY PHONE!" followed later by being slapped and then "OH LOOK, I FOLLOWED THE DIRECTIONS THIS TIME AND IT WORKS NOW!"

And to re-iterate what others have said, this is a leaked SAMSUNG ROM, not some homebrew. Its funny how people that don't read everything are more than not the ones with the bricks!

ardvarkofdoom i typed long response to you here, but the gay web filtering software at my workplace messed it up and deleted it. I dont have the patience to type it all over again, so I'll just say it shortly: you're wrong about pretty much everything you said, as number of downloads doesnt directly indicate number of bricks, if you count number of downloads from other sites, why dont u count number of bricks from other sites and not posted here as well? You're wrong about people not following the instructions and myself ive done flashing with other phones, including gsm omnia i900 a million times. lastly, phones dont have minds of their own to power off in the middle, unless you're dumb enough to flash with drained battery and unlike edge, ev-do,wifi, USB hardly ever has "bad connects" - when its plugged - its plugged. This ROM is unsafe and I do not recomment anyone to download it

Share this post


Link to post
Share on other sites

I'm sure there are some legit claims, but this rom wouldn't have even made it to beta testing if it was bricking one out of every five devices. You don't beta test something with that degree of error. When the official rom is released, it will have an installer that makes it nearly impossible to brick.

To those of you having problems with this, I would look into what your pc is running. I sincerely believe the issue causing the bricks is a usb interruption during the install (at least for the ones that followed directions correctly up to that point).

Edited by GlassEyedPete

Share this post


Link to post
Share on other sites
Another brick here...same symptoms as somedude and pylesw. The only difference is that my EBOOT flash got stuck at 15%, not 48%.

I went to Verizon and managed to get it replaced.

To the ROM author - this is 5th or 6th brick already, with only few dozens of people who tried to flash. We followed the instructions in PDF precisely and it still bricked our phones. Perhaps you should consider withdrawing the ROM, removing the links and files from webhosting, and putting some more work into it, instead of asking for donations...

This is very expensive device, and personally, i'm not attepmting another flush of this ROM to my device, as I dont think I can get Verizon to replace it again - they document everything.

ROM and the downloader program, which performs the flash need to be thoroughly tested before being released to public, this isn't a regular app - if it's faulty it'll brick your phone, and there is nothing you will be able to do about it.

Mines got stuck at 15% too...

Maybe the img file needs to be .rar'ed up?

Maybe the .img files we downloaded were corrupt. I followed the steps to a T man, im not a noob at this stuff at all. I hate it when people assume that we were just some noobs that didnt know what we were doing and thats why our phones were bricked.

Anyways, i think someone should take the .img file that worked for them, rar it up and post a new link. That would be great if someone can do that.

Edited by somedude

Share this post


Link to post
Share on other sites
When the official rom is released, it will have an installer that makes it nearly impossible to brick.

that's when i'll be flashing my Omnia. if it dies again with official rom and installer - I don't have to come up with stories and can just tell Verizon their installer/ROM has failed.

Share this post


Link to post
Share on other sites

My sincere sympathies to the handful that have got bricked...

More good news when it works... I backup up with SPB Backup before the upgrade, then after successful upgrade and a little testing, I did a full restore with SPB. It detected that I had a new ROM, so gave me the option to restore in "ROM Update" mode -- which worked like a charm.

So, not only do I now have a working GPS, all the new features added (and yes, it is quite a bit faster!!), but my phone -- my heavily customized, tweaked, not-recognizable-as-an-Omnia -- is the same as it was before, plus some nice goodies.

I couldn't have asked for more.

Share this post


Link to post
Share on other sites
My sincere sympathies to the handful that have got bricked...

More good news when it works... I backup up with SPB Backup before the upgrade, then after successful upgrade and a little testing, I did a full restore with SPB. It detected that I had a new ROM, so gave me the option to restore in "ROM Update" mode -- which worked like a charm.

So, not only do I now have a working GPS, all the new features added (and yes, it is quite a bit faster!!), but my phone -- my heavily customized, tweaked, not-recognizable-as-an-Omnia -- is the same as it was before, plus some nice goodies.

I couldn't have asked for more.

I can't really complain, but I wish I'd known this yesterday. I spent hours restoring my phone settings. Somebody posted that you couldn't back-up across roms, so I believed them. Live and learn.

Share this post


Link to post
Share on other sites
To those of you having problems with this, I would look into what your pc is running. I sincerely believe the issue causing the bricks is a usb interruption during the install (at least for the ones that followed directions correctly up to that point).

I agree with you it is most likely USB interruption during the install. However - I have flashed the i900 Omnia before on the exact same PC using the same USB port...

USB problems are unavoidable in many cases, Microsoft has actually several open bugs on such USB issues, such as maximum bandwidth exceeding on a USB internal hub, if several devices connected to it, intermittant connection drops in the middle, due to unknown reasons, etc'. That is why proper ROM installers should take this into account and they do (all other ones I've used before)

and make sure phone doesnt get bricked if USB connection gets interrupted. The most common way it's done is you dont start the actual flash "on the fly", without fully downloading it to the phone first and you dont flash before installer runs the checksum of the downloaded image on the phone.

Share this post


Link to post
Share on other sites
I agree with you it is most likely USB interruption during the install. However - I have flashed the i900 Omnia before on the exact same PC using the same USB port...

USB problems are unavoidable in many cases, Microsoft has actually several open bugs on such USB issues, such as maximum bandwidth exceeding on a USB internal hub, if several devices connected to it, intermittant connection drops in the middle, due to unknown reasons, etc'. That is why proper ROM installers should take this into account and they do (all other ones I've used before)

and make sure phone doesnt get bricked if USB connection gets interrupted. The most common way it's done is you dont start the actual flash "on the fly", without fully downloading it to the phone first and you dont flash before installer runs the checksum of the downloaded image on the phone.

Yeah, people need to rephrase their statements. The rom itself is functional/outstanding; however, the delivery method is sh**. I don't know if there are other ways to install these .img files, but it would be hard for it to be worse than the current system.

Metaphorically, we have access to good beer, but you have to drink it from the toilet.

Edited by GlassEyedPete

Share this post


Link to post
Share on other sites
how did you brick it and what did you do differently 2nd time around, to flash successfully?

well the first time i tried it, i accidentally checked two of the boxes (i also didnt do a hard reset)... i had the rom installed succesfully, but then i needed to get it authorized cause i couldnt make or receive calls.

i spoke with the techs and got it authorized. then the data connection didnt work....

by then, my phone had already been formatted by the rom and i reloaded the backup i made.

well, when i was talking to them, i decided to reflash, except without the checks.... bad idea!!!! i should have hard resetted the phone, but since i didnt, it gave me an error right when it installed the rom saying cant work with DPRAM -- something like that. my phone was hanging at the verizon logo so i turned it off and tried the reflash... this time same message but i couldnt turn the phone on at all... just the red dot at the power.

-------------------------

well since i got the new phone, i knew i wasnt supposed to check the boxes and i knew that my phone was clean, so i installed the ram and worked perfectly without needing to authorize or authenticate!

Share this post


Link to post
Share on other sites
+1 flashed successfully. this is my first post so i'll make it good. for some of you i can't figure what went wrong.

this is what i did, full story, step by step. 1st, i've read through the entire threads, this and the gps thread, and the pdf file. downloaded UMDL and CC20. following pdf to the T. installed usb drivers from VZAccess cd (just the drivers i didn't install VZaccess) and restarted computer (i'm running Vista btw and have activesync 4.5).

prior to hooking up omnia to usb, i hard reset (just to be safe, although i knew flashing would do this anyway) then *228 1.

then set in settings/system/data connection - internal data call, then settings/connections/usb connections - active sync,

then /usb to PC - unchecked enabled advanced network functionality. powered off (held down power button).

then on computer (vista) went to control panel/windows mobile device center - mobile device settings/connection settings - i took a chance and unchecked all boxes. i also made sure i had nothing else running in the background and even turned off my screensaver.

opened up UMDL, clicked on "unified image file" selected CC20, made sure bootloader and initializer boxes were unchecked (haven't touched anything else with UMDL). Hit detect.

hooked omnia to usb, turned it on, found phone, rest is history.

after phone restarted, i could send/receive calls, texts, but no mms or gps. so i *228 1, *228 2, now mms works. in phone settings/services/gps put location on, soft reset, said ok to disclaimer, and gps works (on gmaps takes some patience, but got 5 sat locate me within 30 meters)

things i've noticed with this rom: easy hotmail now with windows live, touch scrolling does seem better, backlight auto adjust DOES WORK (more responsive), regedit works (cures escalating ringtone, disconnect data, etc.)

it's like i have a whole new phone!! :excl: :excl:

That's what I don't get. I did everything that you did, only my phone bricked. I think that it is great that the ROM got released early, but I don't think that I'll be trying this again for a while. It'd be hard to explain why I was exchanging my phone twice.... I guess I'll just wait till the official release.

Share this post


Link to post
Share on other sites

Sorry dude, I wasn't saying that you specifically didn't know what you were doing... just that there aren't nearly as many true bricks out there to how many people have truely got this working.

Anyways, Somedude, I'm not sure about the image being corrupt, but I guess anything could be possible. Since 7-zip can only decompress rar but not compress to it, I just zipped the image that I used...

http://www.megaupload.com/?d=BVOWWD4A

Share this post


Link to post
Share on other sites

perfect. absolutely perfect. runs much faster, keyboard is a nice bonus. i have no clue how people are breaking their phones, its pretty simple to follow the directions. once again, this rom runs completely perfectly. great improvement

Share this post


Link to post
Share on other sites
Sorry dude, I wasn't saying that you specifically didn't know what you were doing... just that there aren't nearly as many true bricks out there to how many people have truely got this working.

Anyways, Somedude, I'm not sure about the image being corrupt, but I guess anything could be possible. Since 7-zip can only decompress rar but not compress to it, I just zipped the image that I used...

http://www.megaupload.com/?d=BVOWWD4A

I'm fairly certain the previously uploaded ROM is fine. Since it's been archived and extracts with no problems and people are reporting it runs well it's highly unlikely the actual ROM image is corrupted. The problem is with the shitty installer, which doesnt know how to handle USB interrupts, when downloading EBOOT image stops in the middle and what's even worse - it looks like it's not even verifying image integrity by comparing the checksums of the image, uploaded to phone. As a result, I think it tries to flash incomplete EBOOT image file, after the installer falsefully reports "download complete", if the USB channel drops and it has to resume or overwrite partial image. As we, bricks, reported the installer shows EBOOT download instantly goes to 100% after it hangs in the middle and we restart it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.