Jump to content
PaulOBrien

10/Mar 3.2 - MoDaCo Custom ROM for GSM Hero (now with online kitchen)

Recommended Posts

Anyone know if there is any advantage of installing branded firmware (new released ones) over 2.2? The t-mob is due out shortly, but not sure if its worth the effort. Did use 2.3 for a while but was causing quite a bit of problems, so went back to 2.2 happily.

Share this post


Link to post
Share on other sites

i will get hold of Android 1.6, and have a look, will be next week tho. Maybe another chef will have released something by then too :).

Basically i dont know that much about Android, but i didnt know much about a WinMo 18 months ago and i can decompile WinMo and make my own ROMs.

So everyday i learn something new about Android.

I have & am using Pauls 2.3 build (modified by me :D), i think it is very good. Not had any issues to date. This build can be edited to make different builds, which is what a few people have done already.

I already have my own verison of Pauls build, some further stuff removed.

It should be a case of removing the Android stuff, and replacing it, but i also know it wont be as simple as that. But i will have a good look at it.

Hopefully i can get something working from it?

It wont be long before we see 1.6 builds flying about for HTC Hero. I can't understand why this device is not the first device to get the 1.6 update, seen as its newer and has more capabilities than the older HTC (Magic & G1).

Laters

Edited by shokka9

Share this post


Link to post
Share on other sites

Please, help :D

Well, here is my situation... I have an HTC Hero with MoDaCo ROM 2.3. Everything is ok. But, I'd like to do some tests :) .

So, I do a nandroïd backup and then, I save all my SD card. After this, I launch "parted" in order to have a FAT32 partition (~ 6 Go), an ext2 partition (~ 900 Mo) and a swap-linux partition (96 Mo). Then, I move my ext2 partition into ext3 and then into ext4. At the end, I put my data back onto the FAT32 partition.

But, when I reboot my phone, I can see "HERO", "HTC", "HERO", "HTC", etc...

Do you any idea of my problem ? Is it because of the ext4 partition ?

Thanks a lot.

David.

Share this post


Link to post
Share on other sites
Please, help :D

Well, here is my situation... I have an HTC Hero with MoDaCo ROM 2.3. Everything is ok. But, I'd like to do some tests :) .

So, I do a nandroïd backup and then, I save all my SD card. After this, I launch "parted" in order to have a FAT32 partition (~ 6 Go), an ext2 partition (~ 900 Mo) and a swap-linux partition (96 Mo). Then, I move my ext2 partition into ext3 and then into ext4. At the end, I put my data back onto the FAT32 partition.

But, when I reboot my phone, I can see "HERO", "HTC", "HERO", "HTC", etc...

Do you any idea of my problem ? Is it because of the ext4 partition ?

Thanks a lot.

David.

You should try to watch the boot logs, using logcat, you could see some exceptions at startup and try to fix them.

See my post here http://android.modaco.com/index.php?act=fi...amp;pid=1075524

Share this post


Link to post
Share on other sites

Dear Modaco Admins,

I have just upgraded to the HTC HERO on the orange network. I firstly upgraded the ROM via the HTC website to version: 2.73.61.5

Having saw some youtube posts that have recommended your custom, I have rooted my phone and installed the latest version with the following build number:ModaCo custom rom 2.3 core chinese.

however it still doest seem as smooth as the operation in the clip at link below. I have taskkiller installed, the only thing I havent done is partition my SD, which i will do later.

Also I loved the tilt animation in the clip (at 1.55 into the clip), which I thought was be part of your custom rom. I dont have this, any reason?

LINK:

http://www.youtube.com/watch?v=bRPr4K_mpkM

thanks for your time.

Edited by delbacca

Share this post


Link to post
Share on other sites
Also I loved the tilt animation in the clip (at 1.55 into the clip), which I thought was be part of your custom rom. I dont have this, any reason?

It's there in your Phone too. Just open the Spare Parts application and you'll see an option titled "Fancy rotation animation". There ya go! :)

Share this post


Link to post
Share on other sites

Hey Paul/guys,

Any news on a 2.4 build yet?

I've had 2.3 on my hero for too long now and I'm getting the itch to play with some new features! Lol...

Dickie.

Share this post


Link to post
Share on other sites
It's there in your Phone too. Just open the Spare Parts application and you'll see an option titled "Fancy rotation animation". There ya go! :)

oh right, didnt know its from an app.

is there an app to run apps on phone bootup?

thanks mark'oh!

Edited by delbacca

Share this post


Link to post
Share on other sites
Im Using the latest rom on my hero 2.3-update-hero-modacocustomrom-core-signed.zip

On People widgtet it fail if i try to move and select other person there

It work file with the last ROM

The process name that fail is TouchFlo

Share this post


Link to post
Share on other sites
Here's the magic:

adb shell

   sqlite3 /data/data/com.android.providers.telephony/databases/mmssms.db

   ALTER TABLE sms ADD COLUMN index_on_sim INTEGER DEFAULT -1;

   (Press Control-D)

   exit

Worked.....

Rattled my brain for hours, could not for the life of me, work out why this was happening, i could surf the net, send SMS/MMS, email, make calls.

The only thing i could NOT do was receive SMS!!

WTF??

Now it is fine, take a minute to receive it, but better than ghostly SMS that i was getting!

Thanks for this very useful post.

:)

Share this post


Link to post
Share on other sites
Is there anyway to know if it is really installing apps in ext3?

take out the sdcard, and try to launch the apps :D

easiest & quickest way.

:)

Share this post


Link to post
Share on other sites

Hi

I removed the SDCard to see if the Apps were stored on the SDCard. It turns out only some apps are stored on the SDCard and some on the device. Some apps could be started anyway even though I installed them today and I have restarted the device. Why not all apps on SD?

Btw, I think my Hero is kind a sluggish with the MCR 2.3. Anyone else has this problem?

Also, does anyone have a good app (windows) to extract contacts to the PC and edit the info and send it back to the device? It's kind of hard to copy/paste on the device. Also if same contact is duplicated with different info. I know there is vCardIO but I don't want to edit it in notepad. Any application to help out with this?

Share this post


Link to post
Share on other sites

ideas for 2.4:

  • donut version for the actual htc hero would be great
  • calendar widget that updates the correct day everyday. the stock "desktop" widget that doesn't change the date sucks.
  • in the browser would be great to have a "home" button
  • the camera is still way to slow and unresponsive when trying to take a photo
  • better aps to sd support (more automatic)
  • alarm clock (like everyother phone) where you can set the alarm and turn the phone off and the alarm wakes the phone up at teh designated time
  • when you are on a call - option in settings to keep the screen active, soooo annoying that the screen blacks out/goes to sleep when on a call

love the 2.3 rom paul :) , keep up the awesome work!!!!

Share this post


Link to post
Share on other sites

hey people... i just rooted my hero and applied the modaco rom a couple days ago... and the only thing bugging me is that when i long press on a widget or app (both from the apps menu and also on any one of the home screens) there's a delay for it to 'pick it up'.

what i mean is that the small vibrate thing that happens just before you want to move something around on the screen doesn't happen until i actually start moving it. prior to applying the custom rom if i long pressed an item it'd vibrate after a second or so, so that you knew you could move it... but that doesn't happen now... i don't know if i can move it until i press really hard on the screen and just try moving it and then the small vibrate thing happens after i've started dragging. 

is this just my phone or are other people experiencing it? and also, is there a fix for it??

cheers,

-fuz

Share this post


Link to post
Share on other sites

Does anyone know when 2.4 will be released? It's bee quite awhile, and I'm starting to wonder if my contribution to Paul's Hero fund has gone into a dead end... :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.