Jump to content
PaulOBrien

21/Jan 1.5 - Superboot - rooting without a Custom ROM - NOT FOR ANDROID 2.1

Recommended Posts

Updated to support the December update.

P

Really? Looks the same to me, and the zip file says the boot.img was last modified in October...

Share this post


Link to post
Share on other sites
I don't think superboot works with a dec phone yet, if you want to install mcr1.5 just boot RA Recovery "fastboot-windows boot recovery-ra-pulse-v1.5.2.img" and install using that.

how do you reapply the december update when you are in the endless loop?

Share this post


Link to post
Share on other sites
how do you reapply the december update when you are in the endless loop?

Any of these options...

1. Power on while holding volume + and red key, the update should be on your sd card

2. If you have the Dec bootloader and have flashed the recovery image, power off then hold red key + menu + power to get into the recovery image.

3. Boot the recovery image using your pc connected to the phone

Share this post


Link to post
Share on other sites

Just wondering why the installation uses fastboot flash rather than just fastboot boot, is there any need to flash rather than just boot it?

I tried with just the boot version and it seems to do the same thing.

Share this post


Link to post
Share on other sites
Just wondering why the installation uses fastboot flash rather than just fastboot boot, is there any need to flash rather than just boot it?

I tried with just the boot version and it seems to do the same thing.

Fastboot flash stores the image for future use, fastboot boot is a onetime operation, can be used to test custom ROMs, recovery images etc. without any permanent changes to your phone.

Share this post


Link to post
Share on other sites

Hi. Hope you guys can help me sort out rooting my Pulse and help me get rid of half of the native apps. That's the only reason i installed Superboot! It seems to work fine, I installed Better Terminal but I still can't delete native apps. So I tried from my PC thru ADB Tool but after opening the CP and entering C:\ADB and then adb remount, I get "error: device not found".

What gives?

Thanks,

Update: my phone is rooted.whenever I try removing an app by writing "rm /system/app/IM.apk" for example, I get "rm failed, no such file or folder...."

Edited by bograma

Share this post


Link to post
Share on other sites
This is not necessary if you plan to use a custom ROM, it's only necessary if you want to root your stock ROM!

For my Pulse rooting solution I thought i'd do something a bit different - introducing.... Superboot! :)

Superboot is a boot.img that when flashed, will root your device the first time you boot (installing su and the superuser APK). No need to flash the system partition, no need to use ADB, no messing with the contents of your data partition, no overwriting the shipped ROM on your device, just flash the boot image using the instructions below and you're done!

How to use Superboot - Windows, Linux and OSX

- Download the Superboot zip file from below and extract to a directory

- Put your device in bootloader mode - turn if off, then tap the powerbutton while holding the 'Volume Down' and 'End (Red)' keys

- WINDOWS - double click 'install-superboot-windows.bat'

- MAC - Open a terminal window to the directory containing the files, and type 'chmod +x install-superboot-mac.sh' followed by './install-superboot-mac.sh'

- LINUX - Open a terminal window to the directory containing the files, and type 'chmod +x install-superboot-linux.sh' followed by './install-superboot-linux.sh'

Download

Check if you have the 'December Update' - turn the device off, then turn if on with 'volume down' and 'end call' held. If the build date is Nov 26 2009 or newer, you have the December update applied.

Version for devices WITH the 'December Update' - http://www.romraid.com/paul/pulse/1.5-pulse-superboot.zip

Version for devices WITHOUT the 'December Update' - http://www.romraid.com/paul/pulse/1.4-pulse-superboot.zip

That's it, job done! Enjoy! B)

P

Hi,

I'm trying to download the superboot zip files in this post, but i keep getting redirected to the home page for modaco. Have the files been moved somewhere else? I can download the december-update file from the same general area (romraid.com/paul/pulse/)

Just wondering if I am missing something really obvious here !

Cheers

Share this post


Link to post
Share on other sites

hmmm n00b or incompatable system...

i have win 7 x64

installed the drivers from the PC suite and even tried to update them from the superboot or aman ra folder but they are the same

installed the December update

(ignore the xxxxx just cba putting the actual values...)

turn on to fastboot and get...

USB Fastboot v0.5

Machine ID xxxxx

Build Date Nov 26 2009 11:05:05

Serial Number: UNKNOWN

then I run the installer (fastboot or superboot - both same)

Writing 'recovery' (3xxxxxx bytes) - OKAY

and it just sits there...

I turn off phone and restart - no root access

What am I missing?

cheers in advance

Share this post


Link to post
Share on other sites
hmmm n00b or incompatable system...

i have win 7 x64

installed the drivers from the PC suite and even tried to update them from the superboot or aman ra folder but they are the same

installed the December update

(ignore the xxxxx just cba putting the actual values...)

turn on to fastboot and get...

then I run the installer (fastboot or superboot - both same)

and it just sits there...

I turn off phone and restart - no root access

What am I missing?

cheers in advance

What makes you say it's not rooted? have you tried an app that requires root such as quickboot (which should now be installed)?

Share this post


Link to post
Share on other sites
What makes you say it's not rooted? have you tried an app that requires root such as quickboot (which should now be installed)?

hmmmm

tried multiple times to use quickboot and permissions etc but ignored them.

then i removed the usb cable and it worked...

just installed the t-mo rom with no problems. just gonna try the vanilla rom.

but props starkos for the prompt reply

H

Share this post


Link to post
Share on other sites
hmmmm

tried multiple times to use quickboot and permissions etc but ignored them.

then i removed the usb cable and it worked...

just installed the t-mo rom with no problems. just gonna try the vanilla rom.

but props starkos for the prompt reply

H

or at least i would do if it let me download the zip ... everything fownloads but this wont...

Share this post


Link to post
Share on other sites

HELP!

I installad the recovery image, but in order to use Quick Boot from Market it asked the phone to be rooted, so I followed this guide. After it was rooted the touch screen stop working. Any ideas ?

The BootMode says:

USB FastBoot: V0.5

Machine ID: 1007000 v0

Build Date: Oct 20 2009, 23:21:44

Serial Number: UNKNOW

Any help is welcome.

PD: When I tried the December update it said "Update Failed" in a yellow triangle with a Black Exclamation mark. My phone is not from T-Mobile. Is a demo from Huawei.

I use a Mac but I can get a PC if needed.

Share this post


Link to post
Share on other sites
HELP!

I installad the recovery image, but in order to use Quick Boot from Market it asked the phone to be rooted, so I followed this guide. After it was rooted the touch screen stop working. Any ideas ?

The BootMode says:

USB FastBoot: V0.5

Machine ID: 1007000 v0

Build Date: Oct 20 2009, 23:21:44

Serial Number: UNKNOW

Any help is welcome.

PD: When I tried the December update it said "Update Failed" in a yellow triangle with a Black Exclamation mark. My phone is not from T-Mobile. Is a demo from Huawei.

I use a Mac but I can get a PC if needed.

More info. I tried the superboot for December update and the phone start power cycling (powerof and on constantly) I managed to put it in BootMode (blue scree) and applied the 1.4 superboot and it fixed the power cycling, but the screen is still not working.

Share this post


Link to post
Share on other sites
More info. I tried the superboot for December update and the phone start power cycling (powerof and on constantly) I managed to put it in BootMode (blue scree) and applied the 1.4 superboot and it fixed the power cycling, but the screen is still not working.

Is there any way to undo the 1.4 SuperBoot ? If anyone can write an undo it will really help me a lot. As of today I still coulnd´t fix the touch screen.

Thanks in advance.

Regards.

Share this post


Link to post
Share on other sites
Is there any way to undo the 1.4 SuperBoot ? If anyone can write an undo it will really help me a lot. As of today I still coulnd´t fix the touch screen.

Thanks in advance.

Regards.

restore your nandroid backup.

Share this post


Link to post
Share on other sites
restore your nandroid backup.

Does the "1.4-pulse-superboot" app creates a nandroid backup? If so, how I force a restore?

Is there any way to completly wipe out with a new firmware the U8220 ?

Thanks in advance.

Regards!

Share this post


Link to post
Share on other sites
Does the "1.4-pulse-superboot" app creates a nandroid backup? If so, how I force a restore?

Is there any way to completly wipe out with a new firmware the U8220 ?

Thanks in advance.

Regards!

no backup is created automatically...I thought you might have created one manually through recovery.

you can wipe/delete the existing partitions on the phone, but to have a working phone you must find a replacement img/ROM to put in.

Share this post


Link to post
Share on other sites
no backup is created automatically...I thought you might have created one manually through recovery.

you can wipe/delete the existing partitions on the phone, but to have a working phone you must find a replacement img/ROM to put in.

But to have recovery working I needed to hace root access, and that was that killed the phone.

I´ll try to get a new ROM.

Share this post


Link to post
Share on other sites
But to have recovery working I needed to hace root access, and that was that killed the phone.

I´ll try to get a new ROM.

You don't have to have root access to access the recovery.

you can either install the recovery and then boot with Menu + Red button if you have the december update.

or if you don't have Dec (and if you do as well) you can boot it using:

fastboot boot <filename of recovery image>

Share this post


Link to post
Share on other sites

Hey, I've dl the superboot 1.5 zip, but I'm a not sure where to put the pulse.superboot.img. Does that go on my pulse and then I run the install-superboot-linux.sh on my ubuntu machine?

I can't seem to access the pulse when its in fastboot mode (the blue screen)

cheers

Share this post


Link to post
Share on other sites
Hey, I've dl the superboot 1.5 zip, but I'm a not sure where to put the pulse.superboot.img. Does that go on my pulse and then I run the install-superboot-linux.sh on my ubuntu machine?

I can't seem to access the pulse when its in fastboot mode (the blue screen)

cheers

you dont need to copy it to the pulse just extract the folder with all the files inside to the desktop

open the terminal

go to where you extracted it

type chmod +x install-superboot-linux.sh and then type ./install-superboot-linux.sh while in the blue screen mode

Edited by Richard_Arkless

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.