Jump to content
PaulOBrien

26/Jan 2.2 - MoDaCo Custom ROM for Sprint CDMA Hero (now with online kitchen)

Recommended Posts

Love the new 2.0! Tried to use the kitchen to make a custom version and it won't connect to the network for data. Kinda odd. Haven't had that problem with any of your other builds. Had to flash back to 2.0 to have something that worked. Would love to use the kitchen and get rid of the Sprint fluff that I never use, but if it can't connect to the network for data, I can't use it! Help?

I'm also having the FC issue with quickboot. Would really like to get that back if possible! Any way to get that into the kitchen builds and get the data connection to work?

Edited by woofers1803

Share this post


Link to post
Share on other sites

Hmmm, odd, nothing in the kitchen build affects data! I can update the kitchen to fix the quickboot issue shortly tho.

P

Share this post


Link to post
Share on other sites
Hmmm, odd, nothing in the kitchen build affects data! I can update the kitchen to fix the quickboot issue shortly tho.

P

Any idea why there would be issues with sending MMS? I have been having intermittent issues with sending MMS that seem to come on when I flash. Sometimes wiping seems to fix it, other times it doesn't. Using Handcent, and the dev over there can't seem to figure it out either.

Thanks for the effort on the quickboot thing! Having that back is going to be really nice.

I might just do a wipe of everything and start over tomorrow with a kitchen build if it's got the quickboot in it. Maybe that will work. I really dunno what else to try. The problems started when I flashed a fresh ROM, and have been going downhill ever since. Thought I had it fixed last night, and then I tried to flash a kitchen build... must be my luck! Any other suggestions? Should I just go back to the RUU and re-root it or would a wipe be enough if I wipe the ext partition as well? I have nothing to do for a couple days, so I've got time to make it work!

Has anyone else had issues with Google Maps jumping around with your location? I've tried to find it in the market and it won't show up. I seem to get all the issues that everyone has and then some new ones. Anyone with advice would be greatly appreciated. I have tomorrow totally free and can work on it all day!

Share this post


Link to post
Share on other sites

Stuff in /data (as shown in the kitchen) won't be wiped by the ROM install, you should uninstall those from the Applications menu before installing. Or after installing. :)

P

Share this post


Link to post
Share on other sites

Hello, I am currently running Fresh 1.1 and I'm wondering if this ROM is stable enough for daily use. I don't have a computer at hand regularly so flashing this ROM would be risky. I have minimal apps installed/using. What's your opinion guys? Thanks

Share this post


Link to post
Share on other sites
Shouldn't be...?

P

Yeah... that's kinda what I thought. B) I think I am going to spend tomorrow morning starting over. I think going back and forth between Fresh and the original MoDaCo without wiping anything might have caused me some problems. I should never have gone and tried something new! I had no problems at all with the original release! Either i've got electronic gremlins or something got messed up somewhere.

Can you post something when the quickboot FC is fixed? If it's done by tomorrow morning I would love that to be the ROM i settle with and just flash it once! :)

I'm kinda learning as I go, we'll start over and make up for what I probably screwed up along the way! Thanks for all of the help! Most responsive Dev out there! So much easier than trying to get a hold of other Dev's!

Do we have any idea when we're going to get a custom ROM based on Android 2.0 or 2.1? That would be amazing! Keep up the great work Paul!

Share this post


Link to post
Share on other sites

The quickboot FC can be fixed by running 'adb remount' and 'adb shell ln -s /system/bin/toolbox /system/bin/reboot' :)

P

Share this post


Link to post
Share on other sites
The quickboot FC can be fixed by running 'adb remount' and 'adb shell ln -s /system/bin/toolbox /system/bin/reboot' :)

P

yeaaa it works.

EDit: adb shell reboot only reboots it from a computer. Quickboot still FC.

Edited by david279

Share this post


Link to post
Share on other sites

I installed after doing a Nandroid backup and then wiping. It rebooted, went to the lock screen. When I swiped the lockscreen away. it kept defaulting to the htc bootscreen and never went away. I let it sit for about 10 mins. Can I expect it to take that long?

Thanks. By the way, congratulations on the kitchen!

Share this post


Link to post
Share on other sites

i had to revert back to 2.0..when i created what i wanted, it knock out my network connection...i went in to my msl config everything appears to be what it suppose to..

Edited by reddick

Share this post


Link to post
Share on other sites
i had to revert back to 2.0..when i created what i wanted, it knock out my network connection...i went in to my msl config everything appears to be what it suppose to..

i also wanted to add to this that some how the software version was not added it was blank....

Share this post


Link to post
Share on other sites

reddick, did you try a build with just the default options to see if one of the 'removals' is causing this?

You say the software version was blank... where?

P

Share this post


Link to post
Share on other sites
reddick, did you try a build with just the default options to see if one of the 'removals' is causing this?

You say the software version was blank... where?

P

post-202956-1263404559_thumb.png

the software version of the rom i cooked from your utility it was showing no version number it was blank, i did a reboot and still the same.

Ok, i was on your rom 2.0 i build the rom using your utility i check on the apps i wanted then it baked.I did no wipe or maybe i should ? but i have the cooked file if you like to review it.To fix my i had to go back to 2.0 but still had the issue with no network internet .I had to go back to stock then to custom rom..

Also when the rom was cooked it changed to version 3.1

hope this helps

Edited by reddick

Share this post


Link to post
Share on other sites

I'm trying to get this ROM working for the 5th time. I've tried wiping (everything), partitioning the sd card etc... Every time results in the device getting to the HERO screen and sitting there for up to 30 minutes (The longest I've been patient for). Restarting back into recovery mode and flashing my nandroid backup to the RUU I updated to earlier fixes it, so its not the end of the world but it does stop me from getting this going on my phone.

So questions,

1. how long is it supposed to stay on the "HERO" splash screen after first install?

2. could this be due to using v1.5.2 of the Amon Ra recovery flash

3. does anyone have the stock CDMA HTC Hero ROM backed up (telus)? If I can't get this rom working I'd like to get back to the normal/stock setup on the phone, but stupidly did not nandroid it before installing the new RUU

Share this post


Link to post
Share on other sites

1. Not that long

2. No

3. No....

One point, this is based on the Sprint update, could that be an issue if you're on Telus?

P

Share this post


Link to post
Share on other sites

I followed the link to this guide from someone saying they had the 2.0 Rom working on their Telus Hero, so I assume someone got it working. Just wish they could help me get mine going :)

I'm back to the downgraded HTC RUU and I guess I'm stuck with that until the HTC/Android 2.1 update comes out *crosses fingers it will actually be in Q1 2010*

Share this post


Link to post
Share on other sites

I've updated the core in the online kitchen so installs generated now should have the reboot bug fixed.

Link: http://android.modaco.com/content/htc-hero...rint-cdma-hero/

Feedback please! :)

In other news, i'm going to release a new Beta soon trying to unify as much as possible between this and the GSM version to aid more frequent updates, watch this space...

P

Share this post


Link to post
Share on other sites
i had to revert back to 2.0..when i created what i wanted, it knock out my network connection...i went in to my msl config everything appears to be what it suppose to..

I had the same problem. Tried it twice and am going back to a straight 2.0... Wish it would work! This is a great idea, but for some reason the data connection is gone when it reboots!

Share this post


Link to post
Share on other sites
I had the same problem. Tried it twice and am going back to a straight 2.0... Wish it would work! This is a great idea, but for some reason the data connection is gone when it reboots!

did your rom version changed to 3.1 0r 3.0 ?

Share this post


Link to post
Share on other sites
did your rom version changed to 3.1 0r 3.0 ?

It changed to 3.1 as well. I've got a hunch that removing the sync option might have cooked the data connection, so I am currently installing a build with the sync still in there and we'll see if that works. I'll update it when it's done and let you know if that works.

Share this post


Link to post
Share on other sites
It changed to 3.1 as well. I've got a hunch that removing the sync option might have cooked the data connection, so I am currently installing a build with the sync still in there and we'll see if that works. I'll update it when it's done and let you know if that works.

I am getting stuck at the HTC screen after the lock screen first appears. Have flashed twice with two different built roms. When the screen timeout happens and I wake it up I get the lock screen with the HTC behind it. Taskbar with a connection shows on the lockscreen, but when I unlock it it hides itself.Left it like this for quite a while and nothing. Anyone have any ideas?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.