Jump to content
Sign in to follow this  

[CENTRAL] USB-ActiveSync connection blocking wireless connections

Recommended Posts

My ActiveSync connection over USB blocks wireless connections. My issue is comprised of the following components:

1) Samsung Omnia i900 Windows Mobile smartphone, with ActiveSync syncing with remote Exchange server over 3G/Internet connection.

2) Workstation PC with ActiveSync, firewalled to block the Exchange communication through ActiveSync's Internet passthrough.

3) USB connection between the PC and mobile.

I'd like to use MyMobiler to 'remote control' the phone through the ActiveSync USB connection. I only want to use the USB connection to charge and remote control the phone, while all network activity should still use the phone's 3G connection.

However, when I connect the phone with the PC, the GPRS/3G data connection is disconnected, and the phone seemingly wants to sync with the PC (network passthrough) and won't establish a data connection. At this time, I have no real clue why this happens.

My current configuration is as follows:

Workstation's ActiveSync Connection Settings:

  • Allow USB Connections
  • Computer is connected to Work Network.
  • Checked Allow wireless connection on device when connected to the desktop
    • Start --> Settings --> Connections --> USB Connection Mode: ActiveSync.
    • Start --> Settings --> Connections --> USB to PC: Unchecked Enable advanced network functionality.
    • ActiveSync: When cradled Checked Synchronize all PCs using this connection: `USB Default. This seems to be a prerequisite for allowing *any* communication over ActiveSync, i.e. MyMobiler (and not just syncing contacts/messages/whatnot through ActiveSync).

    In tackling this, I found the following possible solutions:

    [*]ActiveSync on the PC offers the setting "Allow wireless connection on device when connected to the desktop", but apparently this isn't working the way I want.

    [*]Airscanner Airfix seems to try and offer a solution, but killing the ActiveSync process doesn't help either.

    [*]I also found reference to a registry tweak, setting HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows CE Services\AllowDSP=0, which would supposedly disable the ActiveSync passthrough. Having even applied this on my mobile, no resolve.

    [*]Additionally, the thread at WMDC offers a solution through IR and Bluetooth, though doesn't fix my issue with the USB connection.

    I'm wondering whether anyone knows how to further resolve this issue? Perhaps someone has a working configuration that they can share?

    I found this issue (and related ones) scattered throughout the Internet (and on this forum), which is why I want to centralize all 'fixes' in this post.


    Update April 8 2010

    Did a Hard Reset of my phone. Figured I might as well configure this working from the start, before I customize it. Out of the box it worked, I performed the following:

    1) Hard reset

    2) On ActiveSync start, I specified not to sync the devide with my laptop nor with my company's Exchange server. Configured the settings as mentioned above.

    3) Ran MyMobiler v1.23, installed it on my device so I can control it through my laptop.

    The result is, I can connect to my modem using MyMobiler, while still maintaining the wireless connection on my device.

    I'm guessing this functionality will break as soon as I tend to setup the PDA's ActiveSync synchronization with the company's Exchange server. Will perform more tests.

    I tried adding my Exchange account info through MyMobiler's remote connection, but the Email Account wizard detected the link and told me I should set up a partnership from my PC instead.

    I pulled the USB cable, after which the wizard would allow me to specify my Exchange info on the PDA itself.

    The Exchange server enforces a security policy. This at least pertains to the PIN requirements. I used RegShot to make a before and after policy dump to see what exactly changed.

Edited by Bouvrie

Share this post

Link to post
Share on other sites

I am still Struggling mate would you be able to help me.

Exactly same situation, connected Toshiba G910 to my work computer it just disabling the 3G connection and start using work internet connection this is what I don't want.

The only reason to connect my device to pc (runing windows vista business) is to control through mymobiler 1.25 that's it I already have unlimited internet plan for my device.

thanks in advance for your help

Share this post

Link to post
Share on other sites
I am still Struggling mate would you be able to help me.

Too bad you also seem to have membership to this club. ;)

I've been unable to solve this. Since my original thread, I flashed my phone several times so I'm not too sure if/how my current mobile is configured differently from the original one.

However, I just tested it again and had somewhat of a positive result:

1) I went through the activesync partnership setup, specifying that I want to sync my phone to the company's Exchange server directly. I entered the appropriate settings.

2) ActiveSync prompted me on my mobile, telling my company's security policy had to be enforced. I clicked OK and the device started to synchronize my mail and contacts. Oddly enough, my company has a policy in place that requires a PIN lock on the device. While I used to be prompted to configure one, this did not happen this time around. The mail sync worked properly though.

3) On my PC, I specified I wanted to allow wireless communication on my phone when connected, and I finished the partnership wizard.

4) While my device was still connected via USB, I ran MyMobiler, and it connected to my device. I noticed that the 3G connection was still active. PalRingo (IM client) was still running on my mobile and I sent a message to my contact. He replied, showing me I had a network connection.

I'm not too sure which connection was active when I sent the message though. I checked the 'Browser Connection' config on my mobile, and it was set to WAP, with the checkbox 'Automatically detect settings' ticked (thereby probably overruling the WAP connection). Unfortunately, only PalRingo seems to keep the connection available, Internet Explorer and UCWeb both had problems connecting (UCWEB reporting a 'Getting Data (-9002)', not too friendly as to what's the cause).

I disconnected the 3G, and sent another message. This message did not deliver to the contact, so I got the hunch my previous message was sent through the 3G connection. Problem now is though, I can't get the mobile to connect to 3G again when it already detects the USB ActiveSync connection.

My most recent settings that 'worked' (under which my chance finding were made) are:

Desktop ActiveSync:

tick checkboxes "Allow USB Connections", "Allow wireless connections on device when connected to the desktop", untick the rest. I had to specify 'This computer is connected to: The Internet' as opposed to Work before I could send the IM. This still makes me wonder whether the 3G connection was used or not, but disconnecting 3G and sending again failed, so I really hope so. :)

Mobile ActiveSync:

When cradled Synchronize all PCs using this connection: USB checked. (Note: this time the connection is reported as USB, unlike previously where it was `USB Default. Not sure why this is the case.)

Mobile Browser Connection:

Checked the box 'Automatically detect settings', select box stated 'WAP'

Mobile USB Connection Mode:

ActiveSync (obviously, for MyMobiler)

Mobile USB to PC:

Checked 'Enable advanced network functionality'

Sorry I can't be of more help, I wish I knew how to properly configure this all. Having a closed corporate network doesn't help much either... :D

Edited by Bouvrie

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.