Jump to content
jnwhiteh

AOSP Eclair 2.1 r4 for GSM Hero (now with online kitchen)

Recommended Posts

Wondering; Is there a way to add more dictionaries for the predictive typing? Tried to do some research, but it seems like it's not that easy.

Having a Dutch dictionary would make your release completely perfect, in my opinion. Wouldn't switch back to a 2.1 Sense release, way to clunky and flashy for me. I'm so happy with my clean looking Hero atm, with AOSP 2.1 flashed on it. Perfect for my job, lots of emailing, agenda syncing, etc.

Again, thanks for the hard work.

I managed to enable dutch T9 (the standard Hero keyboard) by installing HTC_IME, enabling "Touch Input" in the keyboard & Language settings, setting the phone language to Dutch, and rebooting

Download: http://n0rp.chemlab.org/android/apps/HTC_IME.apk

MD5Sum: 1a2e9587cc2a0d0339050eb628b5e19d

Edited by Huib

Share this post


Link to post
Share on other sites

Loaded this rom last night and its great :) but i cant get co pilot to run B) it just gives a message, co pilot cannot load on this system, Please can you lookinto this.

Cheers.

Share this post


Link to post
Share on other sites
Loaded this rom last night and its great :) but i cant get co pilot to run B) it just gives a message, co pilot cannot load on this system, Please can you lookinto this.

Cheers.

Nope, it's a paid application so you're going to have to do any research as to why it doesn't work. You can provide logcat output, but if the application itself is saying "no", you'll need to contact them.

Share this post


Link to post
Share on other sites

I know it doesn't help much but I can confirm that CoPilot is capable of working on this ROM, it's been fine on my handset. Admittedly I did purchase it prior to moving to AOSP, is it the installer that won't run?

Share this post


Link to post
Share on other sites

I've installed this rom and it's working great apart from the known issues.

I pushed the Gallery3D.apk shared here to my device and it still has the graphical corruptions when changing to landscape mode.

I've also noticed the Hero is running hotter than with MCR 3.1. It is warm to the touch, unlike with MCR 3.1 where it felt slightly colder than my hands.

Share this post


Link to post
Share on other sites
I've installed this rom and it's working great apart from the known issues.

I pushed the Gallery3D.apk shared here to my device and it still has the graphical corruptions when changing to landscape mode.

I've also noticed the Hero is running hotter than with MCR 3.1. It is warm to the touch, unlike with MCR 3.1 where it felt slightly colder than my hands.

Then that's almost certainly some application you're using that's doing something.. I don't share the same experience.

Share this post


Link to post
Share on other sites
Then that's almost certainly some application you're using that's doing something.. I don't share the same experience.

Maybe, I'll check what apps I have, but I mostly have the same ones as on MCR 3.1

Also, has anyone tried pushing Market.apk from a build where it isn't corrupted, like the Hero / Espresso hybrid?

I'll try it myself.

Share this post


Link to post
Share on other sites
Maybe, I'll check what apps I have, but I mostly have the same ones as on MCR 3.1

Also, has anyone tried pushing Market.apk from a build where it isn't corrupted, like the Hero / Espresso hybrid?

I'll try it myself.

Does the tiny graphical issue really botheryou that muc?

Share this post


Link to post
Share on other sites

Great new release! The only new problem I have found so far is video (recordings) freezing on the first frame during playback. This also happens in the Youtube app on low quality clips but not high quality ones.

I still have issues with configuring APNs that can only be resolved by pushing a different apns-conf.xml onto the device. Thanks for another awesome ROM!

Share this post


Link to post
Share on other sites
Hy all.

Once again, thank's a lot for the great work !!!

I noticed something weird : in "Settings", "Language and keyboard", I get two "Android keyboards" !?

There's a 'VoiceSearchwithKeyboard.apk' in /system/app which I assume provides voice search and a keyboard.. remove latinime.apk and it should go back to just one (with a voice search button on it) i think.

Now, we need camera libraries =)

I'd rather get BT working right, do we have any idea what's wrong?

My phone reboots by itself every now and then using this ROM, anyone else have this issue? I just now updating to the latest one, hopefully it will not reboot!

not me, well impressed in general coming from kagudroid, only major problem IMO is BT audio!

Share this post


Link to post
Share on other sites
I'd rather get BT working right, do we have any idea what's wrong?

It doesn't work. That's the start of the problem. I can't test it, that's another problem =)

Share this post


Link to post
Share on other sites
It doesn't work. That's the start of the problem. I can't test it, that's another problem =)

Nice! It works to some degree, pairs up fine and tries to work when a call comes in but it doesn't get routed to the headset. Would a logcat from when that happens be any use?

EDIT: can we get logcat output directed to a file on the sd so it'd survive a reboot and you wouldn't need to be constantly monitoring it....

Edited by kieranc

Share this post


Link to post
Share on other sites

Hi, first... thankyou ... it is a good work...

Just some thoughts:

1) I would like to ask one thing: could you put a busybox with LZO? It is needed by TitaniumBackup (If you backed up for example from a MCR ROM). At the moment I solved by flashing after the GoogleBits the zip found at http://android.modaco.com/content/htc-hero...-coming-to-mcr/

2) When I used Gallery in r1 I thought that it does not work in landscape... Now in r2 (I don't know if it is the new googlebits or me) I noted that the problem is not landscape itself, but rotating... thus if you want to use landscape just keep the phone landscape when launch gallery and it works in landscape (but not portrait... i.e. not rotating...). I hope that this can be useful to someone else

3) about facebook notification... was it a htc thing? it was very useful when some one send me a message on facebook to have the notification...it seems to me that it does not work...

4) I deleted LatinIME.apk (just to solve the strange double keyboard in language settings...) do you think that there are other side effects? :-D I noted none at the moment...

Edited by carpao

Share this post


Link to post
Share on other sites
Loaded this rom last night and its great :) but i cant get co pilot to run B) it just gives a message, co pilot cannot load on this system, Please can you lookinto this.

It appears that the pirated versions that are floating around don't work. The ones from the market run beautifully.

Share this post


Link to post
Share on other sites
Nice! It works to some degree, pairs up fine and tries to work when a call comes in but it doesn't get routed to the headset. Would a logcat from when that happens be any use?

EDIT: can we get logcat output directed to a file on the sd so it'd survive a reboot and you wouldn't need to be constantly monitoring it....

I don't know how we can redirect the logcat output to sdcard like that.

1) I would like to ask one thing: could you put a busybox with LZO? It is needed by TitaniumBackup (If you backed up for example from a MCR ROM). At the moment I solved by flashing after the GoogleBits the zip found at http://android.modaco.com/content/htc-hero...-coming-to-mcr/

I'll have to check the busybox source to see how I can enable this.

2) When I used Gallery in r1 I thought that it does not work in landscape... Now in r2 (I don't know if it is the new googlebits or me) I noted that the problem is not landscape itself, but rotating... thus if you want to use landscape just keep the phone landscape when launch gallery and it works in landscape (but not portrait... i.e. not rotating...). I hope that this can be useful to someone else

Yes, this is the current issue.. the rotation does not work. Cyanogen experiences the same thing on his ROM.

3) about facebook notification... was it a htc thing? it was very useful when some one send me a message on facebook to have the notification...it seems to me that it does not work...

No, notification must be configured in the application is has nothing to do with the operating system. What doesn't work is the contacts information synchronization.

4) I deleted LatinIME.apk (just to solve the strange double keyboard in language settings...) do you think that there are other side effects? :-D I noted none at the moment...

No, I don't think there are any.. but I dont plan to remove it from the ROM.

Share this post


Link to post
Share on other sites

Since were talking keyboards anyways. I needed more dictionaries because typing in dutch with english dictionary on is a real pain in the arse (Yeah i could have turned off the auto correct). So I managed to install HTC_IME and it works flawlessly (including calibration)

Share this post


Link to post
Share on other sites
Since were talking keyboards anyways. I needed more dictionaries because typing in dutch with english dictionary on is a real pain in the arse (Yeah i could have turned off the auto correct). So I managed to install HTC_IME and it works flawlessly (including calibration)

Get me the dictionary files (if you can find them) and we'll include them in the stock keyboard.

Share this post


Link to post
Share on other sites

I found the issue with the LED.. and it's right where I expected it would be. Also have the backup/restore script that is hacked together from the one included with Cyanogenmod.. so I'll be tossing those in the next release (sometime sunday gmt).

Share this post


Link to post
Share on other sites

I pushed cyanogens HTC_IME.apk from http://forum.xda-developers.com/showthread.php?t=567294

This one has all the dictionaries but u cant access them through the menu.

So I edited com.htc.android.htcime_preferences.xml to pick the dutch dictionary and that works.

Also the Clicker on that post by cyanogen does NOT work for 2.1

I took the Clicker.apk from a Hero 2.1 Rom and that did install properly.

Edited by Revoked

Share this post


Link to post
Share on other sites

Just flashed this rom, don't get any service what so ever(im on T-Mobile UK) and get constant force closures even when just unlocking the lock screen. Have tried rebooting a few times and have the same problems over and over, should i try flashing again?

edit - Managed to get it working now just need to install the google bits =x

Edited by mat.

Share this post


Link to post
Share on other sites

:)

Hello,

Using this rom and love it. Thanks. As for almost all 2.1 rom, strange behaviour of 3G/GPRS switch on/off. No available menu to switch. So I downloaded APNDroid, but, each time I use WiFi and therefore disconnect 3G, I can't get 3G back, neither using APNDroid nore if I set it again. The only way is to reboot all the time and get my connection back. Quite puzzling, isn't it ? Any clue ?

Many thanks.

Share this post


Link to post
Share on other sites
:)

Hello,

Using this rom and love it. Thanks. As for almost all 2.1 rom, strange behaviour of 3G/GPRS switch on/off. No available menu to switch. So I downloaded APNDroid, but, each time I use WiFi and therefore disconnect 3G, I can't get 3G back, neither using APNDroid nore if I set it again. The only way is to reboot all the time and get my connection back. Quite puzzling, isn't it ? Any clue ?

Many thanks.

That is an HTC feature. No AOSP ROM has that functionality.

Share this post


Link to post
Share on other sites

I am considering to try this build (looks really promising) :)

i just have one question, is the bug with radio (changing letters in radio name) still present?

Edited by cTn

Share this post


Link to post
Share on other sites
I am considering to try this build (looks really promising) :)

i just have one question, is the bug with radio (changing letters in radio name) still present?

For me, no. I see JU as I'd expect.

Share this post


Link to post
Share on other sites
I know it doesn't help much but I can confirm that CoPilot is capable of working on this ROM, it's been fine on my handset. Admittedly I did purchase it prior to moving to AOSP, is it the installer that won't run?

no its installed fine, but as soon as the co pilot screen loads it just says it cant load. i have other paid apps running fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.