Jump to content
jnwhiteh

AOSP Eclair 2.1 r4 for GSM Hero (now with online kitchen)

Recommended Posts

No, after the first report of that I did precisely that and got absolutely no errors, so without more information I am not quite sure what to tell you. Are you installing the latest GoogleBits?

Thanks for the quick response. I had only installed the main zip. Should I install the google bits before a 1st boot?

Share this post


Link to post
Share on other sites
Thanks for the quick response. I had only installed the main zip. Should I install the google bits before a 1st boot?

Yes, I believe you need to right now due to a change kiall made in the repository, which I'm going to have to revert.. if I know what this issue is.

Share this post


Link to post
Share on other sites
Thanks for the quick response. I had only installed the main zip. Should I install the google bits before a 1st boot?

You couldn't have just installed the main zip. There is no setup program without gbits.

Share this post


Link to post
Share on other sites
Yes, I believe you need to right now due to a change kiall made in the repository, which I'm going to have to revert.. if I know what this issue is.

Cheers. That worked a treat.

I expected to see the new Google sat nav app but can't see it. I'll have to do some searching :)

Share this post


Link to post
Share on other sites
Cheers. That worked a treat.

I expected to see the new Google sat nav app but can't see it. I'll have to do some searching :)

It's called 'Maps', and it's there. It doesn't work outside the U.S.

Share this post


Link to post
Share on other sites
For anyone wondering how to get exchange to sync calendar, you can push this: http://nex.ppckitchen.org/CorCAL.apk to /system/app (don't use adb install, use adb push) and it works, thanks to NexVision from XDA-Developers for that :)

doesn't work here..can you link for original thread?

//

oh..it works,just not as part of sync framework, you have to launch another calendar app :-D

Edited by vorcigernix

Share this post


Link to post
Share on other sites
Guest

I didn't really get an answer to my last question, so I'll rephrase... am I the only one who gets a lot of lag in AOSP builds?

On Cupcake, everything is super fluid. I just installed r3 (but the same goes for all other AOSP builds I've tried), and everything is just so laggy. When scrolling menus or opening up the launcher, instead of a nice smooth motion, it jitters and jumps as it scrolls, sometimes it just shoots right to the bottom and such.

I did a wipe before installing and flashed googlebits 1.7 before first boot.

If I'm not the only who gets this, what's the cause behind it?

Edit: That said, I do appreciate the work on AOSP :) I love my Hero, but my God, I hate Sense UI and all the other HTC crap.

Edited by Guest

Share this post


Link to post
Share on other sites
I didn't really get an answer to my last question, so I'll rephrase... am I the only one who gets a lot of lag in AOSP builds?

On Cupcake, everything is super fluid. I just installed r3 (but the same goes for all other AOSP builds I've tried), and everything is just so laggy. When scrolling menus or opening up the launcher, instead of a nice smooth motion, it jitters and jumps as it scrolls, sometimes it just shoots right to the bottom and such.

I did a wipe before installing and flashed googlebits 1.7 before first boot.

If I'm not the only who gets this, what's the cause behind it?

Edit: That said, I do appreciate the work on AOSP :) I love my Hero, but my God, I hate Sense UI and all the other HTC crap.

I've never experienced the lag that you're reporting. I've got all my animations up to 'fast' in Spare Parts, and don't run into any sort of these issues.

Share this post


Link to post
Share on other sites
I didn't really get an answer to my last question, so I'll rephrase... am I the only one who gets a lot of lag in AOSP builds?

On Cupcake, everything is super fluid. I just installed r3 (but the same goes for all other AOSP builds I've tried), and everything is just so laggy. When scrolling menus or opening up the launcher, instead of a nice smooth motion, it jitters and jumps as it scrolls, sometimes it just shoots right to the bottom and such.

I did a wipe before installing and flashed googlebits 1.7 before first boot.

If I'm not the only who gets this, what's the cause behind it?

Edit: That said, I do appreciate the work on AOSP :) I love my Hero, but my God, I hate Sense UI and all the other HTC crap.

+1

I had exactly the same issues with performance, that's why I reverted back to MCR. Still waiting to test new releases though.

Share this post


Link to post
Share on other sites
@jnwhiteh: Is it possible to fix the market in other roms by pushing any file of your rom or something?

Depends on what's wrong with the market on the ROM. Are you talking copy protected applications or something else?

Share this post


Link to post
Share on other sites
I didn't really get an answer to my last question, so I'll rephrase... am I the only one who gets a lot of lag in AOSP builds?

On Cupcake, everything is super fluid. I just installed r3 (but the same goes for all other AOSP builds I've tried), and everything is just so laggy. When scrolling menus or opening up the launcher, instead of a nice smooth motion, it jitters and jumps as it scrolls, sometimes it just shoots right to the bottom and such.

I did a wipe before installing and flashed googlebits 1.7 before first boot.

If I'm not the only who gets this, what's the cause behind it?

Edit: That said, I do appreciate the work on AOSP :) I love my Hero, but my God, I hate Sense UI and all the other HTC crap.

Same for me, so laggy as I thougth to go back for MCR 3.1, so decided wipe factory reset + dcache, manually delete and format a new ext partition, then delete everything on my SD I really don't need (including old backup of application of android 1.5 + hidden files). Flash to AOSP 2.1 r3 and now it's very smooth I'm impressed by the speed !

Thanks jnwhiteh and all people contributing to this ROM

Edited by kookix

Share this post


Link to post
Share on other sites
Depends on what's wrong with the market on the ROM. Are you talking copy protected applications or something else?

Yes, i mean the protected apps problem. Lot of 2.x ROMs still have this issue.

Share this post


Link to post
Share on other sites

Damn i luv this rom :) so great ^^

when the facebook app integration start working with the phonebook il get so happy!

cuz when u hit the facebook icon in accounts and syncs, inte the settings u cant add the facebook account :/

should work though i read that fpor the nexus one!

Share this post


Link to post
Share on other sites
Same for me, so laggy as I thougth to go back for MCR 3.1, so decided wipe factory reset + dcache, manually delete and format a new ext partition, then delete everything on my SD I really don't need (including old backup of application of android 1.5 + hidden files). Flash to AOSP 2.1 r3 and now it's very smooth I'm impressed by the speed !

Thanks jnwhiteh and all people contributing to this ROM

3.1 is able to use compcache, so they get to cheat quite a bit. Thanks for the report!

Yes, i mean the protected apps problem. Lot of 2.x ROMs still have this issue.

It's a one-line change to build.prop, fairly well documented, so yes.

Damn i luv this rom :) so great ^^

when the facebook app integration start working with the phonebook il get so happy!

cuz when u hit the facebook icon in accounts and syncs, inte the settings u cant add the facebook account :/

should work though i read that fpor the nexus one!

You can, it just opens the facebook account. It's not a 'add a facebook account and sync', it's a 'open facebook and add your account'.

Share this post


Link to post
Share on other sites
On Cupcake, everything is super fluid. I just installed r3 (but the same goes for all other AOSP builds I've tried), and everything is just so laggy. When scrolling menus or opening up the launcher, instead of a nice smooth motion, it jitters and jumps as it scrolls, sometimes it just shoots right to the bottom and such.

By jumping and scrolling to the bottom, did you mean this?

Sorry it's not exactly on topic, but maybe this isnt a fault of the AOSP ROM?

I've sent my Hero back to HTC 3 times when this has been happening to me [stock ROM].. and so far it's not been fixed yet! I fear they cant replicate what's going on. I'm waiting for it to be returned!

Share this post


Link to post
Share on other sites
By jumping and scrolling to the bottom, did you mean this?

Sorry it's not exactly on topic, but maybe this isnt a fault of the AOSP ROM?

I've sent my Hero back to HTC 3 times when this has been happening to me [stock ROM].. and so far it's not been fixed yet! I fear they cant replicate what's going on. I'm waiting for it to be returned!

And this is a great example how serious is HTC, i reported this issue months ago, (multiple times) also with possible tutorial how to replicate this, and what? nothing was fixed since then.

I did HTC a favor and tracked as much info as possible

1. this bug only/mostly happens to ppl running on GPRS/EDGE (2G) network

2. to replicate this, you don't need to do anything special, connecting/disconnecting few times and then transfer some data via browser and vuala

3. in my lame opinion this is some kernel driver problem/ radio problem which is affecting trackball (yes, as a proof, when is phone scrolling by it self, notice that the buttons on the bottom of the screen glows white, second if u run application that has some action bound to trackball, for example better terminal, you will see that application is actually picking trackball moves to the one side, and this "moves" mostly happen when your phone is downloading/uploading data, phone stops transfering and this crazy thing also stops)

so this is obviously somehow related, how? don't ask me, i reported this, HTC obviously doesn't care, what can i do...

Edited by cTn

Share this post


Link to post
Share on other sites
Guest
Damn i luv this rom :) so great ^^

when the facebook app integration start working with the phonebook il get so happy!

cuz when u hit the facebook icon in accounts and syncs, inte the settings u cant add the facebook account :/

should work though i read that fpor the nexus one!

Not sure when Facebook Sync will start working; but I know that at the moment there are two options.

1) Villain 1.1 ROM is Android 2.1 with Sense - not quite as clean and fast as Kagu or AOSP-jnwhiteh; but the best 2.1+Sense atm

2) Just install 'SyncMyPix' from the market - free app will get Facebook photos into your Android Contacts

Add in 'Beautiful Widgets' for a clock/weather display... and who needs SenseUI anyways?

Share this post


Link to post
Share on other sites

hi jnwhiteh

just flashed r3 & found problems during youtube & video playback. there's only sound & video seems to stuck at first frame in youtube & video show white screen.

& camera (at 3mps) app force close at every 2nd pic

im sorry if this been reported, having hard time using the forum search function to search specifically on your thread

Edited by taz5176

Share this post


Link to post
Share on other sites
It's a one-line change to build.prop, fairly well documented, so yes.

Sorry, for annoying again. But i can´t find any documentation about it. I searched by google and searched in developer.android.com and other forums. Can i have link?

Maik

Share this post


Link to post
Share on other sites
Is it possible to add the bits in from Villans 2.1 Rom that makes 5MP camera work correctly ? I love this ROM !

No, as I've already stated. The use exactly the same libraries as we do. The camera application is HTC specific and uses HTC specific APIs, which are not available on our ROM.

Sorry, for annoying again. But i can´t find any documentation about it. I searched by google and searched in developer.android.com and other forums. Can i have link?

Maik

BUILD_FINGERPRINT := "google/passion/passion/mahimahi:2.1/ERD79/22607:user/release-keys"

Only me that still can't seem to get Gmail-push working?

The only flaw left if you ask me

Gmail push works correctly since 1.6 googlebits. I have had 0 issues since then, and I've tested fairly extensively.

Share this post


Link to post
Share on other sites
No, as I've already stated. The use exactly the same libraries as we do. The camera application is HTC specific and uses HTC specific APIs, which are not available on our ROM.

BUILD_FINGERPRINT := "google/passion/passion/mahimahi:2.1/ERD79/22607:user/release-keys"

Gmail push works correctly since 1.6 googlebits. I have had 0 issues since then, and I've tested fairly extensively.

Okay, I just updated with the new stuff, will try to wipe and do a complete reinstall, thanks man

Share this post


Link to post
Share on other sites
Okay, I just updated with the new stuff, will try to wipe and do a complete reinstall, thanks man

Depending on what else is in his build.prop, that may not fix it.. but that's all that I add to a stock AOSP build in order to allow copy protected applications.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.