Jump to content

Installing the WAP browser from the Hero MCR

Recommended Posts


I'm trying to install the WAP Browser that's included with enhanced add on pack from the Modaco HERO custom rom. Installing the .apk file isn't sufficient since I need the library file included in the addon zip file. I'm not sure how I would go about adding that library file to my G1 (I'm running Cyanogen's latest btw).

Any help would be appreciated!

P.S.: If you're wondering why I need a WAP browser, you can read about my problem here: http://forum.xda-developers.com/showthread.php?t=658195


Share this post

Link to post
Share on other sites

I'm the idiot who suggested you give this a try :P

There are lots of reasons why this might not work, not least of which is that the library file must, I imagine, be native code & so depending on the degree to which it's been optimised for one processor family & how much the cpu in the G1 differs from that in the Hero, you might be stuffed.

Still, I don't think it can hurt (much) to try. Make sure you do a nandroid backup first :( I haven't got the enhanced pack to hand atm & Modaco won't let me re download it (I'm getting the mysterious redirection to the home page which seems to randomly affect some users for specific files on romraid.com at specific times), but from what I can remember:

Firstly, do you have adb set up on your PC? If not, search the forum for info on installing adb & making sure it's in your PATH.

I assume the file system layout is sufficiently similar between G1 & Hero, in so far as you have /system/app & /system/lib directories. Check if you're not sure.

I can't remember the name of the .so & .apk, so I'll refer to them below as wap.so & wap.apk. DO NOT use these names; leave the filenames unchanged & replace the names in the instructions below with their real names.

Open a command prompt window (assuming you're using Windows; there's linux equivalents of course)

Put the .so & .apk files into a directory & set that as the current directory (eg if they're in C:\mytemp enter into the command prompt window cd \mytemp)

Enter the following

adb remount

adb push wap.apk /system/app/wap.apk

adb shell chmod 644 /system/app/wap.apk

adb push wap.so /system/lib/wap.so

adb shell chmod 644 /system/lib/wap.so

adb shell reboot
If anything stuffs up, probably safest to do a nandroid restore, but if you prefer you can remove these two files with
adb remount

adb shell

rm /system/app/wap.apk

rm /system/lib/wap.so


Lastly, if you get nowhere, you could try asking for help in the Modaco HTC Dream/G1 specific subforum.

Share this post

Link to post
Share on other sites

Haha thanks for replying in both forums. I pushed the wap library file (named libwapcore.so). Still can't install the wap browser. Tried installing the app using Astro and it failed, using the modaco installer on my pc also fails giving me the error "FAILURE [install_failed_missing_shared_library]. I got the same error before and after pushing the library file.

An interesting tidbit though, one of the permissions the app asks for is Your messages:receive WAP.

*sigh* pathetic i'm trying going through all this trouble to get f**** WAP with 25mb monthly bandwidth

Edited by hybridb

Share this post

Link to post
Share on other sites

Did you try simply pushing the apk? I wouldn't bother trying to install it in the usual manner as it's meant to be in /system/app not /data/app (not that that necessarily explains why it isn't working or would make a difference - again, I don't know for sure).

Re missing library, two guesses: 1) It needs to be 'registered' in some way? But I didn't think this was the linux way. And I know Android isn't linux but still. Hmm, too much guesing. You need someone with a clue to help ;) I still can't redownload the enhanced pack from modaco. Any chance you could upload it somewhere else & post a link? I'd like to take a look at its install script. 2) It doesn't work, hence is missing. This is the less optimistic option ;)

Apologies for too much guesswork & too many ;)s

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.