Jump to content

[HOWTO] Unroot your HTC Desire

Recommended Posts

Hi everybody!

First of all, I'm pretty a newbie in Android hacking world, so, please, be patient with me! :D

I'm going to tell you my Desire Story, and I'd like you (all) to help me recover it! (if possible ;) )

I rooted my Desire (GSM) with the unrevoked method and everything went well. Before rooting, my bootloader was 0.93 and it was 0.93 after rooting. After that, I wanted to expand data partition in the internal storage, so I got S-off using the Alpharev method and applied the Sense table partition. Here too, everything went quite well (not without getting blasphemous B) ).

Yesterday, I thought I want to revert everything and go back to stock Sense ROM (no brand and I'm from Italy).

I read everything in this thread and I downloaded the RUU Utility. I've run it on my PC and had some problems with drivers. I've installed the right drivers and tried again. After updating the signature (as said by the utility), it's stopped, reporting error 140, saying I have a non-compatible bootloader (now, it's 0.75 and I don't know how and when it downgraded :D ).

Finally, my Desire runs only the bootloader (and some trace of ClockworkMod remained). I tried using other RUUs (downloaded by shipped-roms.com) but the error remains the same (cit. Led Zeppelin, LOL! :( )

Please, I really need your help!

P.s.: now I'm trying to flash some PB99IMG from shipped-roms.com, I'll edit this post as soon as I get some kind of result (good or bad)

EDIT: PB99IMG method failed. Error "Main version is older. Update fail." :D

EDIT 2: just to be as much clear as possible, my bootloader version shows this:






Mar 5 2010,21:12: 15

EDIT 3: I tried using these instructions, as said by xda. MISC partition correctly fixed, but the RUU fails again.

Edited by Endriu90

Share this post

Link to post
Share on other sites
Which RUU are you trying to use?

First, I tried with this, then with the first linked in this thread. The RUU says the ROM version in my phone is 2.29.[cannot remember], that's the last version of stock HTC ROM I updated before rooting (talking of about 2 or 3 months ago). All I can do is to boot my Desire in FastBoot or HBoot mode. No ROMs installed. I cannot recharge battery (as I connect phone to PC or AC charger, it automatically boots in FastBoot mode).

EDIT 1: I've just been able to flash succesfully CyanogenMod 6.1.1, all gapps and the latest Radio version. What now?! :D

EDIT 2: I've noticed that internal storage partitions have come back according to stock partition but still now the RUU doesn't work, giving the same 140 error...

EVERYTHING SOLVED: I used a downgrade utility to restore the (broken) BootLoader and it also installed the stock HTC ROM

Edited by Endriu90

Share this post

Link to post
Share on other sites


I hawe download and install htc sync, and run the HTC RUU. When the install of the new RUU start, its comming a HTC mark at the phone, and my computer say that i must conect my phone to the computer...? I hawe conected it, and startet the installation, but every time this thing comes upp...

Share this post

Link to post
Share on other sites

It's not clear to me, but is this guide for every bootloader or only 0.80? I have 0.93 and I want to know if i can uses this

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.