Jump to content
PaulOBrien

22/Jul r3 (JG5) - MoDaCo Custom ROM for Samsung Galaxy S with Online Kitchen

Recommended Posts

would it be possible to include the custom kernel which enables ext4 support?

this would be really great :angry:

Share this post


Link to post
Share on other sites
Thanks. I've Astro file manager but it says that file is not erasable. I need to buy RootExplorer to set permissions to delete it?

Or that is another way to do it?

Afaik this is payable app.

Another way is to use adb shell.

Share this post


Link to post
Share on other sites
Afaik this is payable app.

Another way is to use adb shell.

I definitely agree with you, in fact I'm a donor user. I was just wondering if Astro would suffice for that.

Bought RootExplorer... and it was THE solution. :angry:

Thank you very much!

Share this post


Link to post
Share on other sites
Where are the stock apps in the device?

I did ask in it's own thread, but no-one answered :angry:

system/app

Share this post


Link to post
Share on other sites
yeah i have problems with titamium also, seems to get confused.

When did you run the restore with it? after or before you did the market fix?

Hi guys,

I get my GalaxyS today...

WRT Titanium, from my HTC Hero rom experience, you must never restore EVERYTHING because a lot of what titanium backs up are system programmes, and those will update/change with different roms... so make sure you only restore 3rd party apps, or apps that did not come installed with the phone.

Mark.

Share this post


Link to post
Share on other sites
If I want to go back to the original firmware is it simply a matter of flashing the right version to match the original?

yes

Share this post


Link to post
Share on other sites
READ THIS WHOLE POST BEFORE YOU START! No, really, it contains everything you need to know. :angry:

P

Hi guys, Im desperate for some help!?

Im busy trying to flash my Galaxy S, I got it today... Its quite different from flashing my HTC Hero it seems... now I am worried I have done something to it and cannot get out of "Do not turn off Target!!!"

I downloaded the I9000XWJG1.rar file from the site Paul linked

Downloaded Odin3 and the PIT file

I also cooked and downloaded the rom from Pauls kitchen

I followed the Flash guide that was on the Samsung-Firmwares.com site where I had got the I9000XWJG1, Odin3 and PIT. The first step was to flash the PIT using Odin3. That seemed to be ok, but then the phone would not boot up. It would not even start booting up. It would only respond to going into "download mode". The second problem was that the I9000XWJG1 file is a rar file, not a tar file!? So I looked in the RAR file and sure enough there were 4 tar files. So I thought I was supposed to flash each of those separatedly (there was no way to flash the .rar file)

Now I have been "flashing" the first tar file, the biggest one, for about 20 mins and my phone still says "Do not turn off Target!!!" Im petrified Ive destroyed my phone on day 1??

Please help if possible, thanks,

Mark.

Share this post


Link to post
Share on other sites
Hi guys, Im desperate for some help!?

Im busy trying to flash my Galaxy S, I got it today... Its quite different from flashing my HTC Hero it seems... now I am worried I have done something to it and cannot get out of "Do not turn off Target!!!"

I downloaded the I9000XWJG1.rar file from the site Paul linked

Downloaded Odin3 and the PIT file

I also cooked and downloaded the rom from Pauls kitchen

I followed the Flash guide that was on the Samsung-Firmwares.com site where I had got the I9000XWJG1, Odin3 and PIT. The first step was to flash the PIT using Odin3. That seemed to be ok, but then the phone would not boot up. It would not even start booting up. It would only respond to going into "download mode". The second problem was that the I9000XWJG1 file is a rar file, not a tar file!? So I looked in the RAR file and sure enough there were 4 tar files. So I thought I was supposed to flash each of those separatedly (there was no way to flash the .rar file)

Now I have been "flashing" the first tar file, the biggest one, for about 20 mins and my phone still says "Do not turn off Target!!!" Im petrified Ive destroyed my phone on day 1??

Please help if possible, thanks,

Mark.

First off dont panic, you wont have killed the phone, i dont think anyone has managed to kill one...

You need to flash all those files at the same time.

PIT file goes in the PIT

pda=code

phone=modem

csc=csc

I always choose repartition.

Yours is obviously stuck, do you have a green bar at all on it (progress bar)? just restart, turn the phone off, boot it back into downloading mode and do it again.

Sometimes odin seems to have issues and restarting the pc fixes it too.

Edited by Kilack

Share this post


Link to post
Share on other sites

And if odin doesnt recognise your phone, you can just plug off and plug in again the usb cable. Do this always when something goes wrong and you have to start again.

Share this post


Link to post
Share on other sites
First off dont panic, you wont have killed the phone, i dont think anyone has managed to kill one...

You need to flash all those files at the same time.

PIT file goes in the PIT

pda=code

phone=modem

csc=csc

I always choose repartition.

Yours is obviously stuck, do you have a green bar at all on it (progress bar)? just restart, turn the phone off, boot it back into downloading mode and do it again.

Sometimes odin seems to have issues and restarting the pc fixes it too.

Thanks Kilack!

It seems pretty obvious now you list it so clearly, I wish the instructions had!

I managed to flash one at a time eventually, then saw your instructions... next time I will know better.

tx again

Mark.

Share this post


Link to post
Share on other sites
And if odin doesnt recognise your phone, you can just plug off and plug in again the usb cable. Do this always when something goes wrong and you have to start again.

I'll add that sometimes if you really mess up the flashing, it helps to plug the cable in another USB port on the computer (it will get picked up as another COM port). In one case I found this stopped me having to reboot

Share this post


Link to post
Share on other sites

Okay guys ran into a a bit of a problem I have a rooted Vibrant (Tmo stock rom) and decided to flash JG1 (re-partitioned was check) everything went accordingly and I was able to flash it, it booted up fine I inserted my sim card, got the English language, everything went well except one thing.................I CANNOT GET SIGNAL, I try and go into search for the network manually and Tmo does not come up and it will NOT connect to a network and then I tried to flash JG5 and the same thing I followed everything to a tee.

The phone is fine but it seems as though i have no radio, I have lost all the stock widgets that shipped with the phone, WIFI works and I can get everything to work except I cannot make a call any body have any suggestions? At this point I would be happy putting it back to stock.

PS also the volume up and down buttons are reversed up is down and down is up and I cannot put the phone in recovery mode via holding the up and down buttons together along with the power button, and I cannot adb it because it is not rooted any longer.....Heeeeeeeelp!

Share this post


Link to post
Share on other sites
Okay guys ran into a a bit of a problem I have a rooted Vibrant (Tmo stock rom) and decided to flash JG1 (re-partitioned was check) everything went accordingly and I was able to flash it, it booted up fine I inserted my sim card, got the English language, everything went well except one thing.................I CANNOT GET SIGNAL, I try and go into search for the network manually and Tmo does not come up and it will NOT connect to a network and then I tried to flash JG5 and the same thing I followed everything to a tee.

The phone is fine but it seems as though i have no radio, I have lost all the stock widgets that shipped with the phone, WIFI works and I can get everything to work except I cannot make a call any body have any suggestions? At this point I would be happy putting it back to stock.

PS also the volume up and down buttons are reversed up is down and down is up and I cannot put the phone in recovery mode via holding the up and down buttons together along with the power button, and I cannot adb it because it is not rooted any longer.....Heeeeeeeelp!

Tmobile use 2100 yeah? seems strange the radio would drop out. Most of the flashes have been done on the international versions of the galaxy.

The reverse of the controls seems normal though.. americans love to be different :angry:

Sorry i couldnt help.. hopefully someone else with a vibrant can shed some light.. always pays to wait and less someone else be the guinea pig man :D

Share this post


Link to post
Share on other sites
Okay guys ran into a a bit of a problem I have a rooted Vibrant (Tmo stock rom) and decided to flash JG1 (re-partitioned was check) everything went accordingly and I was able to flash it, it booted up fine I inserted my sim card, got the English language, everything went well except one thing.................I CANNOT GET SIGNAL, I try and go into search for the network manually and Tmo does not come up and it will NOT connect to a network and then I tried to flash JG5 and the same thing I followed everything to a tee.

The phone is fine but it seems as though i have no radio, I have lost all the stock widgets that shipped with the phone, WIFI works and I can get everything to work except I cannot make a call any body have any suggestions? At this point I would be happy putting it back to stock.

PS also the volume up and down buttons are reversed up is down and down is up and I cannot put the phone in recovery mode via holding the up and down buttons together along with the power button, and I cannot adb it because it is not rooted any longer.....Heeeeeeeelp!

You sir, are a daredevil and a champion.

Share this post


Link to post
Share on other sites

Good day, could someone please provide or point me to the 'road sms .apk' ???

greatly appreciated!

Share this post


Link to post
Share on other sites
You sir, are a daredevil and a champion.

Could it be that you've lost your carrier settings from using the CSC file? Maybe you can find a CSC that has Tmo settings?

Try this thread:

http://forum.xda-developers.com/showthread.php?t=725903

Thank you to all I just returned from the Tmo store with a brand new Vibrant......I think I will wait and make sure a flash will work! But I also appreciate the hard work that you guys put into these roms and flashes.

Glad I had my N1 as back-up....whew!

Share this post


Link to post
Share on other sites
Thank you to all I just returned from the Tmo store with a brand new Vibrant......I think I will wait and make sure a flash will work! But I also appreciate the hard work that you guys put into these roms and flashes.

Glad I had my N1 as back-up....whew!

Did you buy a new one, or is it that easy there where you live??? You just go to your carrier and ask a new phone, cause YOU brick it?? Just curious, cause it`s not so simple in Finland...

Share this post


Link to post
Share on other sites

Hey Guys my friend gave me a Captivate and I'm trying to root it and install Modaco. I've rooted plenty Android devices but with this one everytime I run adb reboot recovery it sits on the AT&T logo and doesn't allow me to flash the root file update.zip. It hangs and hangs and finally I just have to reboot bootloader. Any suggestions?

Share this post


Link to post
Share on other sites
Did you buy a new one, or is it that easy there where you live??? You just go to your carrier and ask a new phone, cause YOU brick it?? Just curious, cause it`s not so simple in Finland...

Yes I called CS first just so that it could be notated that I did talk to them already and also keep in mind that I had purchased it 2 days earlier and they also thought that maybe it was my sim card because it was the original one since I started with Tmo. Also the phone worked and powered up and functioned as normal BUT it just would not get signal on T mobile, so they gave a new phone free of charge

Edited by gthmcty1

Share this post


Link to post
Share on other sites
The reverse of the controls seems normal though.. americans love to be different :angry:

LOL, Americans may like to be different, but trust me, if his volume keys were reversed for up to be down volume, then there was something wrong. We're different, but we know up from down.

Share this post


Link to post
Share on other sites

Don't know if it is the ROM or the SGS because I didn't test it beforehand but 'Pure Calendar' app doesn't show up on the market.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.