Jump to content
gengaro86

Liquid Tether 0.3.9-1: Wireless Tethering for Acer Liquid

Recommended Posts

exactly how is it supposed to be made to work..

i switched on the app, started it, the text inside says its on but from PC side what do we have to do?

Share this post


Link to post
Share on other sites
exactly how is it supposed to be made to work..

i switched on the app, started it, the text inside says its on but from PC side what do we have to do?

Connect via wifi to your Liquid in the same way you would connect to any other AP

Share this post


Link to post
Share on other sites
Connect via wifi to your Liquid in the same way you would connect to any other AP

oops..i thought i could tether by usb.. :lol:

Share this post


Link to post
Share on other sites

I had a mess in my bin / xbin dirs, some busybox commands were handled by toolbox, so I rm-ed the duplicates (I made busybox handle almot every shell command). Still no go.

Ok, that's tether_on output:

# ./tether_on

./tether_on

LiquidE: verifying that dhd isn't loaded

ramzswap 10592 1 - Live 0x7f007000

xvmalloc 5552 1 ramzswap, Live 0x7f000000

LiquidE: dhd wasn't loaded.

LiquidE: verifying that wpa_supplicant isn't started

LiquidE: wpa_supplicant wasn't started

LiquidE: Loading wifi driver...

LiquidE: Powering wifi..

Turning on eth0 device..

Enabling ip_forwarding..

Flushing iptables..

Writing new iptables rules..

LiquidE: starting supplicant..

ioctl[SIOCSIWMODE]: No such device

Could not configure driver to use managed mode

ioctl[SIOCGIWRANGE]: No such device

LiquidE: creating a resolv.conf file..

Starting dnsmasq server..

LiquidE: setting prop to fake a real eth0 connection..

Done, tethering started..
Those errors may be the point.. wpa_supplicant gives this output:
# wpa_supplicant -B -D wext -i eth0 -p"/etc/wifi/BCM4325.bin,/etc/wifi/nvram.txt" -c/data/data/net.gengaro.liquid/wpa_tether.conf

SIOCSIFFLAGS: Cannot assign requested address

Could not set interface 'eth0' UP

ioctl[SIOCSIWMODE]: No such device

Could not configure driver to use managed mode

ioctl[SIOCGIWRANGE]: No such device

Edited by liquid_it

Share this post


Link to post
Share on other sites

it work PERFECTLY BUT, after i stop it and tried to connect via wifi from phone, it doesn't work anymore :-(

even from settings, when i try to activate wifi option, it keep say me 'impossible to start WI-FI"

any idea ?

edit: seems the problem was because i have started tethering with wifi that was already active, when i have restarted thethering app,

it show me 'stop' button active again, after i have push it, finally i was able to reactivate wifi opt.

thanks for this GREAT program !

Edited by L0cu7us

Share this post


Link to post
Share on other sites
oops..i thought i could tether by usb.. :lol:

Wired tether is already built into your phone!

If that is what you want download Acer EasyLink

Download this program: http://global-download.acer.com/GDFiles/Ap...cer&SC=PA_6

(On Vista) Device Manager-->Modem-->Acer Android Modem-->Advanced-->enter the sting could be for all that: +CGDCONT=1,”IP”,”apn name”

Open the Acer EasyLink software

Settings

The number is just *99#

Make sure everything else is correct

Voila.

Share this post


Link to post
Share on other sites
I had a mess in my bin / xbin dirs, some busybox commands were handled by toolbox, so I rm-ed the duplicates (I made busybox handle almot every shell command). Still no go.

Ok, that's tether_on output:

# ./tether_on

./tether_on

LiquidE: verifying that dhd isn't loaded

ramzswap 10592 1 - Live 0x7f007000

xvmalloc 5552 1 ramzswap, Live 0x7f000000

LiquidE: dhd wasn't loaded.

LiquidE: verifying that wpa_supplicant isn't started

LiquidE: wpa_supplicant wasn't started

LiquidE: Loading wifi driver...

LiquidE: Powering wifi..

Turning on eth0 device..

Enabling ip_forwarding..

Flushing iptables..

Writing new iptables rules..

LiquidE: starting supplicant..

ioctl[SIOCSIWMODE]: No such device

Could not configure driver to use managed mode

ioctl[SIOCGIWRANGE]: No such device

LiquidE: creating a resolv.conf file..

Starting dnsmasq server..

LiquidE: setting prop to fake a real eth0 connection..

Done, tethering started..

Those errors may be the point..

GREAT man!

Now, the problems seems like the wifi interface isn't properly coming up. Please try these commands, after having turned off your Wifi:

insmod /etc/wifi/dhd.ko "firmware_path=/system/etc/wifi/BCM4320.bin,nvram_path=/system/etc/wifi/nvram.txt"

echo 1 > /sys/module/wifi_power/parameters/power

(wait a few seconds)

lsmod

cat /sys/module/wifi_power/parameters/power

ifconfig eth0 192.168.10.1 up running

ifconfig eth0

Share this post


Link to post
Share on other sites
it work PERFECTLY BUT, after i stop it and tried to connect via wifi from phone, it doesn't work anymore :-(

even from settings, when i try to activate wifi option, it keep say me 'impossible to start WI-FI"

any idea ?

edit: seems the problem was because i have started tethering with wifi that was already active, when i have restarted thethering app,

it show me 'stop' button active again, after i have push it, finally i was able to reactivate wifi opt.

thanks for this GREAT program !

Yep, that's a known bug I forgot to mention :\ (updated OP, thanks again)

Thank you for your feedbacks!

On which rom are you using it?

Edited by gengaro86

Share this post


Link to post
Share on other sites
GREAT man!

Now, the problems seems like the wifi interface isn't properly coming up. Please try these commands, after having turned off your Wifi:

here's the output:

# insmod /etc/wifi/dhd.ko "firmware_path=/system/etc/wifi/BCM4320.bin,nvram_path

=/system/etc/wifi/nvram.txt"

insmod /etc/wifi/dhd.ko "firmware_path=/system/etc/wifi/BCM4320.bin,nvram_path=/

system/etc/wifi/nvram.txt"

# echo 1 > /sys/module/wifi_power/parameters/power

echo 1 > /sys/module/wifi_power/parameters/power

# lsmod

lsmod

dhd 188000 0 - Live 0x7f1a1000

ramzswap 10592 1 - Live 0x7f007000

xvmalloc 5552 1 ramzswap, Live 0x7f000000

# cat /sys/module/wifi_power/parameters/power

cat /sys/module/wifi_power/parameters/power

Y

# ifconfig eth0 192.168.10.1 up running

ifconfig eth0 192.168.10.1 up running

ifconfig: bad address 'running'

# ifconfig

ifconfig

eth0	  Link encap:Ethernet  HWaddr 00:00:00:00:00:00

		  inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0

		  inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link

		  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:1000

		  RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


lo		Link encap:Local Loopback

		  inet addr:127.0.0.1  Mask:255.0.0.0

		  inet6 addr: ::1/128 Scope:Host

		  UP LOOPBACK RUNNING  MTU:16436  Metric:1

		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:0

		  RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


rmnet0	Link encap:Ethernet  HWaddr DE:77:CF:BF:7C:91

		  inet addr:109.118.159.243  Bcast:109.118.159.247  Mask:255.255.255.248


		  inet6 addr: fe80::dc77:cfff:febf:7c91/64 Scope:Link

		  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

		  RX packets:451 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:487 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:1000

		  RX bytes:275581 (269.1 KiB)  TX bytes:50016 (48.8 KiB)
and here's tail of dmesg:
[ 2074.260907] eth0: no IPv6 routers present

[ 2093.340186] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340256] eth0: set mcast_list failed, cnt 3

[ 2093.340320] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340375] eth0: set allmulti 1 failed

[ 2093.340426] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340479] eth0: set promisc 0 failed

[ 2093.340711] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340769] eth0: set mcast_list failed, cnt 3

[ 2093.340987] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.341044] eth0: set allmulti 1 failed

[ 2093.341094] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.341147] eth0: set promisc 0 failed

Share this post


Link to post
Share on other sites

[ 2074.260907] eth0: no IPv6 routers present

[ 2093.340186] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340256] eth0: set mcast_list failed, cnt 3

[ 2093.340320] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340375] eth0: set allmulti 1 failed

[ 2093.340426] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340479] eth0: set promisc 0 failed

[ 2093.340711] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.340769] eth0: set mcast_list failed, cnt 3

[ 2093.340987] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.341044] eth0: set allmulti 1 failed

[ 2093.341094] dhd_prot_ioctl : bus is down. we have nothing to do

[ 2093.341147] eth0: set promisc 0 failed

Seems like that the interface isn't able to set multicast, that's weird.

I'm not sure but this may be related with how phhusson built the kernel.

Anyway, let's ignore them for now and hope they aren't what I think they are, try these now:

killall -15 wpa_supplicant (you may get an error, that's ok)

wpa_supplicant -w -ieth0 -Dwext -c/data/data/net.gengaro.liquid/wpa_tether.conf

paste the wpa_supplicant output along with a "logcat | grep -i wpa_supplicant"

Edited by gengaro86

Share this post


Link to post
Share on other sites

First of all a BIG thank you for your patience!

Here's my output:

# insmod /etc/wifi/dhd.ko "firmware_path=/system/etc/wifi/BCM4320.bin,nvram_path

=/system/etc/wifi/nvram.txt"

insmod /etc/wifi/dhd.ko "firmware_path=/system/etc/wifi/BCM4320.bin,nvram_path=/

system/etc/wifi/nvram.txt"

# echo 1 > /sys/module/wifi_power/parameters/power

echo 1 > /sys/module/wifi_power/parameters/power

# lsmod

lsmod

dhd 188000 0 - Live 0x7f00c000

ramzswap 10592 1 - Live 0x7f007000

xvmalloc 5552 1 ramzswap, Live 0x7f000000

# cat /sys/module/wifi_power/parameters/power

cat /sys/module/wifi_power/parameters/power

Y

# ifconfig eth0 192.168.10.1 up

ifconfig eth0 192.168.10.1 up

# ifconfig

ifconfig

eth0	  Link encap:Ethernet  HWaddr 00:00:00:00:00:00

		  inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0

		  inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link

		  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:1000

		  RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


lo		Link encap:Local Loopback

		  inet addr:127.0.0.1  Mask:255.0.0.0

		  inet6 addr: ::1/128 Scope:Host

		  UP LOOPBACK RUNNING  MTU:16436  Metric:1

		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:0

		  RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


rmnet0	Link encap:Ethernet  HWaddr 52:BF:21:89:2B:D3

		  inet addr:109.119.11.162  Bcast:109.119.11.163  Mask:255.255.255.252

		  inet6 addr: fe80::50bf:21ff:fe89:2bd3/64 Scope:Link

		  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

		  RX packets:313 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:339 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:1000

		  RX bytes:273545 (267.1 KiB)  TX bytes:33806 (33.0 KiB)


# killall -15 wpa_supplicant

killall -15 wpa_supplicant

killall: wpa_supplicant: no process killed

# wpa_supplicant -Bw -ieth0 -Dwext -c/data/data/net.gengaro.liquid/wpa_tether.co

nf

wpa_supplicant -Bw -ieth0 -Dwext -c/data/data/net.gengaro.liquid/wpa_tether.conf


# logcat | grep -i wpa_supplicant

logcat | grep -i wpa_supplicant

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=-1 state=2

I/wpa_supplicant(  903): Trying to associate with SSID 'LiquidCap'

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=-1 state=3

I/wpa_supplicant(  903): Association request to the driver failed

I/wpa_supplicant(  903): Authentication with 00:00:00:00:00:00 timed out.

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=0 state=0

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=-1 state=2

I/wpa_supplicant(  903): Trying to associate with SSID 'LiquidCap'

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=-1 state=3

I/wpa_supplicant(  903): Association request to the driver failed

I/wpa_supplicant(  903): Authentication with 00:00:00:00:00:00 timed out.

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=0 state=0

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=-1 state=2

I/wpa_supplicant(  903): Trying to associate with SSID 'LiquidCap'

I/wpa_supplicant(  903): CTRL-EVENT-STATE-CHANGE id=-1 state=3

I/wpa_supplicant(  903): Association request to the driver failed

(LiquidCap is my network ssid, I'm attaching even wpa_tether.conf, just in case..)

wpa_tether.txt

Edited by liquid_it

Share this post


Link to post
Share on other sites

There's something wrong in the way we get your wifi interface up, it has no MACADDR, it actually means that the controller isn't able to "talk" with the interface through the bus.

Let's see what happens now.

run tether_off script (don't post the output, it's just to have the module unloaded and wifi unpowered)

Now prepare three terminals (:lol:):

logcat | grep -i wpa_supplicant

logcat | grep -i wifihw

start your wifi by using the normal power button and connect to your home wireless router (normally)

after that, provide the output of ifconfig eth0 and the two logcats above.

Also, please provide output of

ls /system/etc/wifi and ls /etc/wifi

Share this post


Link to post
Share on other sites
Now prepare three terminals (:D):

logcat | grep -i wpa_supplicant

logcat | grep -i wifihw

start your wifi by using the normal power button and connect to your home wireless router (normally)

after that, provide the output of ifconfig eth0 and the two logcats above.

Also, please provide output of

ls /system/etc/wifi and ls /etc/wifi

Unfortunately I don't have an ap here, so I can't provide a complete log. BTW here is something (all up, but, obviously, non connection made):

# logcat | grep -i wpa_supplicant

logcat | grep -i wpa_supplicant

I/wpa_supplicant(  924): CTRL-EVENT-STATE-CHANGE id=-1 state=2

I/wpa_supplicant(  924): CTRL-EVENT-SCAN-RESULTS  Ready

I/wpa_supplicant(  924): CTRL-EVENT-SCAN-RESULTS  Ready

I/wpa_supplicant(  924): CTRL-EVENT-SCAN-RESULTS  Ready

(and so on...)
# logcat | grep -i wifihw

logcat | grep -i wifihw

E/WifiHW  (  152): set_wifi_power = 1

W/WifiHW  (  152): wifi_load_driver Ok
# ls -l /etc/wifi

ls -l /etc/wifi

-rw-rw-r-- root	 root	   220653 2010-07-01 10:47 dhd.ko

-rw-rw-rw- root	 root		29662 2010-06-20 21:01 wpa_supplicant.conf

-rw-r--r-- root	 root		  496 2008-08-01 14:00 wifi.conf

-rw-r--r-- root	 root		  499 2008-08-01 14:00 wifiFac.conf

-rw-rw-rw- root	 root		  379 2010-06-20 21:01 nvram.txt

-rw-rw-rw- root	 root	   259656 2010-06-20 21:01 BCM4325Fac.bin

-rw-rw-rw- root	 root	   259204 2010-06-20 21:01 BCM4325.bin

# ls -l /system/etc/wifi

ls -l /system/etc/wifi

-rw-rw-r-- root	 root	   220653 2010-07-01 10:47 dhd.ko

-rw-rw-rw- root	 root		29662 2010-06-20 21:01 wpa_supplicant.conf

-rw-r--r-- root	 root		  496 2008-08-01 14:00 wifi.conf

-rw-r--r-- root	 root		  499 2008-08-01 14:00 wifiFac.conf

-rw-rw-rw- root	 root		  379 2010-06-20 21:01 nvram.txt

-rw-rw-rw- root	 root	   259656 2010-06-20 21:01 BCM4325Fac.bin

-rw-rw-rw- root	 root	   259204 2010-06-20 21:01 BCM4325.bin

# /system/xbin/ifconfig

/system/xbin/ifconfig

eth0	  Link encap:Ethernet  HWaddr 1C:4B:D6:38:FE:42

		  inet6 addr: fe80::1e4b:d6ff:fe38:fe42/64 Scope:Link

		  UP BROADCAST MULTICAST  MTU:1500  Metric:1

		  RX packets:86 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:22 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:1000

		  RX bytes:4988 (4.8 KiB)  TX bytes:1828 (1.7 KiB)


lo		Link encap:Local Loopback

		  inet addr:127.0.0.1  Mask:255.0.0.0

		  inet6 addr: ::1/128 Scope:Host

		  UP LOOPBACK RUNNING  MTU:16436  Metric:1

		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:0

		  RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


rmnet0	Link encap:Ethernet  HWaddr 06:33:AA:22:BF:7F

		  inet addr:109.118.190.215  Bcast:109.118.190.223  Mask:255.255.255.240


		  inet6 addr: fe80::433:aaff:fe22:bf7f/64 Scope:Link

		  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

		  RX packets:361 errors:0 dropped:0 overruns:0 frame:0

		  TX packets:333 errors:0 dropped:0 overruns:0 carrier:0

		  collisions:0 txqueuelen:1000

		  RX bytes:319692 (312.1 KiB)  TX bytes:31224 (30.4 KiB)

As you may see eth0 does have a mac address, here.. :lol:

Share this post


Link to post
Share on other sites

Err, I think I've mispelled you something some posts ago.

Try:

Turn off your WiFi

insmod /etc/wifi/dhd.ko "firmware_path=/system/etc/wifi/BCM4325.bin,nvram_path=/system/etc/wifi/nvram.txt"

echo 1 /sys/module/wifi_power/parameters/power

(wait few seconds)

lsmod

ifconfig eth0

Share this post


Link to post
Share on other sites

I must have messed up my "custom" rom, I just tried to flash lcr1.7 and your app works perfectly.

I did a nandroid of my previous rom, so I'll debug later @home.

So sorry for the time you spent for my faults!!!

Share this post


Link to post
Share on other sites
Time spent in solving problems is never wasted :D

Happy that you "solved", let me know if it's working for you!

I'd say that on a 0-10 satisfaction scale, I'm quite near 13... :lol:

Share this post


Link to post
Share on other sites
Yep, that's a known bug I forgot to mention :\ (updated OP, thanks again)

Thank you for your feedbacks!

On which rom are you using it?

LCR 1.7 with kernel @998mhz (no TS,SVS etc...) :-)

Share this post


Link to post
Share on other sites

Thanks mates! This works great!

I'm donating a giseng coffee right now so that you can find strengths to add an option to change the password on the UI :lol:

Funny thing: I have more upload speed on my Liquid than on my ADSL.

865387919.png

Share this post


Link to post
Share on other sites

Thank you ! It works very well. Really fast and good connection. Thank you again for your hard work !!! I'm waiting for your future Control Panel , even if this version is enough for me =)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.