Jump to content
Sign in to follow this  
ErnstJanF

[REF] Cooking info, kitchen, tools, etc..

Recommended Posts

any tips on especially removing samsung today and widget_plus and making titanium default?

Is it possible to create to build rom with additinal titanium plugins already installed?

thx

Thunder

Just get your hands on the cab's of those samsung apps and convert them to OEM packages, you will see all the files you can delete.

Share this post


Link to post
Share on other sites

and where do i have to put them? The folder in OEM Folder or the files anywhere when I created oem package folder?

Just get your hands on the cab's of those samsung apps and convert them to OEM packages, you will see all the files you can delete.

Share this post


Link to post
Share on other sites
and where do i have to put them? The folder in OEM Folder or the files anywhere when I created oem package folder?

Just 'peek' into the created packages to see which files it contains. Those files can be removed from your OEMApps folder

Share this post


Link to post
Share on other sites

OK I have some basic questions working with romtool:

- If I delete sys or oem packages, do i have to edit some files too?

- If I change oem packages to other versions, where do i have to put the files and in which format?

- If I want to add additional files, where do i put them and in which format and do i have to edit some files for this, too?

- How do I manage to enable titanium as the default today shell for my new rom?

- Can I add titanium panels?

Just 'peek' into the created packages to see which files it contains. Those files can be removed from your OEMApps folder
Edited by Thunder141

Share this post


Link to post
Share on other sites
hey, i managed to get it from megaupload! thanks a bunch! :(

hey ernst,

do you have any idea how 256megs of ram is being eaten up on our device? whats it being reserved for (DMA buffers and stuff....but over a 100 megs of it for DMA and other reserved os mem really???)

any idea how we could mod this to have lesser reserved memory?

also...i upgraded the sys folder with a 23569 build...retained the .rom and .vm folders from 21889 build. also, i used the oem folder untouched and compiled a new rom - didnt optimize anything - just a direct compile & build. but the rom wouldnt boot...the screen goes blank after the initial samsung animation and thats it! i havent ported the new xip...could that be the reason it isnt booting?

thanks!

Share this post


Link to post
Share on other sites

can you give me a quick walkthrough on how to port the xip over which will work with romTool.exe? Do i have to manually use xipkitchen or xipport tools to do it? or can i just replace the updated msxip modules/files into the ROM folder?

Another mistake i had made which might be causing my rom to not boot - i didnt use the original metadata folder....currently recompiling with the original metadata folder! hoping that would work :(

cheers

Share this post


Link to post
Share on other sites
hey ernst,

do you have any idea how 256megs of ram is being eaten up on our device? whats it being reserved for (DMA buffers and stuff....but over a 100 megs of it for DMA and other reserved os mem really???)

any idea how we could mod this to have lesser reserved memory?

also...i upgraded the sys folder with a 23569 build...retained the .rom and .vm folders from 21889 build. also, i used the oem folder untouched and compiled a new rom - didnt optimize anything - just a direct compile & build. but the rom wouldnt boot...the screen goes blank after the initial samsung animation and thats it! i havent ported the new xip...could that be the reason it isnt booting?

thanks!

The reserved RAM is for radio and a few other things that don't have integrated memory.

Share this post


Link to post
Share on other sites
The reserved RAM is for radio and a few other things that don't have integrated memory.

any idea why my 23569 port isnt booting? i've retained .rom/.vm/metadata folders...it goes blank after the samsung animation :)

also, can you give me a quick walkthrough on how to port xip for the pro if u dont mind? thanks a lot m8.

take care,

San

Share this post


Link to post
Share on other sites
any idea why my 23569 port isnt booting? i've retained .rom/.vm/metadata folders...it goes blank after the samsung animation :)

also, can you give me a quick walkthrough on how to port xip for the pro if u dont mind? thanks a lot m8.

take care,

San

Check XDA's 'Chef's corner' for info on cooking

Share this post


Link to post
Share on other sites

Hi ErnstJanF, I'd like to cook my own rom, remove some stuff, etc...I have the official JC2 rom with all the parts :

1. SS_DL.dll SS_DL.dll

2. 2. Phone_B7610XXJC1.bin Phone_B7610XXJC1.bin

3. 3. PDA_B7610NXXJC2_HW_70.MST PDA_B7610NXXJC2_HW_70.MST

4. 4. Eboot_B7610NXXJC2_HW_70.eb0 Eboot_B7610NXXJC2_HW_70.eb0

5. 5. B7610NXEEJC2.csc B7610NXEEJC2.csc

They're all seperated into different files. Can I dump using this (perhaps using just the .MST)? or is there something I need to do before dumping and starting to cook? (perhaps recompile the parts [How?]

Your help is very much appreciated

Share this post


Link to post
Share on other sites

No answers so far?

OK I have some basic questions working with romtool:

- If I delete sys or oem packages, do i have to edit some files too?

- If I change oem packages to other versions, where do i have to put the files and in which format?

- If I want to add additional files, where do i put them and in which format and do i have to edit some files for this, too?

- How do I manage to enable titanium as the default today shell for my new rom?

- Can I add titanium panels?

Share this post


Link to post
Share on other sites
No answers so far?

- For each file you delete, you need to remove the entry in initflashfiles.dat (located in OEM_Lang_xxxx)

- OEM Packages go into the OEM folder, buildOS will recognize them.

- For the other questions I refer you to XDA :)

Share this post


Link to post
Share on other sites

Managed to build a rom with some samsung apps removed.

Rom boots, and shows my added application, too. They run.

But I have no settings anymore, neither windows nor samsung settings, though i didn't remove them. There are no links in start menu and the exe files aren't in the windows folders anymore.

What have I done wrong?

- For each file you delete, you need to remove the entry in initflashfiles.dat (located in OEM_Lang_xxxx)

- OEM Packages go into the OEM folder, buildOS will recognize them.

- For the other questions I refer you to XDA :)

Share this post


Link to post
Share on other sites
Managed to build a rom with some samsung apps removed.

Rom boots, and shows my added application, too. They run.

But I have no settings anymore, neither windows nor samsung settings, though i didn't remove them. There are no links in start menu and the exe files aren't in the windows folders anymore.

What have I done wrong?

Same happened to me, you'll have to create them manually :)

Share this post


Link to post
Share on other sites

but where do i get the exe files? Do you know what all is missing? And my added applications: They are all copied to windows folder instead of "\Programme". No way to get them out of the windows folder with romtool?

And where to put ext packages so that they are recognized by romtool?

Same happened to me, you'll have to create them manually :)
Edited by Thunder141

Share this post


Link to post
Share on other sites
but where do i get the exe files? Do you know what all is missing? And my added applications: They are all copied to windows folder instead of "\Programme". No way to get them out of the windows folder with romtool?

And where to put ext packages so that they are recognized by romtool?

You just create .lnk files using OEMizer :)

You can make your own packages using package creator, but be sure to select your language and put them in the correct folder!

Share this post


Link to post
Share on other sites

Txh so far. Correct folder? What do you mean by that? Can I manage to get some apps to be in "Program Files"? I added some apps to my light rom and they all are placed in windows after i boot my rom. So i thought, i must build ext packages instead of oem packages, but rom tool doesn't recognize those packages. And if they are all placed in windows folder, i could not add some apps, because f.e. the app has png files that already exist for an other app.

OEMIzer? This dosn't help me, because there are no exe files for samsung settings. Only, if i remove it first and then add it as another oem package.

You just create .lnk files using OEMizer :)

You can make your own packages using package creator, but be sure to select your language and put them in the correct folder!

Share this post


Link to post
Share on other sites
Txh so far. Correct folder? What do you mean by that? Can I manage to get some apps to be in "Program Files"? I added some apps to my light rom and they all are placed in windows after i boot my rom. So i thought, i must build ext packages instead of oem packages, but rom tool doesn't recognize those packages. And if they are all placed in windows folder, i could not add some apps, because f.e. the app has png files that already exist for an other app.

OEMIzer? This dosn't help me, because there are no exe files for samsung settings. Only, if i remove it first and then add it as another oem package.

For OEMizer:

Just create a shortcut to settings.exe (/Windows) and place it in YOUR startmenu folder. (/Windows/Startmenu/Programma's for dutch)

Share this post


Link to post
Share on other sites

OK, thx. That works!

Do you know what I have forgotten if motion calibration in samsung settinngs start to calibrate, but doesn't finish?

That's the last point for my rom to work properly

For OEMizer:

Just create a shortcut to settings.exe (/Windows) and place it in YOUR startmenu folder. (/Windows/Startmenu/Programma's for dutch)

Share this post


Link to post
Share on other sites
OK, thx. That works!

Do you know what I have forgotten if motion calibration in samsung settinngs start to calibrate, but doesn't finish?

That's the last point for my rom to work properly

I don't know, I've never cooked a ROM that booted.

Share this post


Link to post
Share on other sites
I don't know, I've never cooked a ROM that booted.

I found it. Camera not workin. Used experimental cab => Camera working and calibration working. Strange

Share this post


Link to post
Share on other sites

As there are no rom_dump-files attached to any thread, I believe everyone has to create a rom_dump himself. Is there a reason for this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.