Jump to content
Sub501

[KERNEL] Sub501 Kernel, mods and control apk

Recommended Posts

what is the difference between these roms and a stock rom in terms of what is affecting the size of the available space after install?. With Modaco roms I only have around 87mb left after install and reboot yet using a stock rom I have 138mb.

As I dont want to use a2sd+ due to the bugs so im relying heavily on the froyo a2sd and although I prefer MCR roms, the amount of free space is making it nigh on impossible to get all my apps on

Share this post


Link to post
Share on other sites
what is the difference between these roms and a stock rom in terms of what is affecting the size of the available space after install?. With Modaco roms I only have around 87mb left after install and reboot yet using a stock rom I have 138mb.

As I dont want to use a2sd+ due to the bugs so im relying heavily on the froyo a2sd and although I prefer MCR roms, the amount of free space is making it nigh on impossible to get all my apps on

The amount of free space you have after first install and reboot will depend on what you bake into your ROM. Also, the MCR is deodexed. Hence, the free space you have on your internal storage will be less, unless you choose to use A2SD/A2SD+. If you bake in A2SD/A2SD+, then all the deodexed files should be moved to the SD Card after first reboot, which will help you regain up to 138 MB free internal storage.

What bugs are you referring to in A2SD+? I have been using A2SD+ through Paul's kitchen since R7 and it works beautifully!

Regards,

Kiran

Share this post


Link to post
Share on other sites
The amount of free space you have after first install and reboot will depend on what you bake into your ROM. Also, the MCR is deodexed. Hence, the free space you have on your internal storage will be less, unless you choose to use A2SD/A2SD+. If you bake in A2SD/A2SD+, then all the deodexed files should be moved to the SD Card after first reboot, which will help you regain up to 138 MB free internal storage.

What bugs are you referring to in A2SD+? I have been using A2SD+ through Paul's kitchen since R7 and it works beautifully!

Regards,

Kiran

http://forum.xda-developers.com/showthread.php?t=748793

This one, Ive actually lost quite a bit of data and I thought it was my memory card at fault until I saw this thread. Now I see why people have been asking for odexed roms from paul, id like to put that request in myself because until the developers find a solution to the a2sd problem I cant risk using it :P

(By the way, I just realised I posted my comment in the wrong thread, these were meant fo the rom thread, sorry for derailing!!)

Edited by Diggedy

Share this post


Link to post
Share on other sites
How to use cifs? I installed cifs manager but it always fail to mount with "invalid argument

"... is it possible for someone to explain me how to do this?

Hi,

Please follow the XDA link from post #3. If GUI is not working then switch to terminal and play with some linux commands. Let us know if worked.

Cheers

Share this post


Link to post
Share on other sites

OK I found the mistake... For Win7, I have a password and I forgot to mention the username and password in CifsManager... Now, It's working fine ! And for my Media hard drive, I have no user information. So I simply put "guest" as username and everything's fine too... Finally !

Share this post


Link to post
Share on other sites
OK I found the mistake... For Win7, I have a password and I forgot to mention the username and password in CifsManager... Now, It's working fine ! And for my Media hard drive, I have no user information. So I simply put "guest" as username and everything's fine too... Finally !

That's excellent. Now we can mark this mod as working. Thanks.

Share this post


Link to post
Share on other sites

a question belonging to cifs:

has someone already tested under more real live customstances, for example to view a directory with 10 photos á 10MB without crashing astro or another filemanager?

Share this post


Link to post
Share on other sites
a question belonging to cifs:

has someone already tested under more real live customstances, for example to view a directory with 10 photos á 10MB without crashing astro or another filemanager?

I've done. It works fine! Perhaps a bit slow, depending of pics size and connection but ok. I even watched a 700M DivX yesterday...

Share this post


Link to post
Share on other sites
I've done. It works fine! Perhaps a bit slow, depending of pics size and connection but ok. I even watched a 700M DivX yesterday...

thanks, will try a few things, to get it faster maybe, i'm sure this is not module spedific

mounted a samba share from mac os x with about 1TB

and went through directories, viewed a few pictures

thumbnail creation take forever

astro shows randomly: do you want force close or wait?

if i wait for it, it comes back to work after a while

Share this post


Link to post
Share on other sites

Many thanks to Sub501 :lol:

I have the R9 WIP using baked with this mod.

Still 54% battery since yesterday 0700 AM.

My use, some browsing, lots of sms, auto brightness, sync exchange every hour from 0800 to 2200.

Share this post


Link to post
Share on other sites
I think the mod has been activated on my r8 - dont see any significant battery savings yet though.

It depends on how the phone is used. In my case, I don't use WiFi and the 3g data is active about 1 hour/day. Most of the time the phone is sleeping, just a few short calls every day. And yes I have 3d2h34s and battery is 74%. This, without using undervolt, just powersave/interactive.

Share this post


Link to post
Share on other sites

Would've liked to had a go off this but I have SetCPU and have just got my head around it so hopefully I'll notice some difference.

Share this post


Link to post
Share on other sites
It depends on how the phone is used. In my case, I don't use WiFi and the 3g data is active about 1 hour/day. Most of the time the phone is sleeping, just a few short calls every day. And yes I have 3d2h34s and battery is 74%. This, without using undervolt, just powersave/interactive.

I dont use wifi or 3G, although 2G data remains activated (but not "always on"). Other than that my usage is as yours, most of the time my phone is on standby. My phone seems hot at random times too. I'm just gonna blame my network and radio.

Share this post


Link to post
Share on other sites
I dont use wifi or 3G, although 2G data remains activated (but not "always on"). Other than that my usage is as yours, most of the time my phone is on standby. My phone seems hot at random times too. I'm just gonna blame my network and radio.

Ah, man, the (global) warming issue ;-). I opened a thread regarding this issue http://android.modaco.com/content/htc-desi...random-reboots/. I got some issues when roaming. Hot phone , even 41 degrees (high fever) and random reboots. The reboots were gone when I switched the operator, don't know why. The phone was also hot after, but 34-36 degrees only. Of course roaming at high speed. Same issue with WiFi, low signal ~20%. From my tests when the WiFi signal is low the phone is warmer. I believe is something normal.

Now back in my home town, the battery has 24 degrees and working pretty good, no reboots at all.

Now I have 3d22h48m and battery at 65%. I'm curious if I can reach one week without charging.

Share this post


Link to post
Share on other sites
You could try turning off your phone at night :lol:.

For sure but putting the phone in flight mode doesn't offer a clear response. It may be the radio hardware, radio software or even the network operator/signal. In my case , when roamed the reboots came from an operator who installed a GSM antenna on top of a... car. It was some kind of a mobile GSM antenna. I suppose something was not ok with that mobile unit.

Share this post


Link to post
Share on other sites

Hi,

Since installing the perflock and governor mods i noticed that the android system process in the battery usage stats is now topping my list at about 70% use....normally my cell standby is there at about 38% with AS being third in the list....is this normal?? Not really nnoticed increased battery performance due to the change in usage of the AS process.

Cheers,

Matt

Share this post


Link to post
Share on other sites
Hi,

Since installing the perflock and governor mods i noticed that the android system process in the battery usage stats is now topping my list at about 70% use....normally my cell standby is there at about 38% with AS being third in the list....is this normal?? Not really nnoticed increased battery performance due to the change in usage of the AS process.

Cheers,

Matt

have you confirmed that the mods are actually installed and working properly?

Since these modifications my phone is lasting an extra 24hrs. The main gain is when it's idle, before the governors weren't present so the cpu was at max speed even when idle, now it lowers during idle so the battery lasts way longer. Maybe your usage pattern is different to mine, but I find this mod to be fantastic for my usage.

Share this post


Link to post
Share on other sites
have you confirmed that the mods are actually installed and working properly?

Since these modifications my phone is lasting an extra 24hrs. The main gain is when it's idle, before the governors weren't present so the cpu was at max speed even when idle, now it lowers during idle so the battery lasts way longer. Maybe your usage pattern is different to mine, but I find this mod to be fantastic for my usage.

Yeah i installed the aLogCat from post #10 and noted that the governor lines now exist as below

I/98mods01_screenstate_scaling( 1127):***Sleeping***: switching cpu frequency governor to ->powersave

and then

I/98mods01_screenstate_scaling( 1127):***awake***: switching cpu frequency governor to ->interactive

Does this not show that the governors are installed correctly??

Admitedly since taking it off charge i had the music player running for the 20 or so min traing journey to work but that doesnt affect the AS process in the battery usage stats usually....

EDIT:after a number of reboots AS process is now back in third slot so maybe a loose process running wild or something....?

Matt

Edited by nevawlkalone

Share this post


Link to post
Share on other sites
Yeah i installed the aLogCat from post #10 and noted that the governor lines now exist as below

I/98mods01_screenstate_scaling( 1127):***Sleeping***: switching cpu frequency governor to ->powersave

and then

I/98mods01_screenstate_scaling( 1127):***awake***: switching cpu frequency governor to ->interactive

Does this not show that the governors are installed correctly??

Admitedly since taking it off charge i had the music player running for the 20 or so min traing journey to work but that doesnt affect the AS process in the battery usage stats usually....

EDIT:after a number of reboots AS process is now back in third slot so maybe a loose process running wild or something....?

Matt

that looks right for the governors yes. see how it goes.... :lol:

Share this post


Link to post
Share on other sites
that looks right for the governors yes. see how it goes.... :lol:

its running good, had a ton of battery left but the AS. process is still killings it...seems to start after its been on charg...anyone else experienced this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.