Jump to content
DanWilson

CyanogenMod 6 Discussion / Help

Recommended Posts

UPDATED FOR CYANOGENMOD 6. :)

Reset (hopefully) the poll since there is a new version of CM6 out. Now fully updated. :P

 ▲

▲ ▲

Updated, noob-friendlier, still Tri-Forcing, made Tom's warning bigger, raging about the loss of DarkTremor A2SD...

After the fairly successful port of Froyo to the Pulse, I've decide to try porting CyanogenMod 6. If this is successful I hope it can one day be included into the official CyanogenMod releases.

CM6 is built on Froyo, but adds many extra features. For many of the bugs we are experiencing in Froyo, we have been looking at how they were fixed in CM6. So rather than port the fixes to Froyo, why not port all of CM6 to the Pulse.

There are still a lot of issues, so use it at your own risk, and don't complain if a feature you feel is important doesn't work.

Downloads

It is too big to fit on the 1.5 system partition, so you must update to a 2.1 official rom before installing this.

Google apps is not included and must be installed seperately.

Current rom: beta-0.30

GApps signed zip: gapps-mdpi-20100930-signed.zip <-- install from recovery

Thanks to Flibblesan for providing hosting.

Install Instructions

Installed fine on my CHT8000.

Tre 2.1 updata for my base (that's what I had already and I didn't not change it; should give me some space to push other apps; not yet tested)

Clockwork Recovery (already installed previously)

Nandorid backup of my previous rom

Full factory wipe

Installed the CM .zip

Installed Google apps .zip

Rebooted - perfect!

Tested apps.

Left the "move apps to sd" setting on automatic, but it looks like nothing it being moved automatically. It seems I can move them manually in the Application Manger.

Discovered that widgets can not be moved to sd (moved them back and rebooted to restore them).

Discovered that apps with widgets can be moved to sd, but you will lose their widgets.

Sucessfully installed HWime (Chinese handwriting recognition), but this also can not be moved to SD.

Swype installer worked, but fc'ed right at the end of the process. Fortunately Swype is installed and working.

Haven't gotten much further, but it really looks good.

Only FC's related to installing system apps that don't run on Froyo.

This seems to wrap everything up. Even though it says CHT8000, it works fine on a Pulse (the guide, the ROM may differ for others).

@twrock - If you'd like me to take this off (for whatever reason) just say. I tried to ask, then got bored.

Edited by DanWilson

Share this post


Link to post
Share on other sites

Bugs:

Outstanding:

Wifi MAC is incorrect

Camera: you can take as many shots as you want, as long you use 2MP (UXGA) in settings. (The bug is the fact we can't get 3MP)

Manual network selection returns all networks, but should only return those available to the user.

Gallery: Push in CM 6.0's Gallery3D.apk has working rotation with minor bugs. (Has a weird bug: IMG) Better than nothing

(Any other bugs with CM6 0.3? Tell me)

Yeah. Second post wasted. Anything you'd like here? I'll start;

Epic thanks to Tom (Dan)

A2SD

Now official Froyo A2SD works. DarkTremor A2SD works. I don't know how. Don't ask me. I shall shoot you down. With some Angry Birds :P

General info

All posts on and after page 15 are CyanogenMod related. Everything before is from the old Froyo release. Yes, there was a before CM6.

SWAP works OK.

Overclock is (I think) 691MHz. I have heard of larger, but I haven't tested it.

Edited by DanWilson

Share this post


Link to post
Share on other sites

Have been using it full time since 0.40.

Can't go back to 2.1, I tried, but it makes me cry.

Share this post


Link to post
Share on other sites
Have been using it full time since 0.40.

Can't go back to 2.1, I tried, but it makes me cry.

Lol. I can't find any bugs other than the camera. Everything else seems fine, time to go on a bug hunt! And does Froyo's A2SD work?

Share this post


Link to post
Share on other sites

There's no option like "Already testing" :P

Anyways, now that 2G/3G data is easy to enable I will test FroYo for a couple of days. So far:

- Phone functionality is good (will test more for quality issues :))

- Sync works perfectly

- Wifi can access and use my WPA2 secured home network nicely

- CAMERA IS NOT WORKING (this is for those who have NEVER read the original thread and wonder)

Will report back later :(

Share this post


Link to post
Share on other sites

I made this up for Fusion, it's a guide to get data working

1. Open CMD

2. Type CD(press space)and drag the folder that has ADB in it to the CMD window

3. Press enter

4. Put in "adb shell" , you should end up with # on the prompt

5. Then put in "mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system" and press enter

6. Put in "chmod 6751 /system/bin/netcfg"

7. Press enter.

8. ????

9. INTERNET!

Enjoy :)

Share this post


Link to post
Share on other sites
I made this up for Fusion, it's a guide to get data working

1. Open CMD

2. Type CD(press space)and drag the folder that has ADB in it to the CMD window

3. Press enter

4. Put in "adb shell" , you should end up with # on the prompt

5. Then put in "mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system" and press enter

6. Put in "chmod 6751 /system/bin/netcfg"

7. Press enter.

8. ????

9. INTERNET!

Enjoy :)

OK - I'll replace Flib's guide because this is more extensive, although remember Linux and Mac! :P

Also, step 5 isn't required for 0.50

Share this post


Link to post
Share on other sites

I LOOOOVE Froyo, but I have a few kinks.

When I'm connected to my home wifi, the connection works great, but wifi indicator shows poor connection (the phone is right next to the router)

post-688453-1284293191_thumb.png

And the second "problem" is that I don't like the Contact arrangment (sort list as). I liked the 2.1 contacts better :P

Edited by Fusion0306

Share this post


Link to post
Share on other sites
OK - I'll replace Flib's guide because this is more extensive, although remember Linux and Mac! :P

Also, step 5 isn't required for 0.50

I had to do step 5 on 0.5 :)

Share this post


Link to post
Share on other sites
I LOOOOVE Froyo, but I have a few kinks.

When I'm connected to my home wifi, the connection works great, but wifi indicator shows poor connection (the phone is right next to the router)

post-688453-1284293191_thumb.png

Yeah that issue should be fixed now.

And I love the Froyo contacts app :P

Share this post


Link to post
Share on other sites
Weird, I didn't... I just "adb remount" -ed

yup, adb remount

I don't see why you can't just do:

adb remount

adb shell

chmod 6751 /system/bin/netcfg

reboot

4 lines, simples.

Edited by flibblesan

Share this post


Link to post
Share on other sites

Weird - I'm getting quite a few reboots... Sometimes just to the Nexus boot animation, sometimes to the Huawei logo (I used the Tre update)...

Share this post


Link to post
Share on other sites

I was willing to give it a try but after reading about binarys and fast boots,I think i'll give it a miss for now. Sound too complicated for me!

Share this post


Link to post
Share on other sites
Weird - I'm getting quite a few reboots... Sometimes just to the Nexus boot animation, sometimes to the Huawei logo (I used the Tre update)...

I bet that'll be caused by JIT being enabled.

Share this post


Link to post
Share on other sites
New bug: market isnt working very well. You can download stuff, but alot off apps arent showing up in the market.

Added.

I was willing to give it a try but after reading about binarys and fast boots,I think i'll give it a miss for now. Sound too complicated for me!

Binarys? Where! :P

Just wait till a update.zip pops up, I'm sure one will arrive soon.

Share this post


Link to post
Share on other sites
New bug: market isnt working very well. You can download stuff, but alot off apps arent showing up in the market.

Yup - even with Eris Market fix (I could install it from Market, applied it - a few more but not all the apps are visible compared to 2.1 ROMs I used).

Couldn't find so far:

- Astro file manager

- Call Backup & restore (by Ritesh Sahu)

- SysMonitor

etc.

Share this post


Link to post
Share on other sites

This is for windows only. A little easier. (From developer forum)

make a nand backup

Download the Froyo 0.50 and unzip it in an folder on your pc.

Download this and unzip it in the same folder. Attached File http://android.modaco.com/index.php?act=at...st&id=62492 (fastboot.zip) ( 264.31K ) Number of downloads: 14

Turn of your phone and go in to fastboot (turn on phone while holding red key and the vol DOWN).

Connect the phone with your usb cable to the pc.

Double click the froyo.bat file and wait for cmd to finish.

Then take out your battery, put it back in and turn on your phone. That's it!

Share this post


Link to post
Share on other sites
When I'm connected to my home wifi, the connection works great, but wifi indicator shows poor connection (the phone is right next to the router)

That is now fixed in git.

For anyone building from source 'repo sync' to pickup the change.

Please report bugs with the github issue tracker in my sig.

Share this post


Link to post
Share on other sites

anyone else noticed that after opening google goggles (purely by accident meant to click market) GPS turns on and stays on? not really big but might drain battery a bit if it's true

EDIT: by stays on I mean the icon doesn't disappear in the status bar

EDIT2: nvm reopening fixed it

Edited by Cazomino05

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.