Jump to content
flibblesan

[ROM][OLED+TFT] FLB-Froyo G2 for ZTE Blade

Recommended Posts

Question: if I add another Dialer app from Market - how can I prevent the original one from starting up again?

I tried to do this with the 2.2 Alpha Rom and replace it with Dialer One; I just deleted the ZTE dialer in /system/app/SmartDialer.apk using a su in a terminal emulator.

But the dialer process still showed up in OSMonitor and in the battery useage list :rolleyes:

Share this post


Link to post
Share on other sites
I just flashed this rom and I'm having trouble to set-up my google account.

it gives me a "Can't establish a reliable data connection to the server" error.

Market, gmail, etc doesn't work. Does anyone knows a fix for this?

Thank!

Do a Fctory Reset and make sure that your first connection to Goggle server is via 3G/GPRS only and not Wifi... So reset, get into phone, enable celluar data connection and then do the sync.

Share this post


Link to post
Share on other sites
I tried to do this with the 2.2 Alpha Rom and replace it with Dialer One; I just deleted the ZTE dialer in /system/app/SmartDialer.apk using a su in a terminal emulator.

But the dialer process still showed up in OSMonitor and in the battery useage list :rolleyes:

Did you reboot after removing it?

Share this post


Link to post
Share on other sites
Did you reboot after removing it?

Yep, I rebooted a couple of times. I assume that both the ZTE dialer and Dialer One (in fact all other dialers) probably use the same underlying system dialer process and that something in the kernal is triggering the dialer to fire-up, so just changing the dialer has no effect.

Share this post


Link to post
Share on other sites

Nice job fli!

ZTE Blade is now active in Sweden and costs 147£ totally unlocked with 2years warranty.

Will buy it tomorrow and try the mod after i've got it :rolleyes:

Share this post


Link to post
Share on other sites
Nice job fli!

ZTE Blade is now active in Sweden and costs 147£ totally unlocked with 2years warranty.

Will buy it tomorrow and try the mod after i've got it :rolleyes:

The only thing that doesn't work, which is common to all Blade 2.2 ROMs, is the lack of coarse based positioning (useful for things like weather apps - e.g. FancyWidget), and we're not going to be able to fix this, until we have kernel source (I understand from reading the posts on XDA regarding fixing coarse based positioning).

Edited by goatee

Share this post


Link to post
Share on other sites

You could dump your ROM before flash it :rolleyes:

Maybe there are some updated bits in the Sweedish version. :huh:

Nice job fli!

ZTE Blade is now active in Sweden and costs 147£ totally unlocked with 2years warranty.

Will buy it tomorrow and try the mod after i've got it :huh:

Edited by PeTiNgA

Share this post


Link to post
Share on other sites
Nice job fli!

ZTE Blade is now active in Sweden and costs 147£ totally unlocked with 2years warranty.

Will buy it tomorrow and try the mod after i've got it :rolleyes:

Ho Ho Ho! Great for the red nose raindears...

Share this post


Link to post
Share on other sites
Any news on whether the dialer still eats all the battery or not with this froyo ROM? :rolleyes:

Before you get flamed for this.... A number of posts including the original post clearly state that the dialer does indeed eat battery.

Share this post


Link to post
Share on other sites
I just flashed this rom and I'm having trouble to set-up my google account.

it gives me a "Can't establish a reliable data connection to the server" error.

Market, gmail, etc doesn't work. Does anyone knows a fix for this?

Thank!

i had this issue on another rom; re-flash fixed it.

rebooting the phone (as per another thread) didnt work.

Share this post


Link to post
Share on other sites

re google account setup,

How long should i leave it signing in? its been nearly 10 minutes, do i switch off and start again? i have tried all the other stuff

Share this post


Link to post
Share on other sites
EDIT: Also titanium backup is hanging at 'asking for root rights...'

I am also having same problem with titanium backup, and AGPS is also not working.

Share this post


Link to post
Share on other sites
i had this issue on another rom; re-flash fixed it.

rebooting the phone (as per another thread) didnt work.

Solution to fix this as stated a number of times before is to logon into market place with only the mobile connection for the first time.

WiFi should not be used for the first logon to Google.

Share this post


Link to post
Share on other sites

Hi,

I'm using the "28/Oct r4b gforums Custom Rom FroYo for ZTE blade (Alpha!),....". How does this new Froyo ROM compare with that?

Thanks, Ash

Edited by Ash.UK

Share this post


Link to post
Share on other sites

very nice this, thanks

shame i cant get angry birds and htc keyboard working though lol :-)

Edited by balb0wa

Share this post


Link to post
Share on other sites
very nice this, thanks

shame i cant get angry birds and htc keyboard working though lol :-)

Angry Birds works perfectly for me (restored from a Ti backup. I prefer Swype and Touchpal to HTC keyboard, so not an issue for me.

Share this post


Link to post
Share on other sites
Can you Change the "ZTE中兴" green logo?

Anybody can change it by replacing the bootanimation.zip inside /system/media/. Just either delete it from the zip or replace it with another bootanimation. The HTC style logo was just a bit of fun.

Nice work!

Does bluetooth HID (i.e. keyboards) work with this Froyo ROM?

I don't have any way of testing this so I'd love some feedback if it works or not.

How about installing adobe flash? Why is that not included?

Honestly I haven't even thought about it. It's something I'll look at adding.

Oh, again a bug: APNs can not be edited (same as with the other Froyo version for the Blade):

T-Mobile HU's mms APN needs to be changed (auth. type should be set to "PAP") but it is just not editable... Any workaround please?

Unzip the rom and edit /system/etc/apns-conf.xml to fix the problem, then zip it up again. Clockwork can flash it without signing. If you have already installed the rom then flashing it again won't remove any of your current settings.

Edited by flibblesan

Share this post


Link to post
Share on other sites
Unzip the rom and edit /system/etc/apns-conf.xml to fix the problem, then zip it up again. Clockwork can flash it without signing. If you have already installed the rom then flashing it again won't remove any of your current settings.

To make it faster, should either / both of these work?

1. Make /system writeable and edit the file directly

2. To speed up the flashing process, make an update.zip with only /system/etc/appns-conf.xml in

TIA!

Share this post


Link to post
Share on other sites
very nice this, thanks

shame i cant get angry birds and htc keyboard working though lol :-)

HTC keyboard needs a special version for Froyo. htc_ime_jonasl_hires22_25.zip

It's not a flashable zip so easiest way to install would be to push the two apk files into /system/app/ using ADB or copy them into the zip and reflash. Angry Birds should work.. I'm sure I've had it working on Froyo. Will test it shortly.

Share this post


Link to post
Share on other sites

Does this build of Froyo still have the bugs from the Alpha version.

Does radio work?

Is there anything that 'isnt' working??

If i can get the bloody drivers for my SF to work i might give this a go!!

Share this post


Link to post
Share on other sites
HTC keyboard needs a special version for Froyo. htc_ime_jonasl_hires22_25.zip

It's not a flashable zip so easiest way to install would be to push the two apk files into /system/app/ using ADB or copy them into the zip and reflash. Angry Birds should work.. I'm sure I've had it working on Froyo. Will test it shortly.

Thanks, got angry birds working , just trying this keyboared, great work :rolleyes:

Share this post


Link to post
Share on other sites
Ahhhh thank you :rolleyes:

I'm running clock work recovery mod

Wipedata/factory reset be the same option ?

And also do a wipe cache partition ?

I would also like to know this. Would a factory reset suffice before flashing using clockwork recovery or is there another way to clear cache?

Am also using Pauls R4 rom.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.