Jump to content
flibblesan

[ROM][OLED+TFT] FLB-Froyo G2 for ZTE Blade

Recommended Posts

can anyone reccomend a t9 dialer ??

NubDial, ThaiDial

Edited by gusthy

Share this post


Link to post
Share on other sites

Issues I have found on r6 are as follows.

1. Have found that some alarm clocks cannot be stopped when they go off and you have to kill the process via applications or take the battery out.

Seems to be related to some tools that prevent sleeping, like MSN

2. When I receive a phone call only the number is displayed and not the contact name, even though the contact (my Wife) is in my phone.

3. WiFi does not always auto reconnect, even using blade wifi fix

For point 3 & 2, fixes are listed in the froyo r6 resolution center topic.

Point 1 is still blocking points for me to use this rom.

I also recalibrated my battery and after I've done this, my battery depletes double as fast. I never had battery issues before, but now I do.

Thank you,

Koen

Edited by K.Rens

Share this post


Link to post
Share on other sites
Successfully loaded tun.ko using file from this post:

http://android.modaco.com/index.php?s=&amp...t&p=1551827

Have to load the module manually, not sure why it doesn't load automatically from openvpn config.

VPN now connects successfully buy still not passing traffic, looking into it now.

Kadu

OK, some further tests.

Works by changing tun settings under openvpn config to:

Load module using: insmod

Path to tun moduel: /system/lib/modules/tun.ko

Needless to say I had copied the file to this location previously

Also works if you create a link for /lib -> /system/lib

ln -s /system/lib /lib
I figure this out because when I attempted to load it manually I get:
modprobe tun

modprobe: chdir(/lib/modules): No such file or directory
Now the only problem is the interface is not coming up properly and also my routes which are pushed by the server. If I manually bring the interface UP and any routes I need everything works perfectly
ifconfig tun0 192.168.20.6 netmask 255.255.255.248 up

route add -net 192.168.5.0 netmask 255.255.255.248 gw 192.168.20.1

Now I can access hosts on both subnets successfully.

Edited by DJ_Kadu

Share this post


Link to post
Share on other sites
Guest

All,

sometimes it seems that the handset has lost the connection to GSM operator, but that is definitely not correct. The signal strength indicator shows a cross, the status bar indicates "no service", initiating a call (MO = mobile originated) is not possible, the handset states "Not registered to network". BUT I am able to call my handset (MT = mobile terminated)! Therefore I am still connected to my GSM networtk operator.

Is there a problem regarding the signal strength or similar?

BTW: Running R6

Thx,

alpinestars

Share this post


Link to post
Share on other sites

Nice job going from r6 to R7 so quickly ;)

Very much appreciated.

One quick question though. Do I need to wipe going from R6 to R7?

I have already applied the contacts fix and the wpa fix to R6, so in laymens terms, what does the new kernel give me? Is it worth upgrading (I probably will if no wipe is required!)

Thanks again.

Share this post


Link to post
Share on other sites

Did the usual wipe/reset factory settings and installed R7, only to get ERROR when starting Wi-Fi. Anybody else tried the wifi on R7 ?

Share this post


Link to post
Share on other sites
Vending is crashing and i'm missing a dialer and contacts "app". RLS7

Just noticed this too NO dialer or NO contacts NO WiFi ????

Edited by Stevvie

Share this post


Link to post
Share on other sites

does APNdroid work for anybody with r6? i still have a data connection in the statusbar and can use the browser.

Share this post


Link to post
Share on other sites
One quick question though. Do I need to wipe going from R6 to R7?

I have already applied the contacts fix and the wpa fix to R6, so in laymens terms, what does the new kernel give me? Is it worth upgrading (I probably will if no wipe is required!)

Thanks again.

Answer from solutions topic http://android.modaco.com/index.php?s=&amp...t&p=1563901

R7 implements the wpa_supplicant fix, contacts/dialer fix. Kernel updated to provide support for TUN, CIFS and EXT4. There isn't any easy way for me to provide a update between r6 and r7 due to the contacts fix. Unless you are comfortable following the instructions on the first page then you'll need to wipe before installing the rom.

r7 uploaded. It contains the fixes from this thread along with a custom kernel. If you have made the changes already then you won't need to update to r7. I'll upload an update that only adds the new kernel later.
Edited by dbeckett

Share this post


Link to post
Share on other sites

Reluctant to go to R7 now - anyone else with these problems?

Share this post


Link to post
Share on other sites
flashed R7 wifi seems not work even wiped

I'm uploading the rom again which should have wifi working. I don't have my phone at the moment so the update is untested. But since it's using the same base and same kernel code as r6 with the exception of the wpa_supplicant 'fix' and the contacts fix, I don't quite understand why wifi is failing. But just in case I made a mistake somewhere I've built the kernel again, checked the base and re-uploading. Vending should definitely work now. Contacts should work and show the call log. Wifi I can't test at the moment but I see no reason why it'll fail.

Share this post


Link to post
Share on other sites

after flashing R7:

Dialer doesn't work,

Market keeps crashing

Wifi doesn't work giving Error message ( when tying to enable WiFi)

There is one more thing I've noticed in this ROM as well as in R6. When I go back to a main screen from let say setting menu and I try to swipe to a side screen it doesn't work at first. I have to try few times before it respond.

Anxiously waiting for R8 ;)

Share this post


Link to post
Share on other sites

Well it'll be r7a ;)

I'm uploading it now. Spent some time looking at the wifi issue and rebuilt the kernel again with governor fixes. Kernel should now be built as a release kernel and not debug which may improve performance.

Share this post


Link to post
Share on other sites

wow! thanks! i love your great work man!! ;)

most energysaving and quick rom i´ve seen out there..

one feature i´d like to kindly ask, for a future release, regarding this post: http://android.modaco.com/content/zte-blad...acy-extensions/

please enable ipv6-privacy-extensions

another thing that would be absolutely great to be included in the kernel is TaintDroid, but as far as i know it´s only available for android 2.1 now..

it would be so nice to have a more security/privacy weighted froyo!

combined with the speed of your rom -- unbeatable!!

all the best! and keep up the good work!!

Share this post


Link to post
Share on other sites

Well, no good for me. Wiped all data and cache, installed 7a over 6 and after reboot it stuck at the green android logo with no progress. My device is OLED San Francisco. Any ideas?

Share this post


Link to post
Share on other sites
Well it'll be r7a ;)

I'm uploading it now. Spent some time looking at the wifi issue and rebuilt the kernel again with governor fixes. Kernel should now be built as a release kernel and not debug which may improve performance.

r7a does not even seem to boot for me on a TFT model. r7 booted without any problem.

Edited by compi.hu

Share this post


Link to post
Share on other sites
Same here. Having flashed to 7a screen doesn't get beyond green android. :-(

me too sticks on green android screen

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using this site, you agree to our Terms of Use.