Jump to content
Sign in to follow this  

Why can't I connect to my Wi-Fi Tether?

Recommended Posts

Does anyone know why this is? I understand many of you have managed it, but I'm struggling.

I've tried the stock Wifi Tether App, and the Vega can see the hotspot but will not connect. I have also tried Barancle, but the Vega doesn't even see this one!?

Help please!

Share this post

Link to post
Share on other sites

Works fine here with my Nexus One using the stock tethering from Froyo. Perhaps you could post a youtube video showing you setting up the Hero and the Vega?

Share this post

Link to post
Share on other sites

I had the same problem. The Nexus and Desire present the WiFi hotspot in infrastructure mode but the Hero only presents in Ad-Hoc mode and Android devices will not tether to an Ad-Hoc spot.

To get my folio and Galaxy Tab working to my hero I had to modify the WPA_supplicant.conf file.

I got all the info from the GTab thread on xda and I also used a scripting app to 'toggle' between Ad-hoc and infrastructure - i will look for the info and post links.

Edited by Bisto321

Share this post

Link to post
Share on other sites
Perhaps it would be easier to change the Vega to allow it to connect to adhoc wifi networks, rather than changing the hero?

Yes, the phone is left alone, it is the tablet that needs to be modified to allow connections to an adhoc site.

Sites that I used for the folio (same tegra2 platform as vega and Viewsonic Gpad) are shown below.

The most important thing to do before you do any modifications of the wpa_supplicant files is to make a copy (on the device and copy one off onto the SD card too). This will help if you have any errors and need to restore stuff!

your wpa_supplicant.conf file will look something like this once you have edited it using the instructions from the XDA thread.

The location of wpa_supplicant.conf is usually in data/misc/wifi/wpa_supplicant.conf - think this is where it was on folio I used root explorer for moving, copying and editing.



ssid="MightyROM" <-------- this is your ssid for your hotspot




auth_alg=OPEN SHARED

wep_key0=1234567890 <-------- this is your wep key



this is the thread i followed -> http://forum.xda-developers.com/showthread...532#post9079532

each time you move back to an infrastructure router (at home or work) it will overwrite the wpa_supplicant.conf file and you will lose adhoc mode again, which is a pain.

So using this second thread I managed to get the little script tool that this chap uses to swap between the 'adhoc' and 'infrastructure' wpa_supplicant files (use the same names as his and then his script will work without modification) and you can then easily 'jump' between the two. One of the Dev's may get round to modifying the wpa_supplicant file (not the wpa_supplicant.conf file, this is just a text file) and you will then not have to worry.


It is not too hard to do just have a good read through each post and ask questions if you want more info - I am sure others have done this for the Advent and they may have more relevant info. This should work but it has not been tried by me on the Advent

Obviously you will need to be rooted for all of the above.

Edited by Bisto321

Share this post

Link to post
Share on other sites

I have been messing with this all evening and I can't get my G2 (Hero) with VillainROM12 (Android 2.1) to tether using either Wireless Tether or Barnacle. I get as far as "Obtaining IP address" on the Vega but then nothing.

I've followed all instructions posted here and on XDA. Any other ideas?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.