Jump to content
PaulOBrien

[OLED+TFT] 09/Feb r12: MoDaCo Custom Froyo ROM download + Online Kitchen

Recommended Posts

Excellent work Paul. Thank You.

Will be flashing r10 very shortly ;)

Edited by asim18

Share this post


Link to post
Share on other sites

Nice one Paul!!! The only quirk in the Kitchen baking sink.... is I unselected TouchPal, unselected Menu button to unlock the screen - it still bundled 'em in... can you have a quick look into that and confirm..???

Fair play ;) the best all rounder ROM .... :D

Oh and disable USB HID debugging events as was mentioned in previous post :)

BTW USB tethering does not work... can anyone confirm this?

Edited by t0mm13b

Share this post


Link to post
Share on other sites

Paul, did you get a chance to look at the issue with the SD card "download" folder being wiped on reboot? I'm checked with r9 earlier and it was still happening for me.

Cheers.

Share this post


Link to post
Share on other sites
Paul, did you get a chance to look at the issue with the SD card "download" folder being wiped on reboot? I'm checked with r9 earlier and it was still happening for me.

Cheers.

I did, and it's not at all obvious where it's doing it unfortunately! I will keeping looking tho.

No new features for r11, just bugfixes I think and stablising the ROM as it is now.

P

Share this post


Link to post
Share on other sites
No new features for r11, just bugfixes I think and stablising the ROM as it is now.

P

How likely is it then that the sync issues are to do with the default dialer? It might be worth having a dialer choice in the kitchen. Yes, I know, its an obsession of mine, but I really hate the ZTE dialer, and from what I've seen, any ROMs that use the stock one seem to sync perfectly. Dont know if thats an actual link or not, but it's an observation.

Edited by jtc42

Share this post


Link to post
Share on other sites
I did, and it's not at all obvious where it's doing it unfortunately! I will keeping looking tho.

No new features for r11, just bugfixes I think and stablising the ROM as it is now.

P

Updated to r10 now and still no Calculator even though I choose it in the kitchen and handcent still craches when I open it enter a thread and the exits the thread I get a FC. Any chance of getting that fixed to r11?

Share this post


Link to post
Share on other sites
After playing around with it a bit more I have only found a few issues but I'm just gonna consolidate them into 1 post.

-NO contact sync works except Google. Facebook, Twitter and Last.FM all sync but information is not displayed on contacts.

-Stock dialer cannot be accessed or set as default as far as I can tell. May link to the point above (as sync is working on FLB with the stock dialer).

-Multitouch not working on keyboard, I've tried 3rd party versions and none are working with multitouch (was working in FLB)

-Has those USB HID debugging events

-USB Tethering not working

Contact sync for third party apps depends on ContactsProvider.apk.

The stock dialer is disabled. It could be enabled by swapping Contacts.apk but this will most likely prevent the ZTE dialer from working.

Multitouch needs android.hardware.touchscreen.multitouch.xml editing to add

<feature name="android.hardware.touchscreen.multitouch.distinct" />

between the permissions tags.

USB tethering is controlled by Settings.apk. Is it not showing up or can you just not enable it?

Share this post


Link to post
Share on other sites
Contact sync for third party apps depends on ContactsProvider.apk.

The stock dialer is disabled. It could be enabled by swapping Contacts.apk but this will most likely prevent the ZTE dialer from working.

Multitouch needs android.hardware.touchscreen.multitouch.xml editing to add

<feature name="android.hardware.touchscreen.multitouch.distinct" />

between the permissions tags.

USB tethering is controlled by Settings.apk. Is it not showing up or can you just not enable it?

Tethering is there in Wireless & Network settings but it b0rks on the host side, i.e. Windows side and unrecognizes it.... which implies a missing driver or similar for the Windows side.... ?

There was a mention about appearance settings in the kitchen for themes, but where?

Edited by t0mm13b

Share this post


Link to post
Share on other sites
Contact sync for third party apps depends on ContactsProvider.apk.

Is there any reason why the contactsprovider from your R6 wouldnt work mashed onto this ROM? Sync worked fine with yours.

The stock dialer is disabled. It could be enabled by swapping Contacts.apk but this will most likely prevent the ZTE dialer from working.

Again, same question as above, but I guess it would disable the shortcut on the default launcher?

Multitouch needs android.hardware.touchscreen.multitouch.xml editing to add

<feature name="android.hardware.touchscreen.multitouch.distinct" />

between the permissions tags.

Is there any way to edit this without reflashing the whole ROM?

USB tethering is controlled by Settings.apk. Is it not showing up or can you just not enable it?

Ignore this one, was a driver failure on my part, works fine now ;)

Thanks for the response.

Share this post


Link to post
Share on other sites
Is there any reason why the contactsprovider from your R6 wouldnt work mashed onto this ROM? Sync worked fine with yours.

Again, same question as above, but I guess it would disable the shortcut on the default launcher?

Is there any way to edit this without reflashing the whole ROM?

Ignore this one, was a driver failure on my part, works fine now ;)

Thanks for the response.

@jtc42: where did you get the driver for the usb tethering or am I missing something? :)

Share this post


Link to post
Share on other sites
Updated to r10 now and still no Calculator even though I choose it in the kitchen and handcent still craches when I open it enter a thread and the exits the thread I get a FC. Any chance of getting that fixed to r11?

Baked another r10 and dident remove as much stuff this time and now I got the Calculator. Before I removed car home, maps, and touchpal but now when I dident I got the calculator, but still the force close on handcent. Used titanium backup to restore handcent from r4 that I upgraded from to r8.

Share this post


Link to post
Share on other sites
@jtc42: where did you get the driver for the usb tethering or am I missing something? ;)

I dont know, I just plugged it into a different USB port and it took AGES to scan but installed and now works O.o Tres confused.

Share this post


Link to post
Share on other sites

The Contacts.apk and ContactsProvider.apk will need signing for this rom. Paul would probably have to do it. The xml file for multitouch is inside /system/etc/permissions and you can edit it with any text editor and ADB push it to the phone, use root explorer or edit the file in the rom and flash again.

Share this post


Link to post
Share on other sites
The Contacts.apk and ContactsProvider.apk will need signing for this rom. Paul would probably have to do it. The xml file for multitouch is inside /system/etc/permissions and you can edit it with any text editor and ADB push it to the phone, use root explorer or edit the file in the rom and flash again.

Aaah bugger okay. Well, looking out for a fix soon hopefully ;) I can live without the multitouch keyboard.... To be honest I can live without contact syncing, but I got used to it in your FLB so it's weird not having it haha. Was very convenient.

Slightly off topic though: Sad to see youve moved on from your FLB ROM, but hopefully you'll be able to bring a lot to the MCR, it'd be great to see you working closer with Paul on this one. It was really nice having a lot of the stock stuff on yours, so fingers crossed you can work with Paul to get that kinda feel back to MCR (yes, I'm on about that damn stock dialer again, that and working sync) :)

Share this post


Link to post
Share on other sites
I dont know, I just plugged it into a different USB port and it took AGES to scan but installed and now works O.o Tres confused.

Oh! am on Win XP home, and checked USB Tethering on the Blade, Win XP seems to be taking ages then it fails.... FibbleSan reported it worked fine under Win 7, that's cool, does XP need a driver for that to work properly?

Share this post


Link to post
Share on other sites
Oh! am on Win XP home, and checked USB Tethering on the Blade, Win XP seems to be taking ages then it fails.... FibbleSan reported it worked fine under Win 7, that's cool, does XP need a driver for that to work properly?

Aaah should have said I'm on Win7x64. For what it's worth, I cannot get ANY device of mine to tether properly on XP, so if you manage, hats off. Unfortunately I can't really do much else to help, sorry ;)

Share this post


Link to post
Share on other sites
Aaah should have said I'm on Win7x64. For what it's worth, I cannot get ANY device of mine to tether properly on XP, so if you manage, hats off. Unfortunately I can't really do much else to help, sorry :D

Ahhh.... not yer fault jtc42.... nowt I can do about that.... meh!!! :)

ah well... I really.... really tried... ;)

Will investigate this XP thingy, icon showing up as if preparing to install some driver... taking ages.... am quick to write this off as EPIC FAIL!!! ;)

Share this post


Link to post
Share on other sites
I confirm for Contacts bug in r10.

I can't synchronize and also i get "android.proccess.acore." error when accessing Contacts.

Try wiping the cache for this application. Was discussed for R9 a few pages back.

Cheers, Nick

Edited by Nick Rhodes

Share this post


Link to post
Share on other sites

Wonder would this be the magic bullet for this usb tethering on XP Home?

On the last page - there's an updated driver suite ... ???

Anyone tried it?

Share this post


Link to post
Share on other sites
The xml file for multitouch is inside /system/etc/permissions and you can edit it with any text editor and ADB push it to the phone, use root explorer or edit the file in the rom and flash again.

Thanks for that, edited on device in Root Explorer, Multitouch working in keyboard now ;)

Share this post


Link to post
Share on other sites
Wonder would this be the magic bullet for this usb tethering on XP Home?

On the last page - there's an updated driver suite ... ???

Anyone tried it?

Wow!!!!!!!!

A Showstopper bug on ROM10

This is under Windows XP Home....

USB Tethering, under Wireless & Network Settings

Check it to enable tethering... Win XP Home starts searching for the drivers (for ever may I add, takes ages)

After say, half an hour later, uncheck the USB Tethering on the handset

the handset freezes and reboots!!!!

BUG!!!!!

Share this post


Link to post
Share on other sites
I did, and it's not at all obvious where it's doing it unfortunately! I will keeping looking tho.

No new features for r11, just bugfixes I think and stablising the ROM as it is now.

P

I get same problem.Had to download the rom 3 times. :-P

Share this post


Link to post
Share on other sites
Try wiping the cache for this application. Was discussed for R9 a few pages back.

Cheers, Nick

Thanks Nick, but no luck with cache wiping :/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.