Jump to content
fonix232

[GUIDE] Ubuntu and the Blade

Recommended Posts

So, I am struggling with a Maverick install, bcos Win7 refuses to boot up (and I am lazy to reinstall it). That's why I began to play with Ubuntu and ADB.

1. Install Android SDK

Install the SDK as defined in the CyanogenMod Wiki

As a sidenote: I used the path

/home/[username]/android-sdk-linux
as it is easier to remember. To automatically add the tools to the terminal, add this line to your
/home/[username]/.bashrc
file:
export PATH=${PATH}:/home/[username]/android-sdk-linux/platform-tools/:/home/[username]/android-sdk-linux/tools/
Replace [username] with your Ubuntu username! After done, run the command "android" in a terminal. Better to do it as sudo tho! It will open a window, install some platforms and update the tools! 2. Add UDEV rules Open a terminal, and type this:
sudo gedit /lib/udev/rules.d/11-android.rules
When prompted, enter your password. A new Text editor will open, just paste these lines and Save: (DO NOT FORGET TO REPLACE [username] WITH YOUR USERNAME!!!)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1353", MODE="0666", OWNER="[username]" #Normal Blade

SUBSYSTEMS=="usb", ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1351", MODE="0666", OWNER="[username]" #Debug Blade

SUBSYSTEMS=="usb", ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1354", MODE="0666", OWNER="[username]" #Recovery Blade

SUBSYSTEMS=="usb", ATTRS{idVendor}=="18d1", ATTRS{idProduct}=="d00d", MODE="0666", OWNER="[username]" #Fastboot Blade

/* Sidenote: Google has some good humour: the Fastboot Product ID says dood (dude) in G33K lang. It also proves ZTE lacks fantasy: their Vendor ID is just a [google_vendor_id_numerics]+1 */

Restart your PC and you're done :D

(Actually restarting UDEV would be probably enough, but don't trust everything what they say)

Edited by fonix232
  • Upvote 4

Share this post


Link to post
Share on other sites
Guest
Open a terminal, and type this:

sudo gedit /lib/udev/rules.d/11-android.rules

Thanks for the post! Note that /etc/udev/rules.d/ is the recommended place for local udev rules, not /lib/udev/rules.d.

Share this post


Link to post
Share on other sites
Thanks for the post! Note that /etc/udev/rules.d/ is the recommended place for local udev rules, not /lib/udev/rules.d.

Well, I found that the second path is better, loads faster, and somewhy the /etc/ path isn't working properly :S

Share this post


Link to post
Share on other sites
Guest
installed as instructed

"No command 'adb' found" error

any ideas

You got the additional $PATH settings wrong.

Share this post


Link to post
Share on other sites
Guest

fonix232,

if it's just for adb (and fastboot), there's no need to install the whole Android SDK. See the hint in bold print on the CM wiki page you linked to. Go to their adb article, download the archive, unpack it to ~/bin (and maybe adjust $PATH accordingly) and you're all set. This should be sufficient for most people not wanting to develop applications für Android.

Furthermore, i second andred in that custom udev rules should be placed in /etc/udev/rules.d/. This will also avoid them being affected by package updates and the like. Also, setting OWNER to your username is not necessary, since you already specify read/write access by setting MODE="0666". Of course, restarting udev is enough, no need to reboot the entire system. After all, we're talking about real operating systems here, not Windows. ;) So, just execute sudo restart udev on an Upstart enabled system such as newer Ubuntu releases and sudo /etc/init.d/udev restart on other flavours.

Edited by Guest

Share this post


Link to post
Share on other sites
fonix232,

if it's just for adb (and fastboot), there's no need to install the whole Android SDK. See the hint in bold print on the CM wiki page you linked to. Go to their adb article, download the archive, unpack it to ~/bin (and maybe adjust $PATH accordingly) and you're all set. This should be sufficient for most people not wanting to develop applications für Android.

I need some other parts from the SDK too, that's why I download (and also, if there's ANY update, the SDK manager will do all what's necessary. No need to download-overwrite, etc).

Furthermore, i second andred in that custom udev rules should be placed in /etc/udev/rules.d/. This will also avoid them being affected by package updates and the like. Also, setting OWNER to your username is not necessary, since you already specify read/write access by setting MODE="0666". Of course, restarting udev is enough, no need to reboot the entire system. After all, we're talking about real operating systems here, not Windows. ;) So, just execute sudo restart udev on an Upstart enabled system such as newer Ubuntu releases and sudo /etc/init.d/udev restart on other flavours.

1. For me, on PC the /etc/ path never worked properly (10.10 Meerkat). On my tablet, both worked.

2. setting OWNER is to make ADB launchable properly. Worked on 10.04 (first distro what needed setting OWNER, anything before that was fine, ADB never asked for sudo), so I added to 10.10 too. Not a bad thing to have there I say.

3. I like restarting the whole system. Sometimes (even if it isn't Windows) some info may stuck, and such. I won't risk it, restart the whole damn stuff, and thanks to the usual Ubuntu boot time, in 30secs my system is up and running. And this is of course to be sure ;)

Share this post


Link to post
Share on other sites

you already have adb in fastboot.zip if this all you need

no no no custom udev rules should be placed in /etc/udev/rules.d/

we are not in "windows i put my files everywhere no matter" ;)

apart this an excellent tutorial ;)

Share this post


Link to post
Share on other sites
Guest

fonix232, don't get me wrong. I very much appreciate you posting this guide!

I need some other parts from the SDK too, that's why I download (and also, if there's ANY update, the SDK manager will do all what's necessary. No need to download-overwrite, etc).

I thought so. Just meant to show people only wanting adb an easier way.

1. For me, on PC the /etc/ path never worked properly (10.10 Meerkat). On my tablet, both worked.

On my Lucid system at home, rules in /etc/udev/rules.d work pefectly. On Maverick at work, "normal" debug mode worked without any additional rules, Didn't test the other modes though. Stuffing your custom rules in /lib will eventually cause problems in case of updates or whatever. That sort of conventions is usually not made up just for the fun of it.

2. setting OWNER is to make ADB launchable properly. Worked on 10.04 (first distro what needed setting OWNER, anything before that was fine, ADB never asked for sudo), so I added to 10.10 too. Not a bad thing to have there I say.

Sounds plausible, but I didn't have any problems with adb or its daemon on my Maverick machine with no additional rules and, thus, no OWNER setting. Your solution will cause problems on multi-user systems where more than one user wants to use adb on the Blade, which should be a rather rare condition. ;)

3. I like restarting the whole system. Sometimes (even if it isn't Windows) some info may stuck, and such. I won't risk it, restart the whole damn stuff, and thanks to the usual Ubuntu boot time, in 30secs my system is up and running. And this is of course to be sure

The 30s (max!) boot time is not why I hate rebooting. It's the 2-5 minutes of freezing all VMs, closing applications and such, and, even more, setting it all up again after the reboot. Plus, I just hate doing stuff that I can avoid. ;)

you already have adb in fastboot.zip if this all you need

That's what I referred to by pointing to the adb article on the CM wiki.

Edited by Guest

Share this post


Link to post
Share on other sites

Hey, for some reason I get this error in the terminal:

[email protected]:~$ adb devices

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

List of devices attached

???????????? no permissions

Share this post


Link to post
Share on other sites
Hey, for some reason I get this error in the terminal:

[email protected]:~$ adb devices

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

List of devices attached

???????????? no permissions

you haven't add the udev rules

so to wake up the deamon at first adb you need to type

sudo ./adb start-server

Share this post


Link to post
Share on other sites

another way of setting up PATH

export PATH="/home/[username]/android-sdk-linux_x86/tools/:$PATH"

export PATH="/home/[username]/android-sdk-linux_x86/platform-tools/:$PATH"

replace [username] with your username, I do this instead of editing .bashrc as I have no PATH line in .bashrc

Share this post


Link to post
Share on other sites

You need to make this much clearer, as it is ambiguous. For example, does "[username]" mean that we enclose our username in square brackets, or is that the OP's own descriptive syntax for this guide?

Little details make all the difference!

PS: For the WHITE UK Orange San Fran, this is my "11-android.rules" file, which has a different debug ID:

SUBSYSTEMS=="usb", ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1353", MODE="0666", OWNER="matt" #Normal Blade (Default setting from Modaco.com)

SUBSYSTEMS=="usb", ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1350", MODE="0666", OWNER="matt" #Debug Blade (was 1351 but changed to 1350 for white SF)

SUBSYSTEMS=="usb", ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="1354", MODE="0666", OWNER="matt" #Recovery Blade

SUBSYSTEMS=="usb", ATTRS{idVendor}=="18d1", ATTRS{idProduct}=="d00d", MODE="0666", OWNER="matt" #Fastboot Blade

Edited by glossywhite

Share this post


Link to post
Share on other sites

you should know that username = your home directory

it's a linux discussion here

people know what they are doing don't need a lot of usefulness details

if you use windows just follow another post for windows users

cheers

Alice

Share this post


Link to post
Share on other sites
you should know that username = your home directory

it's a linux discussion here

people know what they are doing don't need a lot of usefulness details

if you use windows just follow another post for windows users

cheers

Alice

Yes dear, okay dear :mellow:

Actually '~/' == home. I was merely stating that the usage of "[]" could be made less ambiguous, for the uninformed. No need to be such a reactionist, really. Assumption, as they say, is the mother of all f**k-ups - never assume the whole member base knows what we/you do, ok? If everyone "knows what they are doing", then why is there a tutorial here?

Edited by Lew247

Share this post


Link to post
Share on other sites

Just a little note: it all works automatically on Fedora, it's plug n play, no udev rule editing needed, just plug a blade into a Fedora pc & it works. I can't work out how Ubuntu got to be so popular.

Share this post


Link to post
Share on other sites
Just a little note: it all works automatically on Fedora, it's plug n play, no udev rule editing needed, just plug a blade into a Fedora pc & it works. I can't work out how Ubuntu got to be so popular.

I'm struggling with 10.10 - tried 11.04, Unity is pants. Before I go back to 9.04, I might give Fedora a shot.

F14 or F15, 32b or 64b, for reference...?

Edited by LanceH

Share this post


Link to post
Share on other sites
I'm struggling with 10.10 - tried 11.04, Unity is pants. Before I go back to 9.04, I might give Fedora a shot.

F14 or F15, 32b or 64b, for reference...?

Fedora 14 64bit (Gnome2), F15 is due out in a month (Gnome3).

Not saying you'll never need to edit any udev rules, I had to edit them on an older version for a ZTE 3G dongle, but the san francisco/blade works out of the box.

Fedora is a great distro, I've been using it for years.

Share this post


Link to post
Share on other sites
I'm struggling with 10.10 - tried 11.04, Unity is pants. Before I go back to 9.04, I might give Fedora a shot.

F14 or F15, 32b or 64b, for reference...?

Unity is great IMHO, but that is only MHO. I have it working fine in 11.04 amd-64 - maybe PEBKAC? :mellow:

Share this post


Link to post
Share on other sites
Fedora 14 64bit (Gnome2), F15 is due out in a month (Gnome3).

Not saying you'll never need to edit any udev rules, I had to edit them on an older version for a ZTE 3G dongle, but the san francisco/blade works out of the box.

Fedora is a great distro, I've been using it for years.

Will d/l and try. Cheers... my boot image splitting has ceased for a while now... Ubuntu and the A SDK seem to be sorry bedfellows. 9.04 is OK.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.