Jump to content
gauravv

[UPDATED]Performance Tweaks etc on Android!.

Recommended Posts

14 times no wake up since yesterday evening :D B) ;)

I set Advanced Task Killer as yours but when someone call me (not always) or after sleep time (not defined) it remains in sleep and I need to restart :D :D :(

I cannot use it so, no too much reliable! :(

after i had to do a clean install. i had that to. until i did the updates ones more. and the last fix eric pm-ed me.

maybe you can ask eric that one to. don't know if still has it.

and try this: when android starts first with taskkiller you kill almost everything.

then you put him asleep and wakeup again and do this a couple of times all in a very short time.

and do not let him fall asleep. you have to put him to sleep

greets tjeerdos

Share this post


Link to post
Share on other sites

I noticed following:

When you put your phone to sleep, check if it is by touching the screen. Sometimes screen comes back again, then press power/end-call again to put it to sleep again. And recheck by touching the screen.

Since Rev40: When phone is in sleep and you put the phone in your pocket, you might accidently press the end-call key. When so, and the home key is pressed also accidently(which could happen if the phone is in your trouser pocket ffor example) the phone is waked up and unlocked.

Resulting for me in calling my contacts when phone is in my trouser pocket.

It could be that our phone returns to sleep by itself. It is known that SOD happens when phone is going into sleep mode by itself. We always have to put it to sleep by pressing the power / end-call key for preventing from SOD.

I spoke to Elbee about this. This home-key behaviour is also reported on I8000. For me this confirms that the keyboard hardware change in REV40 for B7610 means that it equals better to I8000. I think it is okay. I don't know if devs are working on "wake up problem on homekey" on this moment

For preventing the phone to wake up by itself and make calls accidently when in my trouser pocket I set an unlock pattern in settings. Phone now doesn't make calls accidently anymore.

I don't know if you guys tried this already, if you don't maybe you could?

Attached the keyboard-update I sent to Tjeerdos. It only contains a modified qwerty.kl file for left, right, up, down and "?" button on keyboard. To be shure that it works ok, please reboot your phone after updating.

grtz Erik

o2b2update.tar.gz

Edited by erikcas

Share this post


Link to post
Share on other sites

I also have a request for you guys to think with me.

I am trying to find GPIO for earphones but didn't succeed yet.

Maybe you have a suggestion for me, in which cases the phone (in WinMo!) is triggered to send its signal to the earphones plug.

Things I tried so far:

- Just plugin the earphones and choose earphones. No success...

- Play music, plugin the earphones and choose earphones. No success..

Will try later today:

- Play movie, plugin TV cable and choose TV out

- Make call, plugin headset and choose headset.

Maybe you have suggestions for me to try?

All suggestions are welcome!

Thanks in advance!

grtz Erik

Share this post


Link to post
Share on other sites
I also have a request for you guys to think with me.

I am trying to find GPIO for earphones but didn't succeed yet.

Maybe you have a suggestion for me, in which cases the phone (in WinMo!) is triggered to send its signal to the earphones plug.

Things I tried so far:

- Just plugin the earphones and choose earphones. No success...

- Play music, plugin the earphones and choose earphones. No success..

Will try later today:

- Play movie, plugin TV cable and choose TV out

- Make call, plugin headset and choose headset.

Maybe you have suggestions for me to try?

All suggestions are welcome!

Thanks in advance!

grtz Erik

hi,

just tried it. indeed no working earphone. but i used to have a working earphone.

so is it to easy thinking from me to say maybe you can compare this update to an older update with a working earphone??

greets tjeerdos

Share this post


Link to post
Share on other sites

I confirm that Rev29 was much more stable regarding SODs.

In latest rev. i'm getting SOD in manual locking too (10 times maybe).When in charger, it hasnt happened more than a few times.

Strange but thats my feedback.

I appreciate the work all the ppl do in here. My Pro got much more interesting now.

Share this post


Link to post
Share on other sites
I confirm that Rev29 was much more stable regarding SODs.

In latest rev. i'm getting SOD in manual locking too (10 times maybe).When in charger, it hasnt happened more than a few times.

Strange but thats my feedback.

I appreciate the work all the ppl do in here. My Pro got much more interesting now.

The Rev29 was much more stable than Rev40, and the Rev40 made the phone can not wake up

bye the way, the keyboard backlight still turn on/off with the screen,

Share this post


Link to post
Share on other sites
The Rev29 was much more stable than Rev40, and the Rev40 made the phone can not wake up

bye the way, the keyboard backlight still turn on/off with the screen,

Did anyone try to set an unlock pattern and change behaviour of the homekey?

For some reason, when phone is in sleep, it is woken up by accident when phone is in your pocket when there is any pressure on end-call / power key and pressure on homekey. (Just try it. Put phone in sleep. Then press endcall/power and when screen lights up, press home key. You will notice it will wakeup without you make de usual slide on the screen).

By applying these settings, an unlock pattern is needed to wake up phone completely. By preventing this, it might be prevented from SOD. This works for me.

Adjustments: You can do that in settings -> location and security -> set unlock pattern and after setting pattern, set to require pattern.

Also set in <homekey> ->preferences -> behaviour settings, I set "Home key action" to "Do nothing".

After booting, I kill all tasks with task-killer free app. (which I set to kill all my unwanted apps on screenoff.)

Immediatelyafter that, I put it to sleep 3 or 4 times with power/end call key in short time. After that it wakes up perfectly after half an hour or longer. And every time after that, when stop using phone I put it to sleep with this key (and check if it is by touching screen).

grtz

Erik

Edited by erikcas

Share this post


Link to post
Share on other sites

hey guys ! :D in this time new update comes out about this project on O2 ... can you update this guide with new info please ? B)

Share this post


Link to post
Share on other sites
thanks. downloading it now. trying it later this evening.

greets tjeerdos

great work! earphones works again!

only thing missing is the ~ . me personal don't use ~ so won't miss it for real

thanks

Share this post


Link to post
Share on other sites
great work! earphones works again!

only thing missing is the ~ . me personal don't use ~ so won't miss it for real

thanks

For everyone who can't live without ~

[alt] [sym] n

And for our German friends (maybe Mosci is reading?): Try [alt] [sym] s (alltough two times "s" is quicker, you can outsmart your friends with it.)

Last but not least a suggestion for friends from France: [alt] [sym] c for c cedille

Play and find out!

:D

Grtz

Erik

Share this post


Link to post
Share on other sites

I have been using android for couple of days at few hours intervals, the battery drain is a killer. I lost 30% of battery for 3 hours of usage. most of the time, the phone should have been in standby mode but i don't think it goes into. Anyone has any tips on that?

Share this post


Link to post
Share on other sites

i have been using rev 40 without any problems , ocassionally sod once or twice, can anyone give details of latest rev 46 details?

Share this post


Link to post
Share on other sites
i have been using rev 40 without any problems , ocassionally sod once or twice, can anyone give details of latest rev 46 details?

i can only say that it works good. also the earphone works again.

greets tjeerdos

Share this post


Link to post
Share on other sites
i have been using rev 46. but i can not play angy bird. i have install flash 10.1

Were you able to play in previous update?

Share this post


Link to post
Share on other sites
Did anyone try to set an unlock pattern and change behaviour of the homekey?

For some reason, when phone is in sleep, it is woken up by accident when phone is in your pocket when there is any pressure on end-call / power key and pressure on homekey. (Just try it. Put phone in sleep. Then press endcall/power and when screen lights up, press home key. You will notice it will wakeup without you make de usual slide on the screen).

By applying these settings, an unlock pattern is needed to wake up phone completely. By preventing this, it might be prevented from SOD. This works for me.

Adjustments: You can do that in settings -> location and security -> set unlock pattern and after setting pattern, set to require pattern.

Also set in <homekey> ->preferences -> behaviour settings, I set "Home key action" to "Do nothing".

After booting, I kill all tasks with task-killer free app. (which I set to kill all my unwanted apps on screenoff.)

Immediatelyafter that, I put it to sleep 3 or 4 times with power/end call key in short time. After that it wakes up perfectly after half an hour or longer. And every time after that, when stop using phone I put it to sleep with this key (and check if it is by touching screen).

grtz

Erik

thank you Erikcas for your indications.

I used pattern in the past but it was not so fast and so it is a few time that I preferred to use just end-call / power key.

In every case now I am trying as your suggestion. In weekend I preferred to use WMO but this morning I read your post and so now I am trying again to test REV40 with pattern and for the moment all seems ok.

In every case:

- always when I start android and "advanced task killer" I force its and i repeat more times sleep/wake-up but the problem is that sometimes can happen I have not possibility to force sleep

- surely with test pattern the abnormal wakes-up not desired should be blocked and so SOD condition must be drastically reduced.

- I will try later the REV46 using pattern and if many SOD will be present again I will try with a clean installation to check if cleaning memory can creaste more stability.

@darthveda

You need to use some tool to have less consumption

- Advanced task killer to reduce sleep programs running during sleep (see erickas indication to have sleep killer situation)

- data on deman to stop 3G during sleep

I installed a 3G on/off icon just to activate faster the 3G connection only if I need it, and in this way I have longer battery level

Remember to switch off GPS during no use.

The bigger problem for the power consumption actually is the time with display ON because in the same time keybaord light is ON too!

So if you remove in sleep all the tools/conditions that could reduce battery level the only very dissipative situation will remain the power on display (during calling or touch screen uses or navigation).

Bye

Giorgio

NOTE: always a big difference between sleep with power supply or without. When you charge the wake up is really really fast

Edited by centodue

Share this post


Link to post
Share on other sites

SOD present in every case.

I don't know what can be the cause.

For example my work is in underground place and so no signal in sleep mode could cause some particular status that creates SOD

Calling or messages during sleep can create abnormal status and SOD.

It is sure that in charge there is not a complete sleep situation as in internal battery working.

Edited by centodue

Share this post


Link to post
Share on other sites

hey i am startet first 02 haret and made the partitions okay!

and when i will install on sd card. i waitand wait more than 10 minutes and he dont will load he hang on...

0052354] (do_exit+0x0/0X634)

[79.632869] r5:0000000 r4:0000000

WHY???

Share this post


Link to post
Share on other sites
hey i am startet first 02 haret and made the partitions okay!

and when i will install on sd card. i waitand wait more than 10 minutes and he dont will load he hang on...

0052354] (do_exit+0x0/0X634)

[79.632869] r5:0000000 r4:0000000

WHY???

Reinstall, use my tutorial for it :D

Share this post


Link to post
Share on other sites
Reinstall, use my tutorial for it :D

i had the same problem but fixed it by changing the a line in default.txt. But i installed it on my storage in ext3 partition.

I changed Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init" to this: or mmcblk0p2 if you have a ext3 partition

it has something to do with where you installed android

Ihave a problem as well. Ive fully installed android yesterday with the updates provided in ernstjans thread. All working until i push the camera button. Then it crashes. Also the other keys arent working. Did i use the wrons zimage?

Edited by Bokun23

Share this post


Link to post
Share on other sites

just a question

video playback from say youtube isn't working

is this still under construction ??

or is it a setup fault i made ??

android works great no SOD's any more I love it

keep up the good work.

greetz

Edited by Superwuppy

Share this post


Link to post
Share on other sites
just a question

video playback from say youtube isn't working

is this still under construction ??

or is it a setup fault i made ??

android works great no SOD's any more I love it

keep up the good work.

greetz

That's correct, Android does not support video yet.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.