Jump to content
PaulOBrien

Advent Vega kernel source code now available!

Recommended Posts

Scanno/the_corvus,

Been running 4.0.4 on vega since Saturday nearly everything working (no bluetooth, superuser denies superuser access to requests):-

Camera works with beta1 app.

Wifi working as before.

Accel sensor working.

Sound working.

Google apps loaded, gmail/youtube/play store working.

Voicesearch not working on beta1 now working.

Flash working but still stuttering sound.

Recovery wont work due to above superuser access issues for me but did you copy over "recovery and setrecovery" files from system/bin dir on beta1 as I think the Recovery Reboot apk needs these ?

Still working on resolving issues and need to recheck updates on git to see if I missed anything but nice to have my own compiled kernel + system image working pretty well on my first attempt at a full rom.

Thanks,

Copying the recovery, revovery2 and setrecovery did the trick. Booting into recovery is working now :-)

Share this post


Link to post
Share on other sites

This is sounding great, all these nice .new Roms to be released for the users to try out.. fantastic..I don't feel so bad now about the lack of time I've been putting in ;)

I still wouldnt have fixed 3g though given I have no dongle :(

Share this post


Link to post
Share on other sites

I'm trying to make recovery and bluetooth work... for recovery i compiled /bootable/recovery, but dont know if this is correct, because there is not binary for recovery by default. Anyway, with this binary i cant go to CWM anyway, so something i'm doing wrong.

I'm searching for some sources for a multiple chioce power menu (you know... restart, poweroff, recovery, etc...)

Corvus

Check out github/mrdeadlocked

For the reboot menu stuff, its all there...

Share this post


Link to post
Share on other sites

Eduardo,

Thanks for the update on kernel, like yourself my first thought was amending camera app for accel not touching sensor lib, hopefully scanno can update you on 3g as like Cass I don't have it.

Scanno,

Glad copying the files over fixed it for you, although you don't need recovery2 file.

Cass,

Yeah good to see different people trying to create roms, takes some pressure off yourself hopefully, direct link mentioned for power button menu is here

Also got my superuser problem fixed as I suspected permissions issues but recovery now also works for me.

Share this post


Link to post
Share on other sites

Hi Cass, Eduardo et al.

Great to see so many working on the improvement of the Vega and sister Tablets. Eagerly awaiting

the posting of a version for testing. Thanks to all for the effort you are putting into this. Just sorry I have no

coding experience nor even understand much of what is being mentioned here but am a very willing tester and user.

Again thanks.

Stransky

Share this post


Link to post
Share on other sites

Hi Cass, Eduardo et al.

Great to see so many working on the improvement of the Vega and sister Tablets. Eagerly awaiting

the posting of a version for testing. Thanks to all for the effort you are putting into this. Just sorry I have no

coding experience nor even understand much of what is being mentioned here but am a very willing tester and user.

Again thanks.

Stransky

I have to echo Stransky here - your time, effort, enthusiasm and dedication is greatly appreciated by users like us. I also have little coding experience, or would put myself up to help. Likewise, I am very willing to test out anything required.

Cheers

Yogimax

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi all,

I was trying to test 3G with my huawei dongle on my aosp build based on the config on our github, but failed.... My dongle did not get any power from the usb port.

Can anyone give me some feedback if there builds have usb host?

Share this post


Link to post
Share on other sites
They might... did you use shuttle tools to put usb in host mode?

Yep i used the shuttle tools. Did not have time yet to test and dive into logcat any further. Hope to have some time for that soon. Need to install a terminal prog for that first... because with a dongle i do not have an usb connection for adb...:rolleyes: Just thinking.... Perhaps i should modify vega_postboot.sh to put the usb port in host mode at boot time... Just to make shure it is not the shuttle tools that is the problem.

Edited by Scanno

Share this post


Link to post
Share on other sites

I got usb hostmode working by manually doing a echo 1 > /sys/usbbus/usb_host. The shuttle app needs a script or cannot acces the shell...

Anyway the usb dongle gets power, but it does not recognize a network, i cannot get an apn list, nor gives a list of available networks... [Edit] I see that some files are not put into the image (at least the files that eduardo mentioned that are needed). I put those files into place, but still not working. As soon as i have time i will reflash the boot image with the boot image eduardo made with enabled 3g support (thought i used that image). Logcat -b radio is telling me that there is no sim and radio is disabled.

Edited by Scanno

Share this post


Link to post
Share on other sites

Yep i used the shuttle tools. Did not have time yet to test and dive into logcat any further. Hope to have some time for that soon. Need to install a terminal prog for that first... because with a dongle i do not have an usb connection for adb...:rolleyes: Just thinking.... Perhaps i should modify vega_postboot.sh to put the usb port in host mode at boot time... Just to make shure it is not the shuttle tools that is the problem.

You can use adbwireless... in market... but you need wifi so you only can test logcat -b to see if it's detected but not launch a connection. Or use a powered usb hub.

Share this post


Link to post
Share on other sites

Arrrrr...

What am i doing wrong??? I am changing some stuff in the system.img and after repacking with mkyaffs2image android does not boot anymore.....

Share this post


Link to post
Share on other sites
Arrrrr...

What am i doing wrong??? I am changing some stuff in the system.img and after repacking with mkyaffs2image android does not boot anymore.....

Logcat should show what's up

Share this post


Link to post
Share on other sites

Hi all,

I was trying to test 3G with my huawei dongle on my aosp build based on the config on our github, but failed.... My dongle did not get any power from the usb port.

Can anyone give me some feedback if there builds have usb host?

I realize there is the challenge of getting 3G working because it is there and it should work, but I have resorted to a HUAWEI E560 3G wireless hotspot (about $100US), put the sim in it and you now have wireless access to the network via wpa wifi from your tablet and any other device you want to connect to the E560 up to 5. I also realise that it is one more little thing to carry around, but these devices and the faster more expensive models are flexible and reliable. Personally I would much prefer our wonderful developers to spend time getting ICS on the Vega rock solid than worrying about 3G when there are these type of alternatives.

Edited by gewin

Share this post


Link to post
Share on other sites

Logcat should show what's up

Yeah i know it does show up, but i do not understand why. I am using the same libs, the only difference is that i squashed them and made a new image. The squashfs get mounted so they are created correctly and the system.img is created correctly...

Share this post


Link to post
Share on other sites

Yeah i know it does show up, but i do not understand why. I am using the same libs, the only difference is that i squashed them and made a new image. The squashfs get mounted so they are created correctly and the system.img is created correctly...

I had this problem with honeycomb once.

Try this:

Flash bootable (original compiled system.img) android on yiur tablet.

Start adb

Example: lib.sfs:

shell rm -rf /system/lib.sfs

shell rm -rf /system/lib

shell mkdir /system/lib

push /home/peter/lib.sfs /system

Now you can see if it boots. If it doesn't then it's your squashed file.

If it does use cwm to produce the system.img

Kind Regards,

Areo

Share this post


Link to post
Share on other sites

I had this problem with honeycomb once.

Try this:

Flash bootable (original compiled system.img) android on yiur tablet.

Start adb

Example: lib.sfs:

shell rm -rf /system/lib.sfs

shell rm -rf /system/lib

shell mkdir /system/lib

push /home/peter/lib.sfs /system

Now you can see if it boots. If it doesn't then it's your squashed file.

If it does use cwm to produce the system.img

Kind Regards,

Areo

Yep i was thinking of trying that. Putting the squashfs files in one by one. Strange thing is that while booting i see that lib.sfs gets mounted and i can see the files that are inside the lib.sfs.

Something else... If you do a make otapackage, the build system will generate the image files and a flashable zip file. In the flashscript it formats the system partition with EXT4. Can we use EXT4 or should it be yaffs2.

Anyway there is still a lot to be done. Busybox is included in the build, but put into /systsm/bin and no links are created.

Did anyone compile the ar6002 driver with WoW enabled (what eduardo suggested that might solve the suspend wifi problems)?

Regards,

Scanno

Share this post


Link to post
Share on other sites

Anyway there is still a lot to be done. Busybox is included in the build, but put into /systsm/bin and no links are created.

Did anyone compile the ar6002 driver with WoW enabled (what eduardo suggested that might solve the suspend wifi problems)?

Regards,

Scanno

Ok, about busybox... i added it and dont create any link. I did it because i didnt want to broke any link that maybe can be needed... so if you want to use busybox, you only need to put it behind the command, by example toolbox doesnt have cp, so you can use busybox cp and all works ok. You can use too busybox to mount and you will not need to use -t because fs will be detected.

About ar6002 with wow... yes, i compiled it. You can use this one https://www.codeaurora.org/git/projects/qrd-gb-dsds-7225/repository/revisions/f6156a77044113680d038934b06bde333a1e69ea/show/system/wlan/atheros/AR6kSDK.2.2.1.151 but wifi suspend dont work if you select maintain it on when suspend. If you put it off at suspend it switch on correctly at resume.

About squashfs... why are you using it? because size?

Corvus

Share this post


Link to post
Share on other sites

Ok, about busybox... i added it and dont create any link. I did it because i didnt want to broke any link that maybe can be needed... so if you want to use busybox, you only need to put it behind the command, by example toolbox doesnt have cp, so you can use busybox cp and all works ok. You can use too busybox to mount and you will not need to use -t because fs will be detected.

About ar6002 with wow... yes, i compiled it. You can use this one https://www.codeauro...6kSDK.2.2.1.151 but wifi suspend dont work if you select maintain it on when suspend. If you put it off at suspend it switch on correctly at resume.

About squashfs... why are you using it? because size?

Corvus

I wanted to use squashfs to reduce size and be able to put the gapps on the system partition. But perhaps it can fit all on the system partition... i will check that...

If you put busybox in xbin and create the links there, it will not break the toolbox links created in /system/bin.

Share this post


Link to post
Share on other sites

Yeah i know it does show up, but i do not understand why. I am using the same libs, the only difference is that i squashed them and made a new image. The squashfs get mounted so they are created correctly and the system.img is created correctly...

post the logcat, and any other info like df you can .. also no other changes at all in app or system?

Did you nflash the whole rom or just system over a older install ? if so then maybe dalvik-cache is the problem, wipe it from recovery or just cd /data/dalvik-cache ; rm -rf *

some ideas but without seeing the logs i cant say for sure...

Share this post


Link to post
Share on other sites
I wanted to use squashfs to reduce size and be able to put the gapps on the system partition. But perhaps it can fit all on the system partition... i will check that...If you put busybox in xbin and create the links there, it will not break the toolbox links created in /system/bin.
It wont, this is why i went with squash ... alternative is to limit the system languages that are compiled in, there are some other things you can do to restrict the size of aosp compile that you may be able to get the size down enough to get gapps on without squash. i prefered to keep them all in to reach a wider audience, nothing stopping you compiling less ... its a simple addition to the boardconfig, i just forget what it is right now .. if i dig it out ill post it here ...

edit

Its not BoardConfig its AndroidProducts.. put this in an limit locales to what you need / want .. it will slim things down a bit ...

# This is the list of locales included in AOSP builds

PRODUCT_LOCALES := en_US en_GB fr_FR it_IT de_DE es_ES

Edited by Cass67

Share this post


Link to post
Share on other sites

What i do is use /data... much easy and you can move almost all apps you like there...

How?

Easy...

Compile android, then in the out folder (.../out/target/product/shuttle/) you will have /system and /data... put in /data/app all the apps you like and take from /system/app all that android dont need to boot (like calendar, email, videoeditor, etc.) and move them to /data/app. Then you will have a system.img with less that 158mb that is the limit of the partition.

Once you did it, exec "make snod" and a new system.img will be created and "make userdatatarball-nodeps" and you will get a userdata.img.

Put both of them in your nvflash folder and flash it.

Problems i had with this:

1) First boot dont allways load all correctly, like wallpaper... But rebooting all work ok

2) With gapps, depending where you put some apks it works, or not, or need to confg google account at first boot or doesnt work.... i'm working on this in my (few) spare time.

Remember, when you do make again all the compiled apps will be created again so you will need to move them or delete them

This way i dont need to take out any language or anything...

Edited by the_corvus

Share this post


Link to post
Share on other sites

Question, can't we repartition? I've seen on several devices diferent bootloaders altering the size of /system to give more to /data, and the inverse also.

(It can be done, it's not impossible, but is it available to us ?)

Share this post


Link to post
Share on other sites

Question, can't we repartition? I've seen on several devices diferent bootloaders altering the size of /system to give more to /data, and the inverse also.

(It can be done, it's not impossible, but is it available to us ?)

As far as I know repartitioning to expand the system partition and shrink the data partition increases the chance of errors due to 'bad blocks'...

Note: I'm not a dev, so devs: correct me if I'm wrong...

Edited by rvdgeer

Share this post


Link to post
Share on other sites

As far as I know repartitioning to expand the system partition and shrink the data partition increases the chance of errors due to 'bad blocks'...

Note: I'm not a dev, so devs: correct me if I'm wrong...

From my limited knowledge, bad blocks surge due to excessive writing to the blocks. /system is mounted readonly, so it's only written when flashing.

Having /system on the nand (or whatever it is) storage, and /data on a partition on the sdcard would be much more profitable, as we wouldn't be risking the internal storage that much.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.