Jump to content
flibblesan

FLB-Froyo G2 for ZTE Blade discussion & help thread

Recommended Posts

r11 is the last version of this ROM. Times have changed and we have a brand new official ROM to build upon. FLB was built upon the leaked Chinese ROM with it's many bugs and whilst I've tried my best to fix everything, a lot still remain. Since I don't have the time to rebuild FLB from scratch using the new Swedish ROM I'm calling it a day.

If you want to update to a rom that has all the features FLB provided without the bugs then I really recommend installing Swedish Spring. It's great!

Since the main FLB-Froyo thread is very large I've created this thread for r10 upwards. Please do not post about any bugs or issues with any earlier versions. Keep it on topic.

Main release thread will be locked and a new release thread created for r11.

Edited by flibblesan

Share this post


Link to post
Share on other sites

Current version: r11

Changelog

r11 - 21st March 2011

- Superuser and root fully fixed

- Custom kernel with BFS, BFQ, Smartass, overclock, CIFS, ext4, swap

- Google apps updated

- Notification pull-down widget modified

- ZTE Dialer version available

- Some system files updated to latest zte versions

r10b - 1st March 2011

- virtual operators shown on lockscreen again correctly

- Superuser and busybox permissions fixed

r10 - 28th February 2011

- Added lines to build.prop and replaced all WiFi files to try to resolve all issues.

- Split larger apps off into an extras zip to assist users with smaller system partitions.

- FM Radio app updated to 0.6 RDS

- Added NoFrills CPU Control application from XDA to provide easy overclocking.

- Relocated superuser binary to /system/bin/ and created symlink to xbin to try and resolve issues people have been experiencing.

- Superuser upgraded to latest version

Test Extras

Extra updates and apps that are in test to assist with various issues people are having

ZTE SmartDialer

This will allow people to go back to the SmartDialer which originally came on the phone. This will provide T9 dialing and the facility to input the ZTE service codes for proximity sensor calibration etc. Using the SmartDialer will prevent Facebook & Twitter contact sync from working.

SmartDialer addon (will replace Froyo dialer & contacts with ZTE versions) MD5 4DA998BC4BD2CE51220B8B77F4F97BCF

Froyo dialer addon (to roll back to the stock Froyo dialer & contacts without re-installing rom) MD5 E81281A2339D2A3B487A4BA8436760EC

You probably will need to clear the data for Contacts, ContactsProvider and Phone after installing any of the dialer packs. Do this through Settings > Applications.

Edited by flibblesan

Share this post


Link to post
Share on other sites

To get the ball rolling I'd like some feedback about the wifi in r10. Does it work OK for you? If you have problems could you post with your phone type (San Francisco, Blade etc) and state if it's OLED or TFT and 3mp or 5mp camera. If the wifi was flawless in any previous version of FLB or another ROM then please state this also along with the rom version.

Share this post


Link to post
Share on other sites

As mentioned at the end of the last FLB thread, root/superuser is not working, for example I can't use the reboot app.

Wifi so far seems solid, will need a bit of time to see if my loosing voice connection issue reoccurs (on wifi connection after sleep).

Cheers, Nick

Share this post


Link to post
Share on other sites

Great to see a new version for the best ROM for the Blade. Going to update tonight. Is a full wipe needed?

Share this post


Link to post
Share on other sites

hearing a lot of problems with root on the previous page?

Share this post


Link to post
Share on other sites

Thanks Nick. Have seen the root issue reported and found the problem so I'll upload the rom again.

Done. ROM re-uploaded and superuser working.

Edited by flibblesan

Share this post


Link to post
Share on other sites
Thanks Nick. Have seen the root issue reported and found the problem so I'll upload the rom again.

Done. ROM re-uploaded and superuser working.

Hey flib. Can you tell us if we just need to move the su binary to /system/xbin ? Just downloaded R10 and it would be easier to move some files rather than re-download.

Share this post


Link to post
Share on other sites
Hey flib. Can you tell us if we just need to move the su binary to /system/xbin ? Just downloaded R10 and it would be easier to move some files rather than re-download.

Easier to just use this fix: superuser.zip

Share this post


Link to post
Share on other sites
Easier to just use this fix: superuser.zip

Thanks for that :huh:

Can we remove the su binary from /system/bin/ then?

Edited by css771

Share this post


Link to post
Share on other sites

Can I do this update without a wipe? Currently on 9b. Thanks!

Edited by toge64

Share this post


Link to post
Share on other sites
Can I do this update without a wipe? Currently on 9b. Thanks!

Yep. All roms will work without wiping unless I make some serious system changes which I will always mention.

Share this post


Link to post
Share on other sites
The fix should delete that

Thanks but I just added the files to the zip manually. That's why I wanted to know.

Share this post


Link to post
Share on other sites
Thanks but I just added the files to the zip manually. That's why I wanted to know.

Ah I understand. Then remove /system/bin/su manually. You will also need to update the install script so it sets the correct permissions on xbin/su and not bin/su

Share this post


Link to post
Share on other sites
Ah I understand. Then remove /system/bin/su manually. You will also need to update the install script so it sets the correct permissions on xbin/su and not bin/su

Will do that. Thanks again :huh:

Share this post


Link to post
Share on other sites

I am about to change flb R9b to R10, my question is, i liked a lot the theme GenerationX-FLB.zip, do you think that will work on r10 too?

Just to be sure. Thanks for all your great job! :huh:

i put it on anyway.... its ok the theme. Working great. And for me before with r9b RDS in radio didnt work but no it's ok!

Edited by zaf_4

Share this post


Link to post
Share on other sites
I am about to change flb R9b to R10, my question is, i liked a lot the theme GenerationX-FLB.zip, do you think that will work on r10 too?

Just to be sure. Thanks for all your great job! :huh:

No reason why it shouldn't :)

I like that theme too so when I find my cable and update I'll know for sure :P

Share this post


Link to post
Share on other sites
To get the ball rolling I'd like some feedback about the wifi in r10. Does it work OK for you? If you have problems could you post with your phone type (San Francisco, Blade etc) and state if it's OLED or TFT and 3mp or 5mp camera. If the wifi was flawless in any previous version of FLB or another ROM then please state this also along with the rom version.

WIFI drops connection when asleep, seems to connect fine automatically on wake-up.

OSF OLED 3MP, FLB r10 w/o su fix :huh:

Share this post


Link to post
Share on other sites
WIFI drops connection when asleep, seems to connect fine automatically on wake-up.

OSF OLED 3MP, FLB r10 w/o su fix :huh:

yes it was a pleasant surprise... its the only one rom that i ve been used that wifi connects fine when wake up!

Well done... :)

Share this post


Link to post
Share on other sites

Just installed this over R9A NOT R9B and just get the nexus one boot anim over and over for about 30-40 minutes.

I have tried deleting Devlik cache and wiping data/restoring to factory and then installing this from fresh but STILL get the boot logo. I have also tried a nand restore and still the SAME thing.

Anybody able to help me on this one ?

Share this post


Link to post
Share on other sites
Just installed this over R9A NOT R9B and just get the nexus one boot anim over and over for about 30-40 minutes.

I have tried deleting Devlik cache and wiping data/restoring to factory and then installing this from fresh but STILL get the boot logo. I have also tried a nand restore and still the SAME thing.

Anybody able to help me on this one ?

Try formatting system partition in CW/advanced.

Share this post


Link to post
Share on other sites

sry but noob Q - currently runnning 9b & gb theme & circle mod, would like to try r10 to assist with wi-fi reconnects etc.

What's the best way to backup my current settings/preferences/apps before applying r10 and restoring them afterwards.

Or do I just apply r10 via Android root installer like I did first time (install zip from sdcard) ?

Also can I apply GBTheme & Cirlce mod afterwards OK ?

Thanks JonMaC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.