Jump to content
Test Zeppelin

[ROM][GEN2]CyanogenMod 7 (Android 2.3.7)

Recommended Posts

Hi qwerty_29, your text issue is strange, but there are so many variables it can be hard to track down what the issue is. Regarding your alarm app. If your handset was originally Gen 1, and the stock ROM is only available as a Gen 1 then you will have to revert. In my opinion that is a lot of mucking around for some yellow dots! Easier still would be to download the stock ROM to your PC then open the .zip file and find the alarm.apk that way. Then you can do what you like with the app.

Ciao for now. Anil.

Hehe, didnt know I could do that (such a noob!!)... Thanks for the tip! ;)

Yes, it really is hard to track down the problem, that's why I think I'm going for the full wipe... hopefully that solves it! ;)

Share this post


Link to post
Share on other sites

big improvement on the lastest nightlies (well im not actually using an official build, a self compile). seems alot more reponsive aswell as battery life improvement.

before, when i had a weekend (or more) away i would clockwork on wbaw's ginger stirfry rom as otherwise i would run outa battery if i was without a charge point (eg festivals/camping for surfing). just managed 3 days use with my usual moderate use. very impressed.

dunno what they changed? i didn't check the lastest commits or merges on the website i just did the whole repo sync process etc and got it compiling whilst having a shower hoping there would be sum changes to enjoy. feels good tho. anyone confirm this or do you think its a bit of the placebo effect.....

Share this post


Link to post
Share on other sites

big improvement on the lastest nightlies (well im not actually using an official build, a self compile). seems alot more reponsive aswell as battery life improvement.

before, when i had a weekend (or more) away i would clockwork on wbaw's ginger stirfry rom as otherwise i would run outa battery if i was without a charge point (eg festivals/camping for surfing). just managed 3 days use with my usual moderate use. very impressed.

dunno what they changed? i didn't check the lastest commits or merges on the website i just did the whole repo sync process etc and got it compiling whilst having a shower hoping there would be sum changes to enjoy. feels good tho. anyone confirm this or do you think its a bit of the placebo effect.....

Which nightly are you referring to? N145 or N146?

Flashing another ROM to get you through a weekend? Talk about dedication. :)

Anil.

Share this post


Link to post
Share on other sites

Which nightly are you referring to? N145 or N146?

not a nightly. a self compile. did it on tuesday evening so whatever nightly came out that day? battery is thus now on its thrid day and its at 23% atm. not bad huh.

Flashing another ROM to get you through a weekend? Talk about dedication. :)

not really. just dedication to have a non dead phone when i'm aaway from home. no battey life is usless to me. therefore stirfry is better than nothing :) but now hopefully i will have to do that no more. cm7 has come a hell of a long way since the original rc1 (not 2 weeks ago rc1, the one back around february/march-ish time? cant quite remeber which month it was....)

Share this post


Link to post
Share on other sites

Wifi is killing my battery. strange should we have phones without wifi or wot ? lol

145 with light use + phone calls about 20 min and last less than one day.

Edited by mon3em

Share this post


Link to post
Share on other sites

not really. just dedication to have a non dead phone when i'm aaway from home. no battey life is usless to me. therefore stirfry is better than nothing :) but now hopefully i will have to do that no more. cm7 has come a hell of a long way since the original rc1 (not 2 weeks ago rc1, the one back around february/march-ish time? cant quite remeber which month it was....)

Most people would just take another battery (£5 from eBay), or an external battery pack. You flash another ROM. Sounds pretty dedicated to me. :)

Anil.

Share this post


Link to post
Share on other sites

i'm not seeing battery life that poor - as long as i don't use wifi i can easily get 3 days from 50% on cm7.

is your leaked rom using 2.6.35 kernel as that will make a big difference to battery life.

I never got more than 2 days from 100% on cm7. I have the same usage and same setup on elitemovils r7 rom and yet the difference in battery life is huge.Ive only changed over recently but so far I dont see any reason to go back to cm7 at all. I also notice a small improvement in speed. On top of this I like the customised notifications he has added.

  • Upvote 1

Share this post


Link to post
Share on other sites

so the new 145/146s have the audio.lib and gps reboot fix already fixed?

I was using 133 and 134 and got lots of gallery and gps reboots and was loosing battery maybe due to the audio.lib hiss problem...but your 142plus fixed all that and runs pretty stable, so Im weary of trying standard nightlies...

dunno about gps reboot, i don't think there's any fix for that as it seems so random and few people have it.

but with n145 or later (or my 142+) you don't need the libaudio patch. to me anything after 145 is golden, all except this wifi battery drain.

is anyone still running a build before n126? if so do you lose 10% battery as soon as you turn wifi on, and keep losing it after turning it off? i don't recall that happening with the old kernel.....

Share this post


Link to post
Share on other sites

dunno about gps reboot, i don't think there's any fix for that as it seems so random and few people have it.

but with n145 or later (or my 142+) you don't need the libaudio patch. to me anything after 145 is golden, all except this wifi battery drain.

is anyone still running a build before n126? if so do you lose 10% battery as soon as you turn wifi on, and keep losing it after turning it off? i don't recall that happening with the old kernel.....

I'm still running N88 so I'm sure I'm not up to date enough to comment but WiFi was never a real battery drain. Are you experiencing a major difference in battery life on apparent drain caused by the poor configuration of battery meters? Frankly a lot of places recommend WiFi over 3G because it pulls less power.

Share this post


Link to post
Share on other sites

I have just changed from GSF to nightly 145, and on a whole seem content with it, but I have a problem with WiFi, that it disconnects when the phone is sleeping and does not reconnect automatically when woken, I have to manually reconnect via the settings menu.

Is this normal ?

Share this post


Link to post
Share on other sites

I have just changed from GSF to nightly 145, and on a whole seem content with it, but I have a problem with WiFi, that it disconnects when the phone is sleeping and does not reconnect automatically when woken, I have to manually reconnect via the settings menu.

Is this normal ?

GreenPower should fix this. Get it from Market.

Share this post


Link to post
Share on other sites

you have to "keep wifi alive" in advanced wifi settings....it still disconnects when the screen is off but reconnects when youre out of standby....

also I havent had any wifi battery drain with N142plus, is this a new issue with n145 and after?

Im using n142+ and I have 87% battery after 14 hours use, 30 minutes wifi and 30 minutes telephoning...

Edited by dadashi

Share this post


Link to post
Share on other sites

you have to "keep wifi alive" in advanced wifi settings....it still disconnects when the screen is off but reconnects when youre out of standby....

Hi, dadashi is absolutely correct. Even though there is an option to turn Wi-Fi off when the screen goes off, use never turn off, and it works perfectly. It automatically reconnects and doesn't drain the battery. Weird but true.

Also, a lot of folks are experiencing Wi-Fi power drain issues. I am running N146 and even before that I never experienced this issue. This is just a thought, but my Wi-fi network is setup so that devices are given specific IP address's using the unique device MAC address. For example my Blade always gets 10.10.10.7. It's a shot in the dark but perhaps this may be part of the solution?

Anil.

Edited by Anil k Solanki

Share this post


Link to post
Share on other sites

My Wi-Fi is not working and I cannot find the advanced Wi-Fi settings. Can someone please give me a foolproof run through the steps required to put an end to this problem?

Hi, dadashi is absolutely correct. Even though there is an option to turn Wi-Fi off when the screen goes off, use never turn off, and it works perfectly. It automatically reconnects and doesn't drain the battery. Weird but true.

Also, a lot of folks are experiencing Wi-Fi power drain issues. I am running N146 and even before that I never experienced this issue. This is just a thought, but my Wi-fi network is setup so that devices are given specific IP address's using the unique device MAC address. For example my Blade always gets 10.10.10.7. It's a shot in the dark but perhaps this may be part of the solution?

Anil.

Share this post


Link to post
Share on other sites

is anyone still running a build before n126? if so do you lose 10% battery as soon as you turn wifi on, and keep losing it after turning it off? i don't recall that happening with the old kernel.....

I don't think I have that problem with the new kernel? Never mind the old one. I can't say as I've noticed any unusual battery drain issues.

Does the losing it after turning it off mean you have noticeably higher standby drain after having used wifi? If so, I will double check my overnight drain tonight.

I only really use the wifi for app updates in the market and I've not noticed any significant drops. Nothing like a 10% drop within moments of using it kinda thing.

Edited by targetbsp

Share this post


Link to post
Share on other sites

My Wi-Fi is not working and I cannot find the advanced Wi-Fi settings. Can someone please give me a foolproof run through the steps required to put an end to this problem?

Hi zurpher, is your question specific to this ROM? If you need help then help yourself by at least providing some basic info about your problem.

You can watch a video on how to connect to a Wi-Fi network.

Foolproof Video

Anil.

Share this post


Link to post
Share on other sites

My Wi-Fi is not working and I cannot find the advanced Wi-Fi settings. Can someone please give me a foolproof run through the steps required to put an end to this problem?

go into your wifi settings where you can choose your wifi network and press the menu button to bring the advanced options....

Share this post


Link to post
Share on other sites

I ran the latest CyanogenMod 7.1 and tried Swedish Spring before. Both and my previous long-term ROM by Paul have the WiFi issue. It just scans, tries to connect and then disconnects just to start the whole cycle all over again. Quite frustrating.

I now at least managed to install Google Apps and can access the market. I wanted to re-install Titanium Bachup to get some of my previous APKs back put currently the programme does not start downloading. If you have any ideas what the issue might be with this I would appreciate it. I currently access the internet via 3G but do not have a flatrate.

Hi zurpher, is your question specific to this ROM? If you need help then help yourself by at least providing some basic info about your problem.

You can watch a video on how to connect to a Wi-Fi network.

Foolproof Video

Anil.

Share this post


Link to post
Share on other sites

I ran the latest CyanogenMod 7.1 and tried Swedish Spring before. Both and my previous long-term ROM by Paul have the WiFi issue. It just scans, tries to connect and then disconnects just to start the whole cycle all over again. Quite frustrating.

I now at least managed to install Google Apps and can access the market. I wanted to re-install Titanium Bachup to get some of my previous APKs back put currently the programme does not start downloading. If you have any ideas what the issue might be with this I would appreciate it. I currently access the internet via 3G but do not have a flatrate.

Hi zurpher,

First I would,

  1. Boot into recovery and wipe the Dalvik Cache, and the cache partition.
  2. Flash N146, and Google apps.
  3. Reboot and sign into Google.

That should fix the problems you are experiencing.

I hope this helps. Anil.

Share this post


Link to post
Share on other sites

go into your wifi settings where you can choose your wifi network and press the menu button to bring the advanced options....

I have now set the Wi-Fi sleep policy to never. Unfortunaly, it didn't fix my problem of Wi-Fi "Scanning... >> Connecting... >> Disconnected".

I have now managed to install Titanium Backup but not seem to be able to restore previous applications (before change to CyanogenMod 7). Am I missing something obvious? Would be great to get the apps back without having to manually re-install every single one of them.

Share this post


Link to post
Share on other sites

Hi zurpher,

First I would,

  1. Boot into recovery and wipe the Dalvik Cache, and the cache partition.
  2. Flash N146, and Google apps.
  3. Reboot and sign into Google.

That should fix the problems you are experiencing.

I hope this helps. Anil.

Here is what I did:

  1. Boot into recovery and wiped the Dalvik Cache, and the cache partition.
  2. Flash N146,
  3. reboot,
  4. boot into recovery, wiped cache and data,
  5. and then flashed Google apps.
  6. Reboot and sign into Google.

Is there anything wrong with the way I did it? I don't think that it can cause my Wi-Fi problems. The market works now but re-installing all my previous apps would be time consuming and eat up a lot of my data. There must be a more convenient way.

BTW, can anyone recommend a good off-line satnav application for Android?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.