Jump to content
Test Zeppelin

[ROM][GEN2]CyanogenMod 7 (Android 2.3.7)

Recommended Posts

I prefer to use Sej's kernel rather than the Cm7.2 one: http://blade.windows...-sej-kernel.zip

I find the wifi reconnection more reliable in it with my router. So you could try it and see if it helps your issue?

I have the same problem with sej"s kernel but I dont have it with CM9 KonstaKang 4.0.4. Any ideas?

Share this post


Link to post
Share on other sites

I don't have any i'm afraid :( You could try Swedish Snow. That's Konsta's Gingerbread if his CM9 works.

thanks :(

Share this post


Link to post
Share on other sites

CM7 just compiled. Only changes from me are the faster Adreno libs

http://www.mediafire...z5813ttfjvb3mm6

MD5#FF99FE82D3F7E5045570AC0BC79E727D

Thanks for your builds, but can you include a soft button patch? I've tried decompiling framework-res, changing values and compiling again, but got boot-loop :( It's only 2 lines editing and your builds can get one, useful feature (for people who like soft buttons, other can simply don't enable them )...

Share this post


Link to post
Share on other sites

It's not something I use but if no-one else is making CM7 with it in these days (and I guess most are into CM9 now?) then yeah I'll look into it for the next one.

Share this post


Link to post
Share on other sites

I've tried decompiling framework-res, changing values and compiling again, but got boot-loop

It is something in this. I done similar things on latest targetbsp rom - changed framework-res, removed lot of applications from rom, added hosts file etc then flashed rom.

But I done it wiping only partition cache and dalvik cache. After that all working perfectly.

I read on another forum that there is problem with modified roms with changed framework-res. Then I read gr83 post.

So I decided verify it on my phone.

This time I wiped all possible data (also boot and system partitions).

Next I flashed rom and got boot-loop.

It looks like it is possible to change framework-res and flash rom over existing and working rom,

but if we trying to do similar thing over completly wiped phone there is a problem!

Edit:

test 1. Installed Targetbsp rom - works perfectly.

test 2. Wiped all. Installed Targetbsp rom with changed framework-res to work with SottButtons - got boot-loop.

Edit:

Solution. Wiped all, installed latest targetbsp build, rebooted and waited till all will be working, rebooted and flashed modified rom with changed framework-res, rebooted.

From now it working. I have SoftButton patch. But WTF?

Edited by kjacek

Share this post


Link to post
Share on other sites

Not had one in a while, but in the past, whenever I've had an unexplained boot loop, a dalvik wipe tends to sort it for me.

Share this post


Link to post
Share on other sites

you can't flash an edited framework-res on a completely clean phone, it will cause bootloops.

either you do it right and build it the way you want it to be, or install target's ROM, let it boot and flash framework-res from a zip

Share this post


Link to post
Share on other sites

you can't flash an edited framework-res on a completely clean phone, it will cause bootloops.

either you do it right and build it the way you want it to be, or install target's ROM, let it boot and flash framework-res from a zip

OK, I do it the second way by flashing modified targetbsp rom containing changed framework-res over unmodified targetbsp rom.

But why I can't decompile, change and build framework-res (all by apktool), then add it to the rom and flash it to a completely clean phone? WHY?

And what do you mean 'either you do it right and build it the way you want it to be'? I supposed I done it properly by apktool...

Edited by kjacek

Share this post


Link to post
Share on other sites

ICS is not good enough for daily use. I eagarly wait for JB to satisfy my requirements.

Who said that?

ICS is nearly 100% perfect ATM and it just getting better!

And I am using it as daily driver for the past 1 month or so....

Share this post


Link to post
Share on other sites

Who said that?

ICS is nearly 100% perfect ATM and it just getting better!

And I am using it as daily driver for the past 1 month or so....

It probably depends on how you use your phone. I think it's borderline unusable to be honest! I keep trying it though. :D

Share this post


Link to post
Share on other sites

It probably depends on how you use your phone. I think it's borderline unusable to be honest! I keep trying it though. :D

Thanks to all devs for good work. I agree targetsp that it's maybe a little bit under the borderline to be usable. It's fine but missing some features it should have. It's pity but

derives from a little oldish Blade.

Share this post


Link to post
Share on other sites
Can someone give me CM7 build with soft buttons and good battery life. :unsure:

Soft buttons? That's not going to happen any soon. For the latest stable CM 7.2 download targetbsp's latest compilation. The download link is in his signature.

Share this post


Link to post
Share on other sites

It probably depends on how you use your phone. I think it's borderline unusable to be honest! I keep trying it though. :D

True but the thing is that once you have gotten used to ICS its really,really hard to go back to GB :D

  • Upvote 1

Share this post


Link to post
Share on other sites

Can someone give me CM7 build with soft buttons and good battery life. :unsure:

I've never had any need for soft buttons but I'm currently using the 1st July nightly and it's probably giving me the best battery life I've even had on my blade.

Share this post


Link to post
Share on other sites

How can I fix the issue with google play complying "you must add an account to the device" and exiting every time I try to launch it. I've tried clearing data and reinstalling google play apk and all the gaps but nothing helps. I have gaps from targetbsp.

Share this post


Link to post
Share on other sites

How can I fix the issue with google play complying "you must add an account to the device" and exiting every time I try to launch it. I've tried clearing data and reinstalling google play apk and all the gaps but nothing helps. I have gaps from targetbsp.

Do you have gmail account on your device?

Share this post


Link to post
Share on other sites

Do you have gmail account on your device?

Solved. For some reason I didn't have enough space on /system and googleservicesframework wasn't there. I removed some live wallpapers and other stuff, copied it by hand and it's fine now. Weird though. My /system is 128MB and never was too small before.

Share this post


Link to post
Share on other sites

128mb is a very small system that only the earliest gen 2 tpt's used. We pretty quickly switched to 136 or 138 or something.

The likely cause, considering you used my gapps, is that the latest market version is a fair bit bigger.

I just checked, and even with stock gapps, CM7 needs 132mb and hasn't grown in months. So you have in fact been missing bits of the firmware for a long time with a 128mb system. You need to tpt to a bigger system partition.

Edited by targetbsp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.