Jump to content
PaulOBrien

28 Jul Fr19: MoDaCo Custom ROM for the LG Optimus 2X with Online Kitchen (new: custom kernel)

Recommended Posts

My GPS still doesn't work after the nokia fix.

mine is working even indoor near the window

and also rainy days..

Share this post


Link to post
Share on other sites

Quick report on FR18b2: I flashed the ROM with the OC/UV kernel and found that the 'dialer' partial wake up usage is pretty much gone. There's a problem, though: every now and then, the phone gets really hot with no reason and rebooting fix the issue since its next occurence. I found this out shortly after flashing the new ROM, with no external Apps installed, so I really have no clue on what the cause of this behaviour could be. The phone gets hot right behind the camera lens, towards the SD-card and the card itself seems to get very hot. Trying now to flash FR18 with the old kernel, let's see if this fixes the problem.

Share this post


Link to post
Share on other sites

is there any speed increase from Fr17 to Fr18 beta 2??

currenlty i am on fr17 rc3, and it is fast and very stable.

so is there any increases in speed with fr18?

thanks

Share this post


Link to post
Share on other sites
is there any speed increase from Fr17 to Fr18 beta 2??

currenlty i am on fr17 rc3, and it is fast and very stable.

so is there any increases in speed with fr18?

thanks

the major different to me is only the removal of notification of USB debug mode.

Share this post


Link to post
Share on other sites
just a little offtopic:

Hacked LG Camera app with 20mbps recording in FULL HD with Super Fine setting only instead of 9mbps :(

Double the power since we have dual cores :rolleyes:

Still 24fps right now.

Download in the attachment.

The way I installed this:

1. Titanium backup - uninstall Camera app

2. Root explorer - go into System/App - mount R/W delete the Camera.apk if it's still there

3. Root explorer - copy the modified Camera.apk into System/App - make sure you still have mount R/W enabled.

And it should be in your apps list to try it out.

Make sure you extract the RAR file first <_<

Thanks to somemadcaaant.

He did it faster than me :P

Thank you so much !!!!

Share this post


Link to post
Share on other sites

So, just a status feed...

I've experienced multiple, unexpected reboots with Fr17 and Fr18 with no evidential reasons... phone sitting on standby and just reboots. I've not experienced this since Fr4 and now it happens regularly. Most people will know I don't just post random problems.

My visual diagnosis indicates it's radio related; it seems to occur around the time cell re-selection happens. I'm using the 0504 radio but have not had this problem before Fr17.

I'm not expecting anything as a result of this post but I think it's important to record that something that used to be stable is no longer so. This is in addition to the YouTube bug that has crept into the MCR kernel.

The hunt for performance has some consequences.

Share this post


Link to post
Share on other sites

its already been said in topic and just want to confirm: i have side effects with the ram hack. In gallery when zoom into a picture i get black boxes. a restart wont fix it. besides that the extra ram is usefull :P

Share this post


Link to post
Share on other sites

Hi all, just here to share my experiences. I have been trying all roms for the o2x since I got it two months ago and had mixed experiences. My biggest problem has been that every non-stock rom had huge battery issues even if performance was great.

now since fr18b2 it has all changed. no more dialer wake, great performance and the phone uses hardly any power on idle. it is awesome.

conclusion: the new ril in the Spanish rom has done wonders. somehow the ril and baseband are ESSENTIAL for good battery performance. If you have battery problems I think getting the baseband and ril right for your region seems to be key.

please all try to get fr18b2 with the 0405 baseband on a european model and do a full wipe before installing (especially with a full battery) and you will see the dialer partial wake is gone and battery life should be very good for a powerful phone, easily able to last a full 16-18 hour day.

please all try and follow this and let us know if you find the same.

THANKS PAUL!

Share this post


Link to post
Share on other sites
Hi all, just here to share my experiences. I have been trying all roms for the o2x since I got it two months ago and had mixed experiences. My biggest problem has been that every non-stock rom had huge battery issues even if performance was great.

now since fr18b2 it has all changed. no more dialer wake, great performance and the phone uses hardly any power on idle. it is awesome.

conclusion: the new ril in the Spanish rom has done wonders. somehow the ril and baseband are ESSENTIAL for good battery performance. If you have battery problems I think getting the baseband and ril right for your region seems to be key.

please all try to get fr18b2 with the 0405 baseband on a european model and do a full wipe before installing (especially with a full battery) and you will see the dialer partial wake is gone and battery life should be very good for a powerful phone, easily able to last a full 16-18 hour day.

please all try and follow this and let us know if you find the same.

THANKS PAUL!

sounds great. have you "MCK kernel r14 with overclocking / undervolt support" and "MCK kernel r11 installed to /system partition" checked in online kitchen? (thats how it is on start without changing anything in kernel section.

And how did you choose "Revert SQLite Library to Stock "

Edited by ben1th

Share this post


Link to post
Share on other sites
its already been said in topic and just want to confirm: i have side effects with the ram hack. In gallery when zoom into a picture i get black boxes. a restart wont fix it. besides that the extra ram is usefull :P

Almost confirmed the 64MB hack would only affect the LG's apps, which only they know the GPU got more RAM than the industrial standard.

for LG gallery, you can look for "QuickPic" in the market as an alternative, which is free.. but won't show your picture's in picasa.

for LG video player, try look for "MOBOplaye"r.. with ARMv7FPS support

for LG camera, look for the hack version from xda.. which is able to record 30fps 19mbps full HD.

other than these apps.. everything should work fine with the 64MB hack.

Share this post


Link to post
Share on other sites
Almost confirmed the 64MB hack would only affect the LG's apps, which only they know the GPU got more RAM than the industrial standard.

for LG gallery, you can look for "QuickPic" in the market as an alternative, which is free.. but won't show your picture's in picasa.

for LG video player, try look for "MOBOplaye"r.. with ARMv7FPS support

for LG camera, look for the hack version from xda.. which is able to record 30fps 19mbps full HD.

other than these apps.. everything should work fine with the 64MB hack.

i will give that a try! many thanks!

Share this post


Link to post
Share on other sites
sounds great. have you "MCK kernel r14 with overclocking / undervolt support" and "MCK kernel r11 installed to /system partition" checked in online kitchen? (thats how it is on start without changing anything in kernel section.

And how did you choose "Revert SQLite Library to Stock "

I have the oc/uv kernel (mck r14), no sql hack, no 64mb hack. almost zero lg apps except for calc, smartshare and fm radio. the rest is google without the live wallpapers, sim toolkit and some others not selected. launcher is launcherpro plus. running 0.8.4.1 and not 0.8.5 or 0.8.6 because they have lag when pushing the home button and zooming out. oh and make sure to flash with a full battery.

Share this post


Link to post
Share on other sites

Anyone else having GPS issues? I'm NOT able to recieve any GPS signal. Using fr18b2(standard core) + 0405 baseband.

Edited by GaLaReN

Share this post


Link to post
Share on other sites
Anyone else having GPS issues? I'm NOT able to recieve any GPS signal. Using fr18b2(standard core) + 0405 baseband.

Yes and no. I had them, but fixed it.

Open Hidden menu and select GPS test.

MOLR Protocol: User Plane

SULP -> SLP Server Setting:

Select Google and click Menu button -> Edit.

Remove text in the last field and uncheck TLS.

Use the GPS Test app from Market to check it. It might take a little while the first time because it has to update the GPS assistance data from the SLP server.

If it still doesn't lock on, go back into the same SLP Server Setting and Add a new entry:

Name: Nokia or whatever

slp address: supl.nokia.com

port: 7275

blank cert field

TLS unchecked.

Try GPS Test again.

Share this post


Link to post
Share on other sites

Hi,

thanks for this new version....

one question : after update, how can I restore my desk and widgets ? I have titanium installed..

optimus 2x modaco Fr18 beta2

Share this post


Link to post
Share on other sites
Yes. It got broken in the "Norwegian" fix.

::Trym

Whoops, can't say I use App Advisor, so i'll fix that up for the next Beta. :P

P

Share this post


Link to post
Share on other sites
Hi,

thanks for this new version....

one question : after update, how can I restore my desk and widgets ? I have titanium installed..

optimus 2x modaco Fr18 beta2

It's a non-wipe update so you shouldn't lose your desktop settings.

On an unrelated note, that new camcorder tweak looks sweet, i'll include that in the next Beta kitchen.

P

Share this post


Link to post
Share on other sites
Hi,

thanks for this new version....

one question : after update, how can I restore my desk and widgets ? I have titanium installed..

optimus 2x modaco Fr18 beta2

If you use the default LG launcher you can try restoring LG Home data.

Launcher Pro has a backup/restore feature, but it won't restore widgets because of Android limitations.

I'm sure the same applies to ADWLauncher and other third party launchers.

Share this post


Link to post
Share on other sites
Whoops, can't say I use App Advisor, so i'll fix that up for the next Beta. :P

P

A couple of things, Paul; I deleted a recurring event from the LG Calendar app and the confirmation dialog that pops up contains an '&', but it shows as '&amp;'.

Could you take a look at the default GPS settings? They don't seem to work, and I believe removing TLS from the Google server or using supl.nokia.com fixes it. I'd appreciate it if you could confirm it.

This is probably a long shot;

Sometimes my Gmail sync stalls without showing any errors. Once in a while I realize that my phone hasn't notified me of any emails in a while, and when I check it my two Gmail accounts haven't been updated in hours. I use one @gmail.com and one Google Apps account. Usually they both stall, not just one at a time. Refreshing inside the Gmail app usually gets them going again. Sync settings doesn't report about any issues. Did anyone experience this?

Oh, and more importantly, any word on Gingerbread? :rolleyes:

Share this post


Link to post
Share on other sites
A couple of things, Paul; I deleted a recurring event from the LG Calendar app and the confirmation dialog that pops up contains an '&', but it shows as '&amp;'.

Could you take a look at the default GPS settings? They don't seem to work, and I believe removing TLS from the Google server or using supl.nokia.com fixes it. I'd appreciate it if you could confirm it.

This is probably a long shot;

Sometimes my Gmail sync stalls without showing any errors. Once in a while I realize that my phone hasn't notified me of any emails in a while, and when I check it my two Gmail accounts haven't been updated in hours. I use one @gmail.com and one Google Apps account. Usually they both stall, not just one at a time. Refreshing inside the Gmail app usually gets them going again. Sync settings doesn't report about any issues. Did anyone experience this?

Oh, and more importantly, any word on Gingerbread? :P

The same here about Gmail ...

Share this post


Link to post
Share on other sites
Just to make sure. I have FR12 installed, if I update to the current version, do I need to whipe? If not, will I loose anything? What about options that I have currently installed but would leave out in a new bake?

Never got an answer to this... :P

Share this post


Link to post
Share on other sites
The same here about Gmail ...

Try going to Manage Apps and clear Gmail data and cache... worked for me, sync started again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.