Jump to content
PaulOBrien

28 Jul Fr19: MoDaCo Custom ROM for the LG Optimus 2X with Online Kitchen (new: custom kernel)

Recommended Posts

OMG this is normal in ALL android phones

No. I never had this before fr17. Maybe, it's because of widget locker, but before, I've always seen the lg accept-call screen.

Share this post


Link to post
Share on other sites

I always cooked the AOSP Dialer+Contacts.

With FR18b2 i cooked first time the original LG dialer -- and i have no battery drain. Has someone same experience?

Share this post


Link to post
Share on other sites
Hi, Paul.

I'm still on FR17, I think it's b3.

I want to report some little issues, I had with that rom:

1. Sometimes during an incoming call, I see the stock receive call screen, which looks like the stock lockscreen, instead of the LG one. Could this have happened during the dialer optimizations, you have done?

2. I can't enter my searches in the stock browsers address bar anymore. When I type something there, I get a google search-url, whichseems to be corrupted in some way, so that the main google page is loaded. Here I have to reenter my search in the google search bar to get the results. When I change my search provider to bing, everything works fine.

For the call screen, it's different if your screen is off or on that's normal

Share this post


Link to post
Share on other sites
I always cooked the AOSP Dialer+Contacts.

With FR18b2 i cooked first time the original LG dialer -- and i have no battery drain. Has someone same experience?

I have the opposite experience... up until fr18b1, I had LG dialer, and I had the dialer issue. When I baked my fr18b2, I did it with the Google dialer, and all of a sudden dialer issue is fixed.

Maybe fr18b2 is the fixed.

1 thing I noticed though, which made me switch to Google dialer, was that in LG dialer, the contacts tab seems to be syncronizing 24/7. Even if I disconnect from all accounts and disable syncing completely in settings. In google dialer, it does not seem to be syncing. My own theory is, that LG dialer wants to sync with facebook, and since I always bake my rom without SNS, it can't, therefore keeps trying till the day my phone dies... I may be completely wrong, it's just a theory.

Anyway, I really love fr18b2... Whatever the reason my dialer issue is gone, and the ROM seems to be fast and running smoothly. Thank you so much for your work so far, Paul.

Share this post


Link to post
Share on other sites
For the call screen, it's different if your screen is off or on that's normal

I didn't know that.

The strange thing is, I never had seen this other screen before fr17.

Maybe it was a bug in older versions or caused by an app or sth...

Edit: Does anyone else have the search bug?

Edited by Riemen

Share this post


Link to post
Share on other sites
Hi Paul,

I dont know if it was reported before.

My gtalk application is not working as it should.

Sometimes, and not always, the talk shows all my message to the bottom, and the other person to the top. Which its very annoying.

I couldn´t find a patron to know when exactly this happens.

You date is proberbly wrong

Share this post


Link to post
Share on other sites

@planeth:

Actually i don't really need AOSP or LG dialer directly, as i use Touchpal Dialer. But at the moment i'll stay with this ROM.

And on Friday i go on Holiday for 2 1/2 weeks, and i can't wait for all the new stuff which will happen in the meantime :-D

Share this post


Link to post
Share on other sites

Hello All,

I installed this with the mc14 oc/uv kernel.

Then I installed pimpmycpu.

When I start pimpmycpu everything till 1000MHz is green and all above is grey.

How can I select a OC frequencie...???????

Share this post


Link to post
Share on other sites
When I start pimpmycpu everything till 1000MHz is green and all above is grey.

How can I select a OC frequencie...???????

Longpress and choose!

Share this post


Link to post
Share on other sites
Hello All,

I installed this with the mc14 oc/uv kernel.

Then I installed pimpmycpu.

When I start pimpmycpu everything till 1000MHz is green and all above is grey.

How can I select a OC frequencie...???????

You set a min and a max by long-pressing and picking min/max. Green means activated, grey means deactivated. Besides, you can control mv by just pressing a value and choosing the mv you want.

Setting mv too low will crash your phone... Remember to test stability, before you choose to apply on boot.

Hope that helps.

Share this post


Link to post
Share on other sites

This is my short Rapport for Fr18 Beta 2

No problems and battery is very stable(didn't experience any self magic charging) :P

I am using the 2.6.32.28-mck-10 Kernel(very strange because I choose MCK kernel r11 from the kitchen ) and all the rest is pretty much default. I dont use the F-secure and have the Titanium Backup.

Also No 64mb hack, no sql hack no oc/uv

I am using LG luncher but will use something else like LauncherPRO

Also didn't upgrade my baseband, I am still on 1035.21_20110223.

I will update my baseband and RIL soon. also i will install the hacked camera app(i had it and did a wipe yesterday and forgot to install it again).

I am very happy with how all works and looking forward for the 2.3.4 android ver to reach us sooner than later.

If you guys want me to test something please let me know i am playing around trying to crash the phone but so fas so good.

Share this post


Link to post
Share on other sites
I have the opposite experience... up until fr18b1, I had LG dialer, and I had the dialer issue. When I baked my fr18b2, I did it with the Google dialer, and all of a sudden dialer issue is fixed.

Maybe fr18b2 is the fixed.

1 thing I noticed though, which made me switch to Google dialer, was that in LG dialer, the contacts tab seems to be syncronizing 24/7. Even if I disconnect from all accounts and disable syncing completely in settings. In google dialer, it does not seem to be syncing. My own theory is, that LG dialer wants to sync with facebook, and since I always bake my rom without SNS, it can't, therefore keeps trying till the day my phone dies... I may be completely wrong, it's just a theory.

Anyway, I really love fr18b2... Whatever the reason my dialer issue is gone, and the ROM seems to be fast and running smoothly. Thank you so much for your work so far, Paul.

can someone confirm/check this??? i've also deleted sns...

Share this post


Link to post
Share on other sites

Anyone tell me how to access the hidden menu please?

I'm on FR17 pre-baked and can't seem to get to it.

My GPS is screwing up - sees satellites but never gets a fix so I need to sort it out.

Share this post


Link to post
Share on other sites

I also bake without SNS. It has no impact on dialer usage here. The dialer issue has not come up yet in FR18b2.

Share this post


Link to post
Share on other sites
can someone confirm/check this??? i've also deleted sns...

I dont use SNS. instead i have a twitter app and Facebook app from the store. i use the lg dialer and experience no problems while Facebook is integrated in to my contacts so i get status updates and profile photos on people i call. no problems at all

Share this post


Link to post
Share on other sites

Many thanks to paul again!

FR18B2 MCK14 without ram hack, with sql hack works freaking great! its pretty fast and battery last long!

unplugged for 31 hours and 22% battery left!

I used the phone regular (some calls, some internet, some mails, facebook, twitter, tegra games). wlan was turned on the whole time. 2 hours of gps tracking over 34km bike tour took 22% battery thats good.

GPS works better than in stock! i use the nokia server (wasnt set up by default) and get a fix when i open any programm.

Thanks again!

Share this post


Link to post
Share on other sites

Hmm, for the first time ever I have random reboots (Fr18b1). I have not actually seen it happen, but sometimes I pick up my phone and it's at the SIM-unlock screen, so I suppose it has rebooted. Battery usage is good (12% drop in 7,5 hours; light usage), the dialer is quite present in partial wake though, so now I'm hoping this could get even better :P.

My last wipe was with Fr16 and I haven't upgraded to Fr18b2 yet (I'm going to later today), so if that would solve the reboots please ignore this :rolleyes:.

Share this post


Link to post
Share on other sites

I'm on Fr18b2 and it's an amazing ROM (64MB hack, stock SQL, OC/UV), no battery drain, very stable and fast.

Only problem is that while in a call, the button to open the keypad is grayed so I'm unable to call for example service centers and so on becasue I can't push any number (i.e. please push 1 to access customer area, push 2 to ..., etc)

I'm using GO Dialer, but I have also the same problem with LG dialer.

Suggestion?

Thanks

Federico

Share this post


Link to post
Share on other sites
I'm on Fr18b2 and it's an amazing ROM (64MB hack, stock SQL, OC/UV), no battery drain, very stable and fast.

Only problem is that while in a call, the button to open the keypad is grayed so I'm unable to call for example service centers and so on becasue I can't push any number (i.e. please push 1 to access customer area, push 2 to ..., etc)

I'm using GO Dialer, but I have also the same problem with LG dialer.

Suggestion?

Thanks

Federico

LG Dialer here on FR18b2. Cannot confirm your issue. The button IS gray, but not "grayed out", it works, bringing up the numeric keypad.

::Trym

Share this post


Link to post
Share on other sites
LG Dialer here on FR18b2. Cannot confirm your issue. The button IS gray, but not "grayed out", it works, bringing up the numeric keypad.

::Trym

I did some experiments and I found out that the problem is showing up only when calling a specific number (199... TNT Courier service center) and NOT showing up when calling another service (800... BMW help desk). Quite strange!

Federico

Share this post


Link to post
Share on other sites

Hi!

I'm brand new to this forum und I became a a premium member.

So I baked a FR18 ROM. So on, so good: Very nice ROM!!

My launcher is the launcher pro and I'm using the 1035.21_20110502 Baseband.

I've installed the ROM with the Clockword Mod (CWM 3.0.1.4 R1) in following order:

1) Baseband

2) FR18 ROM

Now everything seemed to be good but I recognized a BIG BATTERY DRAIN! The battery dropped from 45% to 2% in less than 3 hours WITHOUT usage!!

At the moment I'm charging my LGOS and I want to do a battery wipe when it will reach the 100%.

Does anyone has an idea what I can do?

Should I flash the ROM again?

(Fail: I read that I have to wipe BEFORE flashing the ROM; I think I did a full wipe after flashing the ROM - does that caus the problem?)

Greetings

Share this post


Link to post
Share on other sites

Just wanted to say the FR18b2 is EXCELLENT!

I see no mysterious battery drain at all

Only glitch I found is the answer button in the lockscreen which has been mentioned before, but the ROM is fast, smooth and problem free.

Great work Paul!!!

Share this post


Link to post
Share on other sites
Hmm, for the first time ever I have random reboots (Fr18b1). I have not actually seen it happen, but sometimes I pick up my phone and it's at the SIM-unlock screen, so I suppose it has rebooted. Battery usage is good (12% drop in 7,5 hours; light usage), the dialer is quite present in partial wake though, so now I'm hoping this could get even better :P.

My last wipe was with Fr16 and I haven't upgraded to Fr18b2 yet (I'm going to later today), so if that would solve the reboots please ignore this :rolleyes:.

same here - greatest rom though!

actual config: FR18b2,MCK r14 with 64MB-hack, only LG-app used is the dialer

max

Share this post


Link to post
Share on other sites
Anyone tell me how to access the hidden menu please?

I'm on FR17 pre-baked and can't seem to get to it.

My GPS is screwing up - sees satellites but never gets a fix so I need to sort it out.

Anyone able to assist with this please? Desperate to fix my GPS.

Share this post


Link to post
Share on other sites

Whenever I get unusually high battery drain, the microSD in my phone gets extremely hot and when I go to the SD settings it's been dismounted.

It's mostly after I reboot from CWM or sometimes when I have connected the USB cable (debugging on, so no SD-mounts).

A bit weird :/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.