Jump to content
PaulOBrien

28 Jul Fr19: MoDaCo Custom ROM for the LG Optimus 2X with Online Kitchen (new: custom kernel)

Recommended Posts

Because backtoext3 wipes, and if you're coming from a Fr19 Beta / RC, you are already EXT3 and don't need to wipe.

P

... but many are coming from FR18, no? Especially the prebakes!

Edited by abwyatt

Share this post


Link to post
Share on other sites
... but many are coming from FR18, no?

Yes, you said why isn't it included? I explained why - because not everyone needs to convert on flash. Some do, hence they need to use it seperately.

P

Share this post


Link to post
Share on other sites
stock standard solu :) ... try doing a complete wipe, flash the ROM, test for a day or so ... load your apps one by one (do not restore from your Titanium backups if you use it) and test one by one. If all this fails, then I think you have a hardware problem.

I also had lots of instability problems like you and others, and always fixed it with the above approach. With experience and a tested set of apps loaded in Titanium, I now shortcut this process by restoring my apps from Titanium, but without their data if there is a problem. Have not had to do this for a long time though, not since FR17. FR18 and FR19 have flashed over existing installs without a hitch, and have been absolutely stable for me. Regarding basebands which some are linking to instability problems, it has never been my experience that the baseband is a cause for instability. Battery consumption and various functionality problems yes, but instability no. My 2 cents worth :rolleyes:

I might give this a try. The problem is that with this method, and the fact that the problem occurs about once a day, it will take me a couple of hundred days to install my couple of hundred apps :-). I see that this might fix the stability problem, not what is the probability of it fixing the missing mobile data problem (the one that is fixed by switching to 2G)?

Share this post


Link to post
Share on other sites
Yes, you said why isn't it included? I explained why - because not everyone needs to convert on flash. Some do, hence they need to use it seperately.

P

oops, you are right, as usual :) ... yeah, if you just flash over an earlier FR19 install, not so good!

Edited by abwyatt

Share this post


Link to post
Share on other sites
I might give this a try. The problem is that with this method, and the fact that the problem occurs about once a day, it will take me a couple of hundred days to install my couple of hundred apps :-). I see that this might fix the stability problem, not what is the probability of it fixing the missing mobile data problem (the one that is fixed by switching to 2G)?

with hundreds of apps (me too), I would try a shortcut first by restoring your Titanium backups without the data. If that does not work, then you have to do it the hard way or by taking an educated guess as to which might be the problematic apps and systematically going through those only.

are you sure the mobile data problem is not a temporary glitch in your network?

Share this post


Link to post
Share on other sites
e: if that fails then yeah, NVflash the stock ROM back, reroot and start from scratch; pain in the ass but may be your only option?

Yes, it was my only option !

But solved !

I would flash my device with nvflash like this: http://android.modaco.com/content/lg-optim...062-15-03-2011/

than install cwm and flash the new FR19. With a full wipe.

You´ll lose all your data and apps.

I´m not a pro but for me it worked like this.

Thx a lot, our phone seems unbreakable :)

Share this post


Link to post
Share on other sites
are you sure the mobile data problem is not a temporary glitch in your network?

Pretty much, yes. it is quite consistent whenever I move out of WiFi coverage, at home, at work, and other places. The fix seems to be to switch to 2G, and possibly back again if I am lucky :-). If it were a network glitch, fiddling with the mobile data settings on the phone shouldn't solve the problem for them...

Edit: I also had similar problems on CM7, where my marble date would suddenly drop out for no reason even after it was well established.

Edited by Frank Sem-Jacobsen

Share this post


Link to post
Share on other sites
Pretty much, yes. it is quite consistent whenever I move out of WiFi coverage, at home, at work, and other places. The fix seems to be to switch to 2G, and possibly back again if I am lucky :-). If it were a network glitch, fiddling with the mobile data settings on the phone shouldn't solve the problem for them...

are you using Market Enabler or do you have any other APNs installed apart from your own mobile network's APN?

the only time I have seen something similar happen before is when I was using market enabler which, if you use it, installs some additional APNs from a market enabled network. Occasionally, my data connection would go missing because somehow it had hopped onto another APN that did not belong to my network. It happened under similar conditions to what you are describing, switching from WiFi to data in automatic mode, ie. when the WiFi network was no longer present. And yes, sometimes switching to 2G worked, other times no. My solution was to stop using Market Enabler. Luckily this happened at the time when Market enabled access for the country I am located in and I was able to discard Market Enabler.

Anyway, have a look at what is happening with your APNs (assuming you have multiple APNs) when you have the problem again.

Share this post


Link to post
Share on other sites

Hello Paul,

I tried building the kernel with 'tun' support (by enabling CONFIG_TUN) from the LG source but got a compilation error. Not sure if it is due to adding that or just a messed up environment. Having access to Cisco VPN is a necessity for me, requesting to try building the kernel with that support. I will keep my efforts going too.

Having tun support is the only thing holding me back and hope this works soon...

Edited by hackworks

Share this post


Link to post
Share on other sites

Hi Paul,

Amazing rom, Paul. Everything is fine and smooth. That's what we all may expect from our 2X, and you gave it to us. Thousands thanks wouldn't be enough !

Thumbs up.

Okdac :)

Share this post


Link to post
Share on other sites
are you using Market Enabler or do you have any other APNs installed apart from your own mobile network's APN?

the only time I have seen something similar happen before is when I was using market enabler which, if you use it, installs some additional APNs from a market enabled network. Occasionally, my data connection would go missing because somehow it had hopped onto another APN that did not belong to my network. It happened under similar conditions to what you are describing, switching from WiFi to data in automatic mode, ie. when the WiFi network was no longer present. And yes, sometimes switching to 2G worked, other times no. My solution was to stop using Market Enabler. Luckily this happened at the time when Market enabled access for the country I am located in and I was able to discard Market Enabler.

Anyway, have a look at what is happening with your APNs (assuming you have multiple APNs) when you have the problem again.

This might actually have something to it. I checked my access points, and it turns out I have one I didn't have before (a different aspect of the same provider), and that it was selected (this is while collected to WiFi at home). I will pay close attention to this the next time I leave the house. I tried to delete the extra access points, but I do not seem to be able to. I guess there is some common solution to this problem?

Anyway, I appreciate your help.

Share this post


Link to post
Share on other sites
Hello Paul,

I tried building the kernel with 'tun' support (by enabling CONFIG_TUN) from the LG source but got a compilation error. Not sure if it is due to adding that or just a messed up environment. Having access to Cisco VPN is a necessity for me, requesting to try building the kernel with that support. I will keep my efforts going too.

Having tun support is the only thing holding me back and hope this works soon...

The LG source is old and won't work with the new ROMs!

P

Share this post


Link to post
Share on other sites

Hi Paul,

I am using fr19 and I must say its a whole new experiance compared to other roms.

I have only one problem, I have baked a rom with the stock lockscreen and the vibration feedback compared

to the lg one is too weak.

Is there a way to make it stronger?

thank you!

Share this post


Link to post
Share on other sites
The LG source is old and won't work with the new ROMs!

P

Paul, thank you for the update. You saved my weekend from wasted efforts :-)

Share this post


Link to post
Share on other sites
This might actually have something to it. I checked my access points, and it turns out I have one I didn't have before (a different aspect of the same provider), and that it was selected (this is while collected to WiFi at home). I will pay close attention to this the next time I leave the house. I tried to delete the extra access points, but I do not seem to be able to. I guess there is some common solution to this problem?

Anyway, I appreciate your help.

you can try setting the correct APN to default by setting APN Type to 'default' to stop it jumping onto an incorrect APN.

a second APN is usually present for MMS. it should not be selectable. if it is, and it is an MMS APN, make sure the APN Type is set to 'mms'. that will make sure it is not selectable.

when WiFi is enabled the correct data APN should still be enabled. it should not be set on another APN as you are suggesting.

Edited by abwyatt

Share this post


Link to post
Share on other sites

hej, everything is good but one question: why did u disabled the adblocker? the ads in the free apps are really anoying, can sb gimme a link to an adblocker?

couldnt find anything in the market :)

Share this post


Link to post
Share on other sites

requested url not found - i searched for the app in the market and i found it though :)

thanX

Edited by gin0v4

Share this post


Link to post
Share on other sites

What about the RIL ?

After flashing FR19 and 622 baseband should I download the RIL and flash it as well ?

Share this post


Link to post
Share on other sites
What about the RIL ?

After flashing FR19 and 622 baseband should I download the RIL and flash it as well ?

No

Share this post


Link to post
Share on other sites
622 RIL is already included in the FR19 ROM.

thank you.

Today I had a hard day of work :)I reverted to EXT3 (used Fr18RC2 and wanted to upgrade to FR19) then Downloaded and installed stock, installed clockwork 3.0.2.8(the new ver has issues with EXT4) flashed Fr19 flashed base band and just now finished restoring that included Titanium, Resco backup and my launcher pro plus as well. took some time but now seems like i am good.

Had one force close while restoring contacts using Resco (LG home something) but everything seems to bve fast and smooth.

Now just need to setup LG SNS, since i was using original twitter/ facebook apps insted of LG. then i am going to fully charge and re calibrate my battery.

Allot of work but as far as i can see now it was all worth it !

Thank you Paul, you rock !

Have a grate weekend.

Edited by aaww

Share this post


Link to post
Share on other sites

Sorry if what i am going to ask is already answered but it isn't easy to read 220 pages..Today i flashed the baseband 622 and then i flashed the fr19..Firstly i tried the quadrant test right after i installed the rom and i took only 2700 points while i was expecting to get something like 3000 (i am with V10a firmware if this is a critical factor)..Then my other problem is that i have purchased the SPB 3D launcher and i don't like the google launcher,so i want to get rid of it but i can't uninstall it from the setting menu.Have you any idea of how i can delete it?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.