Jump to content
PaulOBrien

20 Jan Gr6 (V20o): MoDaCo Custom ROM for the LG Optimus 2X with Online Kitchen (stock+vanilla)

Recommended Posts

Morning all :-)

Paul, two questions for you before I start baking ...

1) Where can I read about the changes in your MCK r24 kernel compared to the stock kernel? I would like to know the differences so I can decide which to use.

2) I am using the 823 baseband. Is that not a GB baseband? If not, I should then use 725 or 622, then?

Thanks.

1) It is the V10E kernel patched to the .40 (.46 patchset coming up) with the BFQ scheduler enabled and the aformentioned touch sensitivity fixes. It's 'near stock'.

2) I'm not familiar with that baseband, but my source tells me the 0725 GB baseband is best...?

P

Share this post


Link to post
Share on other sites

since I have problems to bake my own vanilla rom with kitchen (toggle buttons and volume bar are still in LG style) I flashed Pauls vanilla prebake

everything works well but I noticed when I wanted to set my alarm clock that deskclock is missing in this prebake.

Paul can u add it in the prebake? would be pretty handy :)

do u have a deskclock apk file for the p990 in the meantime? I didnt find one. thx

Share this post


Link to post
Share on other sites

Hey Paul Voodoo Sound is working with the Stock Kernel did you know that? I think there was a question about that and you answered : not yet supported.

Share this post


Link to post
Share on other sites

1) It is the V10E kernel patched to the .40 (.46 patchset coming up) with the BFQ scheduler enabled and the aformentioned touch sensitivity fixes. It's 'near stock'.

2) I'm not familiar with that baseband, but my source tells me the 0725 GB baseband is best...?

P

Thank for the quick response, Paul.

When will the .46 kernel patching be done? I think I will wait baking until then.

The 823 baseband is leaked from a V21b ROM according to the posts on XDA. It can be downloaded here: http://www.mediafire.com/?rvtodk9969ro0bc

I am using the 823 baseband with the 725 RIL without problems on V10D stock.

Share this post


Link to post
Share on other sites

Unknown. Given LG's track record though, I wouldn't expect it any time soon!

P

I'm looking forward to seeing a few of the ICS apps ported into the MCR kitchens long before that happens! I suspect you'll be a very busy man updating all the kitchens over the next couple of months.blink.gif

Have you got your hands on the ICS apps folder yet to see what can easily be backported to gingerbread? I'm sure plenty of us would be quite happy if you spent some time on that rather than Gr5. Gr4 is good enough for my everyday ROM with the stock kernel, and those ICS flavoured goodies look so tasty.

Share this post


Link to post
Share on other sites

I'm looking forward to seeing a few of the ICS apps ported into the MCR kitchens long before that happens! I suspect you'll be a very busy man updating all the kitchens over the next couple of months.blink.gif

Have you got your hands on the ICS apps folder yet to see what can easily be backported to gingerbread? I'm sure plenty of us would be quite happy if you spent some time on that rather than Gr5. Gr4 is good enough for my everyday ROM with the stock kernel, and those ICS flavoured goodies look so tasty.

You should be glad what we have now(thanks to Paul). Right now there are only some fractions from ICS, nothing more. You can find them on XDA and install by yourself.

Share this post


Link to post
Share on other sites

I'll have a poke around the ICS SDK of course and see what I can find. I'm going to upload the 'Roboto' font to the kitchen shortly.

P

  • Upvote 1

Share this post


Link to post
Share on other sites

With this rom the signal erratically switches between H and 3g. The H signal is definitely not as good for me this time. This is on baseband 725

Share this post


Link to post
Share on other sites

That is normal. H should always only show when data is actually being transferred.

P

On the Extreme pack I get the 3G arrow-icons even when data is disabled. Data of course is not working and the icons are not the green colour they become when connected to Google. Not sure if it's a bug or feature, just thought I'd let you know if you didn't :D

When data is enabled, all is fine and dandy over here.

Edited by d-droid

Share this post


Link to post
Share on other sites

On the Extreme pack I get the 3G arrow-icons even when data is disabled. Data of course is not working and the icons are not the green colour they become when connected to Google. Not sure if it's a bug or feature, just thought I'd let you know if you didn't :D

When data is enabled, all is fine and dandy over here.

Odd!

P

Share this post


Link to post
Share on other sites

I installed Topogigi's rom and it formatted also the /cache partition to ext4. I've seen the back2ext3 script formats /system and /data but not /cache.

What do I have to do with the /cache partition to install your GR4 rom?.

Thanks Paul.

Share this post


Link to post
Share on other sites

I installed Topogigi's rom and it formatted also the /cache partition to ext4. I've seen the back2ext3 script formats /system and /data but not /cache.

What do I have to do with the /cache partition to install your GR4 rom?.

Thanks Paul.

For those with bootloop problem, if you come from topogigi Roms, I think the problem is that the cache partition is also on EXT4...

So try Paul's backtoext3 tool to revert to EXT3 also for the cache partition.

Be aware that all your partitions (/system /data and /cache) will be erased, so, don't forget to make a backup...

PS : Use with CWM...

Share this post


Link to post
Share on other sites

On the Extreme pack I get the 3G arrow-icons even when data is disabled. Data of course is not working and the icons are not the green colour they become when connected to Google. Not sure if it's a bug or feature, just thought I'd let you know if you didn't :D

When data is enabled, all is fine and dandy over here.

I had the same thing with a custom baked ROM.

About 4 hours after flashing the ROM (without rebooting), data completely died.

3G arrows were present, even after enabling aeroplane mode or 'use 2G only' in settings.

Data didn't work (even on wifi) until a reboot.

Its been fine ever since that reboot though, thats about 2 days uptime.

Share this post


Link to post
Share on other sites

I had the same thing with a custom baked ROM.

About 4 hours after flashing the ROM (without rebooting), data completely died.

3G arrows were present, even after enabling aeroplane mode or 'use 2G only' in settings.

Data didn't work (even on wifi) until a reboot.

Its been fine ever since that reboot though, thats about 2 days uptime.

I can confirm that.

Im saying that since the first release: data connection isnt good on gingerbread release.

I had tried all the possible basebands and ril's, but the result is always the same: instable connection.

- Connection die suddenly and just returns after reboot

- Sometimes the signal of network drop and returns again

- At TIM operator cant get the "H" icon on topbar just 3G, with i can VIVO can get it (it's not a feature, believe in me)

Edited by Madsen Felipe

Share this post


Link to post
Share on other sites

For those with bootloop problem, if you come from topogigi Roms, I think the problem is that the cache partition is also on EXT4...

So try this tool to revert to EXT3 also for the cache partition.

Be aware that all your partitions (/system /data and /cache) will be erased, so, don't forget to make a backup...

PS : Use with CWM...

Thank you very much! It solved my bootloop problem!

Share this post


Link to post
Share on other sites

I'll have a poke around the ICS SDK of course and see what I can find. I'm going to upload the 'Roboto' font to the kitchen shortly.

P

That would be great. I'm trying it out just now and it's a really good font for the browser and reading the forums.

Share this post


Link to post
Share on other sites

Baked GR4 with stock lockscreen. The head of the sliders don't grey out when grabbed. Paul can you fix this please?

Hmm, that's strange, i'll have a look.

P

Share this post


Link to post
Share on other sites

I keep on having the same issue with all these Gr3/4 roms. Any help would really be appreciated.

- When I make a call, then after hanging up it will immediately redial the last number i dialed.

- Randomly(?) all phone functionality stops working, and this can only be fixed with restarting the phone.

My baseband is 725, in case that matters, and I do a complete wipe before any flashing.

Thanks for your help

Michael

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.