Jump to content
Sign in to follow this  

[Solved] Phone stuck on android boot logo after failed LG revert

Recommended Posts

I got a new phone and decided to revert my rooted GT540 that had a 2.2 firmware installed, back to LG's default using their updater so my father can use the Gt. Unfortunately it simply stays stuck at the Android boot up screen (shows LG logo Then "Android" then stays there) and nothing I have tried seems to correct it. Any ideas would be very appreciated as to a solution.

I tried fastbooting but the LG rom attempt seems to have overwritten that, and tried using KDZ updater to flash with a 2.1 rom but just as with the official LG update it says successful but stays on the android loading screen :(


Edit: Was able to sort it through trial and error, used the key combination of Power + Camera + volume up to get into fastboot mode (the LG logo appeared first which surprised me as I thought it went into a black screen straight away).

From there I was able to run fastboot commands to install the 2.3 Swiftdroid rom :)

Edited by mistermentality

Share this post

Link to post
Share on other sites

You need to use the KDZ flasher to restore it to LG Stock issue.

Go into Clockworkmod recovery and do a Factory Reset first (to remove all cache etc... and then power off the device and boot it into download mode (Volume - & Power), then flash the LG Stock using the KDZ Flasher -- It can take upto several minutes for the device to boot after. (As long as you don't go below Android 2.1, this will work)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.