Jump to content

Liquid A1 wont turn on

Recommended Posts

I have a problem, the liquid ran out of battery and now will not turn on. when I connect the charger shows no sign of charging, only have a screen backlight. I have tried to access the recovery and nothing. any suggestions?

Share this post

Link to post
Share on other sites

try leaving in connected to the charger for about 30 minutes before trying to turn it on, for some reason charging while the phone is off is really slow

  • Upvote 1

Share this post

Link to post
Share on other sites

guys pls help me,i was using liquid next 1.9.2 rom when i flashed the official 2.2 rom with acer download tool.Now my cell works with every button combo but it only vibrates and does not show any on-screen responses frown.gif

I tried and flashed 2 or 3 different bins for my device but each time i boot my phone, it keeps on vibrating and all the three notification led's blink at the same time

Plaese Help A.S.A.P

>> No Flashing dinfo.bin.

>> .bin Class is : A1

>> Read MgFl Header Ok!!

>> AMSS FileFlag : 63

>> OS FileFlag : 95

>> Please do Not remove USB cable, unless the program indicates you can do it.

>> Download Process Started at AMSS mode.

>> Hex file Start

>> Hex file Succ !!

>> AMSS Start

>> AMSS Succ !!

>> Cmd [AMSS => Fastboot]

>> Wait UsbEvent [AMSS => Fastboot]

>> No UsbEvent [AMSS => Fastboot], Now quit process...

>> Process finished. [Not Succ]

>> Process Result : Download Process was failed...

>> Process finished, USB cable can be removed now.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.