Jump to content
erikcas

CyanogenMod 6.1.1 for B7610 update 01-06 // I am stopping my contributions as my phone died

Recommended Posts

@ all who tried the headsetfix. Does it work for you?

I can't imagine, because the updatefile was packed wrong (the file was not unpacked in the directory where it should be unpacked).

Reuploaded it

Share this post


Link to post
Share on other sites

B7610 screen reached India today...hope to get it by tomorrow at my home.........waiting to try my hand on new android build :) :)

did u bought ir from outside india...

you would have got t in delhi

Share this post


Link to post
Share on other sites

@ all who tried the headsetfix. Does it work for you?

I can't imagine, because the updatefile was packed wrong (the file was not unpacked in the directory where it should be unpacked).

Reuploaded it

Now I tryed the new file and the headset are working very well.

Like you say the first reboot took longer but after that it is working fine.:rolleyes:

Good job.

Many thanks

Share this post


Link to post
Share on other sites

It's going to be even better when some kind soul fixes WiFi/BT, but just having a workable Android on this phone is awesome. Great job and big thanks to all involved! I love it.

Just wondering.. What are the chances of eventually getting CM7?

@Athlos, I tried to install to mystorage using auto-installer first (having manually created partitions), but it hung on the Android on OmniaII screen for me as well. Then I did it manually per most of the instructions in this thread:

  1. reformatted the partitions on my storage (1: FAT32 806MB, 2: EXT4 1024MB, 3: LINSWAP 128MB)
  2. reformatted the single partition on sdcard to FAT32 (1024 bytes clusters)
  3. unpacked cm_beta1.zip to the FAT32 partition on mystorage
  4. unpacked CM-6.1.1-B7610-Beta1.zip to the FAT32 partition on mystorage overwriting existing files
  5. manually unpacked the ext4.tar.gz to the ext4 partition on mystorage (in Ubuntu)
  6. opened /system/etc/fstab in gedit and edited it to the proper swap partition: mmcblk1p3
  7. changed the line in /init.rc that says
    mount vfat /dev/block/mmcblk1p5 /storage
    to
    mount vfat /dev/block/mmcblk1p1 /storage
  8. NO changes to /system/etc/vold.fstab (skip that step)
  9. Here's my startup.txt:
    Set kernel zImage
    
    Set ramsize 180*1024*1024
    
    Set mtype 1626
    
    Set ramaddr 0x50000000
    
    Set kernelcrc 1
    
    Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init console=ttySAC2,115200 vmalloc=256M"
    
    setbitp 0x7F008808 5 1
    
    pfw 0x7f005800 4 0x3
    
    pfw 0x7f005804 4 0x805
    
    pfw 0x7f005808 4 0x7
    
    pfw 0x7f00580c 4 0x0
    
    pfw 0x7f005828 4 0x11
    
    pfw 0x7f00582c 4 0x80
    
    boot

  10. Android on OmniaII screen doesn't take too long, but takes a while to get to the Touch the Android screen
  11. After booting a couple of times, I put the headsetfix update on FAT32 on mystorage

Tried SDcard auto-installer before installing manually to mystorage and it worked like a charm btw!

Share this post


Link to post
Share on other sites

did u bought ir from outside india...

you would have got t in delhi

i tried but didnt got in delhi.....gave my phone to local repair shop but he said he is unable to find the screen in market.....and i think i should give mobile to repair shop for screen replacement or doit myself ?....i used service manual....but its not so clear in regards to display replacement

Share this post


Link to post
Share on other sites

i tried but didnt got in delhi.....gave my phone to local repair shop but he said he is unable to find the screen in market.....and i think i should give mobile to repair shop for screen replacement or doit myself ?....i used service manual....but its not so clear in regards to display replacement

Since you are not sure. Repair shop.

Share this post


Link to post
Share on other sites

It's going to be even better when some kind soul fixes WiFi/BT, but just having a workable Android on this phone is awesome. Great job and big thanks to all involved! I love it.

Just wondering.. What are the chances of eventually getting CM7?

@Athlos, I tried to install to mystorage using auto-installer first (having manually created partitions), but it hung on the Android on OmniaII screen for me as well. Then I did it manually per most of the instructions in this thread:

  1. reformatted the partitions on my storage (1: FAT32 806MB, 2: EXT4 1024MB, 3: LINSWAP 128MB)
  2. reformatted the single partition on sdcard to FAT32 (1024 bytes clusters)
  3. unpacked cm_beta1.zip to the FAT32 partition on mystorage
  4. unpacked CM-6.1.1-B7610-Beta1.zip to the FAT32 partition on mystorage overwriting existing files
  5. manually unpacked the ext4.tar.gz to the ext4 partition on mystorage (in Ubuntu)
  6. opened /system/etc/fstab in gedit and edited it to the proper swap partition: mmcblk1p3
  7. changed the line in /init.rc that says
    mount vfat /dev/block/mmcblk1p5 /storage
    to
    mount vfat /dev/block/mmcblk1p1 /storage
  8. NO changes to /system/etc/vold.fstab (skip that step)
  9. Here's my startup.txt:
    Set kernel zImage
    
    Set ramsize 180*1024*1024
    
    Set mtype 1626
    
    Set ramaddr 0x50000000
    
    Set kernelcrc 1
    
    Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init console=ttySAC2,115200 vmalloc=256M"
    
    setbitp 0x7F008808 5 1
    
    pfw 0x7f005800 4 0x3
    
    pfw 0x7f005804 4 0x805
    
    pfw 0x7f005808 4 0x7
    
    pfw 0x7f00580c 4 0x0
    
    pfw 0x7f005828 4 0x11
    
    pfw 0x7f00582c 4 0x80
    
    boot

  10. Android on OmniaII screen doesn't take too long, but takes a while to get to the Touch the Android screen
  11. After booting a couple of times, I put the headsetfix update on FAT32 on mystorage

Tried SDcard auto-installer before installing manually to mystorage and it worked like a charm btw!

Thank you very much for the guide:)

I managed to load Android succesfully (after a couple reboots) but after i enter the PIN, the phone hangs. I will try and install again later.

Share this post


Link to post
Share on other sites

After serveral time format sd card -->install-->get stuck with "android loading..." or at boot screen, I decided flash again WM rom an reinstall android and surprisely, it's sucessful. An experience for whom geting stuck like me before

However, I can't get root access, SU can't update, SetCPU not working...

Edited by crazyhorse78

Share this post


Link to post
Share on other sites
After serveral time format sd card -->install-->get stuck with "android loading..." or at boot screen, I decided flash again WM rom an reinstall android and surprisely, it's sucessful. An experience for whom geting stuck like me before

However, I can't get root access, SU can't update, SetCPU not working...

Set cpu doesn't add something anyway.

Su and root acces are working, I guarantee you. I reproduced several times, every time it works.

What install method did you use? Did you apply any other tricks from somewhere on the forums?

Share this post


Link to post
Share on other sites

Set cpu doesn't add something anyway.

Su and root acces are working, I guarantee you. I reproduced several times, every time it works.

What install method did you use? Did you apply any other tricks from somewhere on the forums?

I installed on SD as your guide in first page. But in Mini Tool Partition I see as follow:

It has 2 unallocated space, is it abnormal?

post-761694-0-37411400-1323750161_thumb.

Share this post


Link to post
Share on other sites

I installed on SD as your guide in first page. But in Mini Tool Partition I see as follow:

It has 2 unallocated space, is it abnormal?

No, its normal... No need to worry...

Just continue with installation...

Edited by matriX1218

Share this post


Link to post
Share on other sites

Since you are not sure. Repair shop.

received today finally....will give to local repair shop..........and i think samsung service center wont replace my screen ?

Share this post


Link to post
Share on other sites

received today finally....will give to local repair shop..........and i think samsung service center wont replace my screen ?

well great to hear you have got it , lovely , for how much did u got it ..

well i help if you want to replace, but i would say if u are paying so much to buy it , plz be very careful to whom are you giving to repair your phone to.

so be extra careful plz..

have a great time with b7610

Share this post


Link to post
Share on other sites

I have a question:

Will we been gifted for xmas with a new android release? Maybe with wifi and or bluetooth..

No pression just asking

Like i allways said i really like developers hard hard work

Share this post


Link to post
Share on other sites

well great to hear you have got it , lovely , for how much did u got it ..

well i help if you want to replace, but i would say if u are paying so much to buy it , plz be very careful to whom are you giving to repair your phone to.

so be extra careful plz..

have a great time with b7610

in total i paid 2500 INR ......and phone working now and testing android now :)......display seems to be improved from last release i used.....is it now supports 16M colors?

Share this post


Link to post
Share on other sites

I'm run Ok. but

- total ram: 121 MB; free: 41M;

- cannot send message(rẹceiver ok).

- time not update

- incomming call: screen does not light and very slow

file startup.txt:

Set kernel zImage

Set ramsize 180*1024*1024

Set mtype 1626

Set ramaddr 0x50000000

Set kernelcrc 1

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init console=ttySAC2,115200 vmalloc=256M"

setbitp 0x7F008808 5 1

pfw 0x7f005800 4 0x3

pfw 0x7f005804 4 0x805

pfw 0x7f005808 4 0x7

pfw 0x7f00580c 4 0x0

pfw 0x7f005828 4 0x11

pfw 0x7f00582c 4 0x80

boot

Edited by Hoang Thanh Duy

Share this post


Link to post
Share on other sites

I have tried numerous times with different install methods, (auto installer and manually untaring and copying files))

Whatever i do, my phone either hangs randomly in Android or or im getting androird.process errors all the time. (I create partitions with gparted)

Could it be that the internal memory is damaged somehow? Anyway to check reliably?

Thanks and keep it up.

BTW on SD it is working fine

Share this post


Link to post
Share on other sites

my testing : 8gb class 2 card

1. 2 times SOD. first when setting live wallpaper and second during using market maybe due to opening of lots of app.

2. it is not so fast maybe due to my class 2 card....and it becomes slow when data enabled

3. this version is very stable.....sometimes there is delay in waking up from sleep....

4. Battery drains quickly when using data (2g )...

5. Facebook intergration added that is nice addon

6. unable to recognize my sim contacts.....

thanks to developers and erik for making android work..

Share this post


Link to post
Share on other sites

in total i paid 2500 INR ......and phone working now and testing android now :)......display seems to be improved from last release i used.....is it now supports 16M colors?

ohh great that ur phone is working now ................

well it was 16m colors supported before also,

its the os which is limiting the colors . as windows don't support 16 m colors.....

Share this post


Link to post
Share on other sites

my testing : 8gb class 2 card

1. 2 times SOD. first when setting live wallpaper and second during using market maybe due to opening of lots of app.

2. it is not so fast maybe due to my class 2 card....and it becomes slow when data enabled

3. this version is very stable.....sometimes there is delay in waking up from sleep....

4. Battery drains quickly when using data (2g )...

5. Facebook intergration added that is nice addon

6. unable to recognize my sim contacts.....

thanks to developers and erik for making android work..

yes the speed issue might be due to the class of sd ...

i have 8gb 6 class

and its totally smooth

Share this post


Link to post
Share on other sites

yes the speed issue might be due to the class of sd ...

i have 8gb 6 class

and its totally smooth

It will be slow when data is on because apps are updated. When all are updated it will be faster.

Share this post


Link to post
Share on other sites

yes the speed issue might be due to the class of sd ...

i have 8gb 6 class

and its totally smooth

i have ordered class 10 card expecting in 2-3 days and is apps updates auto or we have to do manually....as no download icon shows

Share this post


Link to post
Share on other sites

i have ordered class 10 card expecting in 2-3 days and is apps updates auto or we have to do manually....as no download icon shows

That is a bug in current Beta. Will be solved in next beta.

Share this post


Link to post
Share on other sites

B7610 specs tell us it has 256 mb ram, why in Android we see only 122mb?

http://pdadb.net/index.php?m=specs&id=1830&view=1&c=samsung_gt-b7610_omniapro_samsung_louvre

Many "fake" chinese smartphone with only 650mhz mediatek cpu running android games smoothly, so I believe B7610 speed will be upgraded in next releases, is it possible?

Share this post


Link to post
Share on other sites

B7610 specs tell us it has 256 mb ram, why in Android we see only 122mb?

http://pdadb.net/ind..._samsung_louvre

Many "fake" chinese smartphone with only 650mhz mediatek cpu running android games smoothly, so I believe B7610 speed will be upgraded in next releases, is it possible?

ya B7610 has 256mb ram....but ram is used by different drivers....thats why user available is less

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.