Jump to content
DVDeus

"GSM Only" mode drains battery abnormally..

Recommended Posts

Well, I will ask you guys if maybe someone has experienced similar problem with any 2.3 (zte leak) ROM. Sorry for opening new topic, but I couldn't find any useful information about it. So..

If I choose GSM Only mode, therefore the battery drain should be the lowest, correct? WCDMA should drain more, and it was tested&confirmed in public many times.

Now what is happening to me (and some of my friends with the same phone), is that battery drain is right opposite; "GSM only" mode drains the battery in one day, no matter what, while WCDMA can last for 3 days. Ordinary you would say "Use 3G, what the heck!", but the problem is signal coverage. I cannot use it since almost half of a day I don't have signal coverage with 3G.

Now, to turn the facts around, while I was on roaming this summer (3 times, different operator), GSM Only mode worked as it should, and the phone could last 4days+. While coming back to my country, to join my beloving operator, rapid draining started again.

I tested BlueGinger V5 and CAE V1.3, both act the same. There was no problem on 2.2 ROMs (FLB, SS). The phone is gen1 (TPT to gen2) AMOLED, one of the first series.

If anyone can explain me why and how is this possible, I would be grateful.

Share this post


Link to post
Share on other sites

My ZTE blade lasts 20 hours without doing anything and Ihave GSM only mode - Mobile standbytakes 40% of the battery. UnfortunatelyI don’t have data to compare, but I just turned WCDMA-only on. Let’s see.

Edited by braveslice

Share this post


Link to post
Share on other sites

Do you use data in 2g? Whilst 2g idle uses less battery than 3g (probably mostly due to ropey 3g coverage), 3g is much more efficient for data because it can complete the transfer in a fraction of the time.

Share this post


Link to post
Share on other sites

Do you use data in 2g? Whilst 2g idle uses less battery than 3g (probably mostly due to ropey 3g coverage), 3g is much more efficient for data because it can complete the transfer in a fraction of the time.

2G edge 150 kb/s (bad case scenario) and my 3G 500 kb/s (best case scenario - unlimited data with speed limit).

Cant really be the reason behind it. Maybe if you would use it for torrents.

Edited by braveslice

Share this post


Link to post
Share on other sites

Check my posts . You will find that your blade is not sleeping properly, or is only asleep half the time when.in 2g mode. It is operator dependant hence the change when roaming. On 3g mode blade sleeps 90/ of the time

. I didn't find a fix

Share this post


Link to post
Share on other sites

red321z,What a bad news :(

Thesetopics should be merged.

Link to red's post: My link

If it isoperator dependant, then maybe a complain to the operator?

This should concern all blade owners. When driving a car for example, there is very few places in earth were 3G coverage is 100%.

Edited by braveslice

Share this post


Link to post
Share on other sites

Well I am glad to see a few replies. Now I know I am not alone :)

Looks like a problem with deep sleep, which is operator dependant. I already planned to try another SIM during weeking, just to see the possible difference and to confirm the theory.

We need to convince the phone to go in deep sleep somehow, or to fake roaming mode. I will go back to gen1 next week and try again FLB R11 just to confirm battery usage. Because I am pretty sure that the battery last once longer.

@braveslice: make a full discharge, then charge it to 100% and then use only 3G. Then report battery usage back here.

@red321z: thanks for sharing your "observations"

Share this post


Link to post
Share on other sites

I have noticed this too. I had it on GSM auto (prl) and that would drain the battery very quickly. switched to auto GSM/WCDMA a few days back and noticed an improvement. Perhaps theres an issue with the radio?

Share this post


Link to post
Share on other sites

Like red321z mentioned, it is deep sleep related. Please download CPU Spy from the market, and take a look at % at a single frequency. Reset the timers and immediatelly press on/off button to put the phone in sleep. After lets say one minute being in "deep sleep", refresh the timers so you get the actual usage, and checked the deep sleep time. In GSM only mode, it won't almost one minute, as it should, maybe 30 secs. In WCDMA you will get almost 1 minute of deep sleep. And this is the reason why the phone is draining the battery quickly.

Share this post


Link to post
Share on other sites

This should be ROM related problem, since my FLB worked OK. And also other 2.3 devices I have tested (SGS, Desire S) work OK with my SIM card on GSM only mode. So therefore the Blade itself (I say ROM) doesn't handle operator properly. Is there any config file with some settings or parameters?

Share this post


Link to post
Share on other sites

I have to bump this thread because this is happening to me and I can't find a solution. I have 2 blades, same operator, same software (cyanogenmod N257 android 2.3.7(. One of them suddently doesn't sleep if it's on gsm mode. Only sleeps on 3G or airplane mode. Already did countless fullwipes and formats and TPT's...  

Does anyone have any idea what this could be?

Operator: UZO (Portugal (virtual operator that runs on TMN network 0035196xxxxxxx))

Share this post


Link to post
Share on other sites

I have to bump this thread because this is happening to me and I can't find a solution. I have 2 blades, same operator, same software (cyanogenmod N257 android 2.3.7(. One of them suddently doesn't sleep if it's on gsm mode. Only sleeps on 3G or airplane mode. Already did countless fullwipes and formats and TPT's...

Does anyone have any idea what this could be?

Operator: UZO (Portugal (virtual operator that runs on TMN network 0035196xxxxxxx))

Use the BetterBatteryStats app to determine what app/process is keeping the phone awake.

Share this post


Link to post
Share on other sites

Every software that I test shows that nothing is draining my battery. Already used cpu spy, betterbatterystats and whatever, only spare parts shows 85% running time. If you read what I've said, I tested my backup on other blade, and that same backup suspended on the other blade.  I know that is caused by the GSM module on 2G. Already tested other operator and SIM card. Probably I'll just RMA this because I have other gsm problems (15dB less signal on one blade (that doesn't sleep)) unless anyone has a better idea.

Edited by TigTex

Share this post


Link to post
Share on other sites

Hello Guys,

I think i have the same Problem.

With Froyo FLB 8, the blade ran much longer on 2g only as with 3g activated.

Since switching to GSF and MMHMP battery drains faster on 2g only.

When I set data connection on automatic, it drains only very little compared to 2g only.

Edited by ti_power

Share this post


Link to post
Share on other sites

Same problem here, but i have 0% sleep on 2g only...

My operator is a virtual operator... UZO(Portugal) so i think it's related to that since i tested with another sim card from vodafone and it sleeps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.