Jump to content
KonstaT

[ROM][GEN1-2-3] Moldovan Mile-High-Mountain-Pie RLS9 (Android 2.3.5)

Recommended Posts

Finally took the plunge and installed my first rom on my Gen 1 OLED San Francisco using the TPT method.

Only found a couple of issues,

Sometimes after making a call the screen remains off and I have to pull out the battery.

Any ideas, is it a problem with the proximity calibration? It doesn't happen all the time though.

When playing videos in the ESPN goals app, I get an error dialog saying 'Sorry, video cannot be played'. However behind the dialog the video is playing fine. This was ok in the stock ROM.

Any ideas?

Thanks for great job in making this ROM available.

I'm in a similar position with the Proximity Sensor.

I've read on here theses two bits

"Some users might have to calibrate their proximity sensor. Use ZTE Emode Helper to start engineering mode sensor calibration. If you have ZTE dialer add-on installed, you can also start engineering mode sensor calibration by dialing *983*0#."

"Some users might have to calibrate their proximity. proximity sensor is calibrated on the first boot, so don't cover it while first boot. You can recalibrate proximity by running command 'ztesensortest -c' in terminal. If that doesn't help, you might have to flash ZTE dialer add-on and run emode sensor calibration by dialing *983*0#."

But after running the sensor test in terminal, it hasnt solved it.

Can someone explain how to run the sensor test, is it simply "running command 'ztesensortest -c' in terminal" or do I need to be covering the sensor, or something else?

Cheers

Share this post


Link to post
Share on other sites

Sometimes after making a call the screen remains off and I have to pull out the battery.

Any ideas, is it a problem with the proximity calibration? It doesn't happen all the time though.

Calibrate your proximity sensor. ZTE Emode Helper -> Sensor Test -> calib.

But after running the sensor test in terminal, it hasnt solved it.

Can someone explain how to run the sensor test, is it simply "running command 'ztesensortest -c' in terminal" or do I need to be covering the sensor, or something else?

Cheers

The command line calibration is redundant, it was an old instruction. Use ZTE Emode Helper instead. ZTE Emode Helper -> Sensor Test -> calib.

Tried the normal rls7 but stuck on boot animation even though i have 160mb partition...

Even 128mb partition layout would be more than enough for this ROM. Looks more like someone forgot to wipe...

Edited by KonstaT

Share this post


Link to post
Share on other sites

Even 128mb partition layout would be more than enough for this ROM. Looks more like someone forgot to wipe...

of course, the elementary mistake.laugh.gif

guess i was accustomed to simply updating

Share this post


Link to post
Share on other sites

Finally took the plunge and installed my first rom on my Gen 1 OLED San Francisco using the TPT method.

Only found a couple of issues,

Sometimes after making a call the screen remains off and I have to pull out the battery.

Any ideas, is it a problem with the proximity calibration? It doesn't happen all the time though.

When playing videos in the ESPN goals app, I get an error dialog saying 'Sorry, video cannot be played'. However behind the dialog the video is playing fine. This was ok in the stock ROM.

Any ideas?

Thanks for great job in making this ROM available.

The problem with the screen remaining blank seems to have been solved with a sensor calibration which is great news.

The ESPN goals app still reports an error when trying to watch videos, although the video displays correcty in the background. Unfortunately, removing the error dialog stops the video. I guess this could well be a bug in the App. but it doesn't happen on my stock 2.1 ROM. For those interested this is a very nice free app that gives you highlights and goal clips from the uk premiership football games as they happen.

Share this post


Link to post
Share on other sites

Thank you for this rom!

I thought cm7 was my best friend, but in the last days flashing Nigthly after Nigthly it was annoying slow, so I tried this before anything else and It's great!

Only things I don't like, notification power widget not configurable and all the cyanogen power-user menus...

Share this post


Link to post
Share on other sites

Thanks for this Rom. Have installed. But am having a fair few issues..

Firstly - I cannot connect to my WEP wifi connection at home, just says 'obtaining IP address' then disconnects and retrys.

Secondly - Battery is poor. Fully charged @ 7.15pm, a bit of pretty light usage, 2 calls, few txts, couple of minutes internet over 3G and now battery at 46% @ 1.04am. 7hrs.

Thirdly - A couple of times I have had a random message saying status bar has crashed, it then disappears and reappears again a few seconds later.

Fourthly - Seems to turn screen brightness up every now and then randomly and won't turn screen off even though I set it to time out after 15 seconds. Go back into screen timout settings to check and the 15 second circle is randomly unchecked.

I'm running an OLED gen 1 that was upgraded previously to gen2 via TPT when I installed GSF beta 14. I installed this Rom as normal (not TPT method) through clockwork and did full wipe before (dalvik, data, battery stats). I am running a slightly older version of clockwork mod.

Any help greatly appreciated...

Edited by Sere83

Share this post


Link to post
Share on other sites

Hi.

Tks for this ROM it's Very cool.

But i have a problem with the mods on the MHMP 7.

on the mod M-MHMP-PW6-wifi-bt-gps-data-sync-bright and M-MHMP-RLS7-MIUI-BatteryBar.

If i tray install the M-MHMP-RLS7-MIUI-BatteryBar over the wifi-bt-gps-data-sync-bright i lose my Power widget configs....

And if i install the wifi-bt-gps-data-sync-bright over the MIUI bar i get the circle mod...

why they can't be installed together???

Any help?

Share this post


Link to post
Share on other sites

I would love to try this ROM out since I'm looking for a nice stable ROM to tide me over unitl a stable ICS is released. Unfortunately as I live in China now I can't access either Mediafire or Hotfile unless it's through a VPN which is so slow it's unusable. Does anyone know of anywhere accesible from China where I could download it? I would be hugely grateful.

Share this post


Link to post
Share on other sites

Hi.

Tks for this ROM it's Very cool.

But i have a problem with the mods on the MHMP 7.

on the mod M-MHMP-PW6-wifi-bt-gps-data-sync-bright and M-MHMP-RLS7-MIUI-BatteryBar.

If i tray install the M-MHMP-RLS7-MIUI-BatteryBar over the wifi-bt-gps-data-sync-bright i lose my Power widget configs....

And if i install the wifi-bt-gps-data-sync-bright over the MIUI bar i get the circle mod...

why they can't be installed together???

Any help?

They can't be installed at the same time because both are done by modifying the same file (SystemUI.apk). If you install one on top of the another it will overwrite the previous mod. You just have to stick with the MIUI battery bar if you want to use it, so you'll have few 'extra' buttons in power widget...

If you want to remove/rearrange buttons in power widget (using SystemUI.apk from MIUI battery bar mod), there is some instructions in the power widget thread.

Share this post


Link to post
Share on other sites

I've been trying this for some hours and this ROM is great! Really smooth and battery life is great too! However, I am having the same issue I have had with all ROMs based on stock Blade ROMs, both Froyo and Ginberbread: most of my music library is in AAC, and a lot of AAC songs show Unknown artist and Unknown album, even though they are correctly tagged and all data shows correctly on CM7. Too bad every stock based ROM I try has this issue, because this is the only thing left that makes me stick with CM and it's crazy high battery consumption. I've tried changing the media scanner .apk with the included in CM7 getting the same result. Anyone else with this bug?

Share this post


Link to post
Share on other sites

There seems to be a bug, when i choose the lowest brightness setting from the statusbar widget, the screen will automatically switch of when I'm in the home screen (only). It doesn't happen though if i choose the lowest brightness through the settings app. Anyone has the same problem? Any help to fix this. I'm not using any add on. Cheers.

Share this post


Link to post
Share on other sites

There seems to be a bug, when i choose the lowest brightness setting from the statusbar widget, the screen will automatically switch of when I'm in the home screen (only). It doesn't happen though if i choose the lowest brightness through the settings app. Anyone has the same problem? Any help to fix this. I'm not using any add on. Cheers.

I can't quite understand. Screen is supposed to turn of after some time. You can select screen timeout from settings.

I just tested this and can't see any strange behaviour. Anyone else having this problem?

Share this post


Link to post
Share on other sites

I can't quite understand. Screen is supposed to turn of after some time. You can select screen timeout from settings.

I just tested this and can't see any strange behaviour. Anyone else having this problem?

Hmm it switch off immediately when I press home key (after choosing lowest brightness), or if it's already is at the lowest brightness, then after unlocking the screen, it'll switch off instantly again, in less than a second. I'll try to do another complete wipe and install and will report back. cheers

Share this post


Link to post
Share on other sites

Hmm it switch off immediately when I press home key (after choosing lowest brightness), or if it's already is at the lowest brightness, then after unlocking the screen, it'll switch off instantly again, in less than a second. I'll try to do another complete wipe and install and will report back. cheers

I did a full reinstallation, and I found out it happens only when I use this MIUI launcher. But works fine with Launcherpro and the standard launcher. So I guess that's more of app compatibility issue?

update* espier launcher doesn't work either.

Edited by lee89b

Share this post


Link to post
Share on other sites

Having a very annoying bug with this rom. The native "Films' app cannot open any .mp4 files. My old rom opened these very same files without effort. The only files it does seem, to open is the .3gp files saved from the video recorder. I've tried using 3rd party apps, but they cant open these files using hardware decoding mode and force closes instead. Works in software mode but then it's really slow.sad.gif

Anyone else experience this?

Share this post


Link to post
Share on other sites

Having a very annoying bug with this rom. The native "Films' app cannot open any .mp4 files. My old rom opened these very same files without effort. The only files it does seem, to open is the .3gp files saved from the video recorder. I've tried using 3rd party apps, but they cant open these files using hardware decoding mode and force closes instead. Works in software mode but then it's really slow.sad.gif

Anyone else experience this?

What was your previous ROM? What codecs are you using in your files?

I just opened three files using three different codecs all in mp4 container. MPEG4-video (mp4v), h263, h264 (MPEG4 AVC) and all of these displayed just fine on native 'films' app and I could also hardware decode them using RockPlayer.

Maybe you should wipe and reinstall to see if it would help?

Share this post


Link to post
Share on other sites

Customisable Notification Power Widget & MIUI style Battery Bar

I ported a fully customisable notification power widget. You can freely select which of the nine buttons are displayed and select their order. Toggles for wifi, mobile data, GPS, bluetooth, sound/vibrate, brightness, flight mode, sync and auto-rotate. Options for sound/vibrate and brightness buttons. Long pressing on any of the switches takes you to settings menu. Quickpanel settings is embedded into settings menu. Select Settings -> QuickPanel Settings.

post-834050-0-50629800-1325780932_thumb. post-834050-0-60964000-1325780942_thumb.

post-834050-0-56801200-1325780962_thumb. post-834050-0-30566100-1325780969_thumb.

M-MHMP-RLS7-PowerWidget.zip

included in RLS8

MIUI style battery bar:

post-834050-0-99602600-1325780987_thumb. post-834050-0-55586400-1325780999_thumb.

What is included:

-MIUI style battery bar by Pvy. I've modified it a bit and it also needed a little fixing but all credits to Pvy.

-New fully customisable notification power widget

-Centered clock

-Removed normal battery icon

-Changed order of the status bar icons (moved alarm icon)

-Embeded battery bar settings into settings menu

M-MHMP-RLS7-PowerWidget-MIUI.zip

included in RLS8

Thanks:

lidroid, Pvy and CyanogenMod.

Edited by KonstaT
  • Upvote 4

Share this post


Link to post
Share on other sites

Thanks for this KonstaT, it's really useful!

And it also works fine, just tried it out (PowerWidget+MIUI).

Share this post


Link to post
Share on other sites

Hey KonstaT, that customisable notification power widget is awesome!! Thank you!!!

By the way, will you update this ROM soon? (cus the last version is from November...)

Thanks and keep the good work!!

Share this post


Link to post
Share on other sites

Hey KonstaT, that customisable notification power widget is awesome!! Thank you!!!

By the way, will you update this ROM soon? (cus the last version is from November...)

Thanks and keep the good work!!

I think I already went and declared RLS7 final. :P We'll have to see, I have some new ideas now and couple things I'm working on. I've treated RLS7 more of a test platform to try out new things. I'll definitely still make ROMs, just not sure if it's going to be RLS8 or a completely new ROM based on newer build. It wouldn't be much of a trouble to put together RLS8 from things that I've already posted here (and app updates). Either way I'm going to give that new power widget few days now to see if there is still some bugs that need ironing out. If you find some strange behaviour with that, I'd appreciate the info. :)

Is possible to include a Latest CM Dialpad: T9 Dialer - Additional Fixes ?

Might be possible, will look into it.

Edited by KonstaT
  • Upvote 2

Share this post


Link to post
Share on other sites

Hi Konstat. I flashed it on Chinese v880 and the camera is not working. I've read hiapk forum and negaruku Rom (2.3) from burstlam has a fix for Chinese cameras. There's any chance you could add this fix to your kernel?

Thank you for this great Rom.

Share this post


Link to post
Share on other sites

Just flashed the new power widget (M-MHMP-RLS7-PowerWidget.zip, not the MIUI one) but I got a FC just after rebooting (com.android.systemui crashed).

Now I have no power widget, no USB-battery-signal-clock on my homescreen... :(

Update: I manually uninstalled and reinstalled SystemUI.apk, then rebooted into Recovery, wiped Dalvik cache, rebooted again and now it works!

Guess that just wiping Dalvik cache would have been enough, btw :)

Edited by fox2000

Share this post


Link to post
Share on other sites

I have one more little problem: "Music" app (com.android.music) FCs when requested to play any song. I have two MP3 files on my phone, which played just fine in other ROMs (CM7, namely) so I wouldn't say there's any problem with the MP3s!

If I select them in Root Explorer, they play normally. If I choose to open them with "Music", I get the FC.

Edited by fox2000

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.