Jump to content

Step-by-step HowTo install Superboot (root) for everyone

Recommended Posts

Works for any Android version. Just use the Superboot going with your Android version.

Don't waste your time messing around with drivers for Windows xxx. If it doesn't work for you under Windows, just do as described here.

None of the previously posted procedures worked for me but this way it worked flawlessly (Stock Staraddict)

No need to install any driver for whatever. No need to install LINUX.

This should work with any LINUX (preinstall or boot from CD or USB pen-drive).

- Activate USB-Debugging on your phone (as described in a previous post)

- Turn off (remove the battery once turned off) and unplug your phone

- Start the LINUX distribution of your choice

- Download Superboot

- Unpack the downloaded file (right-click and select unpack here) and remember the path where you did unpack it to

- Open a terminal (command box)

- Enter sudo su to become root (1)

- Enter your password (2)

- Change to the directory where you unpacked Superboot to ( cd ~/Downloads/r2-OUK_P743TV1.0.0B05-skate-superboot/ in my case)

- Enter the following command to start the Superboot-script: ./install-superboot-linux.sh (3)

- Wait until the daemon has started. You should see the message: < waiting for device >

- Plug your phone onto an USB-port of your computer by pressing simultaneously [Vol-] + [Home] (4)

- If your phone does not power on by itself, insert the battery and switch your phone on by pressing simultaneously [Vol-] + [Home] + [Power] (4)

- As soon as you feel your phone vibrating, release the Power-button if you pressed it

- Keep [Vol-] and [Home] pressed until you see the green Android

- As soon as you release the two buttons, you should see the following message on the screen: sending 'boot'

- A few seconds later, the following message should appear on your screen: rebooting...

- Your phone should restart (unplug it)

- After your phone has restarted, you should find the app Superuser on your phone

You're done!

1 Some distributions don't like the sudo command. If sudo su doesn't work for you, just enter su (without sudo)

2 If you had to enter su (without sudo), you will need to enter the root password here

3 This command will not work without the dot ( . ) preceding the slash

4For Staraddict only: Since the buttons Home and Menu are inverted on the Staraddict, you must press the Menu-button instead of the Home-button

(Did I ever mention that I love LINUX?)

Any comments and/or suggestions are welcome.

Edited by Chris_67
  • Upvote 2

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.